a) clean up for this port

b) build both 4-STABLE and 5-CURRENT
loosely depend on submitter.

PR:		52821
Submitted by:	Pedro F. Giffuni <giffunip@yahoo.com>
This commit is contained in:
Maho Nakata 2003-07-29 05:25:36 +00:00
parent ac4ef3820b
commit 532a3d47ea
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=85807
6 changed files with 103 additions and 111 deletions

View File

@ -6,42 +6,48 @@
#
PORTNAME= rayshade
PORTVERSION= 4.0
PORTVERSION= 4.0.6
CATEGORIES= graphics
MASTER_SITES= ftp://graphics.stanford.edu/pub/rayshade/ \
ftp://ftp.princeton.edu/pub/Graphics/rayshade.4.0/
DISTNAME= ${PORTNAME}.${PORTVERSION}
EXTRACT_SUFX= .tar.Z
.ifndef NOPORTDOCS
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} guide.ps.Z
.endif
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= ports@FreeBSD.org
COMMENT= An extensible system for creating ray-traced images
BUILD_DEPENDS= $(LOCALBASE)/lib/librle.a:${PORTSDIR}/graphics/urt
DIST_SUBDIR= rayshade
WRKSRC= ${WRKDIR}/${PORTNAME}.4.0
HAS_CONFIGURE= yes
CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS+= < ${WRKDIR}/config.ans
ALL_TARGET=
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 500113
BROKEN= "Does not compile"
.endif
.if defined (BATCH) || defined(PACKAGE_BUILDING)
USE_REINPLACE= yes
CONFIGURE_ARGS= < ${WRKDIR}/config.ans
pre-configure:
$(SED) -e "s,@CFLAGS@,${CFLAGS}," < ${FILESDIR}/config.ans > \
${WRKDIR}/config.ans
@${MKDIR} ${PREFIX}/bin
${CP} ${FILESDIR}/config.ans ${WRKDIR}/config.ans
${REINPLACE_CMD} -e "s,@CFLAGS@,${CFLAGS},g ; \
s,@CC@,${CC},g ; \
s,@LOCALBASE@,${LOCALBASE},g ; \
s,@PREFIX@,${PREFIX},g" ${WRKDIR}/config.ans
.endif
do-install:
$(INSTALL_PROGRAM) $(WRKSRC)/rayshade/rayshade $(PREFIX)/bin
# THIS ARE NOT USED BY ANY PORT
# $(INSTALL_DATA) $(WRKSRC)/libray/libray.a $(PREFIX)/lib
# $(INSTALL_DATA) $(WRKSRC)/libshade/libshade.a $(PREFIX)/lib
$(MKDIR) $(PREFIX)/share/doc/rayshade
$(INSTALL_DATA) $(WRKSRC)/Doc/Guide/* $(PREFIX)/share/doc/rayshade
$(INSTALL_DATA) $(WRKSRC)/Doc/quickref.txt $(PREFIX)/share/doc/rayshade
.ifndef NOPORTDOCS
${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/guide.ps.Z ${DOCSDIR}
$(MKDIR) $(PREFIX)/share/examples/rayshade
$(INSTALL_DATA) $(WRKSRC)/Examples/* $(PREFIX)/share/examples/rayshade
.endif
.include <bsd.port.post.mk>
.include <bsd.port.mk>

View File

@ -1 +1,2 @@
MD5 (rayshade.4.0.tar.Z) = c81f9507c20cd6060a8bdc611a6771ff
MD5 (rayshade/rayshade.4.0.6.tar.Z) = c81f9507c20cd6060a8bdc611a6771ff
MD5 (rayshade/guide.ps.Z) = 59429e2018ef21bb1e31ca8e0ae26c56

View File

@ -3,18 +3,16 @@
-lm
@CC@
@CFLAGS@
n
/usr/local/include
@LOCALBASE@/include
@LOCALBASE@/lib/librle.a
@PREFIX@/bin
/usr/bin/mkdep
yacc
y

View File

@ -1,53 +1,52 @@
*** Configure.orig Sun Feb 9 21:04:23 1992
--- Configure Sat Feb 26 16:14:13 2000
***************
*** 28,37 ****
PATH=$PATH:'/bsd4.3/usr/bin:/usr/bsd'
export PATH || (echo "OOPS, this isn't sh. Desperation time. I will feed myself to sh."; sh $0; kill $$)
! if test ! -t 0; then
! echo "Say 'sh Configure', not 'sh <Configure'"
! exit 1
! fi
(alias) >/dev/null 2>&1 && \
echo "(I see you are using the Korn shell. Some ksh's blow up on Configure," && \
--- 28,38 ----
PATH=$PATH:'/bsd4.3/usr/bin:/usr/bsd'
export PATH || (echo "OOPS, this isn't sh. Desperation time. I will feed myself to sh."; sh $0; kill $$)
! #FreeBSD's ports don't want to be interactive
! #if test ! -t 0; then
! # echo "Say 'sh Configure', not 'sh <Configure'"
! # exit 1
! #fi
(alias) >/dev/null 2>&1 && \
echo "(I see you are using the Korn shell. Some ksh's blow up on Configure," && \
***************
*** 660,665 ****
--- 661,667 ----
;;
esac
set /usr/ccs/lib/libc.so
+ test -f $1 || set /usr/lib/libc.a
test -f $1 || set /usr/lib/libc.so
test -f $1 || set /usr/lib/libc.so.[0-9]*
eval set \$$#
***************
*** 872,878 ****
: determine where manual pages are on this system
echo " "
case "$sysman" in
! '') sysman=`loc . /usr/man/man1 /usr/man/man1 /usr/man/mann /usr/man/manl /usr/man/local/man1 /usr/man/u_man/man1 /usr/share/man/man1 /usr/catman/u_man/man1 /usr/man/l_man/man1 /usr/local/man/u_man/man1 /usr/local/man/l_man/man1 /usr/man/man.L`
;;
esac
if test -d "$sysman"; then
--- 874,880 ----
: determine where manual pages are on this system
echo " "
case "$sysman" in
! '') sysman=`loc . /usr/local/man/man1 /usr/man/man1 /usr/man/mann /usr/man/manl /usr/man/local/man1 /usr/man/u_man/man1 /usr/share/man/man1 /usr/catman/u_man/man1 /usr/man/l_man/man1 /usr/local/man/u_man/man1 /usr/local/man/l_man/man1 /usr/man/man.L`
;;
esac
if test -d "$sysman"; then
--- Configure.orig Mon Feb 10 12:04:23 1992
+++ Configure Tue Jul 29 14:18:04 2003
@@ -28,10 +28,11 @@
PATH=$PATH:'/bsd4.3/usr/bin:/usr/bsd'
export PATH || (echo "OOPS, this isn't sh. Desperation time. I will feed myself to sh."; sh $0; kill $$)
-if test ! -t 0; then
- echo "Say 'sh Configure', not 'sh <Configure'"
- exit 1
-fi
+#FreeBSD's ports don't want to be interactive
+#if test ! -t 0; then
+# echo "Say 'sh Configure', not 'sh <Configure'"
+# exit 1
+#fi
(alias) >/dev/null 2>&1 && \
echo "(I see you are using the Korn shell. Some ksh's blow up on Configure," && \
@@ -660,6 +661,7 @@
;;
esac
set /usr/ccs/lib/libc.so
+test -f $1 || set /usr/lib/libc.a
test -f $1 || set /usr/lib/libc.so
test -f $1 || set /usr/lib/libc.so.[0-9]*
eval set \$$#
@@ -872,7 +874,7 @@
: determine where manual pages are on this system
echo " "
case "$sysman" in
- '') sysman=`loc . /usr/man/man1 /usr/man/man1 /usr/man/mann /usr/man/manl /usr/man/local/man1 /usr/man/u_man/man1 /usr/share/man/man1 /usr/catman/u_man/man1 /usr/man/l_man/man1 /usr/local/man/u_man/man1 /usr/local/man/l_man/man1 /usr/man/man.L`
+ '') sysman=`loc . /usr/local/man/man1 /usr/man/man1 /usr/man/mann /usr/man/manl /usr/man/local/man1 /usr/man/u_man/man1 /usr/share/man/man1 /usr/catman/u_man/man1 /usr/man/l_man/man1 /usr/local/man/u_man/man1 /usr/local/man/l_man/man1 /usr/man/man.L`
;;
esac
if test -d "$sysman"; then
@@ -1418,14 +1420,8 @@
if $contains '^strchr$' libc.list >/dev/null 2>&1 ; then
if $contains strchr "$strings" >/dev/null 2>&1 ; then
if $contains index "$strings" >/dev/null 2>&1 ; then
- echo "Your system has both index() and strchr(). Shall I use"
- rp="index() rather than strchr()? [$dflt]"
- $echo $n "$rp $c"
- . myread
- case "$ans" in
- n*) d_index="$define" ;;
- *) d_index="$undef" ;;
- esac
+ echo "Your system has both index() and strchr(). I use index() instead."
+ d_index="$define"
else
d_index="$define"
echo "strchr() found."

View File

@ -1,3 +1,5 @@
Rayshade is a system for generating ray-traced images. Rayshade's main
function is to read a multi-line ASCII file describing a scene to be
rendered and produce a file containing the ray traced image.
WWW: http://www-graphics.stanford.edu/~cek/rayshade/

View File

@ -1,33 +1,19 @@
bin/rayshade
share/doc/rayshade/README
share/doc/rayshade/animate.tex
share/doc/rayshade/camera.tex
share/doc/rayshade/guide.tex
share/doc/rayshade/height.tex
share/doc/rayshade/intro.tex
share/doc/rayshade/lights.tex
share/doc/rayshade/objects.tex
share/doc/rayshade/options.tex
share/doc/rayshade/preface.tex
share/doc/rayshade/running.tex
share/doc/rayshade/surfaces.tex
share/doc/rayshade/texture.tex
share/doc/rayshade/transform.tex
share/doc/rayshade/quickref.txt
share/examples/rayshade/ashtray.def.ray
share/examples/rayshade/ashtray.ray
share/examples/rayshade/balls.ray
share/examples/rayshade/blob.ray
share/examples/rayshade/boxball.ray
share/examples/rayshade/coin.ray
share/examples/rayshade/csg.ray
share/examples/rayshade/glass.def.ray
share/examples/rayshade/glass.ray
share/examples/rayshade/mtv.ray
share/examples/rayshade/planet.map
share/examples/rayshade/planet.ray
share/examples/rayshade/pool.ray
share/examples/rayshade/solids.ray
share/examples/rayshade/stripe.ray
@dirrm share/doc/rayshade
@dirrm share/examples/rayshade
%%PORTDOCS%%%%DOCSDIR%%/guide.ps.Z
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTDOCS%%%%EXAMPLESDIR%%/ashtray.def.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/ashtray.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/balls.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/blob.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/boxball.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/coin.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/csg.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/glass.def.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/glass.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/mtv.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/planet.map
%%PORTDOCS%%%%EXAMPLESDIR%%/planet.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/pool.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/solids.ray
%%PORTDOCS%%%%EXAMPLESDIR%%/stripe.ray
%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%