Remove net/ns2, which is practically identical copy of net/ns.

This commit is contained in:
Alexey Dokuchaev 2013-07-29 08:32:16 +00:00
parent 61678df43a
commit 530537e14e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=323875
9 changed files with 1 additions and 228 deletions

1
MOVED
View File

@ -4828,3 +4828,4 @@ x11-toolkits/qwt4||2013-07-26|Has expired: Depends on QT3
x11-wm/bbconf||2013-07-26|Has expired: Depends on QT3
x11-wm/kompmgr||2013-07-26|Has expired: Depends on QT3
audio/artswrapper||2013-07-27|Depend on the expired audio/arts
net/ns2|net/ns|2013-07-29|Duplicate ports merged

View File

@ -441,7 +441,6 @@
SUBDIR += nos-ttb
SUBDIR += nph
SUBDIR += ns
SUBDIR += ns2
SUBDIR += nss-pam-ldapd
SUBDIR += nss-pam-ldapd-sasl
SUBDIR += nss_ldap

View File

@ -1,41 +0,0 @@
# New ports collection makefile for: ns-2
# Date created: 26 April 1999
# Whom: obonilla
#
# $FreeBSD$
#
PORTNAME= ns2
PORTVERSION= 2.35
CATEGORIES= net
MASTER_SITES= SF/nsnam/ns-2/${PORTVERSION}
DISTNAME= ns-src-${PORTVERSION}
MAINTAINER= masaki@club.kyutech.ac.jp
COMMENT= Discrete event simulator for networking research
BUILD_DEPENDS= ${LOCALBASE}/lib/libtclcl.a:${PORTSDIR}/devel/tclcl
MAN1= ns.1
MANCOMPRESSED= no
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-tcl-ver=${TCL_VER} --with-tk-ver=${TK_VER} --x-libraries=${LOCALBASE}/lib --x-includes=${LOCALBASE}/include
USE_GMAKE= yes
USE_TK= 85+
WRKSRC= ${WRKDIR}/ns-${PORTVERSION}
post-patch:
@${REINPLACE_CMD} -e "s,%%LOCALBASE%%,${LOCALBASE},g" \
${WRKSRC}/configure
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/ns ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/ns.1 ${MANPREFIX}/man/man1
.if !defined(NOPORTDOCS)
${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/tcl/ex/*.tcl ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (ns-src-2.35.tar.gz) = 2a32e831bcec7d255042a544577559d15eae67696d0e3d30881cedc1112e2387
SIZE (ns-src-2.35.tar.gz) = 43897172

View File

@ -1,10 +0,0 @@
--- aomdv/aomdv.cc.org 2012-06-04 16:32:39.000000000 +0900
+++ aomdv/aomdv.cc 2012-06-04 16:33:09.000000000 +0900
@@ -82,6 +82,7 @@
//#include <ip.h>
+#include <sys/socket.h>
#include <aomdv/aomdv.h>
#include <aomdv/aomdv_packet.h>
#include <random.h>

View File

@ -1,33 +0,0 @@
--- configure.org 2012-06-04 12:03:13.000000000 +0900
+++ configure 2012-06-04 16:26:34.000000000 +0900
@@ -5571,8 +5571,14 @@
/usr/local/lib/tcl$TCL_HI_VERS \
/usr/local/lib/tcl$TCL_ALT_VERS \
/usr/local/include/tcl$TCL_VERS \
+ %%LOCALBASE%%/include/tcl$TCL_VERS/generic \
+ %%LOCALBASE%%/include/tcl$TCL_VERS/unix \
/usr/local/include/tcl$TCL_HI_VERS \
+ %%LOCALBASE%%/include/tcl$TCL_HI_VERS/generic \
+ %%LOCALBASE%%/include/tcl$TCL_HI_VERS/unix \
/usr/local/include/tcl$TCL_ALT_VERS \
+ %%LOCALBASE%%/include/tcl$TCL_ALT_VERS/generic \
+ %%LOCALBASE%%/include/tcl$TCL_ALT_VERS/unix \
/usr/local/include \
/import/tcl/include/tcl$TCL_VERS \
/import/tcl/include/tcl$TCL_HI_VERS \
@@ -6645,6 +6651,7 @@
../Tcl-$TCLCL_VERS \
../Tcl-$TCLCL_ALT_VERS \
../Tcl \
+ %%LOCALBASE%%/include/tclcl \
/usr/src/local/Tcl \
/usr/src/local/Tcl-1.0 \
/import/Tcl/include \
@@ -6664,6 +6671,7 @@
$x_libraries \
/usr/contrib/lib \
/usr/local/lib \
+ %%LOCALBASE%%/lib \
/usr/lib \
/usr/src/local/Tcl \
/usr/src/local/Tcl-1.0"

View File

@ -1,11 +0,0 @@
--- linkstate/ls.h.org 2012-06-04 21:45:22.000000000 +0900
+++ linkstate/ls.h 2012-06-04 21:45:44.000000000 +0900
@@ -134,7 +134,7 @@
return ib.second ? ib.first : baseMap::end();
}
- void eraseAll() { erase(baseMap::begin(), baseMap::end()); }
+ void eraseAll() { baseMap::erase(baseMap::begin(), baseMap::end()); }
T* findPtr(Key key) {
iterator it = baseMap::find(key);
return (it == baseMap::end()) ? (T *)NULL : &((*it).second);

View File

@ -1,5 +0,0 @@
NS2 is a discrete event simulator targeted at networking research.
NS2 provides substantial support for simulation of TCP, routing,
and multicast protocols.
WWW: http://www.isi.edu/nsnam/ns/

View File

@ -1,125 +0,0 @@
bin/ns
%%EXAMPLESDIR%%/agent-gen-script.tcl
%%EXAMPLESDIR%%/agent-gen.tcl
%%EXAMPLESDIR%%/aomdv.tcl
%%EXAMPLESDIR%%/callback_demo.tcl
%%EXAMPLESDIR%%/dccp.tcl
%%EXAMPLESDIR%%/diffusion-prob-run.tcl
%%EXAMPLESDIR%%/diffusion-rate-run.tcl
%%EXAMPLESDIR%%/dumbbell.tcl
%%EXAMPLESDIR%%/example.tcl
%%EXAMPLESDIR%%/flooding-run.tcl
%%EXAMPLESDIR%%/flooding.tcl
%%EXAMPLESDIR%%/fq-cbr.tcl
%%EXAMPLESDIR%%/fq.tcl
%%EXAMPLESDIR%%/grid2.tcl
%%EXAMPLESDIR%%/gridkeeper.tcl
%%EXAMPLESDIR%%/hier-rtg-10.tcl
%%EXAMPLESDIR%%/hier-rtg-100.tcl
%%EXAMPLESDIR%%/hts100-0.tcl
%%EXAMPLESDIR%%/lantest.tcl
%%EXAMPLESDIR%%/large-scale-web-traffic-old.tcl
%%EXAMPLESDIR%%/large-scale-web-traffic.tcl
%%EXAMPLESDIR%%/large-sim.tcl
%%EXAMPLESDIR%%/mac-test.tcl
%%EXAMPLESDIR%%/many_tcp.tcl
%%EXAMPLESDIR%%/manytcp_trmodel.tcl
%%EXAMPLESDIR%%/mcast.tcl
%%EXAMPLESDIR%%/miptest.tcl
%%EXAMPLESDIR%%/nam-example-em.tcl
%%EXAMPLESDIR%%/nam-example.tcl
%%EXAMPLESDIR%%/nam-large-flowid.tcl
%%EXAMPLESDIR%%/nam-separate-trace.tcl
%%EXAMPLESDIR%%/nam-simplexlink.tcl
%%EXAMPLESDIR%%/omni-run.tcl
%%EXAMPLESDIR%%/pkts.tcl
%%EXAMPLESDIR%%/puma.tcl
%%EXAMPLESDIR%%/ranvar.tcl
%%EXAMPLESDIR%%/rbp_demo.tcl
%%EXAMPLESDIR%%/rc.tcl
%%EXAMPLESDIR%%/redlight.tcl
%%EXAMPLESDIR%%/rng-test.tcl
%%EXAMPLESDIR%%/rng-test2.tcl
%%EXAMPLESDIR%%/route-gen.tcl
%%EXAMPLESDIR%%/sat-aloha.tcl
%%EXAMPLESDIR%%/sat-iridium-links.tcl
%%EXAMPLESDIR%%/sat-iridium-nodes.tcl
%%EXAMPLESDIR%%/sat-iridium.tcl
%%EXAMPLESDIR%%/sat-mixed.tcl
%%EXAMPLESDIR%%/sat-repeater.tcl
%%EXAMPLESDIR%%/sat-teledesic-links.tcl
%%EXAMPLESDIR%%/sat-teledesic-nodes.tcl
%%EXAMPLESDIR%%/sat-teledesic.tcl
%%EXAMPLESDIR%%/sat-wired.tcl
%%EXAMPLESDIR%%/shuttle-mcast.tcl
%%EXAMPLESDIR%%/shuttle.tcl
%%EXAMPLESDIR%%/simple-dyn.tcl
%%EXAMPLESDIR%%/simple-eqp.tcl
%%EXAMPLESDIR%%/simple-eqp1.tcl
%%EXAMPLESDIR%%/simple-fsm-tcp.tcl
%%EXAMPLESDIR%%/simple-heap.tcl
%%EXAMPLESDIR%%/simple-plm.tcl
%%EXAMPLESDIR%%/simple-rtg.tcl
%%EXAMPLESDIR%%/simple-rtp.tcl
%%EXAMPLESDIR%%/simple-tcp.tcl
%%EXAMPLESDIR%%/simple-webcache-comp.tcl
%%EXAMPLESDIR%%/simple-webcache-trace.tcl
%%EXAMPLESDIR%%/simple-webcache.tcl
%%EXAMPLESDIR%%/simple-wireless.tcl
%%EXAMPLESDIR%%/simple.tcl
%%EXAMPLESDIR%%/src_test.tcl
%%EXAMPLESDIR%%/srm-adapt-rep-session.tcl
%%EXAMPLESDIR%%/srm-adapt-rep.tcl
%%EXAMPLESDIR%%/srm-adapt-req-session.tcl
%%EXAMPLESDIR%%/srm-adapt-req.tcl
%%EXAMPLESDIR%%/srm-chain-session.tcl
%%EXAMPLESDIR%%/srm-chain.tcl
%%EXAMPLESDIR%%/srm-demo.tcl
%%EXAMPLESDIR%%/srm-session.tcl
%%EXAMPLESDIR%%/srm-star-session.tcl
%%EXAMPLESDIR%%/srm-star.tcl
%%EXAMPLESDIR%%/srm.tcl
%%EXAMPLESDIR%%/ss.tcl
%%EXAMPLESDIR%%/swp.tcl
%%EXAMPLESDIR%%/t1000.tcl
%%EXAMPLESDIR%%/tcp-et.tcl
%%EXAMPLESDIR%%/tcp-int.tcl
%%EXAMPLESDIR%%/tcpapp.tcl
%%EXAMPLESDIR%%/tcpecn.tcl
%%EXAMPLESDIR%%/tcpsrm.tcl
%%EXAMPLESDIR%%/test-drr.tcl
%%EXAMPLESDIR%%/test-emulator.tcl
%%EXAMPLESDIR%%/test-rcvr.tcl
%%EXAMPLESDIR%%/test-rlm.tcl
%%EXAMPLESDIR%%/test-suite-intserv.tcl
%%EXAMPLESDIR%%/test-suite.tcl
%%EXAMPLESDIR%%/test-tbf.tcl
%%EXAMPLESDIR%%/tg.tcl
%%EXAMPLESDIR%%/topo-gen-script.tcl
%%EXAMPLESDIR%%/topo-gen.tcl
%%EXAMPLESDIR%%/topo-view.tcl
%%EXAMPLESDIR%%/trace-driven.tcl
%%EXAMPLESDIR%%/udpdata.tcl
%%EXAMPLESDIR%%/varybell.tcl
%%EXAMPLESDIR%%/virtual-classifier.tcl
%%EXAMPLESDIR%%/vlantest-flat.tcl
%%EXAMPLESDIR%%/vlantest-hier.tcl
%%EXAMPLESDIR%%/vlantest-mcst.tcl
%%EXAMPLESDIR%%/web-traffic-embobj.tcl
%%EXAMPLESDIR%%/web-traffic.tcl
%%EXAMPLESDIR%%/wired-cum-wireless-sim.tcl
%%EXAMPLESDIR%%/wireless-demo-csci694.tcl
%%EXAMPLESDIR%%/wireless-dsdv-newnode.tcl
%%EXAMPLESDIR%%/wireless-flooding.tcl
%%EXAMPLESDIR%%/wireless-landmark.tcl
%%EXAMPLESDIR%%/wireless-mip-test.tcl
%%EXAMPLESDIR%%/wireless-mitf.tcl
%%EXAMPLESDIR%%/wireless-newnode-energy.tcl
%%EXAMPLESDIR%%/wireless-pkt-demo.tcl
%%EXAMPLESDIR%%/wireless-shadowing-test.tcl
%%EXAMPLESDIR%%/wireless-shadowing-vis-test.tcl
%%EXAMPLESDIR%%/wireless-simple-mac.tcl
%%EXAMPLESDIR%%/wireless-test.tcl
%%EXAMPLESDIR%%/wireless.tcl
%%EXAMPLESDIR%%/worm.tcl
@dirrm %%EXAMPLESDIR%%