- Update to finance/libofx to 0.9.11
- Remake/rename patches - Bump PORTREVISION on dependent ports as the shared library version has increased
This commit is contained in:
parent
4a3989a17e
commit
52eab7776d
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=424012
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= gnucash
|
||||
PORTVERSION= 2.6.14
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= finance gnome
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28stable%29/${PORTVERSION}
|
||||
|
||||
|
@ -3,6 +3,7 @@
|
||||
|
||||
PORTNAME= grisbi
|
||||
PORTVERSION= 1.0.1
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= finance
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20stable/${PORTVERSION:C|1$|x|}/
|
||||
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= homebank
|
||||
PORTVERSION= 5.0.9
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= finance
|
||||
MASTER_SITES= http://homebank.free.fr/public/
|
||||
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= kmymoney
|
||||
PORTVERSION= 4.7.2
|
||||
PORTREVISION= 1
|
||||
PORTREVISION= 2
|
||||
CATEGORIES= finance kde
|
||||
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}/src
|
||||
|
||||
|
@ -2,21 +2,22 @@
|
||||
# $FreeBSD$
|
||||
|
||||
PORTNAME= libofx
|
||||
PORTVERSION= 0.9.10
|
||||
PORTREVISION= 1
|
||||
PORTVERSION= 0.9.11
|
||||
CATEGORIES= finance
|
||||
MASTER_SITES= SF
|
||||
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}
|
||||
|
||||
MAINTAINER= jhale@FreeBSD.org
|
||||
COMMENT= OpenSource implementation of the OFX (Open Financial eXchange)
|
||||
|
||||
LICENSE= GPLv2
|
||||
LICENSE_FILE= ${WRKSRC}/COPYING
|
||||
|
||||
LIB_DEPENDS= libcurl.so:ftp/curl \
|
||||
libxml++-2.6.so:textproc/libxml++26 \
|
||||
libosp.so:textproc/opensp
|
||||
|
||||
USES= gmake iconv pkgconfig pathfix libtool
|
||||
USES= gettext-runtime gmake iconv libtool localbase pathfix pkgconfig
|
||||
USE_GNOME= glib20 glibmm libsigc++20 libxml2
|
||||
CONFIGURE_ARGS= --disable-doxygen --disable-dot --disable-gengetopt \
|
||||
--with-opensp-includes=${LOCALBASE}/include/OpenSP \
|
||||
--with-opensp-libs=${LOCALBASE}/lib
|
||||
@ -25,9 +26,6 @@ USE_LDCONFIG= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
PORTDOCS= *
|
||||
|
||||
CPPFLAGS+= -I${LOCALBASE}/include
|
||||
LDFLAGS+= -L${LOCALBASE}/lib
|
||||
|
||||
OPTIONS_DEFINE= DOCS
|
||||
|
||||
post-install:
|
||||
|
@ -1,2 +1,3 @@
|
||||
SHA256 (libofx-0.9.10.tar.gz) = 54e26a4944ef2785087cfd8ed8f187ab9d397d9b92b5acc199dd7d5d095cf695
|
||||
SIZE (libofx-0.9.10.tar.gz) = 1433837
|
||||
TIMESTAMP = 1474456703
|
||||
SHA256 (libofx-0.9.11.tar.gz) = b0115c876bee5df84002a96f58cca8d73ef7b75d799d6a3a44905c34a8cfe94f
|
||||
SIZE (libofx-0.9.11.tar.gz) = 1097501
|
||||
|
@ -1,6 +1,6 @@
|
||||
--- ./lib/Makefile.in.orig 2014-06-22 19:45:04.000000000 -0400
|
||||
+++ ./lib/Makefile.in 2014-06-22 19:46:20.000000000 -0400
|
||||
@@ -299,7 +299,7 @@
|
||||
--- lib/Makefile.in.orig 2016-10-15 10:42:55 UTC
|
||||
+++ lib/Makefile.in
|
||||
@@ -400,7 +400,7 @@ AM_CPPFLAGS = \
|
||||
|
||||
|
||||
#libofx_la_LIBADD = @LIBOBJS@ ${OPENSPLIBS} -lstdc++
|
@ -1,6 +1,6 @@
|
||||
--- ./lib/ofx_utilities.cpp.orig 2013-04-16 15:50:51.000000000 -0400
|
||||
+++ ./lib/ofx_utilities.cpp 2014-06-22 19:44:48.000000000 -0400
|
||||
@@ -115,9 +115,14 @@
|
||||
--- lib/ofx_utilities.cpp.orig 2013-04-16 19:50:51 UTC
|
||||
+++ lib/ofx_utilities.cpp
|
||||
@@ -115,9 +115,14 @@ time_t ofxdate_to_time_t(const string of
|
||||
char time_zone_specified = false;
|
||||
string ofxdate_whole;
|
||||
time_t temptime;
|
@ -1,5 +1,5 @@
|
||||
--- ./ofxconnect/ofxpartner.cpp.orig 2013-04-16 15:50:51.000000000 -0400
|
||||
+++ ./ofxconnect/ofxpartner.cpp 2014-06-22 19:44:48.000000000 -0400
|
||||
--- ofxconnect/ofxpartner.cpp.orig 2013-04-16 19:50:51 UTC
|
||||
+++ ofxconnect/ofxpartner.cpp
|
||||
@@ -37,6 +37,7 @@
|
||||
#include <vector>
|
||||
#include <algorithm>
|
@ -4,8 +4,8 @@ bin/ofxdump
|
||||
include/libofx/libofx.h
|
||||
lib/libofx.a
|
||||
lib/libofx.so
|
||||
lib/libofx.so.6
|
||||
lib/libofx.so.6.0.0
|
||||
lib/libofx.so.7
|
||||
lib/libofx.so.7.0.0
|
||||
libdata/pkgconfig/libofx.pc
|
||||
man/man1/ofxconnect.1.gz
|
||||
man/man1/ofxdump.1.gz
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= skrooge
|
||||
PORTVERSION= 1.12.5
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= finance kde
|
||||
MASTER_SITES= KDE/stable/${PORTNAME}
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user