sysutils/condor: update 8.2.6 -> 8.2.8

Update to latest stable release, canonicalize patch filenames, eliminate
GCC dependency and MAKE_JOBS_UNSAFE, replace files/condor_config.in with
version-specific example file provided in the dist, move sample files to
etc/*.sample, improvements to condor_config.local.sample and
condor-config script, make rc script more reliable by replacing fixed
sleep delays with more intelligent wait loops.

PR:                  200713
Submitted by:        jwbacon@tds.net (maintainer)
This commit is contained in:
Philip M. Gollucci 2015-07-10 04:07:17 +00:00
parent af3609454e
commit 52e98e03cc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=391689
19 changed files with 93 additions and 2647 deletions

View File

@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= condor
PORTVERSION= 8.2.6
PORTVERSION= 8.2.8
CATEGORIES= sysutils net
MASTER_SITES= http://www.acadix.biz/Ports/distfiles/
DISTNAME= condor_src-${PORTVERSION}-all-all
@ -22,8 +22,6 @@ USE_LDCONFIG= yes
# Does not build with Python 3
USES= cmake cpe gmake perl5 pgsql python:2 shebangfix
CPE_VENDOR= condor_project
# Does not build with gcc 4.2 or clang
USE_GCC= yes
SHEBANG_FILES= src/condor_scripts/condor_qsub \
src/condor_gridmanager/remote_gahp \
src/condor_examples/condor_limits_wrapper.sh \
@ -39,7 +37,9 @@ CMAKE_ARGS+= -DCMAKE_CXX_FLAGS:STRING=${CXXFLAGS} \
-DPYTHON_INCLUDE_DIR:PATH=${LOCALBASE}/include/${PYTHON_VERSION} \
-DPYTHON_LIBRARY:FILEPATH=${LOCALBASE}/lib/lib${PYTHON_VERSION}.so
MAKE_JOBS_UNSAFE= yes
# This was an issue in previous releases, but I've tested 8.2.8 extensively
# on machines with as many as 16 cores.
# MAKE_JOBS_UNSAFE= yes
SUB_FILES= condor-config condor_config.local pkg-message
@ -81,8 +81,9 @@ post-patch:
post-install:
${INSTALL_DATA} \
${STAGEDIR}${ETCDIR}/examples/condor_config.annotated \
${STAGEDIR}${ETCDIR}/condor_config
${INSTALL_DATA} ${WRKDIR}/condor_config.local ${STAGEDIR}${ETCDIR}
${STAGEDIR}${PREFIX}/etc/condor_config.sample
${INSTALL_DATA} ${WRKDIR}/condor_config.local \
${STAGEDIR}${PREFIX}/etc/condor_config.local.sample
${INSTALL_SCRIPT} ${WRKDIR}/condor-config ${STAGEDIR}${PREFIX}/sbin
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
SHA256 (condor_src-8.2.6-all-all.tar.gz) = a63c3b7c0d44635089ded80dadd5ebde5acba87154ca72877c76b80cdc963837
SIZE (condor_src-8.2.6-all-all.tar.gz) = 19137825
SHA256 (condor_src-8.2.8-all-all.tar.gz) = 4a51232f07ecd6648a8dddeebe92e82ee18e3c4819589c83bbd443189c4a7ded
SIZE (condor_src-8.2.8-all-all.tar.gz) = 19137676

View File

@ -5,6 +5,12 @@ if [ -z $EDITOR ]; then
export EDITOR
fi
for file in condor_config condor_config.local; do
if [ ! -e %%PREFIX%%/etc/$file ]; then
cp %%PREFIX%%/etc/$file.sample %%PREFIX%%/etc/$file
fi
done
$EDITOR %%PREFIX%%/etc/condor_config.local
printf "Restart HTCondor? (y/[n]) "
@ -16,7 +22,6 @@ if [ 0$restart = 0y ]; then
ps ax | grep condor
service condor start
sleep 5
printf "\nCondor processes running after start:\n\n"
ps ax | grep condor
fi

View File

@ -29,14 +29,29 @@ stop_cmd=condor_stop
condor_start() {
checkyesno condor_enable && echo "Starting condor_master." && \
%%PREFIX%%/sbin/condor_master ${condor_flags}
while ! ps ax | egrep -v 'grep|rc\.d' | grep -q condor; do
echo 'Waiting for daemons to start...'
sleep 2
done
}
condor_stop() {
# FIXME: condor_off with no arguments should be the same as
# -daemon master according to the man page, but it doesn't work
checkyesno condor_enable && echo "Stopping condor_master." && \
%%PREFIX%%/sbin/condor_off -master
/usr/local/sbin/condor_off -daemon master
# Prevent restart command from issuing start before daemons are down
echo 'Waiting for daemons to shut down...'
sleep 5
tries=1
while ps ax | egrep -v 'grep|rc\.d' | grep -q condor; do
echo 'Waiting for daemons to shut down...'
sleep 2
tries=$(($tries + 1))
if [ $tries = 10 ]; then
printf "condor_off has failed. Force killing condor_master...\n"
killall condor_master
sleep 2
fi
done
}
run_rc_command "$1"

File diff suppressed because it is too large Load Diff

View File

@ -27,15 +27,24 @@ COLLECTOR_NAME = Condor pool at $(CONDOR_HOST)
############################################################################
# Location of logs, job output, etc.
# Put this on a local partition with plenty of space for job output.
# Default is $(TILDE) = /home/condor.
# $(TILDE) = /home/condor.
LOCAL_DIR = $(TILDE)
# /home is often shared by cluster compute nodes, so log files would collide
# If /home is shared by cluster compute nodes, log files would collide
# when using $(TILDE). Put LOCAL_DIR on some other large, local partition.
# LOCAL_DIR = /usr/condor
############################################################################
# Use dynamic provisioning to allow multicore jobs (e.g. openmp) on
# hosts with multiple cores available to HTCondor.
NUM_SLOTS=1
NUM_SLOTS_TYPE_1=1
SLOT_TYPE_1=100%
SLOT_TYPE_1_PARTITIONABLE=true
############################################################################
# When is this machine willing to start a job?
@ -43,13 +52,13 @@ LOCAL_DIR = $(TILDE)
# START = TRUE
# For compute hosts used primarily for other purposes
START = (KeyboardIdle > 15 * 60) && ((LoadAvg - CondorLoadAvg) <= 0.3)
START = (KeyboardIdle > 15 * 60) && ((LoadAvg - CondorLoadAvg) <= 0.5)
# For VM host, assuming we only want to run jobs in the VM
# START = False
# For VM guest, run jobs only when the host is not being used by owner
# START = ( HOST_KeyboardIdle > 150 ) && ( HOST_LoadAvg <= 0.3 ) )
# START = ( HOST_KeyboardIdle > 150 ) && ( HOST_LoadAvg <= 0.5 ) )
############################################################################
# When to suspend a job?
@ -63,7 +72,7 @@ SUSPEND = FALSE
# PREEMPT = FALSE
# Compute host used mainly for non-Condor activities
PREEMPT = (KeyboardIdle < 60) || (LoadAvg - CondorLoadAvg > 0.3)
PREEMPT = (KeyboardIdle < 60) || (LoadAvg - CondorLoadAvg > 0.5)
############################################################################
# When to instantaneously kill a preempting job
@ -88,7 +97,7 @@ KILL = FALSE
# Central manager
# DAEMON_LIST = MASTER, COLLECTOR, NEGOTIATOR, SCHEDD
# Submit/execute host
# Submit and execute host
# DAEMON_LIST = MASTER, SCHEDD, STARTD
# DAEMON_LIST = MASTER, SCHEDD, STARTD, SHARED_PORT

View File

@ -1,11 +1,11 @@
--- build/cmake/CondorPackageConfig.cmake.orig 2013-09-19 15:12:10.000000000 -0500
+++ build/cmake/CondorPackageConfig.cmake 2013-10-20 12:04:52.000000000 -0500
--- build/cmake/CondorPackageConfig.cmake.orig 2015-04-07 15:10:11 UTC
+++ build/cmake/CondorPackageConfig.cmake
@@ -1,3 +1,4 @@
+
###############################################################
#
# Copyright 2011 Red Hat, Inc.
@@ -170,6 +171,23 @@
@@ -174,6 +175,23 @@ if(${OS_NAME} STREQUAL "DARWIN")
# enable if we desire native packaging.
# set ( CPACK_GENERATOR "${CPACK_GENERATOR};PackageMaker" ) ;
# set (CPACK_OSX_PACKAGE_VERSION)

View File

@ -1,6 +1,6 @@
--- build/cmake/macros/SystemSpecificInformations.cmake.orig 2014-11-26 11:22:10.000000000 -0600
+++ build/cmake/macros/SystemSpecificInformations.cmake 2014-12-27 16:30:27.000000000 -0600
@@ -252,7 +252,8 @@
--- build/cmake/macros/SystemSpecificInformations.cmake.orig 2015-04-07 15:10:11 UTC
+++ build/cmake/macros/SystemSpecificInformations.cmake
@@ -252,7 +252,8 @@ if(UNIX)
endif(EXISTS "/etc/issue")
elseif(CMAKE_SYSTEM_NAME MATCHES "FreeBSD")
@ -10,7 +10,7 @@
set( FREEBSD_RELEASE "${CMAKE_MATCH_1}" )
set( FREEBSD_MAJOR "${CMAKE_MATCH_2}" )
set( FREEBSD_MINOR "${CMAKE_MATCH_3}" )
@@ -270,6 +271,15 @@
@@ -270,6 +271,15 @@ if(UNIX)
set( CONDOR_FREEBSD7 ON )
elseif(FREEBSD_MAJOR MATCHES "8" )
set( CONDOR_FREEBSD8 ON )

View File

@ -1,6 +1,6 @@
--- src/condor_includes/condor_crypt_3des.h.orig 2014-12-09 23:15:18.000000000 +0100
+++ src/condor_includes/condor_crypt_3des.h 2015-02-28 19:35:54.722059602 +0100
@@ -61,7 +61,7 @@
--- src/condor_includes/condor_crypt_3des.h.orig 2015-04-07 15:10:11 UTC
+++ src/condor_includes/condor_crypt_3des.h
@@ -61,7 +61,7 @@ class Condor_Crypt_3des : public Condor_
//------------------------------------------
// Private constructor
//------------------------------------------

View File

@ -1,5 +1,5 @@
--- src/condor_includes/config.h.cmake.orig 2014-11-26 11:22:10.000000000 -0600
+++ src/condor_includes/config.h.cmake 2014-12-27 17:19:56.000000000 -0600
--- src/condor_includes/config.h.cmake.orig 2015-04-07 15:10:11 UTC
+++ src/condor_includes/config.h.cmake
@@ -16,7 +16,11 @@
*
*************************************************************/

View File

@ -1,6 +1,6 @@
--- src/condor_io/condor_crypt_3des.cpp.orig 2014-12-09 23:15:18.000000000 +0100
+++ src/condor_io/condor_crypt_3des.cpp 2015-02-28 19:38:25.216863132 +0100
@@ -35,9 +35,9 @@
--- src/condor_io/condor_crypt_3des.cpp.orig 2015-04-07 15:10:11 UTC
+++ src/condor_io/condor_crypt_3des.cpp
@@ -35,9 +35,9 @@ Condor_Crypt_3des :: Condor_Crypt_3des(c
unsigned char * keyData = k.getPaddedKeyData(24);
ASSERT(keyData);
@ -13,7 +13,7 @@
// initialize ivsec
resetState();
@@ -71,9 +71,9 @@
@@ -71,9 +71,9 @@ bool Condor_Crypt_3des :: encrypt(unsign
output = (unsigned char *) malloc(input_len);
if (output) {
@ -26,7 +26,7 @@
return true;
}
else {
@@ -95,9 +95,9 @@
@@ -95,9 +95,9 @@ bool Condor_Crypt_3des :: decrypt(unsign
if (output) {
output_len = input_len;

View File

@ -1,6 +1,6 @@
--- src/condor_power/power_state.cpp.orig 2014-12-26 11:28:32.000000000 -0600
+++ src/condor_power/power_state.cpp 2014-12-26 17:17:04.000000000 -0600
@@ -57,7 +57,8 @@
--- src/condor_power/power_state.cpp.orig 2015-04-07 15:10:11 UTC
+++ src/condor_power/power_state.cpp
@@ -57,7 +57,8 @@ enum
E_ARGCNT = -6, /* too few/many arguments */
E_NOREST = -7, /* failed to switch the machine's power state */
E_CLASSAD = -8, /* error in class-ad (errno = %d) */
@ -10,7 +10,7 @@
};
/** Error messages */
@@ -72,7 +73,8 @@
@@ -72,7 +73,8 @@ static const char *errmsgs[] = {
/* E_ARGCNT -6 */ "wrong number of arguments.\n",
/* E_NOREST -7 */ "failed to switch the machine's power state.\n",
/* E_CLASSAD -8 */ "error in class-ad (errno = %d).\n",
@ -20,7 +20,7 @@
};
/** Typedefs */
@@ -257,6 +259,8 @@
@@ -257,6 +259,8 @@ main( int argc, const char *argv[] )
/** Create the hibernation mechanism. */
# if ( HIBERNATOR_TYPE_DEFINED )
hibernator = new RealHibernator;

View File

@ -1,6 +1,6 @@
--- src/condor_sysapi/idle_time.cpp.orig 2014-11-26 11:22:10.000000000 -0600
+++ src/condor_sysapi/idle_time.cpp 2014-12-27 16:42:00.000000000 -0600
@@ -205,19 +205,28 @@
--- src/condor_sysapi/idle_time.cpp.orig 2015-04-07 15:10:11 UTC
+++ src/condor_sysapi/idle_time.cpp
@@ -205,19 +205,28 @@ calc_idle_time_cpp( time_t & m_idle, tim
return;
}

View File

@ -1,20 +1,20 @@
--- src/condor_utils/condor_config.cpp.orig 2012-04-07 14:37:20.000000000 -0500
+++ src/condor_utils/condor_config.cpp 2012-04-07 14:38:55.000000000 -0500
@@ -656,7 +656,7 @@
--- src/condor_utils/condor_config.cpp.orig 2015-04-07 15:10:11 UTC
+++ src/condor_utils/condor_config.cpp
@@ -910,7 +910,7 @@ real_config(const char* host, int wantsQ
fprintf(stderr,"\nNeither the environment variable %s_CONFIG,\n",
myDistro->GetUc() );
# if defined UNIX
- fprintf(stderr,"/etc/%s/, nor ~%s/ contain a %s_config source.\n",
+ fprintf(stderr,"/usr/local/etc/%s/, nor ~%s/ contain a %s_config source.\n",
+ fprintf(stderr,"/etc/%s/, /usr/local/etc/, nor ~%s/ contain a %s_config source.\n",
myDistro->Get(), myDistro->Get(), myDistro->Get() );
# elif defined WIN32
fprintf(stderr,"nor the registry contains a %s_config source.\n", myDistro->Get() );
@@ -666,7 +666,7 @@
@@ -920,7 +920,7 @@ real_config(const char* host, int wantsQ
fprintf( stderr,"Either set %s_CONFIG to point to a valid config "
"source,\n", myDistro->GetUc() );
# if defined UNIX
- fprintf( stderr,"or put a \"%s_config\" file in /etc/%s or ~%s/\n",
+ fprintf( stderr,"or put a \"%s_config\" file in /usr/local/etc/%s or ~%s/\n",
+ fprintf( stderr,"or put a \"%s_config\" file in /etc/%s/ /usr/local/etc/ or ~%s/\n",
myDistro->Get(), myDistro->Get(), myDistro->Get() );
# elif defined WIN32
fprintf( stderr,"or put a \"%s_config\" source in the registry at:\n"

View File

@ -1,5 +1,5 @@
--- src/python-bindings/dc_tool.cpp.orig 2014-11-26 11:22:10.000000000 -0600
+++ src/python-bindings/dc_tool.cpp 2014-12-27 16:40:45.000000000 -0600
--- src/python-bindings/dc_tool.cpp.orig 2015-04-07 15:10:11 UTC
+++ src/python-bindings/dc_tool.cpp
@@ -7,6 +7,21 @@
# include <pyport.h>
# endif

View File

@ -1,5 +1,5 @@
--- src/python-bindings/secman.cpp.orig 2014-11-26 11:22:10.000000000 -0600
+++ src/python-bindings/secman.cpp 2014-12-27 16:27:22.000000000 -0600
--- src/python-bindings/secman.cpp.orig 2015-04-07 15:10:11 UTC
+++ src/python-bindings/secman.cpp
@@ -7,6 +7,21 @@
# include <pyport.h>
# endif

View File

@ -1,7 +1,5 @@
Sample condor_config and condor_config.local files are available in
%%ETCDIR%%. Copy them to %%PREFIX%%/etc and edit condor_config.local to taste
to get started.
Edit %%PREFIX%%/etc/condor_config.local to taste to get started.
Settings in condor_config.local override the defaults in condor_config.
Use condor_config as a reference, and make all changes to condor_config.local.

View File

@ -25,12 +25,12 @@ DEINSTALL)
# the syadmin is left to deal with this.
# Remove the link to /home/condor
/bin/rm -f /var/db/condor
rm -f /var/db/condor
# Remove /home/condor, if empty
/bin/rmdir /home/condor/config
/bin/rmdir /home/condor/execute
/bin/rmdir /home/condor/log
/bin/rmdir /home/condor/spool
/bin/rmdir /home/condor
rmdir /home/condor/config
rmdir /home/condor/execute
rmdir /home/condor/log
rmdir /home/condor/spool
rmdir /home/condor
;;
esac

View File

@ -42,9 +42,10 @@ bin/condor_vacate_job
bin/condor_version
bin/condor_wait
bin/condor_who
@sample etc/condor_config.sample
@sample etc/condor_config.local.sample
%%ETCDIR%%/condor
%%ETCDIR%%/condor_config
%%ETCDIR%%/condor_config.local
%%ETCDIR%%/examples/README
%%ETCDIR%%/examples/condor.boot.generic
%%ETCDIR%%/examples/condor.boot.rpm
@ -126,7 +127,7 @@ lib/condor_ssh_to_job_sshd_config_template
lib/libchirp_client.a
lib/libclassad.a
lib/libcondorapi.a
lib/libpyclassad%%PYTHON_VER%%_8_2_6.a
lib/libpyclassad%%PYTHON_VER%%_8_2_8.a
lib/python/classad.so
lib/python/htcondor.so
lib/scimark2lib.jar