- Add 2.0-20071128 as libffi-devel
PR: ports/118309 Submitted by: Bjoern Koenig <bkoenig@alpha-tierchen.de> Repocopied by: marcus
This commit is contained in:
parent
75e3c4b7e7
commit
52e8296774
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=203753
@ -575,6 +575,7 @@
|
||||
SUBDIR += libevocosm
|
||||
SUBDIR += libexecinfo
|
||||
SUBDIR += libffi
|
||||
SUBDIR += libffi-devel
|
||||
SUBDIR += libfs++
|
||||
SUBDIR += libftdi
|
||||
SUBDIR += libg++
|
||||
|
@ -1,29 +1,25 @@
|
||||
# New ports collection makefile for: libffi
|
||||
# Date created: 14, June, 1998
|
||||
# Whom: Horance Chou <horance@freedom.ie.cycu.edu.tw>
|
||||
# New ports collection makefile for: libffi-devel
|
||||
# Date created: 28 Nov 2007
|
||||
# Whom: Björn König <bkoenig@alpha-tierchen.de
|
||||
#
|
||||
# $FreeBSD$
|
||||
#
|
||||
|
||||
PORTNAME= libffi
|
||||
PORTVERSION= 1.20
|
||||
PORTREVISION= 1
|
||||
DISTVERSION= 2.0-20071128
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://sources.redhat.com/pub/libffi/
|
||||
MASTER_SITES= ftp://ftp.alpha-tierchen.de/pub/FreeBSD/ports/distfiles/
|
||||
PKGNAMESUFFIX= -devel
|
||||
|
||||
MAINTAINER= horance@freera.net
|
||||
MAINTAINER= bkoenig@alpha-tierchen.de
|
||||
COMMENT= Foreign Function Interface
|
||||
|
||||
USE_AUTOTOOLS= libtool:15
|
||||
INSTALLS_SHLIB= yes
|
||||
CONFIGURE_TARGET= # empty
|
||||
WRKSRC= ${WRKDIR}/${PORTNAME}
|
||||
|
||||
CONFLICTS= gcc-3*
|
||||
GNU_CONFIGURE= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
USE_BZIP2= yes
|
||||
USE_LDCONFIG= yes
|
||||
CONFLICTS= gcc-3* libffi-[0-9]*
|
||||
|
||||
.if ${ARCH} != "i386" && ${ARCH} != "alpha"
|
||||
BROKEN= "Configure fails on !i386 and !alpha"
|
||||
.endif
|
||||
|
||||
.include <bsd.port.post.mk>
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (libffi-1.20.tar.gz) = e4c9c435ebdfcba6fa493fb1abce2ddc
|
||||
SHA256 (libffi-1.20.tar.gz) = 794a23a3feacc11ef431fae9ad79c33b98043cefd6b001707596ca93085dedaa
|
||||
SIZE (libffi-1.20.tar.gz) = 109484
|
||||
MD5 (libffi-2.0-20071128.tar.bz2) = 0bcab912212635eed8d5c6ddfdb6d0a8
|
||||
SHA256 (libffi-2.0-20071128.tar.bz2) = 19dc2d51351fe4d1885ba8e202ff86049d762ea3e180ff587781444fb9b5a199
|
||||
SIZE (libffi-2.0-20071128.tar.bz2) = 384699
|
||||
|
@ -1,11 +0,0 @@
|
||||
--- configure.orig Mon Oct 5 04:26:04 1998
|
||||
+++ configure Sun May 30 19:01:51 1999
|
||||
@@ -1415,6 +1415,8 @@
|
||||
case "$host" in
|
||||
mips-sgi-irix5.* | mips-sgi-irix6.*) TARGET=MIPS; TARGETDIR=mips;;
|
||||
i*86-pc-linux*) TARGET=X86; TARGETDIR=x86;;
|
||||
+i*86-unknown-freebsd*) TARGET=X86; TARGETDIR=x86;;
|
||||
+alpha-unknown-freebsd*) TARGET=ALPHA; TARGETDIR=alpha;;
|
||||
sparc-sun-4*) TARGET=SPARC; TARGETDIR=sparc;;
|
||||
sparc-sun-*) TARGET=SPARC; TARGETDIR=sparc;;
|
||||
alpha*-*-linux* | alpha*-*-osf*) TARGET=ALPHA; TARGETDIR=alpha;;
|
@ -1,11 +0,0 @@
|
||||
--- src/x86/sysv.S.orig Mon Oct 5 16:36:28 1998
|
||||
+++ src/x86/sysv.S Sat Oct 24 00:56:07 1998
|
||||
@@ -33,7 +33,7 @@
|
||||
.globl ffi_prep_args
|
||||
|
||||
# This assumes we are using gas.
|
||||
- .balign 16
|
||||
+ .align 4
|
||||
.globl ffi_call_SYSV
|
||||
.type ffi_call_SYSV,@function
|
||||
|
@ -1,20 +0,0 @@
|
||||
--- src/Makefile.in.orig Mon Oct 5 04:26:33 1998
|
||||
+++ src/Makefile.in Sun May 30 21:48:55 1999
|
||||
@@ -164,7 +164,7 @@
|
||||
SOURCES = $(libffi_la_SOURCES) $(ffitest_SOURCES)
|
||||
OBJECTS = $(libffi_la_OBJECTS) $(ffitest_OBJECTS)
|
||||
|
||||
-all: Makefile $(LTLIBRARIES) $(PROGRAMS)
|
||||
+all: Makefile $(LTLIBRARIES)
|
||||
|
||||
.SUFFIXES:
|
||||
.SUFFIXES: .S .c .lo .o .s
|
||||
@@ -296,7 +296,7 @@
|
||||
done
|
||||
debug.o debug.lo: debug.c ../include/ffi.h ../fficonfig.h \
|
||||
../include/ffi_common.h
|
||||
-ffi.o ffi.lo: x86/ffi.c ../include/ffi.h ../fficonfig.h \
|
||||
+ffi.o ffi.lo: @TARGETDIR@/ffi.c ../include/ffi.h ../fficonfig.h \
|
||||
../include/ffi_common.h
|
||||
ffitest.o ffitest.lo: ffitest.c ../include/ffi.h ../fficonfig.h
|
||||
prep_cif.o prep_cif.lo: prep_cif.c ../include/ffi.h ../fficonfig.h \
|
29
devel/libffi-devel/files/patch-configure
Normal file
29
devel/libffi-devel/files/patch-configure
Normal file
@ -0,0 +1,29 @@
|
||||
--- configure.orig 2006-12-24 23:12:11.000000000 +0000
|
||||
+++ configure 2007-11-28 10:21:03.000000000 +0000
|
||||
@@ -19483,12 +19483,13 @@
|
||||
powerpc*-*-rtems*) TARGET=POWERPC; TARGETDIR=powerpc;;
|
||||
rs6000-*-aix*) TARGET=POWERPC_AIX; TARGETDIR=powerpc;;
|
||||
arm*-*-linux-*) TARGET=ARM; TARGETDIR=arm;;
|
||||
+arm-*-freebsd*) TARGET=ARM; TARGETDIR=arm;;
|
||||
arm*-*-netbsdelf* | arm*-*-knetbsd*-gnu) TARGET=ARM; TARGETDIR=arm;;
|
||||
arm*-*-rtems*) TARGET=ARM; TARGETDIR=arm;;
|
||||
cris-*-*) TARGET=LIBFFI_CRIS; TARGETDIR=cris;;
|
||||
s390-*-linux-*) TARGET=S390; TARGETDIR=s390;;
|
||||
s390x-*-linux-*) TARGET=S390; TARGETDIR=s390;;
|
||||
-x86_64-*-linux* | x86_64-*-freebsd* | x86_64-*-kfreebsd*-gnu) TARGET=X86_64; TARGETDIR=x86;;
|
||||
+x86_64-*-linux* | amd64-*-freebsd* | amd64-*-kfreebsd*-gnu) TARGET=X86_64; TARGETDIR=x86;;
|
||||
x86_64-*-darwin*) TARGET=X86_DARWIN; TARGETDIR=x86;;
|
||||
sh-*-linux* | sh[34]*-*-linux*) TARGET=SH; TARGETDIR=sh;;
|
||||
sh-*-rtems*) TARGET=SH; TARGETDIR=sh;;
|
||||
@@ -21725,11 +21726,6 @@
|
||||
toolexecdir='$(libdir)/gcc-lib/$(target_alias)'
|
||||
toolexeclibdir='$(libdir)'
|
||||
fi
|
||||
-multi_os_directory=`$CC -print-multi-os-directory`
|
||||
-case $multi_os_directory in
|
||||
- .) ;; # Avoid trailing /.
|
||||
- *) toolexeclibdir=$toolexeclibdir/$multi_os_directory ;;
|
||||
-esac
|
||||
|
||||
|
||||
|
@ -1,7 +1,6 @@
|
||||
include/fficonfig.h
|
||||
include/ffi.h
|
||||
include/ffi_mips.h
|
||||
include/ffitarget.h
|
||||
lib/libffi.a
|
||||
lib/libffi.la
|
||||
lib/libffi.so
|
||||
lib/libffi.so.2
|
||||
lib/libffi.so.4
|
||||
|
Loading…
Reference in New Issue
Block a user