Updated to use Coda-5.3.8

removed patches that should no longer be necessary.
This commit is contained in:
Shafeeq Sinnamohideen 2000-06-29 16:25:07 +00:00
parent 4aef356c02
commit 52df72c12d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29987
4 changed files with 22 additions and 16 deletions

View File

@ -13,7 +13,7 @@ PKGNAMESUFFIX= -${CODA_SUITE}
DISTNAME= coda-${PORTVERSION}
EXTRACT_SUFX= .tgz
MAINTAINER= rvb@cs.cmu.edu
MAINTAINER= coda@cs.cmu.edu
LIB_DEPENDS= gdbm.2:${PORTSDIR}/databases/gdbm \
lwp.1:${PORTSDIR}/devel/lwp \
@ -28,6 +28,6 @@ USE_GMAKE= yes
CONFIGURE_ARGS?= --sysconfdir=${PREFIX}/etc/rc.d
CODA_SUITE?= server
CODA_VERSION?= 5.3.7
CODA_VERSION?= 5.3.8
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (coda-5.3.7.tgz) = 009564d134b26af04e95b93b6512cf63
MD5 (coda-5.3.8.tgz) = d5ee7f45e2b9d0732b8fb3d21a7dfd5c

View File

@ -1,16 +1,21 @@
Some bug inside gcc version 2.95.2 19991024 (release) because
resolver.cc will not compile without -pedantic. Go figure.
Adding -pedantic to CXXFLAGS just breaks the other src files.
--- Makefile.in.ORIG Thu Apr 13 14:36:15 2000
+++ coda-src/asr/Makefile.in Thu Apr 13 14:37:56 2000
@@ -44,6 +44,9 @@
--- rc.vice.in Mon May 15 10:41:07 2000
+++ coda-src/scripts/rc.vice.in Wed Jun 28 17:07:15 2000
@@ -58,7 +58,7 @@
}
YFLAGS= -d
# See how we were called.
-case "$1" in
+case "${1:-start}" in
start)
# start auth2 & update stuff: first the scm case
echon "Starting Coda Services: "
@@ -126,6 +126,7 @@
+resolver.o: resolver.cc
+ $(CXX) $(CXXFLAGS) -pedantic -c $<
+
resolver_parser.c: resolver_parser.h
resolver_parser.h: resolver_parser.y
$(YACC) $(YFLAGS) $< && mv y.tab.c $*.c && mv y.tab.h $*.h
*)
echo "Usage: $0 {start|stop}"
+ echo " no parameters mean start"
exit 1
esac

View File

@ -6,6 +6,7 @@ sbin/auth2
sbin/backup
sbin/backup.sh
sbin/bldvldb.sh
sbin/codaconfedit
sbin/codasrv
sbin/codastart
sbin/createvol_rep