- Update to version 1.0-rc4
- Convert to PLIST_FILES Approved by: maintainer (lme)
This commit is contained in:
parent
241777bb51
commit
52c57401d2
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=239780
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= aircrack-ng
|
||||
DISTVERSION= 1.0-rc1
|
||||
DISTVERSION= 1.0-rc4
|
||||
CATEGORIES= net-mgmt security
|
||||
MASTER_SITES= http://download.aircrack-ng.org/ \
|
||||
http://bsd-geek.de/FreeBSD/distfiles/
|
||||
@ -15,13 +15,21 @@ MAINTAINER= lme@FreeBSD.org
|
||||
COMMENT= An 802.11 WEP and WPA-PSK keys cracking program
|
||||
|
||||
USE_GMAKE= yes
|
||||
MAKE_ARGS+= UNSTABLE=true # build some extra tools
|
||||
USE_OPENSSL= yes
|
||||
SUB_FILES= pkg-message
|
||||
|
||||
MAN1= aircrack-ng.1 airdriver-ng.1 airdecap-ng.1 aireplay-ng.1 \
|
||||
airodump-ng.1 airolib-ng.1 airmon-ng.1 airsev-ng.1 \
|
||||
airtun-ng.1 buddy-ng.1 easside-ng.1 ivstools.1 kstats.1 \
|
||||
makeivs-ng.1 packetforge-ng.1 wesside-ng.1
|
||||
MAN1= airbase-ng.1 aircrack-ng.1 airdecap-ng.1 airdecloak-ng.1 \
|
||||
aireplay-ng.1 airodump-ng.1 airserv-ng.1 airtun-ng.1 \
|
||||
buddy-ng.1 easside-ng.1 ivstools.1 kstats.1 makeivs-ng.1 \
|
||||
packetforge-ng.1 tkiptun-ng.1 wesside-ng.1
|
||||
|
||||
PLIST_FILES= bin/aircrack-ng bin/airdecap-ng bin/airdecloak-ng \
|
||||
bin/buddy-ng bin/ivstools bin/kstats bin/makeivs-ng \
|
||||
bin/packetforge-ng \
|
||||
sbin/airbase-ng sbin/aireplay-ng sbin/airodump-ng \
|
||||
sbin/airserv-ng sbin/airtun-ng sbin/easside-ng \
|
||||
sbin/tkiptun-ng sbin/wesside-ng
|
||||
|
||||
OPTIONS= SQLITE "Use SQLite for storing pre-computed key tables" off
|
||||
|
||||
@ -30,9 +38,8 @@ OPTIONS= SQLITE "Use SQLite for storing pre-computed key tables" off
|
||||
.if defined(WITH_SQLITE)
|
||||
USE_SQLITE= yes
|
||||
MAKE_ARGS+= SQLITE=true
|
||||
PLIST_SUB+= SQLITE=""
|
||||
.else
|
||||
PLIST_SUB+= SQLITE="@comment "
|
||||
MAN1+= airolib-ng.1
|
||||
PLIST_FILES+= bin/airolib-ng
|
||||
.endif
|
||||
|
||||
post-patch:
|
||||
@ -43,10 +50,13 @@ post-patch:
|
||||
-e 's|^RANLIB[[:blank:]]*|&?|' \
|
||||
-e 's|^AR[[:blank:]]*|&?|' \
|
||||
${WRKSRC}/common.mak
|
||||
# Do not install scripts (Linux-specific)
|
||||
# Do not install scripts (Linux-specific) and their manpages
|
||||
@${REINPLACE_CMD} \
|
||||
-e '/$$(SCRIPTS)/d' \
|
||||
-E '/scripts|@echo/d' \
|
||||
${WRKSRC}/Makefile
|
||||
@${REINPLACE_CMD} \
|
||||
-E 's/air(driver|mon)-ng\.1 //' \
|
||||
${WRKSRC}/manpages/Makefile
|
||||
@${REINPLACE_CMD} \
|
||||
-e 's|-lpthread|${PTHREAD_LIBS}|' \
|
||||
${WRKSRC}/src/Makefile
|
||||
|
@ -1,3 +1,3 @@
|
||||
MD5 (aircrack-ng-1.0-rc1.tar.gz) = 113f0be4a2454f5c73cec25412b20f64
|
||||
SHA256 (aircrack-ng-1.0-rc1.tar.gz) = 220a72aaf00ffb80095c6968a4f9f1399507d483fa08a7f4248c101c60a469f3
|
||||
SIZE (aircrack-ng-1.0-rc1.tar.gz) = 1208442
|
||||
MD5 (aircrack-ng-1.0-rc4.tar.gz) = 7cb19c296f0b5ebaa4009f95c498a53f
|
||||
SHA256 (aircrack-ng-1.0-rc4.tar.gz) = c43047f524eafb26ecd12680e89fcb7fb806be1073b09649248fcf64e767e417
|
||||
SIZE (aircrack-ng-1.0-rc4.tar.gz) = 1536616
|
||||
|
@ -1,18 +0,0 @@
|
||||
--- src/airserv-ng.c.orig 2008-06-10 02:55:09.000000000 +0700
|
||||
+++ src/airserv-ng.c 2008-08-11 13:39:46.000000000 +0700
|
||||
@@ -37,6 +37,15 @@
|
||||
|
||||
#ifdef __MACH__
|
||||
#include <libkern/OSByteOrder.h>
|
||||
+#elif defined(__FreeBSD__)
|
||||
+#include <machine/endian.h>
|
||||
+#if BYTE_ORDER == BIG_ENDIAN
|
||||
+# define __cpu_to_be32(x) (x)
|
||||
+# define __cpu_to_be64(x) (x)
|
||||
+#elif BYTE_ORDER == LITTLE_ENDIAN
|
||||
+# define __cpu_to_be32(x) __bswap32(x)
|
||||
+# define __cpu_to_be64(x) __bswap64(x)
|
||||
+#endif
|
||||
#else
|
||||
#include <asm/byteorder.h>
|
||||
#endif /* __MACH__ */
|
@ -1,18 +0,0 @@
|
||||
--- src/osdep/network.c.orig 2008-06-10 02:55:09.000000000 +0700
|
||||
+++ src/osdep/network.c 2008-08-11 13:29:42.000000000 +0700
|
||||
@@ -32,6 +32,15 @@
|
||||
|
||||
#ifdef __MACH__
|
||||
#include <libkern/OSByteOrder.h>
|
||||
+#elif defined(__FreeBSD__)
|
||||
+#include <machine/endian.h>
|
||||
+#if BYTE_ORDER == BIG_ENDIAN
|
||||
+# define __be32_to_cpu(x) (x)
|
||||
+# define __be64_to_cpu(x) (x)
|
||||
+#elif BYTE_ORDER == LITTLE_ENDIAN
|
||||
+# define __be32_to_cpu(x) __bswap32(x)
|
||||
+# define __be64_to_cpu(x) __bswap64(x)
|
||||
+#endif
|
||||
#else
|
||||
#include <asm/byteorder.h>
|
||||
#endif /* __MACH__ */
|
@ -1,15 +0,0 @@
|
||||
bin/aircrack-ng
|
||||
bin/airdecap-ng
|
||||
%%SQLITE%%bin/airolib-ng
|
||||
bin/buddy-ng
|
||||
bin/ivstools
|
||||
bin/kstats
|
||||
bin/makeivs-ng
|
||||
bin/packetforge-ng
|
||||
sbin/airbase-ng
|
||||
sbin/aireplay-ng
|
||||
sbin/airodump-ng
|
||||
sbin/airserv-ng
|
||||
sbin/airtun-ng
|
||||
sbin/easside-ng
|
||||
sbin/wesside-ng
|
Loading…
Reference in New Issue
Block a user