Upgrade to 1.0.1

This commit is contained in:
Thomas Gellekum 2001-06-26 11:56:42 +00:00
parent f7d88d9aa6
commit 52bfdf64d4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=44452
17 changed files with 92 additions and 2798 deletions

View File

@ -1,22 +1,19 @@
# New ports collection makefile for: gnustep
# Date created: 03 October 1998
# New ports collection makefile for: gnustep-make
# Date created: 17 April 2001
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnustep
PORTVERSION= 0.6.6
PORTNAME= gnustep-make
PORTVERSION= 1.0.1
CATEGORIES= devel
MASTER_SITES= http://ftp.codefactory.se/pub/gnu/gstep/ \
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/core/ \
http://ftp.codefactory.se/pub/gnu/gstep/ \
http://planetmirror.com/pub/gnustep/core/
DISTNAME= gstep-core-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 300000
@ -25,18 +22,10 @@ BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
USE_NEWGCC= yes
PREFIX= ${LOCALBASE}/GNUstep
WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xgps \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
--with-tiff-include=${LOCALBASE}/include # --enable-threads=posix
CONFIGURE_TARGET=
USE_BISON= yes
USE_GMAKE= yes
USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
NO_MTREE= yes
@ -46,18 +35,17 @@ GNU_ARCH= ix86
.else
GNU_ARCH= ${MACHINE_ARCH}
.endif
PLIST_SUB+= GNU_ARCH=${GNU_ARCH} VERSION=${PORTVERSION}
ETCDIR= ${PREFIX}/../etc
PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
post-patch:
.for f in bundle gswapp gswbundle woapp wobundle
${PERL} -pi -e 's/\$$\(TAR\) ch --exclude=CVS --to-stdout/\$$\(TAR\) -ch --exclude=CVS -f -/g' ${WRKSRC}/make/${f}.make
.for f in gswapp gswbundle woapp wobundle
${PERL} -pi -e 's/\$$\(TAR\) ch --exclude=CVS --to-stdout/\$$\(TAR\) -ch --exclude=CVS -f -/g' ${WRKSRC}/${f}.make
.endfor
post-install:
@${MKDIR} ${ETCDIR}
${INSTALL_SCRIPT} ${FILESDIR}/GNUstep.sh ${ETCDIR}/rc.d
${INSTALL_DATA} ${FILESDIR}/gdomap_if ${ETCDIR}
${SED} -e "s/\(objc_threaded:=\)/\1 ${PTHREAD_LIBS}/" \
< ${WRKSRC}/config.make \
> ${PREFIX}/System/Makefiles/${GNU_ARCH}/${OPSYS:L}/config.make
@${CAT} ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (gstep-core-0.6.6.tar.gz) = 23d87610859a542b98c348fd9e66b8f8
MD5 (gnustep-make-1.0.1.tar.gz) = 3c6d49bce1efdb2b318195dd611775be

View File

@ -1,31 +0,0 @@
#!/bin/sh
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
echo "$0: Cannot determine the PREFIX" >&2
exit 1
fi
IFFILE=${PREFIX}/etc/gdomap_if
PIDFILE=/var/run/gdomap.pid
GNUSTEP_SYSTEM_ROOT=${PREFIX}/GNUstep/System
case "$1" in
start)
if [ -e ${GNUSTEP_SYSTEM_ROOT}/Makefiles/GNUstep.sh ]; then
. ${GNUSTEP_SYSTEM_ROOT}/Makefiles/GNUstep.sh
if [ -x ${GNUSTEP_SYSTEM_ROOT}/Tools/gdomap ]; then
rm -f ${PIDFILE}
${GNUSTEP_SYSTEM_ROOT}/Tools/gdomap -a ${IFFILE} -I ${PIDFILE}
echo -n ' GNUstep'
fi
fi
;;
stop)
[ -r ${PIDFILE} ] && kill $(cat ${PIDFILE}) && echo -n ' GNUstep'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
;;
esac
exit 0

View File

@ -1 +0,0 @@
127.0.0.1 255.255.255.0

View File

@ -1,11 +0,0 @@
--- gui/Source/GNUmakefile.preamble.orig Sun Oct 15 21:47:59 2000
+++ gui/Source/GNUmakefile.preamble Sun Oct 15 21:48:16 2000
@@ -63,7 +63,7 @@
ADDITIONAL_CFLAGS =
# Additional include directories the compiler should search
-ADDITIONAL_INCLUDE_DIRS = -I../Headers
+ADDITIONAL_INCLUDE_DIRS = -I../Headers -I${LOCALBASE}/include
# Additional LDFLAGS to pass to the linker
ADDITIONAL_LDFLAGS =

View File

@ -1,11 +0,0 @@
--- xgps/Source/GNUmakefile.preamble.orig Sun Oct 15 22:12:02 2000
+++ xgps/Source/GNUmakefile.preamble Sun Oct 15 22:12:26 2000
@@ -55,7 +55,7 @@
ADDITIONAL_CFLAGS =
# Additional include directories the compiler should search
-ADDITIONAL_INCLUDE_DIRS = -I../Headers \
+ADDITIONAL_INCLUDE_DIRS = -I../Headers -I${LOCALBASE}/include \
-I$(GNUSTEP_TARGET_CPU)/$(GNUSTEP_TARGET_OS) \
-I./SharedX

View File

@ -0,0 +1,13 @@
--- target.make.orig Thu May 10 22:07:23 2001
+++ target.make Tue Jun 5 09:26:45 2001
@@ -79,8 +79,8 @@
ifeq ("$(objc_threaded)","")
TARGET_SYSTEM_LIBS := $(CONFIG_SYSTEM_LIBS) -lm
else
- INTERNAL_CFLAGS = -D_REENTRANT
- INTERNAL_OBJCFLAGS = -D_REENTRANT
+ INTERNAL_CFLAGS = -D_REENTRANT -D_THREAD_SAFE
+ INTERNAL_OBJCFLAGS = -D_REENTRANT -D_THREAD_SAFE
TARGET_SYSTEM_LIBS := $(CONFIG_SYSTEM_LIBS) $(objc_threaded) -lm
endif
endif

View File

@ -1 +1 @@
Objective-C libraries based on the OpenStep standard
GNUstep makefile package

File diff suppressed because it is too large Load Diff

View File

@ -1,21 +1,20 @@
# New ports collection makefile for: gnustep
# Date created: 03 October 1998
# New ports collection makefile for: gnustep-objc
# Date created: 17 April 2001
# Whom: Thomas Gellekum <tg@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= gnustep
PORTVERSION= 0.6.6
CATEGORIES= devel
MASTER_SITES= http://ftp.codefactory.se/pub/gnu/gstep/ \
http://planetmirror.com/pub/gnustep/core/
DISTNAME= gstep-core-${PORTVERSION}
PORTNAME= gnustep-objc
PORTVERSION= 1.0.1
CATEGORIES= lang devel
MASTER_SITES= ftp://ftp.gnustep.org/pub/gnustep/libs/
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff
BUILD_DEPENDS= ${SYSTEMDIR}/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make \
${LOCALBASE}/lib/libcallback.a:${PORTSDIR}/devel/ffcall
RUN_DEPENDS= ${SYSTEMDIR}/Makefiles/GNUstep.sh:${PORTSDIR}/devel/gnustep-make
.include <bsd.port.pre.mk>
@ -23,22 +22,11 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
BROKEN= "Sorry, this port does not work on FreeBSD-2.2.x"
.endif
USE_NEWGCC= yes
PREFIX= ${LOCALBASE}/GNUstep
WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
CONFIGURE_ENV= INSTALL_PROGRAM="${INSTALL} -c" INSTALL_DATA="${INSTALL} -c"
CONFIGURE_ARGS= --with-library-combo=gnu-gnu-gnu-xgps \
--with-jpeg-library=${LOCALBASE}/lib \
--with-jpeg-include=${LOCALBASE}/include \
--with-tiff-library=${LOCALBASE}/lib \
--with-tiff-include=${LOCALBASE}/include # --enable-threads=posix
CONFIGURE_TARGET=
USE_BISON= yes
USE_NEWGCC= yes
USE_GMAKE= yes
USE_XLIB= yes
MAKEFILE=
MAKE_FLAGS= OPTFLAG="${CFLAGS}"
MAKEFILE= GNUmakefile
ALL_TARGET=
NO_MTREE= yes
.if ${MACHINE_ARCH} == "i386"
@ -46,18 +34,16 @@ GNU_ARCH= ix86
.else
GNU_ARCH= ${MACHINE_ARCH}
.endif
PLIST_SUB+= GNU_ARCH=${GNU_ARCH} VERSION=${PORTVERSION}
PLIST_SUB+= GNU_ARCH=${GNU_ARCH} OPSYS=${OPSYS:L} VERSION=${PORTVERSION}
ETCDIR= ${PREFIX}/../etc
SYSTEMDIR= ${PREFIX}/System
post-patch:
.for f in bundle gswapp gswbundle woapp wobundle
${PERL} -pi -e 's/\$$\(TAR\) ch --exclude=CVS --to-stdout/\$$\(TAR\) -ch --exclude=CVS -f -/g' ${WRKSRC}/make/${f}.make
.endfor
do-build:
@(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
post-install:
@${MKDIR} ${ETCDIR}
${INSTALL_SCRIPT} ${FILESDIR}/GNUstep.sh ${ETCDIR}/rc.d
${INSTALL_DATA} ${FILESDIR}/gdomap_if ${ETCDIR}
do-install:
@(cd ${WRKSRC}; . ${PREFIX}/System/Makefiles/GNUstep.sh; \
${SETENV} ${MAKE_ENV} ${GMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${INSTALL_TARGET})
.include <bsd.port.post.mk>

View File

@ -1 +1 @@
MD5 (gstep-core-0.6.6.tar.gz) = 23d87610859a542b98c348fd9e66b8f8
MD5 (gnustep-objc-1.0.1.tar.gz) = c77481c092c1518f94d9a0c099b8006a

View File

@ -1,31 +0,0 @@
#!/bin/sh
if ! PREFIX=$(expr $0 : "\(/.*\)/etc/rc\.d/$(basename $0)\$"); then
echo "$0: Cannot determine the PREFIX" >&2
exit 1
fi
IFFILE=${PREFIX}/etc/gdomap_if
PIDFILE=/var/run/gdomap.pid
GNUSTEP_SYSTEM_ROOT=${PREFIX}/GNUstep/System
case "$1" in
start)
if [ -e ${GNUSTEP_SYSTEM_ROOT}/Makefiles/GNUstep.sh ]; then
. ${GNUSTEP_SYSTEM_ROOT}/Makefiles/GNUstep.sh
if [ -x ${GNUSTEP_SYSTEM_ROOT}/Tools/gdomap ]; then
rm -f ${PIDFILE}
${GNUSTEP_SYSTEM_ROOT}/Tools/gdomap -a ${IFFILE} -I ${PIDFILE}
echo -n ' GNUstep'
fi
fi
;;
stop)
[ -r ${PIDFILE} ] && kill $(cat ${PIDFILE}) && echo -n ' GNUstep'
;;
*)
echo "Usage: `basename $0` {start|stop}" >&2
;;
esac
exit 0

View File

@ -1 +0,0 @@
127.0.0.1 255.255.255.0

View File

@ -1,11 +0,0 @@
--- gui/Source/GNUmakefile.preamble.orig Sun Oct 15 21:47:59 2000
+++ gui/Source/GNUmakefile.preamble Sun Oct 15 21:48:16 2000
@@ -63,7 +63,7 @@
ADDITIONAL_CFLAGS =
# Additional include directories the compiler should search
-ADDITIONAL_INCLUDE_DIRS = -I../Headers
+ADDITIONAL_INCLUDE_DIRS = -I../Headers -I${LOCALBASE}/include
# Additional LDFLAGS to pass to the linker
ADDITIONAL_LDFLAGS =

View File

@ -1,11 +0,0 @@
--- xgps/Source/GNUmakefile.preamble.orig Sun Oct 15 22:12:02 2000
+++ xgps/Source/GNUmakefile.preamble Sun Oct 15 22:12:26 2000
@@ -55,7 +55,7 @@
ADDITIONAL_CFLAGS =
# Additional include directories the compiler should search
-ADDITIONAL_INCLUDE_DIRS = -I../Headers \
+ADDITIONAL_INCLUDE_DIRS = -I../Headers -I${LOCALBASE}/include \
-I$(GNUSTEP_TARGET_CPU)/$(GNUSTEP_TARGET_OS) \
-I./SharedX

View File

@ -1 +1 @@
Objective-C libraries based on the OpenStep standard
A snapshot of libobjc, meant to be used with GNUstep

File diff suppressed because it is too large Load Diff