net-p2p/libtorrent-rasterbar and net-p2p/libtorrent-rasterbar-python: Update 1.1.9 -> 1.1.10

Port changes for net-p2p/libtorrent-rasterbar:
* Change to cmake
* Add LICENSE_FILE
* Add USES=compiler:c++14-lang
* Remove the TEST option, add the cmake-based do-test target, but it is broken upstream

Port changes for net-p2p/libtorrent-rasterbar-python:
* Complete redesign, made it an individual port instead of a slave

Bump 5 dependencies.

Reported by:	TJ <tj@mrsk.me>
This commit is contained in:
Yuri Victorovich 2018-10-06 20:13:20 +00:00
parent 72f19888fd
commit 52bc58eee4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=481391
13 changed files with 70 additions and 70 deletions

View File

@ -3,7 +3,7 @@
PORTNAME= miro
PORTVERSION= 6.0
PORTREVISION= 19
PORTREVISION= 20
CATEGORIES= multimedia
MASTER_SITES= ftp://ftp.osuosl.org/pub/pculture.org/miro/src/ \
http://ftp.osuosl.org/pub/pculture.org/miro/src/

View File

@ -3,7 +3,7 @@
PORTNAME= deluge
DISTVERSIONPREFIX= ${PORTNAME}-
DISTVERSION= 1.3.15
PORTREVISION= 5
PORTREVISION= 6
CATEGORIES= net-p2p python
PKGNAMESUFFIX= -cli

View File

@ -1,31 +1,28 @@
# Created by: Doug Barton <dougb@FreeBSD.org>
# $FreeBSD$
CATEGORIES= net-p2p python
PORTNAME= libtorrent-rasterbar
DISTVERSION= 1.1.10
CATEGORIES= net-p2p ipv6 python
MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Python bindings for libtorrent-rasterbar
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/../../COPYING
LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar \
${PY_BOOST}
MASTERDIR= ${.CURDIR}/../libtorrent-rasterbar
USES= localbase python:2.7
USE_PYTHON= distutils autoplist
BUILD_WRKSRC= ${WRKSRC}/bindings/python
INSTALL_WRKSRC= ${BUILD_WRKSRC}
SLAVE_PORT= yes
USES= python:2.7
USE_PYTHON= distutils
PYDISTUTILS_PKGNAME= python_libtorrent
PLIST= ${NONEXISTENT}
PLIST_FILES= %%PYTHON_SITELIBDIR%%/libtorrent.so
OPTIONS_EXCLUDE= DOCS EXAMPLES
WRKSRC_SUBDIR= bindings/python
# ensure python paths are correctly identified
CONFIGURE_ENV= PYTHON_INCLUDEDIR="${PYTHON_INCLUDEDIR}" \
PYTHON_VERSION="${PYTHON_VERSION}"
.include "${MASTERDIR}/Makefile"
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1538852302
SHA256 (libtorrent-rasterbar-1.1.10.tar.gz) = 07b2b391e0d16bc693d793e352338488a0e41f3130b70884bb2e0270ea00b8c2
SIZE (libtorrent-rasterbar-1.1.10.tar.gz) = 3902542

View File

@ -0,0 +1,17 @@
--- setup.py.orig 2018-10-06 18:51:57 UTC
+++ setup.py
@@ -131,11 +131,11 @@ else:
source_list = os.listdir(os.path.join(os.path.dirname(__file__), "src"))
source_list = [os.path.abspath(os.path.join(os.path.dirname(__file__), "src", s)) for s in source_list if s.endswith(".cpp")]
- if extra_cmd:
+ if True or extra_cmd:
flags = flags_parser()
# ldflags must be parsed first to ensure the correct library search path order
- extra_link = flags.parse(ldflags)
- extra_compile = flags.parse(extra_cmd)
+ extra_link = flags.parse(os.environ['LDFLAGS'])
+ extra_compile = flags.parse(os.environ['CFLAGS'])
# for some reason distutils uses the CC environment variable to determine
# the compiler to use for C++

View File

@ -0,0 +1,4 @@
The python vinfing of libtorrent, an open source C++ library implementing the
BitTorrent protocol.
WWW: http://libtorrent.org/

View File

@ -2,35 +2,24 @@
# $FreeBSD$
PORTNAME= libtorrent-rasterbar
DISTVERSION= 1.1.9
CATEGORIES?= net-p2p ipv6
DISTVERSION= 1.1.10
CATEGORIES= net-p2p ipv6
MASTER_SITES= https://github.com/arvidn/libtorrent/releases/download/libtorrent-${PORTVERSION:S/./_/g}/
MAINTAINER= yuri@FreeBSD.org
COMMENT?= C++ library implementing a BitTorrent client
COMMENT= C++ library implementing a BitTorrent client
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
BROKEN_powerpc64= fails to build: client_test.cpp: undefined reference to std::__cxx11::basic_string
LIB_DEPENDS+= libboost_chrono.so:devel/boost-libs \
LIB_DEPENDS= libboost_chrono.so:devel/boost-libs \
libboost_random.so:devel/boost-libs \
libboost_system.so:devel/boost-libs
USES+= compiler:c++11-lib iconv:wchar_t libtool pathfix pkgconfig ssl
USE_CXXSTD= c++11
GNU_CONFIGURE= yes
USES= cmake:outsource compiler:c++14-lang iconv:wchar_t libtool pathfix pkgconfig ssl
USE_LDCONFIG= yes
TEST_TARGET= check
CONFIGURE_ARGS= --disable-static \
--enable-dht \
--enable-encryption \
--enable-pool-allocators \
--enable-deprecated-functions \
--with-boost=${LOCALBASE} \
--with-libiconv \
--with-openssl=${OPENSSLBASE}
SHLIB_VER= 9
PLIST_SUB+= SHLIB_VER="${SHLIB_VER}"
@ -39,7 +28,7 @@ DOCFILES= AUTHORS ChangeLog
PORTDOCS= ${DOCFILES} docs/*
PORTEXAMPLES= *.cpp
OPTIONS_DEFINE= DEBUG DOCS EXAMPLES LOGGING TEST
OPTIONS_DEFINE= DEBUG DOCS EXAMPLES LOGGING
OPTIONS_DEFAULT=LOGGING
OPTIONS_SUB= yes
LOGGING_DESC= Enable disk stat logging and logging to disk
@ -47,36 +36,18 @@ LOGGING_DESC= Enable disk stat logging and logging to disk
DEBUG_CONFIGURE_ENABLE= debug
EXAMPLES_CONFIGURE_ENABLE= examples
LOGGING_CONFIGURE_ENABLE= logging disk-stats
TEST_CONFIGURE_ENABLE= tests
.include <bsd.port.options.mk>
.if defined(SLAVE_PORT) && ${SLAVE_PORT:tl} == "yes" && defined(USE_PYTHON)
CONFIGURE_ARGS+= --enable-python-binding
.else
CONFIGURE_ARGS+= --disable-python-binding
.endif
post-patch:
@${REINPLACE_CMD} -e 's|/usr/local/include|${PREFIX}/include|' \
${WRKSRC}/Jamfile
post-configure:
${FIND} ${WRKSRC} -name Makefile -o -name link_flags | \
${XARGS} ${REINPLACE_CMD} 's| *-R${LOCALBASE}/lib||'
post-install:
.if defined(SLAVE_PORT) && ${SLAVE_PORT:tl} == "yes" && defined(USE_PYTHON)
${STRIP_CMD} ${STAGEDIR}${PYTHON_SITELIBDIR}/libtorrent.so
.else
${STRIP_CMD} \
${STAGEDIR}${PREFIX}/lib/libtorrent-rasterbar.so.${SHLIB_VER}
.endif
@${RM} ${STAGEDIR}${PREFIX}/include/libtorrent/tommath.h.orig ${STAGEDIR}${PREFIX}/include/libtorrent/Makefile*
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOCFILES:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR})
cd ${WRKSRC} && ${COPYTREE_SHARE} docs ${STAGEDIR}${DOCSDIR}
${RM} ${STAGEDIR}${DOCSDIR}/docs/._*
post-install-EXAMPLES-on:
@ -84,4 +55,10 @@ post-install-EXAMPLES-on:
${INSTALL_DATA} ${WRKSRC}/examples/${PORTEXAMPLES} \
${STAGEDIR}${EXAMPLESDIR}
do-test: # broken: https://github.com/arvidn/libtorrent/issues/3327
@cd ${BUILD_WRKSRC} && \
${SETENV} ${CONFIGURE_ENV} ${CMAKE_BIN} ${CMAKE_ARGS} -Dbuild_tests=ON ${CMAKE_SOURCE_PATH} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${ALL_TARGET} && \
${SETENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} test
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1534791500
SHA256 (libtorrent-rasterbar-1.1.9.tar.gz) = d57a0f5b159f58003c3031943463503f0d05ae3e428dd7c2383d1e35fb2c4e8c
SIZE (libtorrent-rasterbar-1.1.9.tar.gz) = 3903742
TIMESTAMP = 1538843172
SHA256 (libtorrent-rasterbar-1.1.10.tar.gz) = 07b2b391e0d16bc693d793e352338488a0e41f3130b70884bb2e0270ea00b8c2
SIZE (libtorrent-rasterbar-1.1.10.tar.gz) = 3902542

View File

@ -0,0 +1,10 @@
--- CMakeLists.txt.orig 2018-10-06 18:06:13 UTC
+++ CMakeLists.txt
@@ -1,6 +1,6 @@
cmake_minimum_required(VERSION 3.8)
project(libtorrent)
-set (SOVERSION "8")
+set (SOVERSION "9") # https://github.com/arvidn/libtorrent/issues/3326
set (VERSION "1.1.10")
set(sources

View File

@ -1,12 +1,3 @@
%%TEST%%bin/bt_get
%%TEST%%bin/bt_get2
%%TEST%%bin/client_test
%%TEST%%bin/connection_tester
%%TEST%%bin/dump_torrent
%%TEST%%bin/make_torrent
%%TEST%%bin/simple_client
%%TEST%%bin/stats_counters
%%TEST%%bin/upnp_test
include/libtorrent/ConvertUTF.h
include/libtorrent/add_torrent_params.hpp
include/libtorrent/address.hpp
@ -206,5 +197,4 @@ include/libtorrent/web_peer_connection.hpp
include/libtorrent/xml_parse.hpp
lib/libtorrent-rasterbar.so
lib/libtorrent-rasterbar.so.%%SHLIB_VER%%
lib/libtorrent-rasterbar.so.%%SHLIB_VER%%.0.0
libdata/pkgconfig/libtorrent-rasterbar.pc

View File

@ -3,6 +3,7 @@
PORTNAME= qbittorrent
DISTVERSION= 4.1.3
PORTREVISION= 1
CATEGORIES= net-p2p ipv6
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}

View File

@ -3,7 +3,7 @@
PORTNAME= tribler
PORTVERSION= 6.5.2
PORTREVISION= 8
PORTREVISION= 9
CATEGORIES= net-p2p
MASTER_SITES= https://github.com/Tribler/tribler/releases/download/v${PORTVERSION}/
DISTNAME= Tribler-v${PORTVERSION}

View File

@ -3,7 +3,7 @@
PORTNAME= leechcraft
PORTVERSION= 0.6.70
PORTREVISION= 34
PORTREVISION= 35
CATEGORIES= x11
MASTER_SITES= http://dist.leechcraft.org/LeechCraft/0.6.70/
@ -78,6 +78,7 @@ BITTORRENT_DESC= Full-featured BitTorrent client plugin
BITTORRENT_CMAKE_ON= -DENABLE_TORRENT:BOOL=true
BITTORRENT_CMAKE_OFF= -DENABLE_TORRENT:BOOL=false
BITTORRENT_LIB_DEPENDS= libtorrent-rasterbar.so:net-p2p/libtorrent-rasterbar
BITTORRENT_BROKEN= see https://dev.leechcraft.org/issues/2062
BLASQ_DESC= Cloud image storage services client (like Flickr or Picasa)
BLASQ_CMAKE_ON= -DENABLE_BLASQ:BOOL=true