Update to 1.3. Now includes a man page.

This commit is contained in:
Christian Weisgerber 2003-01-01 22:06:00 +00:00
parent bc7c6610e0
commit 52b4e59232
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=72124
6 changed files with 27 additions and 18 deletions

View File

@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= jday
PORTVERSION= 1.2
PORTVERSION= 1.3
CATEGORIES= astro
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= jday
@ -14,10 +14,6 @@ MAINTAINER= naddy@FreeBSD.org
GNU_CONFIGURE= yes
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/jday
${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/jday
.endif
MAN1= jday.1
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (jday-1.2.tar.gz) = 33f63d8e7880dc7f5181db280a243c4d
MD5 (jday-1.3.tar.gz) = 4b6e8e4c9322a50322e0eebf86cb32f4

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- jday.c.orig Mon Dec 30 16:49:30 2002
+++ jday.c Mon Dec 30 16:49:44 2002
@@ -122,7 +122,7 @@
if ( day < 1 ) day = 1;
case 3:
if ( ! strcmp((const char *)argv[1], (const char *) "-d") ) {
- if ( 3 != sscanf( argv[2], "%d/%d/%d", & year, & mo, & day ) ) {
+ if ( 3 != sscanf( argv[2], "%ld/%d/%d", & year, & mo, & day ) ) {
fprintf( stderr, "failed sscanf for ymd\n" );
exit (-1);
} else {

View File

@ -1 +1 @@
Convert calendar dates to and from astronomical julian dates
Astronomical julian date calculator

View File

@ -1,9 +1,6 @@
The jday binary can be used to convert calendar dates to astronomical
Julian dates. This number is useful for a variety of purposes.
Especially related to calculating elapsed time between instances
over large or short periods of time.
The associated j2d binary can convert Julian dates to calendar
dates.
jday and j2d are command line utilities to convert calendar dates
to astronomical julian dates, and julian dates to calendar dates.
There is a corresponding library libjday.a which can be used for
the same functionality within applications.
WWW: http://jday.sourceforge.net/

View File

@ -1,4 +1,6 @@
bin/jday
@comment $FreeBSD$
bin/dbd
bin/j2d
%%PORTDOCS%%share/doc/jday/README
%%PORTDOCS%%@dirrm share/doc/jday
bin/jday
include/jday.h
lib/libjday.a