2007-04-12 cad/geda-projectmanager: project dead

2007-04-19 audio/xmpeg3: does not work
This commit is contained in:
Martin Wilke 2007-04-23 07:33:10 +00:00
parent b2faaadcac
commit 52b26197ae
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=190695
11 changed files with 2 additions and 167 deletions

2
MOVED
View File

@ -2941,3 +2941,5 @@ devel/crossgo32-djgpp2-pdcurses||2007-04-14|Removed, Archaic port
www/xsm|www/extsm|2007-04-16|was moved to resolve conflict with x11/xsm import
lang/tk-wrapper|x11-toolkits/tk-wrapper|2007-04-16|Moved to correct category
lang/gcc-objc|lang/gcc41|2007-04-21|Has expired, obsolete
cad/geda-projectmanager||2007-04-23|Has expired: project dead
audio/xmpeg3||2007-04-23|Has expired: does not work

View File

@ -730,7 +730,6 @@
SUBDIR += xmms2-scrobbler
SUBDIR += xmmsctrl
SUBDIR += xmp
SUBDIR += xmpeg3
SUBDIR += xmradio
SUBDIR += xsidplay
SUBDIR += xsynth-dssi

View File

@ -1,35 +0,0 @@
# New ports collection makefile for: xmpeg3
# Date created: 7 July 1997
# Whom: doconnor@ist.flinders.edu.au
#
# $FreeBSD$
#
PORTNAME= xmpeg3
PORTVERSION= 1.0
CATEGORIES= audio tk82
MASTER_SITES= ftp://ftp.funet.fi/pub/sci/audio/mpeg/amp/
DISTNAME= xmp3_1.0.0
EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= Simple TCL interface to the Amp Mpeg-3 player
RUN_DEPENDS= amp:${PORTSDIR}/audio/amp \
wish8.2:${PORTSDIR}/x11-toolkits/tk82
IGNORE= does not work
DEPRECATED= ${IGNORE}
EXPIRATION_DATE= 2007-04-19
PLIST_FILES= bin/xmpeg3
WRKSRC= ${WRKDIR}/xmpeg3
NO_BUILD= yes
post-patch:
@${REINPLACE_CMD} -e 's|@@PREFIX@@|${PREFIX}|' ${WRKSRC}/xmpeg3
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/xmpeg3 ${PREFIX}/bin
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
MD5 (xmp3_1.0.0.tgz) = b8c9738a33f0b6e2a4e7f1f5649c54ef
SHA256 (xmp3_1.0.0.tgz) = 7aa7d2254a0fa14e201499f603f3a6cc60bf9e89fd011239bece5329cd9770c3
SIZE (xmp3_1.0.0.tgz) = 6495

View File

@ -1,63 +0,0 @@
--- xmpeg3.orig Tue Mar 25 13:21:26 1997
+++ xmpeg3 Thu Oct 30 16:00:48 1997
@@ -1,3 +1,4 @@
+#!@@PREFIX@@/bin/wish8.2
#############################################################################
# Visual Tcl v1.07 Project
#
@@ -12,11 +13,11 @@
global Recursif_intelligent; set Recursif_intelligent {0}
global artiste; set artiste {}
global player_mode; set player_mode {disc}
-global random::a1; set random::a1 { 1941 1860 1812 1776 1492 1215 1066 12013 }
-global random::a2; set random::a2 { 1111 2222 3333 4444 5555 6666 7777 827 }
-global random::a3; set random::a3 { 1111 2222 3333 4444 5555 6666 7777 251 }
-global random::m1; set random::m1 {8729 43215 8810 53075 59930 23253 16377 62489 11794}
-global random::m2; set random::m2 {18086 23696 42786 37815 59442 39280 18624 35510 38884}
+global random.a1; set random.a1 { 1941 1860 1812 1776 1492 1215 1066 12013 }
+global random.a2; set random.a2 { 1111 2222 3333 4444 5555 6666 7777 827 }
+global random.a3; set random.a3 { 1111 2222 3333 4444 5555 6666 7777 251 }
+global random.m1; set random.m1 {8729 43215 8810 53075 59930 23253 16377 62489 11794}
+global random.m2; set random.m2 {18086 23696 42786 37815 59442 39280 18624 35510 38884}
global termine; set termine {2}
global xmpeg3_version; set xmpeg3_version {1.0}
global widget;
@@ -244,19 +245,19 @@
}
proc random {} {
-global random::m1 random::m2 random::a1 random::a2;
- set random::m1 [random::rand16 [set random::a1] [set random::m1]];
- set random::m2 [random::rand16 [set random::a2] [set random::m2]];
- return [expr (([lindex [set random::m1] 1] << 16) + [lindex [set random::m2] 1]) & 0x7FFFFFFF];
+global random.m1 random.m2 random.a1 random.a2;
+ set random.m1 [random.rand16 [set random.a1] [set random.m1]];
+ set random.m2 [random.rand16 [set random.a2] [set random.m2]];
+ return [expr (([lindex [set random.m1] 1] << 16) + [lindex [set random.m2] 1]) & 0x7FFFFFFF];
}
-proc random::rand16 {a m} {
+proc random.rand16 {a m} {
set n [expr [lindex $m 0] + [lindex $a 0] * [lindex $m 1] + [lindex $a 1] * [lindex $m 2] + [lindex $a 2] * [lindex $m 3] + [lindex $a 3] * [lindex $m 4] + [lindex $a 4] * [lindex $m 5] + [lindex $a 5] * [lindex $m 6] + [lindex $a 6] * [lindex $m 7] + [lindex $a 7] * [lindex $m 8]];
return [concat [expr $n >> 16] [expr $n & 0xFFFF] [lrange $m 1 7]];
}
-proc random::srand16 {seed} {
+proc random.srand16 {seed} {
set n1 [expr $seed & 0xFFFF];
set n2 [expr $seed & 0x7FFFFFFF];
set n2 [expr 30903 * $n1 + ($n2 >> 16)];
@@ -305,9 +306,9 @@
}
proc srandom {seed} {
-global random::m1 random::m2;
- set random::m1 [random::srand16 $seed];
- set random::m2 [random::srand16 [expr 4321+$seed]];
+global random.m1 random.m2;
+ set random.m1 [random.srand16 $seed];
+ set random.m2 [random.srand16 [expr 4321+$seed]];
return {};
}

View File

@ -1,2 +0,0 @@
This is a small TCL interface for the Amp MPEG layer 3 player. It allows you
to keep track lists and do random play, etc.

View File

@ -28,7 +28,6 @@
SUBDIR += geda-gattrib
SUBDIR += geda-gschem
SUBDIR += geda-netlist
SUBDIR += geda-projectmanager
SUBDIR += geda-symbols
SUBDIR += geda-symcheck
SUBDIR += geda-utils

View File

@ -1,44 +0,0 @@
# New ports collection makefile for: geda
# Date created: 24 Nov 1998
# Whom: Vanilla I. Shu <vanilla@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= projectmanager
PORTVERSION= 20060123
PORTREVISION= 2
CATEGORIES= cad
MASTER_SITES= ftp://ftp.geda.seul.org/pub/geda/devel/${PORTVERSION}/ \
http://geda.seul.org/devel/${PORTVERSION}/ \
http://www.tinkerbox.org/projects/files/gEDA/
PKGNAMEPREFIX= geda-
DISTNAME= geda-${PORTVERSION}
MAINTAINER= stas@FreeBSD.org
COMMENT= The gEDA's project manager
IGNORE= project dead
DEPRECATED= ${IGNORE}
EXPIRATION_DATE=2007-04-12
GNU_CONFIGURE= yes
USE_GNOME= gtk20
CFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
.if !defined(WITHOUT_NLS)
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
post-patch:
@${REINPLACE_CMD} -E \
-e "s,^(DATADIR[[:space:]]*=[[:space:]]*)gEDA,\1geda," \
${WRKSRC}/configure
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
MD5 (geda-20060123.tar.gz) = 6642b79f7ccb193f6c7f4733d03ebf02
SHA256 (geda-20060123.tar.gz) = 566a8a3e491ebcdc3ce938c15509acb91ed06dd9189140d06f8efe1ac3796c77
SIZE (geda-20060123.tar.gz) = 398714

View File

@ -1,3 +0,0 @@
The gEDA's project manager suite.
WWW: http://www.geda.seul.org

View File

@ -1,12 +0,0 @@
bin/geda
bin/graphman
bin/raw2gw
%%NLS%%share/locale/de_DE/LC_MESSAGES/geda.mo
%%NLS%%share/locale/fr_FR/LC_MESSAGES/geda.mo
%%NLS%%share/locale/it/LC_MESSAGES/geda.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/geda.mo
%%NLS%%share/locale/ru/LC_MESSAGES/geda.mo
%%NLS%%@dirrmtry share/locale/fr_FR/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/fr_FR
%%NLS%%@dirrmtry share/locale/de_DE/LC_MESSAGES
%%NLS%%@dirrmtry share/locale/de_DE