Update to latest version

PR:		36596
Submitted by:	maintainer
This commit is contained in:
David W. Chapman Jr. 2002-04-01 02:01:59 +00:00
parent fb21b76a21
commit 5299d2fd32
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57097
5 changed files with 10 additions and 147 deletions

View File

@ -6,26 +6,21 @@
#
PORTNAME= openal
PORTVERSION= 20020217
PORTVERSION= 20020329fbsd
CATEGORIES= audio
MASTER_SITES= ftp://ftp.openal.org/pub/openal/
MASTER_SITES= http://math.smsu.edu/~erik/files/fbsd/\
http://smluc.org/~erik/\
http://csc.smsu.edu/~greenwald/
MAINTAINER= erik@smluc.org
WRKSRC= ${WRKDIR}/tmp/${PORTNAME}/linux
USE_AUTOCONF= yes
INSTALLS_SHLIB= yes
post-patch:
@${PERL} -pi -e 's|autoconf|${AUTOCONF}|; \
s|autoheader|${AUTOHEADER}|' ${WRKSRC}/autogen.sh
pre-configure:
@cd ${WRKSRC} && ${SH} autogen.sh
WRKSRC= ${WRKDIR}/${PORTNAME}/linux
GNU_CONFIGURE= yes
USE_GMAKE= yes
post-install:
${INSTALL_DATA} ${WRKSRC}/doc/openal.info ${PREFIX}/info
@install-info ${PREFIX}/info/openal.info ${PREFIX}/info/dir
install-info ${PREFIX}/info/openal.info ${PREFIX}/info/dir
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (openal-20020217.tar.gz) = d8664ed879cf878a740fe9721e91fca4
MD5 (openal-20020329fbsd.tar.gz) = c0882ccf87e99a5898e36d06fbe01df6

View File

@ -1,11 +0,0 @@
--- configure.in.orig Wed Feb 20 11:40:35 2002
+++ configure.in Wed Feb 20 11:40:46 2002
@@ -734,7 +734,7 @@
dnl Should we use turn warnings into errors?
if test x$SHOULD_USE_WERROR = xyes; then
- WFLAGS="$WFLAGS -Werror -pedantic-errors"
+ WFLAGS="$WFLAGS"
fi
dnl if we are forced to live with redundant decls, turn off those errors

View File

@ -1,101 +0,0 @@
--- src/arch/bsd/bsd_dsp.c.orig Thu Apr 12 15:59:49 2001
+++ src/arch/bsd/bsd_dsp.c Wed Feb 20 14:27:54 2002
@@ -8,12 +8,16 @@
*
*/
#include "al_siteconfig.h"
+#include "al_config.h"
+#include "al_main.h"
+#include "al_debug.h"
+#include "alc/alc_context.h"
+#include "arch/interface/interface_sound.h"
+#include "arch/bsd/bsd_dsp.h"
#include <AL/altypes.h>
-#include <AL/alkludge.h>
-
-#include "al_siteconfig.h"
+#include <errno.h>
#include <fcntl.h>
#include <machine/soundcard.h>
#include <stdio.h>
@@ -26,12 +30,6 @@
#include <sys/types.h>
#include <unistd.h>
-#include "arch/interface/interface_sound.h"
-#include "arch/bsd/bsd_dsp.h"
-
-#include "al_main.h"
-#include "al_debug.h"
-#include "alc/alc_context.h"
static int alcChannel_to_dsp_channel(ALuint alcc);
@@ -101,9 +99,9 @@
* dma buffer size.
*
*/
-void *grab_native(void) {
+void *grab_write_native(void) {
const char *dsppath = "/dev/dsp";
- int divisor = _alSpot(_AL_DEF_BUFSIZ) | (2<<16);
+ int divisor = _alSpot(_ALC_DEF_BUFSIZ) | (2<<16);
dsp_fd = open(dsppath, O_WRONLY | O_NONBLOCK);
@@ -219,7 +217,7 @@
return;
}
-float get_nativechannel(UNUSED(void *handle), ALuint channel) {
+float get_nativechannel(UNUSED(void *handle), ALCenum channel) {
int retval = 0;
channel = alcChannel_to_dsp_channel(channel);
@@ -242,7 +240,7 @@
*
* Kludgey, and obviously not the right way to do this
*/
-int set_nativechannel(UNUSED(void *handle), ALuint channel, float volume) {
+int set_nativechannel(UNUSED(void *handle), ALCenum channel, float volume) {
int unnormalizedvolume;
unnormalizedvolume = volume * 100;
@@ -313,7 +311,7 @@
UNUSED(unsigned int *bufsiz),
ALenum *fmt,
unsigned int *speed) {
- ALuint channels = _al_ALFORMAT(*fmt);
+ ALuint channels = _al_ALCHANNELS(*fmt);
if(dsp_fd < 0) {
return AL_FALSE;
@@ -365,3 +363,26 @@
UNUSED(unsigned int *speed)) {
return AL_FALSE;
}
+
+
+#define DONTCARE (1<<16)
+
+static ALboolean use_select = AL_TRUE;
+
+void *grab_read_native(void)
+{
+ static int read_fd;
+
+#ifndef CAPTURE_SUPPORT
+ return NULL;
+#endif
+
+ read_fd = aquire_read();
+ if( read_fd < 0) {
+ return NULL;
+ }
+
+ return &read_fd;
+
+}
+

View File

@ -1,20 +0,0 @@
--- src/threads/posixthreads.c.orig Wed May 9 12:40:39 2001
+++ src/threads/posixthreads.c Wed Feb 20 12:37:03 2002
@@ -19,6 +19,10 @@
extern int pthread_atfork(void (*)(void), void (*)(void), void (*)(void));
#endif
+#if defined(BSD_TARGET)
+int pthread_atfork(void (*a)(void),void (*b)(void),void (*c)(void)){return -1;}
+#endif
+
typedef int (*ptfunc)(void *);
static void *RunThread(void *data) {
@@ -88,7 +92,7 @@
}
extern unsigned int Posix_SelfThread(void) {
- return (unsigned int) pthread_self();
+ return (unsigned long)(unsigned long *) pthread_self();
}