Update to 0.5.20050618.

This commit is contained in:
Hiroki Sato 2007-06-25 15:03:38 +00:00
parent 231a6812c7
commit 5292123396
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=194231
3 changed files with 29 additions and 12 deletions

View File

@ -5,12 +5,12 @@
# $FreeBSD$
PORTNAME= portbrowser
PORTVERSION= 0.4
PORTREVISION= 1
PORTVERSION= 0.5.20050618
CATEGORIES= ports-mgmt
MASTER_SITES= http://www.bytelabs.org/
DISTNAME= pb-browser-${PORTVERSION}
EXTRACT_SUFX= .tgz
MASTER_SITES= ${MASTER_SITE_LOCAL}
MASTER_SITE_SUBDIR= hrs
DISTNAME= pb-browser-current-20050618
#MASTER_SITES= http://www.bytelabs.org/
MAINTAINER= hrs@FreeBSD.org
COMMENT= Graphical frontend for the BSD ports system
@ -19,12 +19,10 @@ USE_GNOME= gtk20
MAKE_ENV= MANDIR=${PREFIX}/man/man \
BINDIR=${PREFIX}/bin \
NOMANCOMPRESS=YES
CFLAGS+= -DINDEXFILE=\\\"${PORTSDIR}/${INDEXFILE}\\\" \
-DPORTS_DIR=\\\"${PORTSDIR}\\\"
PLIST_FILES= bin/pbrowser
MAN1= pbrowser.1
post-patch:
@${REINPLACE_CMD} -e 's|"INDEX"|"${INDEXFILE}"|' \
${WRKSRC}/src/pkgobject.h
.include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
MD5 (pb-browser-0.4.tgz) = 90c50e5785d43c092285e8b77d2b01a9
SHA256 (pb-browser-0.4.tgz) = b9be76d7d78751e85de5705a657605f2c7ca26ec0ad91bddf7648c87a40e12d5
SIZE (pb-browser-0.4.tgz) = 49213
MD5 (pb-browser-current-20050618.tar.gz) = c959fc5d224084809d97e68d14e54042
SHA256 (pb-browser-current-20050618.tar.gz) = 7b9a2ac79da28501ea8c9db9c40c1bfd465261a18532bc3e0588cb49aebaadb5
SIZE (pb-browser-current-20050618.tar.gz) = 49032

View File

@ -0,0 +1,19 @@
--- src/pkgobject.h.orig Sat Jun 18 07:29:56 2005
+++ src/pkgobject.h Mon Jun 25 01:20:20 2007
@@ -31,12 +31,16 @@
#include "pkgquery.h"
+#ifndef PORTS_DIR
#define PORTS_DIR "/usr/ports/" /* standard place for the ports dir */
+#endif
+#ifndef INDEXFILE
#if (defined __FreeBSD__) && (__FreeBSD_version >= 500036)
#define INDEXFILE PORTS_DIR"INDEX-5" /* this is kind of weird but thats the way it's done on FreeBSD */
#else
#define INDEXFILE PORTS_DIR"INDEX" /* where is the INDEX File located? */
+#endif
#endif
#ifdef __OpenBSD__