Remove this outdated port. The linemode browser is now part of the

www/libwww package.

PR:		36652
Submitted by:	Tilman Linneweh <tilman@arved.de>
This commit is contained in:
Patrick Li 2002-04-02 23:11:11 +00:00
parent cb34b54f3e
commit 528851127a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=57243
8 changed files with 0 additions and 109 deletions

View File

@ -120,7 +120,6 @@
SUBDIR += libwww
SUBDIR += libxpg4-ns
SUBDIR += linbot
SUBDIR += linemode
SUBDIR += links
SUBDIR += linux-flashplugin
SUBDIR += linux-lesstif-ns

View File

@ -1,27 +0,0 @@
# New ports collection makefile for: linemode
# Whom: NIIMI Satoshi <sa2c@and.or.jp>
#
# $FreeBSD$
#
PORTNAME= linemode
PORTVERSION= 4.0D
CATEGORIES= www
MASTER_SITES= ftp://ftp.w3.org/pub/linemode/old/ \
ftp://ftp.w3.org/pub/libwww/old/ \
ftp://ftp-eu.w3.org/pub/linemode/old/ \
ftp://ftp-eu.w3.org/pub/libwww/old/
DISTFILES= w3c-libwww-${PORTVERSION}.tar.gz \
www_${PORTVERSION}_src.tar.gz
MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/WWW
do-build:
cd ${WRKSRC}; ./BUILD linemode
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/LineMode/freebsd/www ${PREFIX}/bin/
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
MD5 (w3c-libwww-4.0D.tar.gz) = ac5a02be08b0b618d506bca35bc8d060
MD5 (www_4.0D_src.tar.gz) = 8cc325c3b8e8b6bf4df1ddd734b6771e

View File

@ -1,35 +0,0 @@
--- ./Library/Implementation/HTString.c.orig Sun Mar 31 18:52:30 2002
+++ ./Library/Implementation/HTString.c Sun Mar 31 18:53:07 2002
@@ -62,32 +62,6 @@
}
-/*
-** strcasestr(s1,s2) -- like strstr(s1,s2) but case-insensitive.
-*/
-PUBLIC char * strcasestr (char * s1, char * s2)
-{
- char * ptr = s1;
-
- if (!s1 || !s2 || !*s2) return s1;
-
- while (*ptr) {
- if (TOUPPER(*ptr) == TOUPPER(*s2)) {
- char * cur1 = ptr + 1;
- char * cur2 = s2 + 1;
- while (*cur1 && *cur2 && TOUPPER(*cur1) == TOUPPER(*cur2)) {
- cur1++;
- cur2++;
- }
- if (!*cur2) return ptr;
- }
- ptr++;
- }
- return NULL;
-}
-
-
-
/* Allocate a new copy of a string, and returns it
*/
PUBLIC char * HTSACopy (char ** dest, CONST char * src)

View File

@ -1,18 +0,0 @@
--- ./Library/Implementation/HTString.h.orig Sun Mar 31 18:52:36 2002
+++ ./Library/Implementation/HTString.h Sun Mar 31 18:52:50 2002
@@ -61,14 +61,6 @@
*/
extern char * HTStrMatch (CONST char * tmpl, CONST char * name);
extern char * HTStrCaseMatch (CONST char * tmpl, CONST char * name);
-/*
-
-Case-insensitive strstr
-
- This works like strstr() but is not case-sensitive.
-
- */
-extern char * strcasestr (char * s1, char * s2);
/*
Strip white space off a string

View File

@ -1 +0,0 @@
WWW LineMode Browser from the W3 Consortium (W3C)

View File

@ -1,24 +0,0 @@
WELCOME TO THE WORLD-WIDE WEB LINE MODE BROWSER
===============================================
(c) COPYRIGHT CERN 1994.
Please first read the full copyright statement in the file COPYRIGHT.
The CERN Line Mode Browser is a character based World-Wide Web
Browser. It is developed for use on dumb terminals and as a test tool
for the CERN Common Code Library. It can be run in interactive mode,
non- interactive mode and as a proxy client. Furthermore it gives a
variety of possibilities for data format conversion, filtering etc. It
is primarily intended as a test-tool for quick access to the Web or
used in batch jobs.
For more information on the Line Mode Browser, please look at the page
WWW: http://info.cern.ch/hypertext/WWW/LineMode/Status.html
Have fun!
--
www-bug@info.cern.ch, November 1994

View File

@ -1 +0,0 @@
bin/www