- Update to 4.0.20 release

- Add experimental WITH_PROC_SCOPE_PTH knob to use process scope
  threads instead of system scope threads with libpthread
This commit is contained in:
Alex Dupre 2004-05-18 10:59:11 +00:00
parent f07c4360d3
commit 5286e6eabb
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=109423
6 changed files with 33 additions and 46 deletions

View File

@ -6,7 +6,6 @@
#
PORTNAME= mysql
PORTREVISION= 0
PKGNAMESUFFIX= -scripts
COMMENT= Multithreaded SQL database (scripts)

View File

@ -6,8 +6,8 @@
#
PORTNAME?= mysql
PORTVERSION= 4.0.18
PORTREVISION?= 1
PORTVERSION= 4.0.20
PORTREVISION?= 0
CATEGORIES= databases
MASTER_SITES= ftp://planetmirror.com/pub/mysql/Downloads/MySQL-4.0/ \
http://www.softagency.co.jp/MySQL/Downloads/MySQL-4.0/ \
@ -18,7 +18,7 @@ MASTER_SITES= ftp://planetmirror.com/pub/mysql/Downloads/MySQL-4.0/ \
ftp://ftp.rtfm.no/pub/mysql/Downloads/MySQL-4.0/ \
http://www.mysql.cz/Downloads/MySQL-4.0/ \
ftp://ftp.u-paris10.fr/mysql.com/Downloads/MySQL-4.0/ \
http://mysql.oms-net.nl/Downloads/MySQL-4.0/ \
http://mysql.proserve.nl/Downloads/MySQL-4.0/ \
ftp://ftp.free.fr/pub/MySQL/Downloads/MySQL-4.0/
PKGNAMESUFFIX?= -server
@ -128,6 +128,8 @@ pre-fetch:
@${ECHO} " DB_DIR=directory Set alternate directory for database files"
@${ECHO} " (default is /var/db/mysql)."
@${ECHO} " WITH_LINUXTHREADS=yes Use the linuxthreads pthread library."
@${ECHO} " WITH_PROC_SCOPE_PTH=yes Use process scope threads"
@${ECHO} " (try it if you use libpthread)."
@${ECHO} " OVERWRITE_DB=yes Re-initialize default databases."
@${ECHO} " BUILD_OPTIMIZED=yes Enable compiler optimizations"
@${ECHO} " (use it if you need speed)."
@ -140,6 +142,9 @@ post-patch:
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = @server_scripts@|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man_MANS =|man_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
@${REINPLACE_CMD} -e "s|install-data-am: install-pkgincludeHEADERS|install-data-am:|g" ${WRKSRC}/include/Makefile.in
.if defined(WITH_PROC_SCOPE_PTH)
@${REINPLACE_CMD} -e "s|PTHREAD_SCOPE_SYSTEM|PTHREAD_SCOPE_PROCESS|g" ${WRKSRC}/libmysqld/lib_sql.cc ${WRKSRC}/sql/mysqld.cc
.endif
post-build:
@${SED} "s|%%DB_DIR%%|${DB_DIR}|g" ${PKGDIR}/pkg-install > ${WRKDIR}/pkg-install
@ -188,6 +193,9 @@ post-patch:
@${REINPLACE_CMD} -e "s|SUBDIRS =|SUBDIRS = include @sql_client_dirs@ tests scripts man|g" ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e "s|bin_SCRIPTS =|bin_SCRIPTS = mysql_config mysql_fix_privilege_tables mysqlbug|g" ${WRKSRC}/scripts/Makefile.in
@${REINPLACE_CMD} -e "s|man_MANS =|man_MANS = ${MAN1}|g" ${WRKSRC}/man/Makefile.in
.if defined(WITH_PROC_SCOPE_PTH)
@${REINPLACE_CMD} -e "s|PTHREAD_SCOPE_SYSTEM|PTHREAD_SCOPE_PROCESS|g" ${WRKSRC}/tools/mysqlmanager.c
.endif
post-install:
@${SED} "s|%%PREFIX%%|${PREFIX}|g" < ${FILESDIR}/mysql-client.sh > ${PREFIX}/etc/rc.d/000.mysql-client.sh

View File

@ -1,2 +1,2 @@
MD5 (mysql-4.0.18.tar.gz) = 702151a3e21d9e5f32e8850032aefdad
SIZE (mysql-4.0.18.tar.gz) = 13422686
MD5 (mysql-4.0.20.tar.gz) = 7c75ac74e23396bd228dbc2c2d1131df
SIZE (mysql-4.0.20.tar.gz) = 13807983

View File

@ -1,15 +1,16 @@
--- configure.orig Fri Oct 17 07:29:41 2003
+++ configure Wed Oct 22 15:12:52 2003
@@ -9058,7 +9059,7 @@
;;
esac
fi
-HOSTNAME=$ac_cv_path_HOSTNAME
+HOSTNAME="$ac_cv_path_HOSTNAME -s"
--- configure.orig Tue May 18 11:12:39 2004
+++ configure Tue May 18 11:14:27 2004
@@ -18816,9 +18816,6 @@
if test -n "$HOSTNAME"; then
echo "$as_me:$LINENO: result: $HOSTNAME" >&5
@@ -9250,43 +9251,8 @@
-# Ensure that we have --preserve-dup-deps defines, otherwise we get link
-# problems of 'mysql' with CXX=g++
-LIBTOOL="$LIBTOOL --preserve-dup-deps"
#AC_LIBTOOL_DLOPEN AC_LIBTOOL_WIN32_DLL AC_DISABLE_FAST_INSTALL AC_DISABLE_SHARED AC_DISABLE_STATIC
@@ -19970,43 +19967,8 @@
echo "$as_me:$LINENO: checking \"how to check if pid exists\"" >&5
echo $ECHO_N "checking \"how to check if pid exists\"... $ECHO_C" >&6
PS=$ac_cv_path_PS
@ -53,7 +54,7 @@
echo "$as_me:$LINENO: result: \"$FIND_PROC\"" >&5
echo "${ECHO_T}\"$FIND_PROC\"" >&6
@@ -12667,8 +12633,8 @@
@@ -23603,8 +23565,8 @@
# Some system specific hacks
#
@ -64,7 +65,7 @@
case $SYSTEM_TYPE in
*solaris2.7*)
@@ -22458,7 +22424,7 @@
@@ -33605,7 +33567,7 @@
/* ) rel_srcdir="$srcdir" ;;
* ) rel_srcdir="../$srcdir" ;;
esac

View File

@ -1,6 +1,6 @@
--- scripts/Makefile.in.orig Mon Feb 23 13:02:34 2004
+++ scripts/Makefile.in Mon Feb 23 13:04:46 2004
@@ -271,24 +271,7 @@
--- scripts/Makefile.in.orig Fri May 14 02:54:11 2004
+++ scripts/Makefile.in Tue May 18 10:22:57 2004
@@ -271,25 +271,7 @@
vio_dir = @vio_dir@
vio_libs = @vio_libs@
@ -21,12 +21,13 @@
- mysql_explain_log \
- mysql_tableinfo \
- mysqld_multi \
- make_win_src_distribution
- make_win_src_distribution \
- make_win_binary_distribution
+bin_SCRIPTS =
EXTRA_SCRIPTS = make_binary_distribution.sh \
@@ -463,7 +446,7 @@
@@ -465,7 +447,7 @@
uninstall: uninstall-am
install-am: all-am

View File

@ -1,22 +0,0 @@
--- scripts/mysql_install_db.sh.orig Thu Mar 11 10:20:57 2004
+++ scripts/mysql_install_db.sh Thu Mar 11 10:27:09 2004
@@ -118,7 +118,7 @@
if [ $? -ne 0 ]
then
resolved=`$bindir/resolveip localhost 2>&1`
- if [ $? -eq 0 ]
+ if [ $? -ne 0 ]
then
echo "Neither host '$hostname' and 'localhost' could not be looked up with"
echo "$bindir/resolveip"
@@ -128,8 +128,8 @@
exit 1
fi
echo "WARNING: The host '$hostname' could not be looked up with resolveip."
- echo "This probably means that your libc libraries are not 100 % compatible"
- echo "with this binary MySQL version. The MySQL daemon, mysqld, should work"
+ echo "This probably means that your host name is not listed in your"
+ echo "/etc/hosts file (as it should). The MySQL daemon, mysqld, should work"
echo "normally with the exception that host name resolving will not work."
echo "This means that you should use IP addresses instead of hostnames"
echo "when specifying MySQL privileges !"