- Update to 4.10.1

- Finish to convert USES
- Replace post-patch target by patch (configure script)
- Remove unneeded patches
- Remove desktopfileutils, because MimeType entry is not present in desktop
file
This commit is contained in:
Olivier Duchateau 2013-05-08 15:42:11 +00:00
parent 3dd8bf4dc9
commit 5256282e7b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=317687
6 changed files with 19 additions and 103 deletions

View File

@ -2,10 +2,10 @@
# $FreeBSD$
PORTNAME= xfce4-panel
PORTVERSION= 4.10.0
PORTREVISION= 6
PORTVERSION= 4.10.1
CATEGORIES= x11-wm xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
MASTER_SITE_SUBDIR= src/xfce/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= xfce@FreeBSD.org
@ -15,19 +15,18 @@ LIB_DEPENDS= wnck-1:${PORTSDIR}/x11-toolkits/libwnck \
cairo:${PORTSDIR}/graphics/cairo \
dbus-glib-1:${PORTSDIR}/devel/dbus-glib
USES= pathfix pkgconfig
USES= desktop-file-utils pathfix pkgconfig
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_BZIP2= yes
USE_GMAKE= yes
USE_GNOME= glib20 gtk20 intltool intlhack desktopfileutils
USE_GNOME= glib20 gtk20 intltool intlhack
USE_LDCONFIG= yes
USE_PERL5= yes
USE_XFCE= configenv garcon libexo libmenu libutil xfconf
USE_XORG= x11 sm
CONFIGURE_ARGS+=--enable-gio-unix \
--disable-gtk-doc-html
CONFIGURE_ARGS+=--enable-gio-unix
OPTIONS_DEFINE= NLS DOCS
@ -50,13 +49,4 @@ CONFIGURE_ARGS+=--without-html-dir
PLIST_SUB+= APIDOCS="@comment "
.endif
post-patch:
.if empty(PORT_OPTIONS:MNLS)
@${REINPLACE_CMD} -e 's| icons \\| icons|' \
-e 's| po||' ${WRKSRC}/Makefile.in
.endif
post-install:
@-update-desktop-database
.include <bsd.port.mk>

View File

@ -1,2 +1,2 @@
SHA256 (xfce4/xfce4-panel-4.10.0.tar.bz2) = 3321f998af2bbd14ba68654a8881774f6ea2ec4f1a3544598e7f47d3ed0009b9
SIZE (xfce4/xfce4-panel-4.10.0.tar.bz2) = 1036257
SHA256 (xfce4/xfce4-panel-4.10.1.tar.bz2) = 573052ed1b65e247415f92df120c8a78f9e4152c2636d38c923f82e32b8475d6
SIZE (xfce4/xfce4-panel-4.10.1.tar.bz2) = 1061090

View File

@ -0,0 +1,11 @@
--- ./configure.orig 2013-05-05 15:47:13.000000000 +0000
+++ ./configure 2013-05-05 21:39:20.000000000 +0000
@@ -13517,7 +13517,7 @@
fi
fi
- USE_NLS=yes
+# USE_NLS=yes
gt_cv_have_gettext=no

View File

@ -1,46 +0,0 @@
--- ./libxfce4panel/xfce-panel-convenience.c.orig 2012-04-28 20:31:35.000000000 +0000
+++ ./libxfce4panel/xfce-panel-convenience.c 2013-04-06 21:01:14.000000000 +0000
@@ -158,7 +158,7 @@
gchar *name;
gchar *filename;
gint src_w, src_h;
- gdouble wratio, hratio;
+ gdouble ratio;
GdkPixbuf *dest;
GError *error = NULL;
gint size = MIN (dest_width, dest_height);
@@ -170,15 +170,13 @@
if (G_UNLIKELY (g_path_is_absolute (source)))
{
- pixbuf = gdk_pixbuf_new_from_file_at_scale (source, dest_width, dest_height, TRUE, &error);
+ pixbuf = gdk_pixbuf_new_from_file (source, &error);
if (G_UNLIKELY (pixbuf == NULL))
{
g_message ("Failed to load image \"%s\": %s",
source, error->message);
g_error_free (error);
}
-
- return pixbuf;
}
else
{
@@ -233,13 +231,11 @@
if (src_w > dest_width || src_h > dest_height)
{
/* calculate the new dimensions */
- wratio = (gdouble) src_w / (gdouble) size;
- hratio = (gdouble) src_h / (gdouble) size;
+ ratio = MIN ((gdouble) dest_width / (gdouble) src_w,
+ (gdouble) dest_height / (gdouble) src_h);
- if (hratio > wratio)
- dest_width = rint (src_w / hratio);
- else
- dest_height = rint (src_h / wratio);
+ dest_width = rint (src_w * ratio);
+ dest_height = rint (src_h * ratio);
dest = gdk_pixbuf_scale_simple (pixbuf,
MAX (dest_width, 1),

View File

@ -1,38 +0,0 @@
--- ./plugins/actions/actions.c.orig 2012-04-28 20:31:35.000000000 +0000
+++ ./plugins/actions/actions.c 2013-02-18 19:39:14.000000000 +0000
@@ -705,7 +705,7 @@
if (timeout->time_left == 0)
{
- /* unattended shutdown, so don't allow apps to cancel shutdown */
+ /* unattended shutdown, don't save the session to avoid blocking the logout */
timeout->unattended = TRUE;
gtk_dialog_response (GTK_DIALOG (timeout->dialog),
@@ -928,22 +928,22 @@
{
case ACTION_TYPE_LOGOUT:
succeed = actions_plugin_action_dbus_xfsm ("Logout", FALSE,
- unattended, &error);
+ !unattended, &error);
break;
case ACTION_TYPE_LOGOUT_DIALOG:
succeed = actions_plugin_action_dbus_xfsm ("Logout", TRUE,
- unattended, &error);
+ !unattended, &error);
break;
case ACTION_TYPE_RESTART:
succeed = actions_plugin_action_dbus_xfsm ("Restart", FALSE,
- unattended, &error);
+ !unattended, &error);
break;
case ACTION_TYPE_SHUTDOWN:
succeed = actions_plugin_action_dbus_xfsm ("Shutdown", FALSE,
- unattended, &error);
+ !unattended, &error);
break;
case ACTION_TYPE_HIBERNATE:

View File

@ -138,6 +138,7 @@ share/icons/hicolor/scalable/apps/xfce4-panel.svg
%%NLS%%share/locale/si/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/sk/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/sq/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/sr/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/sv/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/ta/LC_MESSAGES/xfce4-panel.mo
%%NLS%%share/locale/te/LC_MESSAGES/xfce4-panel.mo
@ -199,5 +200,3 @@ share/xfce4/panel/plugins/windowmenu.desktop
@dirrmtry etc/xdg/xfce4/panel
@dirrmtry etc/xdg/xfce4
@dirrmtry etc/xdg
@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true