MFH: r444694
math/openblas: unblock on Tier2 architectures - Limit DYNAMIC_ARCH to i386 and amd64 - Fix build on aarch64 [1] PR: 218547 Submitted by: andrew [1] Approved by: portmgr blanket [1], phd_kimberlite@yahoo.co.jp (maintainer) Approved by: ports-secteam blanket
This commit is contained in:
parent
840cd35cbe
commit
523e314c64
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2017Q2/; revision=444695
@ -33,7 +33,14 @@ OPENBLAS_SVER= 0
|
||||
OPENBLAS_FILES= ${OPENBLAS_LIBS:S|$|.so|} ${OPENBLAS_LIBS:S|$|.so.${OPENBLAS_SVER}|} ${OPENBLAS_LIBS:S|$|.a|}
|
||||
PLIST_FILES= ${OPENBLAS_FILES:S|^|lib/|}
|
||||
|
||||
OPTIONS_DEFINE= DYNAMIC_ARCH INTERFACE64 OPENMP AVX AVX2
|
||||
OPTIONS_DEFINE= INTERFACE64 OPENMP
|
||||
OPTIONS_DEFINE_i386= DYNAMIC_ARCH AVX AVX2
|
||||
OPTIONS_DEFINE_amd64= ${OPTIONS_DEFINE_i386}
|
||||
|
||||
.if defined(BATCH) || defined(PACKAGE_BUILDING)
|
||||
OPTIONS_DEFAULT_i386= DYNAMIC_ARCH
|
||||
OPTIONS_DEFAULT_amd64= DYNAMIC_ARCH
|
||||
.endif
|
||||
|
||||
DYNAMIC_ARCH_DESC= Support multiple CPU types on i386 and amd64
|
||||
INTERFACE64_DESC= Use 8 byte integers on 64-bit architectures
|
||||
@ -41,10 +48,6 @@ OPENMP_DESC= Use OpenMP for threading
|
||||
AVX_DESC= Support Advanced Vector Extensions (AVX)
|
||||
AVX2_DESC= Support Advanced Vector Extensions 2 (AVX2)
|
||||
|
||||
.if defined(BATCH) || defined(PACKAGE_BUILDING)
|
||||
OPTIONS_DEFAULT= DYNAMIC_ARCH
|
||||
.endif
|
||||
|
||||
.include <bsd.port.options.mk>
|
||||
|
||||
.if defined(TARGET_CPU_ARCH)
|
||||
@ -60,7 +63,7 @@ BUILDFLAGS+= BINARY32=1
|
||||
BUILDFLAGS+= BINARY64=1
|
||||
.endif
|
||||
|
||||
.if ! ( ${PORT_OPTIONS:MDYNAMIC_ARCH} && ( ${ARCH} == "amd64" || ${ARCH} == "i386" ) )
|
||||
.if ! ${PORT_OPTIONS:MDYNAMIC_ARCH} && ( ${ARCH} == "amd64" || ${ARCH} == "i386" )
|
||||
MANUAL_PACKAGE_BUILD= Optimizes for the build machine.
|
||||
.endif
|
||||
|
||||
|
11
math/openblas/files/patch-cpuid__arm64.c
Normal file
11
math/openblas/files/patch-cpuid__arm64.c
Normal file
@ -0,0 +1,11 @@
|
||||
--- cpuid_arm64.c.orig 2016-09-01 03:58:42 UTC
|
||||
+++ cpuid_arm64.c
|
||||
@@ -132,6 +132,8 @@ int detect(void)
|
||||
|
||||
|
||||
}
|
||||
+#else
|
||||
+ return CPU_ARMV8;
|
||||
#endif
|
||||
|
||||
return CPU_UNKNOWN;
|
Loading…
Reference in New Issue
Block a user