- Update to 0.43

PR:		170147
Submitted by:	Ports Fury
This commit is contained in:
Martin Wilke 2012-08-05 08:13:22 +00:00
parent 26e5c730d7
commit 52183c360c
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=302089
7 changed files with 43 additions and 121 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= bastet
PORTVERSION= 0.41
PORTREVISION= 1
PORTVERSION= 0.43
CATEGORIES= games
MASTER_SITES= http://fph.altervista.org/prog/files/
EXTRACT_SUFX= .tgz
@ -15,7 +14,34 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= An ncurses Tetris clone which is harder than every other Tetris
USE_GMAKE= yes
MAKE_ENV= DATADIR=${DATADIR}
LICENSE= GPLv3 # (or later)
.include <bsd.port.mk>
LIB_DEPENDS= boost_program_options:${PORTSDIR}/devel/boost-libs
USE_NCURSES= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAN6= bastet.6
PLIST_FILES= bin/bastet
.include <bsd.port.pre.mk>
.if ${ARCH} != "i386"
USE_GCC= 4.6+
.endif
post-patch:
@${REINPLACE_CMD} -e \
's|^CXXFLAGS+=-D|CXXFLAGS+=$$(CPPFLAGS) -D| ; \
s|$$(CXX) -MM|$$(CXX) $$(CPPFLAGS) -MM| ; \
s| -ggdb | |' ${WRKSRC}/Makefile
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bastet ${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/bastet.6 ${MAN6PREFIX}/man/man6
.include <bsd.port.post.mk>

View File

@ -1,2 +1,2 @@
SHA256 (bastet-0.41.tgz) = 32e58210499d4c525a2b2c82e08e1bbbc53de455b74922c94ac25a1fb7e17463
SIZE (bastet-0.41.tgz) = 24195
SHA256 (bastet-0.43.tgz) = e208c68684cc9b818a08b0d3f5f1e7ef381b1e4d8bc801a90b5ff6a8f00d8168
SIZE (bastet-0.43.tgz) = 29115

View File

@ -1,21 +0,0 @@
--- Makefile.orig Tue Oct 19 19:54:58 2004
+++ Makefile Thu Oct 21 20:43:02 2004
@@ -1,8 +1,8 @@
#makefile for bastet (c) 2004 Federico Poloni
#default paths
-BIN_PREFIX=/usr/bin/
-DATA_PREFIX=/var/games/
+BIN_PREFIX=$(PREFIX)/bin/
+DATA_PREFIX=$(PREFIX)/share/bastet/
HISCORE=bastet.scores
#in order to handle highscores properly, bastet must be setuid.
@@ -41,6 +41,7 @@
cp $(EXNAME) $(BIN_PREFIX)
chown $(GAME_USER) $(BIN_PREFIX)$(EXNAME)
chmod u+s $(BIN_PREFIX)$(EXNAME)
+ mkdir -p $(DATA_PREFIX)
touch $(DATA_PREFIX)$(HISCORE)
chown $(GAME_USER) $(DATA_PREFIX)$(HISCORE)
chmod 644 $(DATA_PREFIX)$(HISCORE)

View File

@ -1,11 +0,0 @@
--- bast.c.orig Thu Oct 21 20:32:29 2004
+++ bast.c Thu Oct 21 20:32:39 2004
@@ -1,7 +1,7 @@
#include <stdlib.h>
#include <stdio.h>
#include <ncurses.h>
-#include <termio.h>
+#include <termios.h>
#include <assert.h>
#include <unistd.h>
#include <string.h>

View File

@ -1,67 +0,0 @@
diff -ru game.c bastet-0.41/game.c
--- game.c Sat Dec 18 00:28:00 2004
+++ bastet-0.41/game.c Sat Dec 18 00:56:26 2004
@@ -12,6 +12,9 @@
#include "game.h"
#include "main.h"
#include "bast.h"
+#include <sys/select.h>
+
+void bast_clear();
const DOT block_data[BLOCK_TYPES][BLOCK_ORIENTS][BLOCK_DOTS] =
{
@@ -66,7 +70,7 @@
/* Delay before block drop one step down (usec).
We start at one sec. and then decreases the delay by 23% at each level. */
-const int delay[NO_LEVELS] = {1000000, 770000, 593000, 457000, 352000, 271000, 208000, 160000, 124000, 95000};
+const int delay[NO_LEVELS] = {999999, 770000, 593000, 457000, 352000, 271000, 208000, 160000, 124000, 95000};
/* Window in which the action takes place. */
WINDOW *well_win;
@@ -278,6 +282,7 @@
refresh();
}
+struct timeval mytimeout;
/* Drop a block in the well. When done return y-cord. of where block
ended. If it's not possible to even start with a new block return -1. */
int drop_block(int type, int level)
@@ -288,14 +293,13 @@
int orient = 0;
int ch;
fd_set inputs, test_fds;
- struct timeval timeout;
int sel_ret;
if (0 == check_block_pos(y, x, type, orient))
return -1; /* Oh no, game over. */
- timeout.tv_sec = 0;
- timeout.tv_usec = delay[level];
+ mytimeout.tv_sec = 0;
+ mytimeout.tv_usec = delay[level];
FD_ZERO(&inputs);
FD_SET(0, &inputs);
@@ -308,7 +312,7 @@
while(1) {
test_fds = inputs;
- sel_ret = select(FD_SETSIZE, &test_fds, (fd_set *) 0, (fd_set *) 0, &timeout);
+ sel_ret = select(FD_SETSIZE, &test_fds, (fd_set *) 0, (fd_set *) 0, &mytimeout);
ch = getch();
@@ -391,8 +402,8 @@
set_block(y, x, type, orient);
return y;
}
- timeout.tv_sec = 0;
- timeout.tv_usec = delay[level];
+ mytimeout.tv_sec = 0;
+ mytimeout.tv_usec = delay[level];
}
}
}

View File

@ -1,15 +1,13 @@
Have you ever thought Tetris(R) was evil because it wouldn't send
you that straight "I" brick you needed in order to clear four rows
at the same time?
Have you ever thought Tetris(R) was evil because it wouldn't send you
that straight "I" brick you needed in order to clear four rows at the
same time?
Well Tetris(R) probably isn't evil, but Bastet
certainly is. Bastet stands for "bastard tetris", and is a
simple ncurses-based Tetris(R) clone for Linux. Unlike normal
Tetris(R), however, Bastet does not choose your next brick at random.
Instead, Bastet uses a special algorithm designed to choose the
worst brick possible.
Well Tetris(R) probably isn't evil, but Bastet certainly is. Bastet
stands for "bastard tetris", and is a simple ncurses-based Tetris(R)
clone for Linux. Unlike normal Tetris(R), however, Bastet does not
choose your next brick at random. Instead, Bastet uses a special
algorithm designed to choose the worst brick possible.
As you can imagine, playing Bastet can be a
very frustrating experience!
As you can imagine, playing Bastet can be a very frustrating experience!
WWW: http://fph.altervista.org/prog/bastet.shtml
WWW: http://fph.altervista.org/prog/bastet.html

View File

@ -1,3 +0,0 @@
bin/bastet
%%DATADIR%%/bastet.scores
@dirrm %%DATADIR%%