MFH: r560820

Fix JIT support in the PHP8 build

Approved by:		tz
Differential Revision:	https://reviews.freebsd.org/D28042
This commit is contained in:
Torsten Zuehlsdorff 2021-01-10 21:58:59 +00:00
parent be4078e768
commit 5209d0c3b7
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=561112
2 changed files with 31 additions and 0 deletions

View File

@ -0,0 +1,20 @@
--- config.m4.orig 2020-11-24 17:04:03 UTC
+++ config.m4
@@ -29,7 +29,7 @@ if test "$PHP_OPCACHE" != "no"; then
if test "$PHP_OPCACHE_JIT" = "yes"; then
case $host_cpu in
- x86*)
+ x86*|amd64|i386)
;;
*)
AC_MSG_WARN([JIT not supported by host architecture])
@@ -60,7 +60,7 @@ if test "$PHP_OPCACHE" != "no"; then
*x86_64-*-darwin*)
DASM_FLAGS="-D X64APPLE=1 -D X64=1"
;;
- *x86_64*)
+ *x86_64*|amd64-*-freebsd*)
DASM_FLAGS="-D X64=1"
;;
esac

View File

@ -0,0 +1,11 @@
--- jit/Makefile.frag.orig 2020-11-24 17:04:03 UTC
+++ jit/Makefile.frag
@@ -5,7 +5,7 @@ $(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c
$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua
$(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
-$(builddir)/jit/zend_jit.lo: \
+jit/zend_jit.lo: \
$(builddir)/jit/zend_jit_x86.c \
$(srcdir)/jit/zend_jit_helpers.c \
$(srcdir)/jit/zend_jit_disasm_x86.c \