MFH: r560820
Fix JIT support in the PHP8 build Approved by: tz Differential Revision: https://reviews.freebsd.org/D28042
This commit is contained in:
parent
be4078e768
commit
5209d0c3b7
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/branches/2021Q1/; revision=561112
20
www/php80-opcache/files/patch-config.m4
Normal file
20
www/php80-opcache/files/patch-config.m4
Normal file
@ -0,0 +1,20 @@
|
||||
--- config.m4.orig 2020-11-24 17:04:03 UTC
|
||||
+++ config.m4
|
||||
@@ -29,7 +29,7 @@ if test "$PHP_OPCACHE" != "no"; then
|
||||
|
||||
if test "$PHP_OPCACHE_JIT" = "yes"; then
|
||||
case $host_cpu in
|
||||
- x86*)
|
||||
+ x86*|amd64|i386)
|
||||
;;
|
||||
*)
|
||||
AC_MSG_WARN([JIT not supported by host architecture])
|
||||
@@ -60,7 +60,7 @@ if test "$PHP_OPCACHE" != "no"; then
|
||||
*x86_64-*-darwin*)
|
||||
DASM_FLAGS="-D X64APPLE=1 -D X64=1"
|
||||
;;
|
||||
- *x86_64*)
|
||||
+ *x86_64*|amd64-*-freebsd*)
|
||||
DASM_FLAGS="-D X64=1"
|
||||
;;
|
||||
esac
|
11
www/php80-opcache/files/patch-jit_Makefile.frag
Normal file
11
www/php80-opcache/files/patch-jit_Makefile.frag
Normal file
@ -0,0 +1,11 @@
|
||||
--- jit/Makefile.frag.orig 2020-11-24 17:04:03 UTC
|
||||
+++ jit/Makefile.frag
|
||||
@@ -5,7 +5,7 @@ $(builddir)/minilua: $(srcdir)/jit/dynasm/minilua.c
|
||||
$(builddir)/jit/zend_jit_x86.c: $(srcdir)/jit/zend_jit_x86.dasc $(srcdir)/jit/dynasm/*.lua $(builddir)/minilua
|
||||
$(builddir)/minilua $(srcdir)/jit/dynasm/dynasm.lua $(DASM_FLAGS) -o $@ $(srcdir)/jit/zend_jit_x86.dasc
|
||||
|
||||
-$(builddir)/jit/zend_jit.lo: \
|
||||
+jit/zend_jit.lo: \
|
||||
$(builddir)/jit/zend_jit_x86.c \
|
||||
$(srcdir)/jit/zend_jit_helpers.c \
|
||||
$(srcdir)/jit/zend_jit_disasm_x86.c \
|
Loading…
Reference in New Issue
Block a user