multimedia/butt: update 0.1.25 -> 0.1.27

Relnotes:	https://danielnoethen.de/butt/Changelog.html
This commit is contained in:
Kurt Jaeger 2020-12-27 20:41:19 +00:00
parent 07c54168f4
commit 51cba9640b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=559424
5 changed files with 22 additions and 92 deletions

View File

@ -1,7 +1,7 @@
# $FreeBSD$ # $FreeBSD$
PORTNAME= butt PORTNAME= butt
PORTVERSION= 0.1.25 PORTVERSION= 0.1.27
CATEGORIES= multimedia graphics CATEGORIES= multimedia graphics
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION} MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@ -23,10 +23,10 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libsamplerate.so:audio/libsamplerate \ libsamplerate.so:audio/libsamplerate \
libvorbis.so:audio/libvorbis libvorbis.so:audio/libvorbis
USES= autoreconf compiler:c++11-lang gmake jpeg pkgconfig xorg ssl uidfix USES= autoreconf compiler:c++11-lang gettext \
gmake jpeg pkgconfig xorg ssl uidfix
USE_XORG= x11 xrender xcursor xfixes xext xft xinerama USE_XORG= x11 xrender xcursor xfixes xext xft xinerama
GNU_CONFIGURE= yes GNU_CONFIGURE= yes
PLIST_FILES= bin/butt PLIST_FILES= bin/butt share/locale/de/LC_MESSAGES/butt.mo
.include <bsd.port.mk> .include <bsd.port.mk>

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1604949832 TIMESTAMP = 1609088325
SHA256 (butt-0.1.25.tar.gz) = 7c9f44227584e30040315a5c86419bf3e654bd3523634d34b18c9017206334cb SHA256 (butt-0.1.27.tar.gz) = e19a9b457414d2ca68947b49f4c3180ca8b3210b1c4f3925d71eacf1d47bab87
SIZE (butt-0.1.25.tar.gz) = 983685 SIZE (butt-0.1.27.tar.gz) = 1081649

View File

@ -1,64 +0,0 @@
--- configure.ac.orig 2020-11-09 19:04:41.803234000 +0100
+++ configure.ac 2020-11-09 19:48:22.239576000 +0100
@@ -66,6 +66,7 @@
build_linux=no
build_windows=no
build_mac=no
+build_freebsd=no
# Detect the target system
case "${host_os}" in
@@ -102,6 +103,25 @@
build_mac=yes
AC_MSG_NOTICE([MacOS detected])
;;
+ freebsd*)
+ build_freebsd=yes
+ AC_MSG_NOTICE([FreeBSD detected])
+
+ AS_IF([test "x$enable_aac" != "xno"],
+ [
+ AC_CHECK_LIB([fdk-aac], [aacEncOpen], [],
+ [AC_MSG_ERROR([**** Could not find libfdk-aac ****])]
+ )
+ ])
+ AS_IF([test "x$enable_ssl" != "xno"], [
+ AC_CHECK_LIB([ssl], [SSL_CTX_new], [],
+ [AC_MSG_ERROR([**** Could not find libssl ****])]
+ )
+ AC_CHECK_LIB([crypto], [EVP_EncryptInit], [],
+ [AC_MSG_ERROR([**** Could not find libcrypto ****])]
+ )
+ ])
+ ;;
*)
AC_MSG_ERROR(["OS $host_os is not supported"])
;;
@@ -111,6 +131,7 @@
AM_CONDITIONAL([LINUX], [test "$build_linux" = "yes"])
AM_CONDITIONAL([WINDOWS], [test "$build_windows" = "yes"])
AM_CONDITIONAL([OSX], [test "$build_mac" = "yes"])
+AM_CONDITIONAL([FREEBSD], [test "$build_freebsd" = "yes"])
AC_CHECK_PROG([FLTKCONFIG],[fltk-config], [fltk-config])
@@ -141,6 +162,19 @@
])
fi
+#Add dbus library for FreeBSD
+if test "$build_freebsd" = "yes"; then
+ AC_MSG_NOTICE([])
+ PKG_CHECK_MODULES([DBUS], [dbus-1], [
+ AC_DEFINE([HAVE_DBUS], [1], [Use dbus to get current tracks])
+ LIBS="$LIBS $DBUS_LIBS"
+ CFLAGS="$CFLAGS $LIBS $DBUS_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $DBUS_CFLAGS"
+ ], [
+ AC_DEFINE([HAVE_DBUS], [0], [Use dbus to get current tracks])
+ AC_MSG_ERROR([**** Coud not find dbus dev files])
+ ])
+fi
# Checks for header files.
AC_PATH_X
AC_CHECK_HEADERS([fcntl.h limits.h netdb.h netinet/in.h stdlib.h string.h sys/socket.h unistd.h])

View File

@ -1,11 +0,0 @@
--- src/FLTK/fl_funcs.cpp.orig 2020-11-09 19:05:50.529619000 +0100
+++ src/FLTK/fl_funcs.cpp 2020-11-09 19:14:30.905597000 +0100
@@ -155,7 +155,7 @@
fl_g->choice_cfg_app->add("VOX");
fl_g->check_cfg_use_app->value(cfg.main.app_update);
fl_g->choice_cfg_app->value(cfg.main.app_update_service);
-#elif __linux__ && HAVE_DBUS
+#elif (__linux__ || __FreeBSD__) && HAVE_DBUS
fl_g->choice_cfg_app->add("Rhythmbox");
fl_g->choice_cfg_app->add("Banshee");
fl_g->choice_cfg_app->add("Clementine");

View File

@ -1,13 +1,18 @@
--- src/Makefile.am.orig 2020-11-09 19:05:11.378421000 +0100 --- src/Makefile.am.orig 2020-12-27 21:27:17.416688000 +0100
+++ src/Makefile.am 2020-11-09 19:12:12.772675000 +0100 +++ src/Makefile.am 2020-12-27 21:27:34.578674000 +0100
@@ -34,6 +34,10 @@ @@ -25,7 +25,6 @@
butt_SOURCES += currentTrack.h currentTrackLinux.cpp if WINDOWS
butt_SOURCES += resource.rc currentTrack.h currentTrack.cpp
AM_CPPFLAGS += -DHAVE_LIBFDK_AAC
-LDADD = -lintl
endif endif
+if FREEBSD if OSX
+butt_SOURCES += currentTrack.h currentTrackLinux.cpp @@ -38,6 +37,7 @@
+endif
+
# used only under MinGW to compile the resource.rc file (manifest and program icon)
.rc.o: if FREEBSD
butt_SOURCES += currentTrack.h currentTrackLinux.cpp
+LDADD = -lintl
endif
# used only under MinGW to compile the resource.rc file (manifest and program icon)