Update deskutils/charmtimetracker to 1.12.0, latest upstream release.

Changes https://github.com/KDAB/Charm/releases/tag/1.12.0

 - qtkeychain is now a mandatory dependency
 - the KDAB-internal billing code is no longer optional, but
   can be user-configured away (I hope by default)
 - duplicate idle detection dialog removed
 - lots of other small fixes
This commit is contained in:
Adriaan de Groot 2018-08-31 21:41:41 +00:00
parent 236c9afbd3
commit 519df5d921
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=478612
5 changed files with 37 additions and 49 deletions

View File

@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= charmtimetracker
DISTVERSION= 1.11.4
PORTREVISION= 2
DISTVERSION= 1.12.0
PORTREVISION= 0
CATEGORIES= deskutils
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
PATCHFILES= 51a0a34e9673.patch:-p1
# PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
MAINTAINER= adridg@FreeBSD.org
COMMENT= Time tracker
@ -17,11 +16,10 @@ COMMENT= Time tracker
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libqt5keychain.so:security/qtkeychain@qt5
USES= cmake:outsource compiler:c++11-lib qt:5
# Use bundled keychain; the keychain is only used for KDAB-internal
# features not available or configurable in the port.
CMAKE_ARGS= -DCharm_VERSION:STRING=${PORTVERSION} \
-DCMAKE_DISABLE_FIND_PACKAGE_Qt5Keychain=TRUE
CMAKE_ARGS= -DCharm_VERSION:STRING=${PORTVERSION}
USE_GITHUB= yes
GH_ACCOUNT= KDAB

View File

@ -1,5 +1,3 @@
TIMESTAMP = 1535709914
SHA256 (KDAB-Charm-1.11.4_GH0.tar.gz) = 24f31c76e30a56e87647a8aafa87e448e86e23e9e796c225b0e824a40dfb663b
SIZE (KDAB-Charm-1.11.4_GH0.tar.gz) = 809067
SHA256 (51a0a34e9673.patch) = 31e7d3213fe887cbe469b684888fb85852403b3ef515338453213367282f482f
SIZE (51a0a34e9673.patch) = 895
TIMESTAMP = 1535747617
SHA256 (KDAB-Charm-1.12.0_GH0.tar.gz) = 82e1b2356bd5a29f4b6b19b6c7dc7a8b0ce32574a5999b617647743e012f52b6
SIZE (KDAB-Charm-1.12.0_GH0.tar.gz) = 825231

View File

@ -1,47 +1,34 @@
- Shuffle a little to enforce C++11 in a normal way
- Drop non-standard flags (unbreak PPC64)
- Don't install license, since the ports LICENSE_FILE already does that
--- CMakeLists.txt.orig 2016-11-02 11:10:18 UTC
Hopefully the bundled parts of ECM handle compiler flags properly.
--- CMakeLists.txt.orig 2018-06-15 07:34:16 UTC
+++ CMakeLists.txt
@@ -1,4 +1,8 @@
-PROJECT( Charm )
+CMAKE_MINIMUM_REQUIRED( VERSION 2.6.0 )
+PROJECT( Charm CXX )
@@ -1,5 +1,7 @@
-CMAKE_MINIMUM_REQUIRED( VERSION 2.8.12 )
-PROJECT( Charm CXX )
+CMAKE_MINIMUM_REQUIRED( VERSION 3.10 )
+PROJECT( Charm VERSION ${Charm_VERSION} LANGUAGES CXX )
+SET( CMAKE_CXX_STANDARD 11 )
+SET( CMAKE_CXX_STANDARD_REQUIRED ON )
+
include(FeatureSummary)
@@ -12,7 +14,6 @@ include(KDEFrameworkCompilerSettings NO_
include(ECMInstallIcons)
-
IF( NOT Charm_VERSION )
FIND_PACKAGE( Git QUIET )
IF( EXISTS ${GIT_EXECUTABLE} )
@@ -34,12 +38,8 @@ ENDIF()
MESSAGE( STATUS "Building Charm ${Charm_VERSION} in ${CMAKE_BUILD_TYPE} mode" )
-CMAKE_MINIMUM_REQUIRED( VERSION 2.6.0 )
SET( CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/CMake" )
-IF(CMAKE_COMPILER_IS_GNUCXX OR ${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang")
- SET(CMAKE_CXX_FLAGS "-std=c++0x ${CMAKE_CXX_FLAGS}")
-ENDIF()
IF(MSVC)
SET(CMAKE_CXX_FLAGS "-D_USING_V110_SDK71_=1 ${CMAKE_CXX_FLAGS}")
ENDIF()
@@ -191,7 +185,7 @@ IF( APPLE AND "${QT_VERSION_MAJOR}.${QT_
ENDIF()
IF( CMAKE_BUILD_TYPE MATCHES "^[Rr]elease$" )
- ADD_DEFINITIONS( -DQT_NO_DEBUG_OUTPUT )
+ ADD_DEFINITIONS( -DQT_NO_DEBUG_OUTPUT -DNDEBUG )
ENDIF()
# Always include the source and build directories in the include path
@@ -264,7 +258,7 @@ CONFIGURE_FILE( CharmCMake.h.cmake ${CMA
@@ -119,7 +120,7 @@ CONFIGURE_FILE( CharmCMake.h.cmake ${CMA
SET( LICENSE_FILE "License.txt" )
SET( README_FILE "ReadMe.txt" )
SET( README_FILE "ReadMe.md" )
IF( NOT APPLE )
- INSTALL( FILES "${LICENSE_FILE}" "${README_FILE}" DESTINATION ${DOC_INSTALL_DIR} )
+ INSTALL( FILES "${README_FILE}" DESTINATION ${DOC_INSTALL_DIR} )
ENDIF()
# Only support CPack packaging on newer versions of CMake.
IF (WIN32)

View File

@ -1,5 +1,5 @@
Charm is a program for OS X, Linux and Windows that helps to keep track
of time. It is built around two major ideas - tasks and events. Tasks
Charm is a program for FreeBSD, OS X, Linux and Windows that helps to keep
track of time. It is built around two major ideas - tasks and events. Tasks
are the things time is spend on, repeatedly. For example, ironing
laundry is a task. The laundry done for two hours on last Tuesday is an
event in that task. When doing laundry multiple times, the events will

View File

@ -1,4 +1,9 @@
bin/charmtimetracker
share/applications/charmtimetracker.desktop
%%DOCSDIR%%/ReadMe.txt
share/icons/hicolor/128x128/apps/Charm-128x128.png
share/doc/HTML/charmtimetracker/ReadMe.md
share/icons/hicolor/128x128/apps/Charm.png
share/icons/hicolor/16x16/apps/Charm.png
share/icons/hicolor/256x256/apps/Charm.png
share/icons/hicolor/32x32/apps/Charm.png
share/icons/hicolor/48x48/apps/Charm.png
share/icons/hicolor/64x64/apps/Charm.png