Upgrade to LLVM 2.0.

From the release notes: "This is the first LLVM release to correctly
compile and optimize major software like LLVM itself, Mozilla/Seamonkey,
Qt 4.3rc1, kOffice, etc out of the box on linux/x86"

For details on the changes to LLVM see:

http://llvm.org/releases/2.0/docs/ReleaseNotes.html

Submitted by:	se
PR:		ports/114169
This commit is contained in:
Brooks Davis 2007-07-18 14:53:39 +00:00
parent c2f327cc44
commit 5198c6449d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=195856
9 changed files with 127 additions and 198 deletions

View File

@ -6,6 +6,15 @@ You should get into the habit of checking this file for changes each
time you update your ports collection, before attempting any port
upgrades.
20070718:
AFFECTS: user of devel/llvm
AUTHOR: brooks@freebsd.org
The llvm bytecode and .ll formats have changed as have numerious
internal APIs. Existing users should consult the release notes.
http://llvm.org/releases/2.0/docs/ReleaseNotes.html
20070716:
AFFECTS: users of editors/emacs
AUTHOR: nobutaka@FreeBSD.org

View File

@ -6,7 +6,7 @@
#
PORTNAME= llvm
PORTVERSION= 1.9
PORTVERSION= 2.0
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
@ -21,10 +21,11 @@ USE_GCC= 3.3+
CONFIGURE_FLAGS+= --enable-optimized
MAN1= bugpoint.1 gccas.1 gccld.1 llc.1 lli.1 llvm-ar.1 \
MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
llvm-prof.1 llvm-ranlib.1 llvm2cpp.1 llvmc.1 llvmgcc.1 \
llvm-prof.1 llvm-ranlib.1 llvm-upgrade.1 \
llvm2cpp.1 llvmc.1 llvmgcc.1 \
llvmgxx.1 opt.1 stkrc.1 tblgen.1
.include <bsd.port.pre.mk>
@ -38,6 +39,9 @@ post-patch:
${WRKSRC}/Makefile.config.in
post-install:
${RM} -f ${PREFIX}/bin/.dir ${PREFIX}/lib/.dir
${RM} -f ${PREFIX}/bin/.dir \
${PREFIX}/etc/.dir \
${PREFIX}/etc/llvm/.dir \
${PREFIX}/lib/.dir
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (llvm-1.9.tar.gz) = 866ba97420f5ce978b6a6b1cb4338890
SHA256 (llvm-1.9.tar.gz) = 17b82323151925ff5a7ad09a21781a0fa50ead4b87a339cee262271e4ededa13
SIZE (llvm-1.9.tar.gz) = 4835549
MD5 (llvm-2.0.tar.gz) = 6f88002301a25f31a492052695f6138e
SHA256 (llvm-2.0.tar.gz) = 84d7ca0331963d2b2be7e18af61a80f49653c692f0bad63c5d26b2a2f7bc3375
SIZE (llvm-2.0.tar.gz) = 4715502

View File

@ -1,56 +0,0 @@
--- include/llvm/Module.h.orig Wed Mar 8 18:38:51 2006
+++ include/llvm/Module.h Tue Aug 8 11:26:39 2006
@@ -24,6 +24,53 @@
#include "llvm/ADT/SetVector.h"
#include "llvm/Support/DataTypes.h"
+// Workarounds for FreeBSD 4
+#include <osreldate.h>
+#if __FreeBSD_version < 500000
+#ifndef INT8_MIN
+#define INT8_MIN (-0x7f-1)
+#endif
+#ifndef INT16_MIN
+#define INT16_MIN (-0x7fff-1)
+#endif
+#ifndef INT32_MIN
+#define INT32_MIN (-0x7fffffff-1)
+#endif
+#ifndef INT64_MIN
+#define INT64_MIN (-0x7fffffffffffffffL-1)
+#endif
+#ifndef INT8_MAX
+#define INT8_MAX 0x7f
+#endif
+#ifndef INT16_MAX
+#define INT16_MAX 0x7fff
+#endif
+#ifndef INT32_MAX
+#define INT32_MAX 0x7fffffff
+#endif
+#ifndef INT64_MAX
+#define INT64_MAX 0x7fffffffffffffffL
+#endif
+#ifndef UINT8_MAX
+#define UINT8_MAX 0xff
+#endif
+#ifndef UINT16_MAX
+#define UINT16_MAX 0xffff
+#endif
+#ifndef UINT32_MAX
+#define UINT32_MAX 0xffffffffU
+#endif
+#ifndef UINT64_MAX
+#define UINT64_MAX 0xffffffffffffffffUL
+#endif
+
+static inline long long
+llabs(long long x)
+{
+ return x > 0 ? x : -x;
+}
+#endif
+
namespace llvm {
class GlobalVariable;

View File

@ -16,32 +16,39 @@ bin/llvm-nm
bin/llvm-prof
bin/llvm-ranlib
bin/llvm-stub
bin/llvm-upgrade
bin/llvm2cpp
bin/llvmc
bin/opt
etc/llvm/.dir
etc/llvm/c
etc/llvm/c++
etc/llvm/cpp
etc/llvm/cxx
etc/llvm/ll
include/llvm/ADT/BitSetVector.h
include/llvm/ADT/CStringMap.h
etc/llvm/st
include/llvm-c/LinkTimeOptimizer.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
include/llvm/ADT/DenseMap.h
include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
include/llvm/ADT/HashExtras.h
include/llvm/ADT/IndexedMap.h
include/llvm/ADT/PostOrderIterator.h
include/llvm/ADT/SCCIterator.h
include/llvm/ADT/STLExtras.h
include/llvm/ADT/SetOperations.h
include/llvm/ADT/SetVector.h
include/llvm/ADT/SmallPtrSet.h
include/llvm/ADT/SmallSet.h
include/llvm/ADT/SmallString.h
include/llvm/ADT/SmallVector.h
include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
include/llvm/ADT/Tree.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/VectorExtras.h
@ -56,12 +63,6 @@ include/llvm/Analysis/CFGPrinter.h
include/llvm/Analysis/CallGraph.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
include/llvm/Analysis/DataStructure/CallTargets.h
include/llvm/Analysis/DataStructure/DSGraph.h
include/llvm/Analysis/DataStructure/DSGraphTraits.h
include/llvm/Analysis/DataStructure/DSNode.h
include/llvm/Analysis/DataStructure/DSSupport.h
include/llvm/Analysis/DataStructure/DataStructure.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/ET-Forest.h
include/llvm/Analysis/FindUsedTypes.h
@ -70,6 +71,7 @@ include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
include/llvm/Analysis/LoadValueNumbering.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
include/llvm/Analysis/Passes.h
include/llvm/Analysis/PostDominators.h
include/llvm/Analysis/ProfileInfo.h
@ -83,35 +85,33 @@ include/llvm/Analysis/ValueNumbering.h
include/llvm/Analysis/Verifier.h
include/llvm/Argument.h
include/llvm/Assembly/AsmAnnotationWriter.h
include/llvm/Assembly/AutoUpgrade.h
include/llvm/Assembly/CachedWriter.h
include/llvm/Assembly/Parser.h
include/llvm/Assembly/PrintModulePass.h
include/llvm/Assembly/Writer.h
include/llvm/BasicBlock.h
include/llvm/Bytecode/Analyzer.h
include/llvm/Bytecode/Archive.h
include/llvm/Bytecode/BytecodeHandler.h
include/llvm/Bytecode/Format.h
include/llvm/Bytecode/Reader.h
include/llvm/Bytecode/WriteBytecodePass.h
include/llvm/Bytecode/Writer.h
include/llvm/Bitcode/Archive.h
include/llvm/Bitcode/BitCodes.h
include/llvm/Bitcode/BitstreamReader.h
include/llvm/Bitcode/BitstreamWriter.h
include/llvm/Bitcode/LLVMBitCodes.h
include/llvm/Bitcode/ReaderWriter.h
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/CallingConvLower.h
include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFWriter.h
include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FileWriters.h
include/llvm/CodeGen/InstrScheduling.h
include/llvm/CodeGen/IntrinsicLowering.h
include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
include/llvm/CodeGen/LiveIntervalAnalysis.h
include/llvm/CodeGen/LiveVariables.h
include/llvm/CodeGen/MachOWriter.h
include/llvm/CodeGen/MachORelocation.h
include/llvm/CodeGen/MachineBasicBlock.h
include/llvm/CodeGen/MachineCodeEmitter.h
include/llvm/CodeGen/MachineConstantPool.h
include/llvm/CodeGen/MachineDebugInfo.h
include/llvm/CodeGen/MachineFrameInfo.h
include/llvm/CodeGen/MachineFunction.h
include/llvm/CodeGen/MachineFunctionPass.h
@ -119,10 +119,13 @@ include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
include/llvm/CodeGen/MachineModuleInfo.h
include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterScavenging.h
include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/SSARegMap.h
include/llvm/CodeGen/SchedGraphCommon.h
include/llvm/CodeGen/ScheduleDAG.h
@ -148,6 +151,7 @@ include/llvm/ExecutionEngine/GenericValue.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
include/llvm/Function.h
include/llvm/GlobalAlias.h
include/llvm/GlobalValue.h
include/llvm/GlobalVariable.h
include/llvm/InlineAsm.h
@ -166,11 +170,12 @@ include/llvm/LinkAllVMCore.h
include/llvm/LinkTimeOptimizer.h
include/llvm/Linker.h
include/llvm/Module.h
include/llvm/Module.h.orig
include/llvm/ModuleProvider.h
include/llvm/ParameterAttributes.h
include/llvm/Pass.h
include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassSupport.h
include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/Allocator.h
@ -180,7 +185,6 @@ include/llvm/Support/CallSite.h
include/llvm/Support/Casting.h
include/llvm/Support/CommandLine.h
include/llvm/Support/Compiler.h
include/llvm/Support/Compressor.h
include/llvm/Support/ConstantRange.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataTypes.h
@ -197,19 +201,22 @@ include/llvm/Support/LeakDetector.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/Mangler.h
include/llvm/Support/MathExtras.h
include/llvm/Support/MemoryBuffer.h
include/llvm/Support/MutexGuard.h
include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
include/llvm/Support/SlowOperationInformer.h
include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/Streams.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/Timer.h
include/llvm/Support/TypeInfo.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTable.h
include/llvm/SymbolTableListTraits.h
include/llvm/System/Alarm.h
include/llvm/System/Disassembler.h
include/llvm/System/DynamicLibrary.h
include/llvm/System/IncludeFile.h
include/llvm/System/LICENSE.TXT
@ -225,11 +232,13 @@ include/llvm/Target/MRegisterInfo.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
include/llvm/Target/TargetFrameInfo.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetInstrItineraries.h
include/llvm/Target/TargetJITInfo.h
include/llvm/Target/TargetLowering.h
include/llvm/Target/TargetMachOWriterInfo.h
include/llvm/Target/TargetMachine.h
include/llvm/Target/TargetMachineRegistry.h
include/llvm/Target/TargetOptions.h
@ -253,19 +262,22 @@ include/llvm/ValueSymbolTable.h
lib/LLVMARM.o
lib/LLVMAlpha.o
lib/LLVMCBackend.o
lib/LLVMDataStructure.o
lib/LLVMExecutionEngine.o
lib/LLVMHello.a
lib/LLVMHello.la
lib/LLVMHello.so.0
lib/LLVMIA64.o
lib/LLVMInterpreter.o
lib/LLVMJIT.o
lib/LLVMMSIL.o
lib/LLVMPowerPC.o
lib/LLVMSparc.o
lib/LLVMX86.o
lib/libLLVMAnalysis.a
lib/libLLVMArchive.a
lib/libLLVMAsmParser.a
lib/libLLVMBCReader.a
lib/libLLVMBCWriter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
lib/libLLVMCodeGen.a
lib/libLLVMCore.a
lib/libLLVMDebugger.a
@ -277,20 +289,17 @@ lib/libLLVMSupport.a
lib/libLLVMSystem.a
lib/libLLVMTarget.a
lib/libLLVMTransformUtils.a
lib/libLLVMTransforms.a
lib/libLLVMbzip2.a
lib/libLLVMipa.a
lib/libLLVMipo.a
lib/libLLVMlto.a
%%DOCSDIR%%/html.tar.gz
%%DOCSDIR%%/html/AliasAnalysis.html
%%DOCSDIR%%/html/BitCodeFormat.html
%%DOCSDIR%%/html/Bugpoint.html
%%DOCSDIR%%/html/BytecodeFormat.html
%%DOCSDIR%%/html/CFEBuildInstrs.html
%%DOCSDIR%%/html/CodeGenerator.html
%%DOCSDIR%%/html/CodingStandards.html
%%DOCSDIR%%/html/CommandGuide/bugpoint.html
%%DOCSDIR%%/html/CommandGuide/gccas.html
%%DOCSDIR%%/html/CommandGuide/gccld.html
%%DOCSDIR%%/html/CommandGuide/index.html
%%DOCSDIR%%/html/CommandGuide/llc.html
%%DOCSDIR%%/html/CommandGuide/lli.html
@ -306,6 +315,7 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
%%DOCSDIR%%/html/CommandGuide/llvm-upgrade.html
%%DOCSDIR%%/html/CommandGuide/llvm2cpp.html
%%DOCSDIR%%/html/CommandGuide/llvmc.html
%%DOCSDIR%%/html/CommandGuide/llvmgcc.html
@ -317,6 +327,8 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/CommandLine.html
%%DOCSDIR%%/html/CompilerDriver.html
%%DOCSDIR%%/html/CompilerWriterInfo.html
%%DOCSDIR%%/html/DeveloperPolicy.html
%%DOCSDIR%%/html/ExceptionHandling.html
%%DOCSDIR%%/html/ExtendingLLVM.html
%%DOCSDIR%%/html/FAQ.html
%%DOCSDIR%%/html/GarbageCollection.html
@ -329,6 +341,7 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/Lexicon.html
%%DOCSDIR%%/html/LinkTimeOptimization.html
%%DOCSDIR%%/html/MakefileGuide.html
%%DOCSDIR%%/html/Passes.html
%%DOCSDIR%%/html/ProgrammersManual.html
%%DOCSDIR%%/html/Projects.html
%%DOCSDIR%%/html/ReleaseNotes.html
@ -349,8 +362,6 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/index.html
%%DOCSDIR%%/html/llvm.css
%%DOCSDIR%%/ps/bugpoint.ps
%%DOCSDIR%%/ps/gccas.ps
%%DOCSDIR%%/ps/gccld.ps
%%DOCSDIR%%/ps/llc.ps
%%DOCSDIR%%/ps/lli.ps
%%DOCSDIR%%/ps/llvm-ar.ps
@ -365,6 +376,7 @@ lib/libLLVMipo.a
%%DOCSDIR%%/ps/llvm-nm.ps
%%DOCSDIR%%/ps/llvm-prof.ps
%%DOCSDIR%%/ps/llvm-ranlib.ps
%%DOCSDIR%%/ps/llvm-upgrade.ps
%%DOCSDIR%%/ps/llvm2cpp.ps
%%DOCSDIR%%/ps/llvmc.ps
%%DOCSDIR%%/ps/llvmgcc.ps
@ -381,11 +393,11 @@ lib/libLLVMipo.a
@dirrm include/llvm/Debugger
@dirrm include/llvm/Config
@dirrm include/llvm/CodeGen
@dirrm include/llvm/Bytecode
@dirrm include/llvm/Bitcode
@dirrm include/llvm/Assembly
@dirrm include/llvm/Analysis/DataStructure
@dirrm include/llvm/Analysis
@dirrm include/llvm/ADT
@dirrm include/llvm-c
@dirrm include/llvm
@dirrm etc/llvm
@dirrm %%DOCSDIR%%/ps

View File

@ -6,7 +6,7 @@
#
PORTNAME= llvm
PORTVERSION= 1.9
PORTVERSION= 2.0
CATEGORIES= devel lang
MASTER_SITES= http://llvm.org/releases/${PORTVERSION}/
@ -21,10 +21,11 @@ USE_GCC= 3.3+
CONFIGURE_FLAGS+= --enable-optimized
MAN1= bugpoint.1 gccas.1 gccld.1 llc.1 lli.1 llvm-ar.1 \
MAN1= bugpoint.1 llc.1 lli.1 llvm-ar.1 \
llvm-as.1 llvm-bcanalyzer.1 llvm-config.1 llvm-db.1 \
llvm-dis.1 llvm-extract.1 llvm-ld.1 llvm-link.1 llvm-nm.1 \
llvm-prof.1 llvm-ranlib.1 llvm2cpp.1 llvmc.1 llvmgcc.1 \
llvm-prof.1 llvm-ranlib.1 llvm-upgrade.1 \
llvm2cpp.1 llvmc.1 llvmgcc.1 \
llvmgxx.1 opt.1 stkrc.1 tblgen.1
.include <bsd.port.pre.mk>
@ -38,6 +39,9 @@ post-patch:
${WRKSRC}/Makefile.config.in
post-install:
${RM} -f ${PREFIX}/bin/.dir ${PREFIX}/lib/.dir
${RM} -f ${PREFIX}/bin/.dir \
${PREFIX}/etc/.dir \
${PREFIX}/etc/llvm/.dir \
${PREFIX}/lib/.dir
.include <bsd.port.post.mk>

View File

@ -1,3 +1,3 @@
MD5 (llvm-1.9.tar.gz) = 866ba97420f5ce978b6a6b1cb4338890
SHA256 (llvm-1.9.tar.gz) = 17b82323151925ff5a7ad09a21781a0fa50ead4b87a339cee262271e4ededa13
SIZE (llvm-1.9.tar.gz) = 4835549
MD5 (llvm-2.0.tar.gz) = 6f88002301a25f31a492052695f6138e
SHA256 (llvm-2.0.tar.gz) = 84d7ca0331963d2b2be7e18af61a80f49653c692f0bad63c5d26b2a2f7bc3375
SIZE (llvm-2.0.tar.gz) = 4715502

View File

@ -1,56 +0,0 @@
--- include/llvm/Module.h.orig Wed Mar 8 18:38:51 2006
+++ include/llvm/Module.h Tue Aug 8 11:26:39 2006
@@ -24,6 +24,53 @@
#include "llvm/ADT/SetVector.h"
#include "llvm/Support/DataTypes.h"
+// Workarounds for FreeBSD 4
+#include <osreldate.h>
+#if __FreeBSD_version < 500000
+#ifndef INT8_MIN
+#define INT8_MIN (-0x7f-1)
+#endif
+#ifndef INT16_MIN
+#define INT16_MIN (-0x7fff-1)
+#endif
+#ifndef INT32_MIN
+#define INT32_MIN (-0x7fffffff-1)
+#endif
+#ifndef INT64_MIN
+#define INT64_MIN (-0x7fffffffffffffffL-1)
+#endif
+#ifndef INT8_MAX
+#define INT8_MAX 0x7f
+#endif
+#ifndef INT16_MAX
+#define INT16_MAX 0x7fff
+#endif
+#ifndef INT32_MAX
+#define INT32_MAX 0x7fffffff
+#endif
+#ifndef INT64_MAX
+#define INT64_MAX 0x7fffffffffffffffL
+#endif
+#ifndef UINT8_MAX
+#define UINT8_MAX 0xff
+#endif
+#ifndef UINT16_MAX
+#define UINT16_MAX 0xffff
+#endif
+#ifndef UINT32_MAX
+#define UINT32_MAX 0xffffffffU
+#endif
+#ifndef UINT64_MAX
+#define UINT64_MAX 0xffffffffffffffffUL
+#endif
+
+static inline long long
+llabs(long long x)
+{
+ return x > 0 ? x : -x;
+}
+#endif
+
namespace llvm {
class GlobalVariable;

View File

@ -16,32 +16,39 @@ bin/llvm-nm
bin/llvm-prof
bin/llvm-ranlib
bin/llvm-stub
bin/llvm-upgrade
bin/llvm2cpp
bin/llvmc
bin/opt
etc/llvm/.dir
etc/llvm/c
etc/llvm/c++
etc/llvm/cpp
etc/llvm/cxx
etc/llvm/ll
include/llvm/ADT/BitSetVector.h
include/llvm/ADT/CStringMap.h
etc/llvm/st
include/llvm-c/LinkTimeOptimizer.h
include/llvm/ADT/APInt.h
include/llvm/ADT/APSInt.h
include/llvm/ADT/BitVector.h
include/llvm/ADT/DenseMap.h
include/llvm/ADT/DepthFirstIterator.h
include/llvm/ADT/EquivalenceClasses.h
include/llvm/ADT/FoldingSet.h
include/llvm/ADT/GraphTraits.h
include/llvm/ADT/HashExtras.h
include/llvm/ADT/IndexedMap.h
include/llvm/ADT/PostOrderIterator.h
include/llvm/ADT/SCCIterator.h
include/llvm/ADT/STLExtras.h
include/llvm/ADT/SetOperations.h
include/llvm/ADT/SetVector.h
include/llvm/ADT/SmallPtrSet.h
include/llvm/ADT/SmallSet.h
include/llvm/ADT/SmallString.h
include/llvm/ADT/SmallVector.h
include/llvm/ADT/Statistic.h
include/llvm/ADT/StringExtras.h
include/llvm/ADT/StringMap.h
include/llvm/ADT/Tree.h
include/llvm/ADT/UniqueVector.h
include/llvm/ADT/VectorExtras.h
@ -56,12 +63,6 @@ include/llvm/Analysis/CFGPrinter.h
include/llvm/Analysis/CallGraph.h
include/llvm/Analysis/ConstantFolding.h
include/llvm/Analysis/ConstantsScanner.h
include/llvm/Analysis/DataStructure/CallTargets.h
include/llvm/Analysis/DataStructure/DSGraph.h
include/llvm/Analysis/DataStructure/DSGraphTraits.h
include/llvm/Analysis/DataStructure/DSNode.h
include/llvm/Analysis/DataStructure/DSSupport.h
include/llvm/Analysis/DataStructure/DataStructure.h
include/llvm/Analysis/Dominators.h
include/llvm/Analysis/ET-Forest.h
include/llvm/Analysis/FindUsedTypes.h
@ -70,6 +71,7 @@ include/llvm/Analysis/IntervalIterator.h
include/llvm/Analysis/IntervalPartition.h
include/llvm/Analysis/LoadValueNumbering.h
include/llvm/Analysis/LoopInfo.h
include/llvm/Analysis/LoopPass.h
include/llvm/Analysis/Passes.h
include/llvm/Analysis/PostDominators.h
include/llvm/Analysis/ProfileInfo.h
@ -83,35 +85,33 @@ include/llvm/Analysis/ValueNumbering.h
include/llvm/Analysis/Verifier.h
include/llvm/Argument.h
include/llvm/Assembly/AsmAnnotationWriter.h
include/llvm/Assembly/AutoUpgrade.h
include/llvm/Assembly/CachedWriter.h
include/llvm/Assembly/Parser.h
include/llvm/Assembly/PrintModulePass.h
include/llvm/Assembly/Writer.h
include/llvm/BasicBlock.h
include/llvm/Bytecode/Analyzer.h
include/llvm/Bytecode/Archive.h
include/llvm/Bytecode/BytecodeHandler.h
include/llvm/Bytecode/Format.h
include/llvm/Bytecode/Reader.h
include/llvm/Bytecode/WriteBytecodePass.h
include/llvm/Bytecode/Writer.h
include/llvm/Bitcode/Archive.h
include/llvm/Bitcode/BitCodes.h
include/llvm/Bitcode/BitstreamReader.h
include/llvm/Bitcode/BitstreamWriter.h
include/llvm/Bitcode/LLVMBitCodes.h
include/llvm/Bitcode/ReaderWriter.h
include/llvm/CallGraphSCCPass.h
include/llvm/CallingConv.h
include/llvm/CodeGen/AsmPrinter.h
include/llvm/CodeGen/CallingConvLower.h
include/llvm/CodeGen/DwarfWriter.h
include/llvm/CodeGen/ELFWriter.h
include/llvm/CodeGen/ELFRelocation.h
include/llvm/CodeGen/FileWriters.h
include/llvm/CodeGen/InstrScheduling.h
include/llvm/CodeGen/IntrinsicLowering.h
include/llvm/CodeGen/LinkAllCodegenComponents.h
include/llvm/CodeGen/LiveInterval.h
include/llvm/CodeGen/LiveIntervalAnalysis.h
include/llvm/CodeGen/LiveVariables.h
include/llvm/CodeGen/MachOWriter.h
include/llvm/CodeGen/MachORelocation.h
include/llvm/CodeGen/MachineBasicBlock.h
include/llvm/CodeGen/MachineCodeEmitter.h
include/llvm/CodeGen/MachineConstantPool.h
include/llvm/CodeGen/MachineDebugInfo.h
include/llvm/CodeGen/MachineFrameInfo.h
include/llvm/CodeGen/MachineFunction.h
include/llvm/CodeGen/MachineFunctionPass.h
@ -119,10 +119,13 @@ include/llvm/CodeGen/MachineInstr.h
include/llvm/CodeGen/MachineInstrBuilder.h
include/llvm/CodeGen/MachineJumpTableInfo.h
include/llvm/CodeGen/MachineLocation.h
include/llvm/CodeGen/MachineModuleInfo.h
include/llvm/CodeGen/MachinePassRegistry.h
include/llvm/CodeGen/MachineRelocation.h
include/llvm/CodeGen/Passes.h
include/llvm/CodeGen/RegAllocRegistry.h
include/llvm/CodeGen/RegisterScavenging.h
include/llvm/CodeGen/RuntimeLibcalls.h
include/llvm/CodeGen/SSARegMap.h
include/llvm/CodeGen/SchedGraphCommon.h
include/llvm/CodeGen/ScheduleDAG.h
@ -148,6 +151,7 @@ include/llvm/ExecutionEngine/GenericValue.h
include/llvm/ExecutionEngine/Interpreter.h
include/llvm/ExecutionEngine/JIT.h
include/llvm/Function.h
include/llvm/GlobalAlias.h
include/llvm/GlobalValue.h
include/llvm/GlobalVariable.h
include/llvm/InlineAsm.h
@ -166,11 +170,12 @@ include/llvm/LinkAllVMCore.h
include/llvm/LinkTimeOptimizer.h
include/llvm/Linker.h
include/llvm/Module.h
include/llvm/Module.h.orig
include/llvm/ModuleProvider.h
include/llvm/ParameterAttributes.h
include/llvm/Pass.h
include/llvm/PassAnalysisSupport.h
include/llvm/PassManager.h
include/llvm/PassManagers.h
include/llvm/PassSupport.h
include/llvm/Support/AIXDataTypesFix.h
include/llvm/Support/Allocator.h
@ -180,7 +185,6 @@ include/llvm/Support/CallSite.h
include/llvm/Support/Casting.h
include/llvm/Support/CommandLine.h
include/llvm/Support/Compiler.h
include/llvm/Support/Compressor.h
include/llvm/Support/ConstantRange.h
include/llvm/Support/DOTGraphTraits.h
include/llvm/Support/DataTypes.h
@ -197,19 +201,22 @@ include/llvm/Support/LeakDetector.h
include/llvm/Support/ManagedStatic.h
include/llvm/Support/Mangler.h
include/llvm/Support/MathExtras.h
include/llvm/Support/MemoryBuffer.h
include/llvm/Support/MutexGuard.h
include/llvm/Support/OutputBuffer.h
include/llvm/Support/PassNameParser.h
include/llvm/Support/PatternMatch.h
include/llvm/Support/PluginLoader.h
include/llvm/Support/SlowOperationInformer.h
include/llvm/Support/StableBasicBlockNumbering.h
include/llvm/Support/Streams.h
include/llvm/Support/SystemUtils.h
include/llvm/Support/Timer.h
include/llvm/Support/TypeInfo.h
include/llvm/Support/type_traits.h
include/llvm/SymbolTable.h
include/llvm/SymbolTableListTraits.h
include/llvm/System/Alarm.h
include/llvm/System/Disassembler.h
include/llvm/System/DynamicLibrary.h
include/llvm/System/IncludeFile.h
include/llvm/System/LICENSE.TXT
@ -225,11 +232,13 @@ include/llvm/Target/MRegisterInfo.h
include/llvm/Target/SubtargetFeature.h
include/llvm/Target/TargetAsmInfo.h
include/llvm/Target/TargetData.h
include/llvm/Target/TargetELFWriterInfo.h
include/llvm/Target/TargetFrameInfo.h
include/llvm/Target/TargetInstrInfo.h
include/llvm/Target/TargetInstrItineraries.h
include/llvm/Target/TargetJITInfo.h
include/llvm/Target/TargetLowering.h
include/llvm/Target/TargetMachOWriterInfo.h
include/llvm/Target/TargetMachine.h
include/llvm/Target/TargetMachineRegistry.h
include/llvm/Target/TargetOptions.h
@ -253,19 +262,22 @@ include/llvm/ValueSymbolTable.h
lib/LLVMARM.o
lib/LLVMAlpha.o
lib/LLVMCBackend.o
lib/LLVMDataStructure.o
lib/LLVMExecutionEngine.o
lib/LLVMHello.a
lib/LLVMHello.la
lib/LLVMHello.so.0
lib/LLVMIA64.o
lib/LLVMInterpreter.o
lib/LLVMJIT.o
lib/LLVMMSIL.o
lib/LLVMPowerPC.o
lib/LLVMSparc.o
lib/LLVMX86.o
lib/libLLVMAnalysis.a
lib/libLLVMArchive.a
lib/libLLVMAsmParser.a
lib/libLLVMBCReader.a
lib/libLLVMBCWriter.a
lib/libLLVMBitReader.a
lib/libLLVMBitWriter.a
lib/libLLVMCodeGen.a
lib/libLLVMCore.a
lib/libLLVMDebugger.a
@ -277,20 +289,17 @@ lib/libLLVMSupport.a
lib/libLLVMSystem.a
lib/libLLVMTarget.a
lib/libLLVMTransformUtils.a
lib/libLLVMTransforms.a
lib/libLLVMbzip2.a
lib/libLLVMipa.a
lib/libLLVMipo.a
lib/libLLVMlto.a
%%DOCSDIR%%/html.tar.gz
%%DOCSDIR%%/html/AliasAnalysis.html
%%DOCSDIR%%/html/BitCodeFormat.html
%%DOCSDIR%%/html/Bugpoint.html
%%DOCSDIR%%/html/BytecodeFormat.html
%%DOCSDIR%%/html/CFEBuildInstrs.html
%%DOCSDIR%%/html/CodeGenerator.html
%%DOCSDIR%%/html/CodingStandards.html
%%DOCSDIR%%/html/CommandGuide/bugpoint.html
%%DOCSDIR%%/html/CommandGuide/gccas.html
%%DOCSDIR%%/html/CommandGuide/gccld.html
%%DOCSDIR%%/html/CommandGuide/index.html
%%DOCSDIR%%/html/CommandGuide/llc.html
%%DOCSDIR%%/html/CommandGuide/lli.html
@ -306,6 +315,7 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/CommandGuide/llvm-nm.html
%%DOCSDIR%%/html/CommandGuide/llvm-prof.html
%%DOCSDIR%%/html/CommandGuide/llvm-ranlib.html
%%DOCSDIR%%/html/CommandGuide/llvm-upgrade.html
%%DOCSDIR%%/html/CommandGuide/llvm2cpp.html
%%DOCSDIR%%/html/CommandGuide/llvmc.html
%%DOCSDIR%%/html/CommandGuide/llvmgcc.html
@ -317,6 +327,8 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/CommandLine.html
%%DOCSDIR%%/html/CompilerDriver.html
%%DOCSDIR%%/html/CompilerWriterInfo.html
%%DOCSDIR%%/html/DeveloperPolicy.html
%%DOCSDIR%%/html/ExceptionHandling.html
%%DOCSDIR%%/html/ExtendingLLVM.html
%%DOCSDIR%%/html/FAQ.html
%%DOCSDIR%%/html/GarbageCollection.html
@ -329,6 +341,7 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/Lexicon.html
%%DOCSDIR%%/html/LinkTimeOptimization.html
%%DOCSDIR%%/html/MakefileGuide.html
%%DOCSDIR%%/html/Passes.html
%%DOCSDIR%%/html/ProgrammersManual.html
%%DOCSDIR%%/html/Projects.html
%%DOCSDIR%%/html/ReleaseNotes.html
@ -349,8 +362,6 @@ lib/libLLVMipo.a
%%DOCSDIR%%/html/index.html
%%DOCSDIR%%/html/llvm.css
%%DOCSDIR%%/ps/bugpoint.ps
%%DOCSDIR%%/ps/gccas.ps
%%DOCSDIR%%/ps/gccld.ps
%%DOCSDIR%%/ps/llc.ps
%%DOCSDIR%%/ps/lli.ps
%%DOCSDIR%%/ps/llvm-ar.ps
@ -365,6 +376,7 @@ lib/libLLVMipo.a
%%DOCSDIR%%/ps/llvm-nm.ps
%%DOCSDIR%%/ps/llvm-prof.ps
%%DOCSDIR%%/ps/llvm-ranlib.ps
%%DOCSDIR%%/ps/llvm-upgrade.ps
%%DOCSDIR%%/ps/llvm2cpp.ps
%%DOCSDIR%%/ps/llvmc.ps
%%DOCSDIR%%/ps/llvmgcc.ps
@ -381,11 +393,11 @@ lib/libLLVMipo.a
@dirrm include/llvm/Debugger
@dirrm include/llvm/Config
@dirrm include/llvm/CodeGen
@dirrm include/llvm/Bytecode
@dirrm include/llvm/Bitcode
@dirrm include/llvm/Assembly
@dirrm include/llvm/Analysis/DataStructure
@dirrm include/llvm/Analysis
@dirrm include/llvm/ADT
@dirrm include/llvm-c
@dirrm include/llvm
@dirrm etc/llvm
@dirrm %%DOCSDIR%%/ps