Fix build for FreeBSD with clang version 10.0.1 rc1 f79cd71e145.
This commit is contained in:
parent
b476e22214
commit
51825d7f5e
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=541123
@ -33,6 +33,12 @@ EXTRASVERSION= 2
|
||||
OPTIONS_DEFINE= EXAMPLES NLS
|
||||
OPTIONS_SUB= yes
|
||||
|
||||
.include <bsd.port.pre.mk>
|
||||
|
||||
.if (${OSVERSION} >= 1300096)
|
||||
EXTRA_PATCHES= ${PATCHDIR}/extrapatch-BambooTracker_BambooTracker.pro
|
||||
.endif
|
||||
|
||||
do-install:
|
||||
@${MKDIR} ${STAGEDIR}${PREFIX}/share/icons \
|
||||
${STAGEDIR}${MANPREFIX}/man/fr.UTF-8/man1
|
||||
@ -52,4 +58,4 @@ do-install-EXAMPLES-on:
|
||||
${WRKDIR}/${PORTNAME}-extras-${EXTRASVERSION}/*.btm \
|
||||
${STAGEDIR}${EXAMPLESDIR}
|
||||
|
||||
.include <bsd.port.mk>
|
||||
.include <bsd.port.post.mk>
|
||||
|
@ -0,0 +1,11 @@
|
||||
--- BambooTracker/BambooTracker.pro.orig 2020-06-28 12:11:07 UTC
|
||||
+++ BambooTracker/BambooTracker.pro
|
||||
@@ -47,7 +47,7 @@ msvc {
|
||||
}
|
||||
else:if(gcc|clang) {
|
||||
# Pedantic settings, warning -> error escalation and C standard specification
|
||||
- CPPFLAGS += -Wall -Wextra -Werror -pedantic -pedantic-errors
|
||||
+ CPPFLAGS += -Wall
|
||||
QMAKE_CFLAGS += -std=gnu11
|
||||
|
||||
# Attempt to get the compiler version for version-specific handling
|
Loading…
Reference in New Issue
Block a user