graphics/digikam: update to 7.0.0 release

Relnotes:	https://www.digikam.org/news/
This commit is contained in:
Dima Panov 2020-07-17 15:34:03 +00:00
parent 95116534c3
commit 515e79eeb1
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=542441
11 changed files with 72 additions and 110 deletions

View File

@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= digikam
DISTVERSION= 6.4.0
PORTREVISION= 3
DISTVERSION= 7.0.0
CATEGORIES= graphics kde
MASTER_SITES= KDE/stable/${PORTNAME}/${PORTVERSION}
DIST_SUBDIR= KDE/digikam/${PORTVERSION}
@ -42,8 +41,8 @@ USE_KDE= archive auth bookmarks calendarcore codecs completion config \
kio marble libkipi notifications notifyconfig parts service \
solid sonnet textwidgets threadweaver unitconversion \
widgetsaddons windowsystem xmlgui
USE_QT= concurrent core dbus gui network opengl printsupport sql \
widgets x11extras xml xmlpatterns \
USE_QT= concurrent core dbus declarative gui location network opengl \
printsupport sql webchannel widgets x11extras xml xmlpatterns \
sql-sqlite3_run \
buildtools_build qmake_build
USE_XORG= ice sm x11 xext

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1575016178
SHA256 (KDE/digikam/6.4.0/digikam-6.4.0.tar.xz) = 775012ff515bdd25a0b894c95bf5d33e7122b523da9c0f3af260ec3eff498d6f
SIZE (KDE/digikam/6.4.0/digikam-6.4.0.tar.xz) = 340146992
TIMESTAMP = 1594993390
SHA256 (KDE/digikam/7.0.0/digikam-7.0.0.tar.xz) = dc0718e30031e692d7f05367b44e797fed61f12d27063641b6a5cf4d8b26e911
SIZE (KDE/digikam/7.0.0/digikam-7.0.0.tar.xz) = 571511148

View File

@ -1,11 +1,11 @@
--- CMakeLists.txt.orig 2019-08-30 21:55:44 UTC
--- CMakeLists.txt.orig 2020-04-23 11:51:20 UTC
+++ CMakeLists.txt
@@ -14,6 +14,8 @@ set(ECM_MIN_VERSION "1.5.0")
@@ -9,6 +9,8 @@ set(ECM_MIN_VERSION "1.7.0")
cmake_minimum_required(VERSION ${CMAKE_MIN_VERSION})
+cmake_policy(SET CMP0063 OLD) # Suppress visibility warnings
+
############## ECM setup #################################################################################################################
execute_process(COMMAND ${CMAKE_COMMAND} --version OUTPUT_VARIABLE VERSION_CMAKE_INFO)
message(STATUS "CMake version: ${VERSION_CMAKE_INFO}")
find_package(ECM ${ECM_MIN_VERSION} CONFIG REQUIRED)

View File

@ -1,22 +1,25 @@
--- core/CMakeLists.txt.orig 2019-07-31 16:12:57 UTC
--- core/CMakeLists.txt.orig 2020-04-23 11:51:20 UTC
+++ core/CMakeLists.txt
@@ -8,6 +8,7 @@
@@ -10,6 +10,7 @@ APPLY_COMMON_POLICIES()
project(digikam)
# ==============================================================================
+cmake_policy(SET CMP0063 OLD) # Suppress visibility warnings
message(STATUS "----------------------------------------------------------------------------------")
message(STATUS "Starting CMake configuration for: ${PROJECT_NAME}")
@@ -401,6 +402,11 @@ endif()
message(STATUS "Check dependencies for ${PROJECT_NAME} version ${DIGIKAM_VERSION_STRING}")
message(STATUS "")
@@ -341,8 +342,13 @@ endif()
find_package(Doxygen)
find_package(Lqr-1)
-if(NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
+#if(NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD)
find_package(Lqr-1)
+#endif()
+if(LQR-1_FOUND)
+ include_directories(${LQR-1_INCLUDE_DIRS})
+ set(liblqr_LIBS ${LQR-1_LIBRARIES})
+ link_directories(${LQR-1_LIBDIR})
+endif()
endif()
# -- libgphoto2 rules ----------------------------------------------------------

View File

@ -1,20 +1,20 @@
Add PATH_SUFFIXES to properly find the QtAV library.
--- core/cmake/modules/FindQtAV.cmake.orig 2017-01-08 22:08:44 UTC
--- core/cmake/modules/FindQtAV.cmake.orig 2020-04-23 11:51:20 UTC
+++ core/cmake/modules/FindQtAV.cmake
@@ -43,6 +43,7 @@ if (NOT APPLE)
@@ -52,6 +52,7 @@ if (NOT APPLE)
libQtAV
libQtAV1
HINTS ${_qt5_install_prefix}/../
+ PATH_SUFFIXES qt5
)
find_library(QTAV_WIDGETS_LIBRARY
@@ -51,6 +52,7 @@ if (NOT APPLE)
@@ -60,6 +61,7 @@ if (NOT APPLE)
libQtAVWidgets
libQtAVWidgets1
HINTS ${_qt5_install_prefix}/../
+ PATH_SUFFIXES qt5
)
set(QTAV_INCLUDE_DIRS "${QTAV_CORE_INCLUDE_DIR} ${QTAV_WIDGETS_INCLUDE_DIR}")

View File

@ -1,10 +0,0 @@
--- core/dplugins/generic/view/presentation/opengl/presentationgl.cpp.orig 2020-05-19 18:08:49 UTC
+++ core/dplugins/generic/view/presentation/opengl/presentationgl.cpp
@@ -44,6 +44,7 @@
#include <QMatrix>
#include <QMouseEvent>
#include <QPainter>
+#include <QPainterPath>
#include <QPixmap>
#include <QTimer>
#include <QWheelEvent>

View File

@ -1,10 +0,0 @@
--- core/libs/dimg/filters/curves/curveswidget.cpp.orig 2020-05-19 18:09:18 UTC
+++ core/libs/dimg/filters/curves/curveswidget.cpp
@@ -41,6 +41,7 @@
#include <QFont>
#include <QFontMetrics>
#include <QPaintEvent>
+#include <QPainterPath>
#include <QMouseEvent>
// KDE includes

View File

@ -1,10 +0,0 @@
--- core/libs/dimg/filters/levels/histogrampainter.cpp.orig 2020-05-19 18:09:04 UTC
+++ core/libs/dimg/filters/levels/histogrampainter.cpp
@@ -30,6 +30,7 @@
// Qt includes
#include <QPainter>
+#include <QPainterPath>
// KDE includes

View File

@ -1,11 +0,0 @@
--- core/libs/rawengine/libraw/internal/libraw_x3f.cpp.orig 2016-11-06 10:43:01 UTC
+++ core/libs/rawengine/libraw/internal/libraw_x3f.cpp
@@ -1392,7 +1392,7 @@ static void huffman_decode_row(x3f_info_
x3f_directory_entry_t *DE,
int bits,
int row,
- int offset,
+ int16_t offset,
int *minimum)
{
x3f_directory_entry_header_t *DEH = &DE->header;

View File

@ -1,33 +0,0 @@
Digikam bundles libxmp. Since this is already in Exiv2, we end up
with two copies of a bunch of symbols, and when Digikam loads
both libraries, and it then initializes Exiv2, that in turn calls
into the *wrong* copy of libxmp.
Just remove the bundled copy.
diff --git core/app/DigikamCoreTarget.cmake core/app/DigikamCoreTarget.cmake
index bf8c9f09e7..53284724b4 100644
--- core/app/DigikamCoreTarget.cmake
+++ core/app/DigikamCoreTarget.cmake
@@ -24,7 +24,7 @@ set(DIGIKAMCORE_OBJECTS
$<TARGET_OBJECTS:libwso2_src>
$<TARGET_OBJECTS:libmd5_src>
- $<TARGET_OBJECTS:libxmp_src>
+ # $<TARGET_OBJECTS:libxmp_src>
$<TARGET_OBJECTS:libdng_src>
$<TARGET_OBJECTS:dngwriter_src>
diff --git core/libs/dngwriter/CMakeLists.txt core/libs/dngwriter/CMakeLists.txt
index dc28a9c865..dc83173b37 100644
--- core/libs/dngwriter/CMakeLists.txt
+++ core/libs/dngwriter/CMakeLists.txt
@@ -66,7 +66,7 @@ foreach(_currentfile ${libxmp_SRCS})
endif()
endforeach()
-add_library(libxmp_src OBJECT ${libxmp_SRCS})
+# add_library(libxmp_src OBJECT ${libxmp_SRCS})
#------------------------------------------------------------------------------------

View File

@ -19,12 +19,14 @@ include/digikam/dcolor.h
include/digikam/dcolorblend.h
include/digikam/dcolorcomposer.h
include/digikam/dcolorpixelaccess.h
include/digikam/dcolorselector.h
include/digikam/dhistoryview.h
include/digikam/digikam_config.h
include/digikam/digikam_core_export.h
include/digikam/digikam_database_export.h
include/digikam/digikam_export.h
include/digikam/digikam_globals.h
include/digikam/digikam_gui_export.h
include/digikam/dimg.h
include/digikam/dimgbuiltinfilter.h
include/digikam/dimgloaderobserver.h
@ -36,6 +38,7 @@ include/digikam/ditemslist.h
include/digikam/dmessagebox.h
include/digikam/dmetainfoiface.h
include/digikam/dplugin.h
include/digikam/dpluginaboutdlg.h
include/digikam/dpluginaction.h
include/digikam/dpluginauthor.h
include/digikam/dpluginbqm.h
@ -51,9 +54,9 @@ include/digikam/drawdecodersettings.h
include/digikam/drawdecoding.h
include/digikam/drawinfo.h
include/digikam/dsavesettingswidget.h
include/digikam/dshareddata.h
include/digikam/dwizarddlg.h
include/digikam/dwizardpage.h
include/digikam/dynamicthread.h
include/digikam/editortool.h
include/digikam/filesaveconflictbox.h
include/digikam/filteraction.h
@ -66,6 +69,7 @@ include/digikam/graphicsdimgview.h
include/digikam/historyimageid.h
include/digikam/iccprofile.h
include/digikam/icctransform.h
include/digikam/imagedialog.h
include/digikam/imageiface.h
include/digikam/imageregionwidget.h
include/digikam/imagezoomsettings.h
@ -73,6 +77,8 @@ include/digikam/iofilesettings.h
include/digikam/iteminfo.h
include/digikam/iteminfolist.h
include/digikam/loadingdescription.h
include/digikam/loadsavethread.h
include/digikam/managedloadsavethread.h
include/digikam/metaengine.h
include/digikam/metaengine_data.h
include/digikam/photoinfocontainer.h
@ -82,6 +88,7 @@ include/digikam/previewtoolbar.h
include/digikam/queuesettings.h
include/digikam/rginfo.h
include/digikam/thumbnailinfo.h
include/digikam/thumbnailloadthread.h
include/digikam/wbcontainer.h
lib/cmake/DigikamCore/DigikamCoreConfig-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/DigikamCore/DigikamCoreConfig.cmake
@ -92,6 +99,7 @@ lib/cmake/DigikamDatabase/DigikamDatabaseConfigVersion.cmake
lib/cmake/DigikamGui/DigikamGuiConfig-%%CMAKE_BUILD_TYPE%%.cmake
lib/cmake/DigikamGui/DigikamGuiConfig.cmake
lib/cmake/DigikamGui/DigikamGuiConfigVersion.cmake
lib/cmake/DigikamPlugin/DigikamPluginConfig.cmake
lib/libdigikamcore.so
lib/libdigikamcore.so.%%SHLIB_VER%%
lib/libdigikamdatabase.so
@ -218,6 +226,7 @@ lib/libdigikamgui.so.%%SHLIB_VER%%
%%QT_PLUGINDIR%%/digikam/generic/Generic_PrintCreator_Plugin.so
%%QT_PLUGINDIR%%/digikam/generic/Generic_Rajce_Plugin.so
%%QT_PLUGINDIR%%/digikam/generic/Generic_SendByMail_Plugin.so
%%QT_PLUGINDIR%%/digikam/generic/Generic_SlideShow_Plugin.so
%%QT_PLUGINDIR%%/digikam/generic/Generic_SmugMug_Plugin.so
%%QT_PLUGINDIR%%/digikam/generic/Generic_TimeAdjust_Plugin.so
%%QT_PLUGINDIR%%/digikam/generic/Generic_Twitter_Plugin.so
@ -334,16 +343,9 @@ share/applications/org.kde.showfoto.desktop
%%DATADIR%%/data/wood-pattern.png
%%DATADIR%%/database/dbconfig.xml
%%DATADIR%%/database/mysql-global.conf
%%DATADIR%%/facesengine/dlib_face_recognition_resnet_model_v1.dat
%%DATADIR%%/facesengine/haarcascade_frontalface_alt.xml
%%DATADIR%%/facesengine/haarcascade_frontalface_alt2.xml
%%DATADIR%%/facesengine/haarcascade_frontalface_alt_tree.xml
%%DATADIR%%/facesengine/haarcascade_frontalface_default.xml
%%DATADIR%%/facesengine/haarcascade_mcs_lefteye.xml
%%DATADIR%%/facesengine/haarcascade_mcs_mouth.xml
%%DATADIR%%/facesengine/haarcascade_mcs_nose.xml
%%DATADIR%%/facesengine/haarcascade_mcs_righteye.xml
%%DATADIR%%/facesengine/haarcascade_profileface.xml
%%DATADIR%%/facesengine/deploy.prototxt
%%DATADIR%%/facesengine/openface_nn4.small2.v1.t7
%%DATADIR%%/facesengine/res10_300x300_ssd_iter_140000_fp16.caffemodel
%%DATADIR%%/facesengine/shapepredictor.dat
%%DATADIR%%/geoiface/backend-googlemaps-js.js
%%DATADIR%%/geoiface/backend-googlemaps.html
@ -507,6 +509,37 @@ share/applications/org.kde.showfoto.desktop
%%DATADIR%%/themes/frames/preview.png
%%DATADIR%%/themes/frames/style.css
%%DATADIR%%/themes/frames/template.xsl
%%DATADIR%%/themes/html5responsive/README
%%DATADIR%%/themes/html5responsive/html5responsive.desktop
%%DATADIR%%/themes/html5responsive/preview.png
%%DATADIR%%/themes/html5responsive/resources/css/basic.css
%%DATADIR%%/themes/html5responsive/resources/css/brownCard.css
%%DATADIR%%/themes/html5responsive/resources/css/default-skin/default-skin.css
%%DATADIR%%/themes/html5responsive/resources/css/default-skin/default-skin.png
%%DATADIR%%/themes/html5responsive/resources/css/default-skin/default-skin.svg
%%DATADIR%%/themes/html5responsive/resources/css/default-skin/preloader.gif
%%DATADIR%%/themes/html5responsive/resources/css/feed.css
%%DATADIR%%/themes/html5responsive/resources/css/fundament.css
%%DATADIR%%/themes/html5responsive/resources/css/lightbox.css
%%DATADIR%%/themes/html5responsive/resources/css/photoswipe.css
%%DATADIR%%/themes/html5responsive/resources/images/BrownCard/brownCard.png
%%DATADIR%%/themes/html5responsive/resources/images/BrownCard/brownCardAlbum.jpg
%%DATADIR%%/themes/html5responsive/resources/images/BrownCard/photoCorners.png
%%DATADIR%%/themes/html5responsive/resources/images/BrownCard/roughPhotoCard.png
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/Contact_corners.png
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/Large_contact.png
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/LightBox_topless.jpg
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/Lightbox_top.jpg
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/Monochrome-strip.jpg
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/SafetyFilm-strip.jpg
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/SlideFrame_landscape.png
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/SlideFrame_portrait.png
%%DATADIR%%/themes/html5responsive/resources/images/Lightbox/SlideFrame_square.png
%%DATADIR%%/themes/html5responsive/resources/js/photoswipe-ui-default.min.js
%%DATADIR%%/themes/html5responsive/resources/js/photoswipe.min.js
%%DATADIR%%/themes/html5responsive/resources/xslt/convertNewlinesToHtmlBreaksTemplate.xsl
%%DATADIR%%/themes/html5responsive/resources/xslt/xmlJsEscapeTemplate.xsl
%%DATADIR%%/themes/html5responsive/template.xsl
%%DATADIR%%/themes/matrix/bg.png
%%DATADIR%%/themes/matrix/matrix.desktop
%%DATADIR%%/themes/matrix/preview.png
@ -746,6 +779,7 @@ share/solid/actions/digikam-opencamera.desktop
%%NLS%%share/locale/hi/LC_MESSAGES/digikam.mo
%%NLS%%share/locale/hr/LC_MESSAGES/digikam.mo
%%NLS%%share/locale/hu/LC_MESSAGES/digikam.mo
%%NLS%%share/locale/id/LC_MESSAGES/digikam.mo
%%NLS%%share/locale/is/LC_MESSAGES/digikam.mo
%%NLS%%share/locale/it/LC_MESSAGES/digikam.mo
%%NLS%%share/locale/ja/LC_MESSAGES/digikam.mo