Add gribouy 0.0.8, Gribouy is a Type1 font editor.

This commit is contained in:
Alexander Nedotsukov 2003-11-20 14:26:26 +00:00
parent 318a536982
commit 5147a729ae
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=94466
6 changed files with 65 additions and 0 deletions

View File

@ -73,6 +73,7 @@
SUBDIR += gnome-cups-manager
SUBDIR += gnomephotoprinter
SUBDIR += gnomeprint
SUBDIR += gribouy
SUBDIR += gsfonts
SUBDIR += gtklp
SUBDIR += guitartex

22
print/gribouy/Makefile Normal file
View File

@ -0,0 +1,22 @@
# New ports collection makefile for: gribouy
# Date created: 20 Nov 2003
# Whom: bland@FreeBSD.org
#
# $FreeBSD$
#
PORTNAME= gribouy
PORTVERSION= 0.0.8
CATEGORIES= print gnome
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= gribouy/unstable.pkg/${PORTVERSION:R}
MAINTAINER= gnome@FreeBSD.org
COMMENT= Gribouy is a Type1 font editor
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack libglade2 libgnomeui
GNU_CONFIGURE= yes
.include <bsd.port.mk>

1
print/gribouy/distinfo Normal file
View File

@ -0,0 +1 @@
MD5 (gribouy-0.0.8.tar.gz) = dd6879b3fd8db0436eebb7ab89641c13

View File

@ -0,0 +1,26 @@
--- src/gribouy-main.c.orig Thu Nov 20 04:01:59 2003
+++ src/gribouy-main.c Thu Nov 20 04:03:00 2003
@@ -660,10 +660,11 @@
static GtkTreeIter *
model_append (const gchar *key, gpointer *value, GtkListStore **user_data)
{
- g_return_if_fail (GTK_IS_LIST_STORE (*user_data));
GtkTreeIter *iter;
GtkTreeSelection *selection;
+ g_return_if_fail (GTK_IS_LIST_STORE (*user_data));
+
iter = g_new0 (GtkTreeIter, 1);
gtk_list_store_append (GTK_LIST_STORE (*user_data), iter);
gtk_list_store_set (GTK_LIST_STORE (*user_data),
@@ -679,8 +680,9 @@
static void
construct_model (gchar *key, gpointer *value, GtkListStore **user_data)
{
- g_return_if_fail (GTK_IS_LIST_STORE (*user_data));
GtkTreeIter iter;
+
+ g_return_if_fail (GTK_IS_LIST_STORE (*user_data));
gtk_list_store_append (GTK_LIST_STORE (*user_data), &iter);
gtk_list_store_set (GTK_LIST_STORE (*user_data),

5
print/gribouy/pkg-descr Normal file
View File

@ -0,0 +1,5 @@
Gribouy comes from the french word "Gribouille". It is a font editor
released under the GNU General Public License (GPL) and a program
that requires GNOME to work.
WWW: http://www.nongnu.org/gribouy/

10
print/gribouy/pkg-plist Normal file
View File

@ -0,0 +1,10 @@
bin/gribouy
share/gnome/applications/gribouy.desktop
share/gnome/gnome-2.0/ui/gribouy-ui.xml
share/gnome/gribouy/glade/gribouy.glade
share/gnome/pixmaps/gribouy.png
share/gnome/pixmaps/gribouy/gribouy-graphics.png
share/gnome/pixmaps/gribouy/gribouy-logo.jpg
@dirrm share/gnome/pixmaps/gribouy
@dirrm share/gnome/gribouy/glade
@dirrm share/gnome/gribouy