- Fix run error when using zsh or sh as shell [1][2]

- Fix build error with custom LOCALBASE

PR:		ports/145349 [1]
		ports/144760 [2]
Submitted by:	Ryan Steinmetz <rpsfa@rit.edu> [1],
		Erwan david <erwan@rail.eu.org> [2]
This commit is contained in:
Wen Heping 2010-04-06 02:52:08 +00:00
parent e3b5ff9ba8
commit 50e16d28ba
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=252299
2 changed files with 24 additions and 1 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= tmux
PORTVERSION= 1.2
PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@ -24,9 +25,21 @@ PLIST_FILES= bin/tmux
PORTDOCS= CHANGES FAQ NOTES
PORTEXAMPLES= *
CFLAGS+= -I${LOCALBASE}/include
#LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ARGS+= CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
.include <bsd.port.pre.mk>
.if ${OSVERSION} <= 703100
EXTRA_PATCHES= ${FILESDIR}/extra-patch-configure
.endif
post-patch:
@${REINPLACE_CMD} -e '/^#define HAVE_TREE_H/d' \
${WRKSRC}/configure
@${REINPLACE_CMD} -e 's#/usr/local#${LOCALBASE}#g' \
${WRKSRC}/Makefile
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/tmux ${PREFIX}/bin
@ -45,4 +58,4 @@ post-install:
@${INSTALL_DATA} ${WRKSRC}/examples/* ${EXAMPLESDIR}
.endif
.include <bsd.port.mk>
.include <bsd.port.post.mk>

View File

@ -0,0 +1,10 @@
--- configure.orig 2010-03-17 09:12:09.000000000 +0800
+++ configure 2010-03-17 09:11:28.000000000 +0800
@@ -204,6 +204,7 @@
FreeBSD|DragonFly)
cat <<EOF >>$CONFIG_H
#define HAVE_ASPRINTF
+#define HAVE_BROKEN_KQUEUE
#define HAVE_BZERO
#define HAVE_DAEMON
#define HAVE_FGETLN