- Fix botched local patch which was breaking compilation with esound

PR:		ports/74128
Reported by:	Michael C. Shultz <ringworm@inbox.lv>
This commit is contained in:
Pav Lucistnik 2004-11-21 14:53:51 +00:00
parent c4a4284f05
commit 50df4f8e0e
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=122073
2 changed files with 6 additions and 7 deletions

View File

@ -22,17 +22,13 @@ USE_REINPLACE= yes
USE_GMAKE= yes USE_GMAKE= yes
USE_AUTOCONF_VER= 213 USE_AUTOCONF_VER= 213
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib" LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --disable-alsa CONFIGURE_ARGS= --disable-alsa
CFLAGS+= -fPIC CFLAGS+= -fPIC
.include <bsd.port.pre.mk> .include <bsd.port.pre.mk>
.if ${OSVERSION} >= 503000
BROKEN= "Does not compile on FreeBSD >= 5.x"
.endif
.if ${OSVERSION} > 500013 || ${MACHINE_ARCH} == "alpha" .if ${OSVERSION} > 500013 || ${MACHINE_ARCH} == "alpha"
USE_GNOME+= esound USE_GNOME+= esound
CONFIGURE_ARGS+= --disable-oss --enable-esd CONFIGURE_ARGS+= --disable-oss --enable-esd

View File

@ -1,5 +1,5 @@
--- configure.in.orig Sat Jan 20 02:06:28 2001 --- configure.in.orig Sat Jan 20 02:06:28 2001
+++ configure.in Sun Apr 8 11:32:48 2001 +++ configure.in Sun Nov 21 15:34:41 2004
@@ -142,7 +142,7 @@ @@ -142,7 +142,7 @@
sys/soundcard.h machine/soundcard.h \ sys/soundcard.h machine/soundcard.h \
sys/ultrasound.h linux/ultrasound.h machine/ultrasound.h \ sys/ultrasound.h linux/ultrasound.h machine/ultrasound.h \
@ -9,7 +9,7 @@
dnl ----------------------------------------------------------------------- dnl -----------------------------------------------------------------------
dnl Check OS/architecture independent drivers dnl Check OS/architecture independent drivers
@@ -173,15 +173,10 @@ @@ -173,15 +173,13 @@
fi]) fi])
fi fi
@ -24,6 +24,9 @@
- fi]) - fi])
+if test "$enable_esd" = yes; then +if test "$enable_esd" = yes; then
+ AC_CHECK_LIB(esd, esd_play_stream) + AC_CHECK_LIB(esd, esd_play_stream)
+ if test "${enable_dynamic}" != "yes"; then
+ LIBS="${LIBS} ${LDFLAGS} -lesd"
+ fi
+ DRIVERS="${DRIVERS} esd.o" + DRIVERS="${DRIVERS} esd.o"
+ AC_DEFINE(DRIVER_ESD) + AC_DEFINE(DRIVER_ESD)
fi fi