Skip libcrypto.pc when using SSL from base system

- Bump PORTREVISION for package change

Differential Revision:	https://reviews.freebsd.org/D27289
Submitted by:	bdrewery
This commit is contained in:
Sunpoet Po-Chuan Hsieh 2020-11-24 20:48:56 +00:00
parent cc4bf9b263
commit 5053732434
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=556193
2 changed files with 11 additions and 10 deletions

View File

@ -3,6 +3,7 @@
PORTNAME= libfido2
PORTVERSION= 1.5.0
PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= https://developers.yubico.com/libfido2/Releases/
@ -24,4 +25,12 @@ PLIST_SUB= PORTVERSION=${PORTVERSION}
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>
.include <bsd.port.pre.mk>
post-patch:
# we do not ship libcrypto.pc in base system
.if ${SSL_DEFAULT} == base
@${REINPLACE_CMD} -e '/libcrypto/d' ${WRKSRC}/CMakeLists.txt ${WRKSRC}/src/libfido2.pc.in
.endif
.include <bsd.port.post.mk>

View File

@ -1,14 +1,6 @@
--- CMakeLists.txt.orig 2020-09-01 07:17:43 UTC
+++ CMakeLists.txt
@@ -72,7 +72,6 @@ if(MSVC)
else()
include(FindPkgConfig)
pkg_search_module(CBOR libcbor)
- pkg_search_module(CRYPTO libcrypto)
# XXX workaround libcbor's missing .pc file
if(NOT CBOR_FOUND)
@@ -177,8 +176,8 @@ endif()
@@ -177,8 +177,8 @@ endif()
add_definitions(-DTLS=${TLS})