Update to 4.6.8

This commit is contained in:
Michael Johnson 2008-03-12 12:33:07 +00:00
parent 4459f0cf50
commit 5006da9e61
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=208889
5 changed files with 6 additions and 18 deletions

View File

@ -3,11 +3,12 @@
# Whom: Maxim Sobolev <sobomax@FreeBSD.org>
#
# $FreeBSD$
#
# $MCom: ports-experimental/devel/nspr/Makefile,v 1.5 2008/03/12 12:26:44 ahze Exp $
PORTNAME= nspr
PORTVERSION= 4.6.7
DISTVERSION= 4.6.8
CATEGORIES= devel
#MASTER_SITES= LOCAL/ahze
MASTER_SITES= ${MASTER_SITE_MOZILLA}
MASTER_SITE_SUBDIR= nspr/releases/v${PORTVERSION}/src

View File

@ -1,3 +1,3 @@
MD5 (nspr-4.6.7.tar.gz) = 75d5de21ebc1a21886a25673920490ff
SHA256 (nspr-4.6.7.tar.gz) = 314e078f954677f469f2a60e8aca8efa3dd1807f7e1a109cc688a2469e2e3b70
SIZE (nspr-4.6.7.tar.gz) = 1303759
MD5 (nspr-4.6.8.tar.gz) = 6cbf681f8b7312cd54f04b7dbea381bc
SHA256 (nspr-4.6.8.tar.gz) = 47750e6a99e2570fa2119f21d5d201174282679352379a565e3e5a80453e48b1
SIZE (nspr-4.6.8.tar.gz) = 1313108

View File

@ -1,6 +1,3 @@
$FreeBSD$
--- ../config/autoconf.mk.in.orig Wed Oct 17 02:31:02 2001
+++ ../config/autoconf.mk.in Thu Aug 8 19:22:44 2002
@@ -17,7 +17,7 @@

View File

@ -1,5 +1,3 @@
$FreeBSD$
--- ../pr/src/pthreads/ptio.c.orig Mon Feb 2 10:41:43 2004
+++ ../pr/src/pthreads/ptio.c Mon Feb 2 10:44:49 2004
@@ -3470,6 +3470,17 @@

View File

@ -33,11 +33,3 @@ Better to just keep calling it pthread_t isntead of casting to anything.
+ return thred->id; /* and I don't know what they will do with it */
#endif
}
@@ -1116,5 +1116,7 @@
PRStatus rv = PR_SUCCESS;
PRThread* thred = pt_book.first;
+#if !defined(_PR_DCETHREADS) && (defined(DEBUG) || defined(FORCE_PR_ASSERT))
PRThread *me = PR_CurrentThread();
+#endif
PR_LOG(_pr_gc_lm, PR_LOG_ALWAYS, ("Begin PR_EnumerateThreads\n"));