Add dhex, a ncurses-based hex-editor with diff mode.

Feature safe:	yes
This commit is contained in:
Emanuel Haupt 2011-01-23 12:47:04 +00:00
parent ccb1c1d4f2
commit 4febb29427
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=268132
5 changed files with 56 additions and 0 deletions

View File

@ -33,6 +33,7 @@
SUBDIR += cooledit
SUBDIR += cream
SUBDIR += dedit
SUBDIR += dhex
SUBDIR += diakonos
SUBDIR += dkns
SUBDIR += doxymacs

26
editors/dhex/Makefile Normal file
View File

@ -0,0 +1,26 @@
# New ports collection makefile for: dhex
# Date created: 23 Jan 2011
# Whom: Emanuel Haupt <ehaupt@FreeBSD.org>
#
# $FreeBSD$
#
PORTNAME= dhex
PORTVERSION= 0.62
CATEGORIES= editors
MASTER_SITES= http://www.dettus.net/dhex/ \
CRITICAL
DISTNAME= ${PORTNAME}_${PORTVERSION}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= A ncurses-based hex-editor with diff mode
LICENSE= GPLv2
PLIST_FILES= bin/dhex
MAKE_JOBS_SAFE= yes
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin
.include <bsd.port.mk>

2
editors/dhex/distinfo Normal file
View File

@ -0,0 +1,2 @@
SHA256 (dhex_0.62.tar.gz) = fcf9a48e30cebb99bf6cc0e8f9521ac61f7bfae942785a218a0ce32091009e5b
SIZE (dhex_0.62.tar.gz) = 45399

View File

@ -0,0 +1,20 @@
--- ./Makefile.orig 2011-01-12 13:34:30.000000000 +0100
+++ ./Makefile 2011-01-23 13:27:13.000000000 +0100
@@ -1,7 +1,7 @@
-CC= gcc
-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
-CPPFLAGS= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
-CFLAGS= -O3 -Wall -std=c99
+CC?= gcc
+#LDFLAGS+= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
+#CPPFLAGS+= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
+CFLAGS+= -std=c99
#CFLAGS+= -ffunction-sections -fdata-sections
#LDFLAGS+= --gc-sections
LIBS= -lncurses
@@ -24,5 +24,3 @@
clean:
rm -f dhex $(OFILES)
-
-

7
editors/dhex/pkg-descr Normal file
View File

@ -0,0 +1,7 @@
dhex is a more than just another hex editor: It includes a diff mode, which can
be used to easily and conveniently compare two binary files. Since it is based
on ncurses and is themeable, it can run on any number of systems and scenarios.
With its utilization of search logs, it is possible to track changes in
different iterations of files easily.
WWW: http://www.dettus.net/dhex/