- Chase libstatgrab version

- Patch for new API complianting

PR:		ports/84357
Submitted by:	maintainer
This commit is contained in:
Sergey Matveychuk 2005-07-31 10:14:40 +00:00
parent f4c8c825ad
commit 4fc1fb9b92
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=140532
2 changed files with 48 additions and 3 deletions

View File

@ -7,6 +7,7 @@
PORTNAME= Unix-Statgrab
PORTVERSION= 0.03
PORTREVISION= 1
CATEGORIES= devel perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Unix
@ -15,7 +16,7 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tim@bishnet.net
COMMENT= Perl extension for collecting information about the machine
LIB_DEPENDS= statgrab.6:${PORTSDIR}/devel/libstatgrab
LIB_DEPENDS= statgrab.7:${PORTSDIR}/devel/libstatgrab
USE_GNOME= pkgconfig
@ -27,9 +28,10 @@ MAN3= Unix::Statgrab.3
.include <bsd.port.pre.mk>
.if ${PERL_LEVEL} < 500600
post-patch:
${PERL} -i -pe 's/}\(/}->(/' ${WRKSRC}/lib/Unix/Statgrab.pm
.if ${PERL_LEVEL} < 500600
@${PERL} -i -pe 's/}\(/}->(/' ${WRKSRC}/lib/Unix/Statgrab.pm
.endif
@${RM} ${WRKSRC}/lib/Unix/Statgrab.pm.orig
.include <bsd.port.post.mk>

View File

@ -0,0 +1,43 @@
diff -ruN Unix-Statgrab-0.03/Statgrab.xs Unix-Statgrab-0.03.new/Statgrab.xs
--- Statgrab.xs Sun Apr 3 06:32:41 2005
+++ Statgrab.xs Sat Jul 30 12:10:10 2005
@@ -1113,13 +1113,13 @@
RETVAL
IV
-dup (self, num = 0)
+duplex (self, num = 0)
sg_network_iface_stats_my *self;
int num;
CODE:
if (num < 0 || num >= self->nifs)
XSRETURN_UNDEF;
- RETVAL = IF(num)->dup;
+ RETVAL = IF(num)->duplex;
OUTPUT:
RETVAL
diff -ruN Unix-Statgrab-0.03/lib/Unix/Statgrab.pm Unix-Statgrab-0.03.new/lib/Unix/Statgrab.pm
--- lib/Unix/Statgrab.pm Sun Apr 3 06:45:44 2005
+++ lib/Unix/Statgrab.pm Sat Jul 30 12:09:53 2005
@@ -479,7 +479,7 @@
The speed of the interface, in megabits/sec
-=item * B<dup($if)>
+=item * B<duplex($if)>
One of C<SG_IFACE_DUPLEX_FULL>, C<SG_IFACE_DUPLEX_HALF> and C<SG_IFACE_DUPLEX_UNKNOWN>. Unknown could mean that duplex hasn't been negotiated yet.
diff -ruN Unix-Statgrab-0.03/t/Unix-Statgrab.t Unix-Statgrab-0.03.new/t/Unix-Statgrab.t
--- t/Unix-Statgrab.t Sun Apr 3 06:35:08 2005
+++ t/Unix-Statgrab.t Sat Jul 30 12:09:29 2005
@@ -50,7 +50,7 @@
ierrors oerrors collisions systime/ ],
get_network_io_stats_diff => [ qw/num_ifaces interface_name tx rx ipackets opackets
ierrors oerrors collisions systime/ ],
- get_network_iface_stats => [ qw/num_ifaces interface_name speed dup up/ ],
+ get_network_iface_stats => [ qw/num_ifaces interface_name speed duplex up/ ],
get_page_stats => [ qw/pages_pagein pages_pageout systime/ ],
get_page_stats_diff => [ qw/pages_pagein pages_pageout systime/ ],
get_user_stats => [ qw/num_entries name_list/ ],