Revert my delete, and set this MAINTAINER to ports.

Vrweb is obsolete by its authors and the new version is
java-based VRWave ( not ported yet ) so I don't work
around this but somebody may make this port works again..
This commit is contained in:
Yukihiro Nakai 1999-10-20 10:59:09 +00:00
parent 67d4b3fdf4
commit 4f9241fa57
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=22537
11 changed files with 163 additions and 0 deletions

43
www/vrweb/Makefile Normal file
View File

@ -0,0 +1,43 @@
# New ports collection makefile for: vrweb
# Version required: 1.5
# Date created: 20 June 1997
# Whom: Yukihiro Nakai <Nakai@Mlab.t.u-tokyo.ac.jp>
#
# $FreeBSD$
#
DISTNAME= vrweb-1.5
CATEGORIES= www
MASTER_SITES= http://sunsite.unc.edu/pub/packages/infosystems/WWW/VRML/VRweb/UNIX/vrweb-1.5/
DISTFILES= vrweb-src-1.5.tar.gz help-1.5.tar.gz
MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= GL.14:${PORTSDIR}/graphics/Mesa3
BROKEN= install
USE_GMAKE= yes
USE_X_PREFIX= yes
do-configure:
(cd ${WRKSRC}; \
${LN} -s `which ${GMAKE}` ${WRKSRC}/config/scripts/make; \
${WRKSRC}/makeall -r; \
${WRKSRC}/makeall -m; )
do-build:
(cd ${WRKSRC}; \
${WRKSRC}/makeall -i; )
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/installed/harmony/bin/FREEBSD/vrweb-mesa \
${PREFIX}/bin/vrweb
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/vrweb
${CP} -R ${WRKDIR}/help/* ${PREFIX}/share/doc/vrweb
${MKDIR} ${PREFIX}/share/doc/vrweb/icons
${CP} ${WRKDIR}/icons/* ${PREFIX}/share/doc/vrweb/icons
.endif
.include <bsd.port.mk>

2
www/vrweb/distinfo Normal file
View File

@ -0,0 +1,2 @@
MD5 (vrweb-src-1.5.tar.gz) = 48c9867d538bda770a288834bb63e90d
MD5 (help-1.5.tar.gz) = 658d46bc14a7178a61b81dd5e89b3505

14
www/vrweb/files/patch-aa Normal file
View File

@ -0,0 +1,14 @@
*** src/common/utils/unixsocket.C.orig Mon Jun 23 02:12:28 1997
--- src/common/utils/unixsocket.C Mon Jun 23 02:17:04 1997
***************
*** 67,72 ****
--- 67,75 ----
#if defined(BSDI)
# define DONT_HAVE_SENDFD
#endif
+ #if defined(FreeBSD)
+ # define DONT_HAVE_SENDFD
+ #endif
#if ! (defined HAVE_SENDFD || defined DONT_HAVE_SENDFD)
#error SEND_FD

12
www/vrweb/files/patch-ab Normal file
View File

@ -0,0 +1,12 @@
*** src/common/OS/directory.C.orig Mon Jun 23 02:29:52 1997
--- src/common/OS/directory.C Mon Jun 23 02:31:27 1997
***************
*** 32,37 ****
--- 32,38 ----
* includes <sys/dir.h>, which is silly because <sys/dir.h>
* needs <sys/types.h>.
*/
+ #include <machine/types.h>
#include "types.h"
#ifdef apollo
#include <sys/dir.h>

10
www/vrweb/files/patch-ac Normal file
View File

@ -0,0 +1,10 @@
--- src/harmony/Imakefile.orig Fri Apr 17 12:39:50 1998
+++ src/harmony/Imakefile Fri Apr 17 12:39:57 1998
@@ -1,7 +1,6 @@
# src/harmony Imakefile
DIRS = \
- mesa \
ge3d \
vrml \
iicmviews \

11
www/vrweb/files/patch-ad Normal file
View File

@ -0,0 +1,11 @@
--- src/harmony/ge3d/mesa/ge3d_mesa.C.orig Thu Apr 23 16:05:07 1998
+++ src/harmony/ge3d/mesa/ge3d_mesa.C Thu Apr 23 16:05:30 1998
@@ -131,7 +131,7 @@
#endif
/* #include <GL/glx.h> */
-#include <mesa/GL/glu.h>
+#include <GL/glu.h>
#include <stdio.h>
#include <math.h>

13
www/vrweb/files/patch-ae Normal file
View File

@ -0,0 +1,13 @@
--- src/harmony/scene/mesacontext.C.orig Thu Apr 23 16:08:17 1998
+++ src/harmony/scene/mesacontext.C Thu Apr 23 16:08:47 1998
@@ -95,8 +95,8 @@
#include <IV-X11/Xdefs.h> /* Display, Font of X11 */
/* include <mesa/GL/xmesa.h> */
-#include <mesa/GL/glx.h>
-#include <mesa/GL/glu.h>
+#include <GL/glx.h>
+#include <GL/glu.h>
#include <IV-X11/Xundefs.h> /* get back to IV's names */
#include <iostream.h>

11
www/vrweb/files/patch-af Normal file
View File

@ -0,0 +1,11 @@
--- src/harmony/scene/Imakefile.orig Thu Apr 23 16:25:17 1998
+++ src/harmony/scene/Imakefile Thu Apr 23 16:29:05 1998
@@ -135,7 +135,7 @@
#endif
#ifdef MESA_GL
MESA_CCLDLIBS = $(APP_CCLDLIBS) -l$(MESA_GE3D) $(MESA_LIBS) $(IV_CCLDLIBS) $(EXTRA_CCLDLIBS)
-MESA_CCDEPLIBS = $(HGLIBDIR)/lib$(MESA_GE3D).a $(HGLIBDIR)/libMesaGL.a $(HGLIBDIR)/libMesaGLU.a
+MESA_CCDEPLIBS = $(HGLIBDIR)/lib$(MESA_GE3D).a
#endif
# Mosaic CCI

1
www/vrweb/pkg-comment Normal file
View File

@ -0,0 +1 @@
A browser for a VRML 1.0 format file

18
www/vrweb/pkg-descr Normal file
View File

@ -0,0 +1,18 @@
VRweb is a browser for VRML 1.0.
VRweb homepage is:
http://www.iicm.edu/vrweb/
VRML sample files in:
http://www.iicm.edu/vrml
You need texture files for some samples. Get
http://www.iicm.edu/0x811b9908_0x002e3f24
http://www.iicm.edu/0x811b9908_0x002e3c4a
and untar them in your directory.
tar xzvf 0x811b9908_0x002e3f24
tar xzvf 0x811b9908_0x002e3c4a
WWW: http://www.iicm.edu/vrweb/

28
www/vrweb/pkg-plist Normal file
View File

@ -0,0 +1,28 @@
bin/vrweb
share/doc/vrweb/README-help
share/doc/vrweb/anchors.html
share/doc/vrweb/basics.html
share/doc/vrweb/custom.html
share/doc/vrweb/display.html
share/doc/vrweb/edit.html
share/doc/vrweb/editdlg.html
share/doc/vrweb/icons/harmonylogo.tif
share/doc/vrweb/icons/harmonymask.xbm
share/doc/vrweb/icons/hyperg.tif
share/doc/vrweb/icons/hyperg_mask.xbm
share/doc/vrweb/install.html
share/doc/vrweb/keybd.html
share/doc/vrweb/keybd1c.html
share/doc/vrweb/mouse.html
share/doc/vrweb/navigate/index.html
share/doc/vrweb/navigate/modes.html
share/doc/vrweb/statline.gif
share/doc/vrweb/toolbar.gif
share/doc/vrweb/vrweb.gif
share/doc/vrweb/vrwebbg.gif
share/doc/vrweb/vrwebhlp.html
share/doc/vrweb/vrwebsmall.gif
share/doc/vrweb/whatsnew.html
@dirrm share/doc/vrweb/icons
@dirrm share/doc/vrweb/navigate
@dirrm share/doc/vrweb