IPv6 enabled mozilla-M17.

Submitted by:	ume
Repo copied by:	PW
This commit is contained in:
Munechika SUMIKAWA 2000-08-29 10:40:23 +00:00
parent ef9fe3db4a
commit 4f912dcce4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=32095
4 changed files with 56 additions and 9 deletions

View File

@ -1,17 +1,18 @@
# New ports collection makefile for: mozilla
# Date created: 31 Mar 1998
# Whom: eivind/dima/jseger
# New ports collection makefile for: mozilla+ipv6
# Date created: 25 Aug 2000
# Whom: sumikawa
#
# $FreeBSD$
#
PORTNAME= mozilla
PORTVERSION= M17
CATEGORIES= www
PKGNAMESUFFIX= +ipv6
CATEGORIES= www ipv6
MASTER_SITES= ftp://ftp.mozilla.org/pub/mozilla/releases/${PORTVERSION:S/M/m/}/src/
DISTNAME= ${PORTNAME}-source-${PORTVERSION}
MAINTAINER= reg@FreeBSD.org
MAINTAINER= sumikawa@FreeBSD.org
LIB_DEPENDS= gtk12.2:${PORTSDIR}/x11-toolkits/gtk12 \
IDL.2:${PORTSDIR}/devel/ORBit

View File

@ -1,5 +1,7 @@
--- nsprpub/pr/include/md/_freebsd.h.orig Wed Dec 22 15:39:04 1999
+++ nsprpub/pr/include/md/_freebsd.h Thu Feb 3 03:48:20 2000
Index: nsprpub/pr/include/md/_freebsd.h
diff -u nsprpub/pr/include/md/_freebsd.h.orig nsprpub/pr/include/md/_freebsd.h
--- nsprpub/pr/include/md/_freebsd.h.orig Thu Dec 23 08:39:04 1999
+++ nsprpub/pr/include/md/_freebsd.h Fri Apr 28 22:14:54 2000
@@ -21,6 +21,7 @@
#include "prthread.h"
@ -17,3 +19,16 @@
#if !defined(_PR_PTHREADS)
/*
* libc_r doesn't have poll(). Although libc has poll(), it is not
@@ -61,6 +62,12 @@
#endif
#define _PR_HAVE_SYSV_SEMAPHORES
#define PR_HAVE_SYSV_NAMED_SHARED_MEMORY
+
+#ifdef _PR_INET6
+#define _PR_HAVE_GETIPNODEBYNAME
+#define _PR_HAVE_GETIPNODEBYADDR
+#define _PR_INET6_PROBE
+#endif
#define USE_SETJMP

View File

@ -0,0 +1,12 @@
--- build/autoconf/make-makefile.orig Tue Mar 14 12:17:32 2000
+++ build/autoconf/make-makefile Sun Aug 27 02:52:27 2000
@@ -43,7 +43,8 @@
# called from "mozilla/gfx/src", then $source_subdir would be
# "gfx/src/".
$source_subdir = "$object_fullpath/";
-$source_subdir =~ s|^$object_root/||;
+my $quoted_object_root = quotemeta($object_root);
+$source_subdir =~ s|^$quoted_object_root/||;
# Prefix makefiles with $source_subdir so that paths
# will be relative to the top of the object tree.

View File

@ -1,5 +1,7 @@
--- nsprpub/config/FreeBSD.mk.orig Wed Oct 20 14:19:53 1999
+++ nsprpub/config/FreeBSD.mk Thu Feb 3 03:48:20 2000
Index: nsprpub/config/FreeBSD.mk
diff -u nsprpub/config/FreeBSD.mk.orig nsprpub/config/FreeBSD.mk
--- nsprpub/config/FreeBSD.mk.orig Thu Oct 21 06:19:53 1999
+++ nsprpub/config/FreeBSD.mk Fri Apr 28 21:01:01 2000
@@ -21,14 +21,16 @@
include $(MOD_DEPTH)/config/UNIX.mk
@ -20,3 +22,20 @@
CPU_ARCH = x86
endif
CPU_ARCH_TAG = _$(CPU_ARCH)
@@ -61,3 +63,16 @@
MKSHLIB = $(LD) $(DSO_LDOPTS)
G++INCLUDES = -I/usr/include/g++
+
+# IPv6 support part of the standard FreeBSD 4.0 release.
+ifneq (,$(filter-out 2.0 2.1 2.2 3,$(basename $(OS_RELEASE))))
+USE_IPV6 = 1
+endif
+
+# IPv6 support part of the KAME.
+ifeq ($(shell test -f /usr/local/v6/lib/libinet6.a && echo kame),kame)
+USE_IPV6 = 1
+OS_LIBS += -L/usr/local/v6/lib -linet6
+endif
+
+OS_LIBS += -lxpg4