net-im/telegram-desktop: Cleanup and set new maintainer

Reported by:	glebius

(cherry picked from commit 50119a0b43)
This commit is contained in:
Olivier Cochard 2021-11-17 18:05:06 +01:00
parent 137f9da62a
commit 4f2cbc20d9
10 changed files with 9 additions and 133 deletions

View File

@ -6,7 +6,7 @@ MASTER_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/releases/download/v
DISTNAME= tdesktop-${DISTVERSION}-full
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= henry.hu.sh@gmail.com
MAINTAINER= glebius@FreeBSD.org
COMMENT= Telegram Desktop messaging app
LICENSE= GPLv3
@ -62,11 +62,8 @@ CMAKE_ARGS= -DDESKTOP_APP_SPECIAL_TARGET="" -DTDESKTOP_LAUNCHER_BASENAME="telegr
-DTDESKTOP_API_ID=${TELEGRAM_API_ID} -DTDESKTOP_API_HASH=${TELEGRAM_API_HASH} \
-Ddisable_autoupdate=1
CMAKE_ON= DESKTOP_APP_USE_PACKAGED DESKTOP_APP_DISABLE_CRASH_REPORTS \
TDESKTOP_DISABLE_REGISTER_CUSTOM_SCHEME TDESKTOP_DISABLE_DESKTOP_FILE_GENERATION \
DESKTOP_APP_DISABLE_WAYLAND_INTEGRATION
CMAKE_OFF= DESKTOP_APP_USE_PACKAGED_RLOTTIE DESKTOP_APP_USE_PACKAGED_VARIANT \
DESKTOP_APP_USE_GLIBC_WRAPS TDESKTOP_USE_PACKAGED_TGVOIP \
DESKTOP_APP_USE_PACKAGED_FONTS
CMAKE_OFF= DESKTOP_APP_USE_PACKAGED_FONTS
# Disable DCHECKs, otherwise video calls will crash.
CXXFLAGS+= -DNDEBUG
@ -74,6 +71,8 @@ CXXFLAGS+= -DNDEBUG
# see Bugzilla #245452 for details
NO_CCACHE= yes
INSTALLS_ICONS= yes
# Telegram uses OpenAL for its audio, but libtgvoip (for voice calls) can use PulseAudio or ALSA.
# It dynamically loads PulseAudio, and if this fails, it loads ALSA.
# If both of them are not installed, then voice calls do not work, but other functionalities still work.
@ -97,9 +96,11 @@ TELEGRAM_API_ID= 601761
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == clang && ${COMPILER_VERSION} <= 100
post-patch:
@${REINPLACE_CMD} -e '/-fstack-clash-protection/d' ${WRKSRC}/cmake/options_linux.cmake
.if ${COMPILER_VERSION} < 120
LLVM_VER= 12
BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
CC= ${LOCALBASE}/bin/clang${LLVM_VER}
CXX= ${LOCALBASE}/bin/clang++${LLVM_VER}
.endif
.include <bsd.port.post.mk>

View File

@ -1,11 +0,0 @@
--- Telegram/SourceFiles/chat_helpers/stickers_emoji_pack.cpp.orig 2021-10-08 09:51:22 UTC
+++ Telegram/SourceFiles/chat_helpers/stickers_emoji_pack.cpp
@@ -99,7 +99,7 @@ constexpr auto kRefreshTimeout = 7200 * crl::time(1000
},
5,
};
- static const auto list = std::array{
+ static const auto list = std::array<const Lottie::ColorReplacements*, 5>{
&color1,
&color2,
&color3,

View File

@ -1,10 +0,0 @@
--- Telegram/ThirdParty/libtgvoip/os/posix/NetworkSocketPosix.cpp.orig 2019-04-03 18:20:00 UTC
+++ Telegram/ThirdParty/libtgvoip/os/posix/NetworkSocketPosix.cpp
@@ -64,6 +64,7 @@ void NetworkSocketPosix::SetMaxPriority(){
if(res<0){
LOGE("error setting darwin-specific net priority: %d / %s", errno, strerror(errno));
}
+#elif defined(__FreeBSD__)
#elif defined(__linux__)
int prio=6;
int res=setsockopt(fd, SOL_SOCKET, SO_PRIORITY, &prio, sizeof(prio));

View File

@ -1,27 +0,0 @@
--- Telegram/ThirdParty/libtgvoip/webrtc_dsp/rtc_base/platform_thread_types.cc.orig 2018-11-23 01:03:16 UTC
+++ Telegram/ThirdParty/libtgvoip/webrtc_dsp/rtc_base/platform_thread_types.cc
@@ -11,9 +11,13 @@
#include "rtc_base/platform_thread_types.h"
#if defined(WEBRTC_LINUX)
+#ifdef __FreeBSD__
+#include <sys/thr.h>
+#else
#include <sys/prctl.h>
#include <sys/syscall.h>
#endif
+#endif
namespace rtc {
@@ -27,6 +31,10 @@ PlatformThreadId CurrentThreadId() {
return gettid();
#elif defined(WEBRTC_FUCHSIA)
return zx_thread_self();
+#elif defined(__FreeBSD__)
+ long tid;
+ thr_self(&tid);
+ return tid;
#elif defined(WEBRTC_LINUX)
return syscall(__NR_gettid);
#else

View File

@ -1,13 +0,0 @@
--- Telegram/ThirdParty/tgcalls/tgcalls/Manager.cpp.orig 2021-07-21 01:10:26 UTC
+++ Telegram/ThirdParty/tgcalls/tgcalls/Manager.cpp
@@ -72,10 +72,6 @@ bool Manager::ResolvedNetworkStatus::operator==(const
return true;
}
-bool Manager::ResolvedNetworkStatus::operator!=(const ResolvedNetworkStatus &rhs) {
- return !(*this == rhs);
-}
-
Manager::Manager(rtc::Thread *thread, Descriptor &&descriptor) :
_thread(thread),
_encryptionKey(descriptor.encryptionKey),

View File

@ -1,10 +0,0 @@
--- Telegram/ThirdParty/tgcalls/tgcalls/Manager.h.orig 2021-07-21 01:10:21 UTC
+++ Telegram/ThirdParty/tgcalls/tgcalls/Manager.h
@@ -17,7 +17,6 @@ class Manager final : public std::enable_shared_from_t
bool isLowDataRequested = false;
bool operator==(const ResolvedNetworkStatus &rhs);
- bool operator!=(const ResolvedNetworkStatus &rhs);
};
public:

View File

@ -1,20 +0,0 @@
--- Telegram/lib_base/base/bytes.h.orig 2021-10-06 07:02:39 UTC
+++ Telegram/lib_base/base/bytes.h
@@ -145,7 +145,7 @@ template <
vector concatenate(Args &&...args) {
const auto size = details::spansLength(args...);
auto result = vector(size);
- details::spansAppend(make_span(result), args...);
+ details::spansAppend(bytes::make_span(result), args...);
return result;
}
@@ -156,7 +156,7 @@ vector concatenate(SpanRange args) {
size += bytes::make_span(arg).size();
}
auto result = vector(size);
- auto buffer = make_span(result);
+ auto buffer = bytes::make_span(result);
for (const auto &arg : args) {
const auto part = bytes::make_span(arg);
bytes::copy(buffer, part);

View File

@ -1,13 +0,0 @@
--- Telegram/lib_base/base/zlib_help.h.orig 2020-05-12 13:19:31 UTC
+++ Telegram/lib_base/base/zlib_help.h
@@ -6,8 +6,8 @@
//
#pragma once
-#include <zip.h>
-#include <unzip.h>
+#include "minizip/zip.h"
+#include "minizip/unzip.h"
#include "logs.h"
#ifdef small

View File

@ -1,10 +0,0 @@
--- Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h.orig 2021-07-07 09:00:15 UTC
+++ Telegram/lib_webview/webview/platform/linux/webview_linux_webkit_gtk.h
@@ -6,6 +6,7 @@
//
#pragma once
+#include <type_traits> // Required for glib/gatomic.h
#include <JavaScriptCore/JavaScript.h>
#include <gtk/gtk.h>
#include <webkit2/webkit2.h>

View File

@ -1,11 +0,0 @@
--- cmake/external/rlottie/CMakeLists.txt.orig 2020-10-23 14:48:52 UTC
+++ cmake/external/rlottie/CMakeLists.txt
@@ -7,7 +7,7 @@
add_library(external_rlottie INTERFACE IMPORTED GLOBAL)
add_library(desktop-app::external_rlottie ALIAS external_rlottie)
-if (DESKTOP_APP_USE_PACKAGED)
+if (0) # DESKTOP_APP_USE_PACKAGED
find_package(rlottie QUIET)
if (rlottie_FOUND)