Update to 0.10.0.90.

This commit is contained in:
Maxim Sobolev 2001-09-11 16:23:44 +00:00
parent e21ef27847
commit 4f0e364f53
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=47690
10 changed files with 32 additions and 138 deletions

View File

@ -6,7 +6,7 @@
#
PORTNAME= pan
PORTVERSION= 0.10.0
PORTVERSION= 0.10.0.90
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/${PORTVERSION}/

View File

@ -1 +1 @@
MD5 (pan-0.10.0.tar.bz2) = 157889e9cd9a4e3b619076adf84b53e1
MD5 (pan-0.10.0.90.tar.bz2) = f00c070de046a1bdb7ccbb381afb641e

View File

@ -1,31 +0,0 @@
$FreeBSD$
--- gmime/gmime-utils.c 2001/08/22 18:22:18 1.1
+++ gmime/gmime-utils.c 2001/08/22 18:35:26
@@ -32,7 +32,7 @@
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
-#include <langinfo.h>
+#include <locale.h>
#define d(x)
@@ -128,11 +128,12 @@
get_codeset (void)
{
const gchar * codeset;
+ gchar *s;
- codeset = nl_langinfo (CODESET);
- if (!codeset || !*codeset)
- codeset = DEFAULT_CODESET;
-
+ codeset = DEFAULT_CODESET;
+ if ((s = setlocale(LC_CTYPE, NULL)) != NULL)
+ if ((s = strchr(s, '.')) != NULL)
+ codeset = s + 1;
return codeset;
}

View File

@ -1,36 +0,0 @@
$FreeBSD$
--- pan/message-send.c 2001/08/22 18:36:41 1.1
+++ pan/message-send.c 2001/08/22 18:36:50
@@ -25,7 +25,7 @@
#include <string.h>
#include <sys/types.h>
-#include <langinfo.h>
+#include <locale.h>
#include <glib.h>
@@ -75,6 +75,7 @@
gboolean force_new_message_id)
{
gchar * tmp;
+ gchar * s;
const gchar * pch;
debug_enter ("build_nntp_header");
@@ -153,9 +154,10 @@
/* Add mime header, charset type, encoding type */
g_string_append (postme, "Mime-Version: 1.0\r\n");
- pch = nl_langinfo (CODESET);
- if (!is_nonempty_string (pch))
- pch = "ISO-8859-1";
+ pch = "ISO-8859-1";
+ if ((s = setlocale(LC_CTYPE, NULL)) != NULL)
+ if ((s = strchr(s, '.')) != NULL)
+ pch = s + 1;
g_string_sprintfa (postme, "Content-Type: text/plain; charset=%s\r\n", pch);
g_string_append (postme, "Content-Transfer-Encoding: 8bit\r\n");

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- po/Makefile.in.in 2001/09/11 16:16:39 1.1
+++ po/Makefile.in.in 2001/09/11 16:16:49
@@ -106,7 +106,7 @@
@catalogs='$(CATALOGS)'; \
for cat in $$catalogs; do \
cat=`basename $$cat`; \
- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
dir=$(localedir)/$$lang/LC_MESSAGES; \
$(mkinstalldirs) $(DESTDIR)$$dir; \
if test -r $$cat; then \

View File

@ -6,7 +6,7 @@
#
PORTNAME= pan
PORTVERSION= 0.10.0
PORTVERSION= 0.10.0.90
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/${PORTVERSION}/

View File

@ -1 +1 @@
MD5 (pan-0.10.0.tar.bz2) = 157889e9cd9a4e3b619076adf84b53e1
MD5 (pan-0.10.0.90.tar.bz2) = f00c070de046a1bdb7ccbb381afb641e

View File

@ -1,31 +0,0 @@
$FreeBSD$
--- gmime/gmime-utils.c 2001/08/22 18:22:18 1.1
+++ gmime/gmime-utils.c 2001/08/22 18:35:26
@@ -32,7 +32,7 @@
#include <stdlib.h>
#include <string.h>
#include <ctype.h>
-#include <langinfo.h>
+#include <locale.h>
#define d(x)
@@ -128,11 +128,12 @@
get_codeset (void)
{
const gchar * codeset;
+ gchar *s;
- codeset = nl_langinfo (CODESET);
- if (!codeset || !*codeset)
- codeset = DEFAULT_CODESET;
-
+ codeset = DEFAULT_CODESET;
+ if ((s = setlocale(LC_CTYPE, NULL)) != NULL)
+ if ((s = strchr(s, '.')) != NULL)
+ codeset = s + 1;
return codeset;
}

View File

@ -1,36 +0,0 @@
$FreeBSD$
--- pan/message-send.c 2001/08/22 18:36:41 1.1
+++ pan/message-send.c 2001/08/22 18:36:50
@@ -25,7 +25,7 @@
#include <string.h>
#include <sys/types.h>
-#include <langinfo.h>
+#include <locale.h>
#include <glib.h>
@@ -75,6 +75,7 @@
gboolean force_new_message_id)
{
gchar * tmp;
+ gchar * s;
const gchar * pch;
debug_enter ("build_nntp_header");
@@ -153,9 +154,10 @@
/* Add mime header, charset type, encoding type */
g_string_append (postme, "Mime-Version: 1.0\r\n");
- pch = nl_langinfo (CODESET);
- if (!is_nonempty_string (pch))
- pch = "ISO-8859-1";
+ pch = "ISO-8859-1";
+ if ((s = setlocale(LC_CTYPE, NULL)) != NULL)
+ if ((s = strchr(s, '.')) != NULL)
+ pch = s + 1;
g_string_sprintfa (postme, "Content-Type: text/plain; charset=%s\r\n", pch);
g_string_append (postme, "Content-Transfer-Encoding: 8bit\r\n");

View File

@ -0,0 +1,14 @@
$FreeBSD$
--- po/Makefile.in.in 2001/09/11 16:16:39 1.1
+++ po/Makefile.in.in 2001/09/11 16:16:49
@@ -106,7 +106,7 @@
@catalogs='$(CATALOGS)'; \
for cat in $$catalogs; do \
cat=`basename $$cat`; \
- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
+ lang=`echo $$cat | sed 's/\.mo$$//'`; \
dir=$(localedir)/$$lang/LC_MESSAGES; \
$(mkinstalldirs) $(DESTDIR)$$dir; \
if test -r $$cat; then \