Remove expired ports:

2020-08-15 audio/py-cddb: Uses deprecated version of python
2020-08-15 databases/py-sybase: Uses deprecated version of python
2020-08-15 devel/py-pp: Uses deprecated version of python
2020-08-15 security/py-keyczar: Uses deprecated version of python
2020-08-15 math/py-pysparse: Uses deprecated version of python
2020-08-15 net/py-beanstalkc: Uses deprecated version of python
2020-08-15 x11-toolkits/py-wxPython30: Uses deprecated version of python
2020-08-15 net-im/py-skype4py: Uses deprecated version of python
2020-08-15 net-im/telepathy-haze: Uses deprecated version of python
This commit is contained in:
Rene Ladan 2020-08-15 12:29:48 +00:00
parent 6a738d22ee
commit 4f09c27405
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=544935
47 changed files with 9 additions and 639 deletions

9
MOVED
View File

@ -15365,3 +15365,12 @@ www/py-wsgiauth||2020-08-15|Has expired: Uses deprecated version of python
x11-toolkits/py-wax||2020-08-15|Has expired: Uses deprecated version of python
x11-toolkits/py-wxPython-common||2020-08-15|Has expired: Uses deprecated version of python
x11-toolkits/py-wxPython28-common||2020-08-15|Has expired: Uses deprecated version of python
audio/py-cddb||2020-08-15|Has expired: Uses deprecated version of python
databases/py-sybase||2020-08-15|Has expired: Uses deprecated version of python
devel/py-pp||2020-08-15|Has expired: Uses deprecated version of python
security/py-keyczar||2020-08-15|Has expired: Uses deprecated version of python
math/py-pysparse||2020-08-15|Has expired: Uses deprecated version of python
net/py-beanstalkc||2020-08-15|Has expired: Uses deprecated version of python
x11-toolkits/py-wxPython30||2020-08-15|Has expired: Uses deprecated version of python
net-im/py-skype4py||2020-08-15|Has expired: Uses deprecated version of python
net-im/telepathy-haze||2020-08-15|Has expired: Uses deprecated version of python

View File

@ -651,7 +651,6 @@
SUBDIR += py-apetag
SUBDIR += py-aubio
SUBDIR += py-audioread
SUBDIR += py-cddb
SUBDIR += py-discid
SUBDIR += py-discogs-client
SUBDIR += py-eyed3

View File

@ -1,27 +0,0 @@
# Created by: Hye-Shik Chang
# $FreeBSD$
PORTNAME= cddb
PORTVERSION= 1.4
PORTREVISION= 2
CATEGORIES= audio python
MASTER_SITES= SF/${PORTNAME}-py/${PORTNAME}-py/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= CDDB-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Python module to fetch information on audio CDs from CDDB
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
USES= python:2.7
USE_PYTHON= distutils autoplist pythonprefix
post-install:
${STRIP_CMD} ${STAGEDIR}${PYTHONPREFIX_SITELIBDIR}/cdrom.so
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (CDDB-1.4.tar.gz) = bcd0f2f21848f2fcd692c542f124ec3e1414391ddeb6114f6f7bc5724a831d25
SIZE (CDDB-1.4.tar.gz) = 39562

View File

@ -1,20 +0,0 @@
--- unix/cdrommodule.c.orig 2003-08-31 23:24:30 UTC
+++ unix/cdrommodule.c
@@ -29,7 +29,7 @@
#include <linux/cdrom.h>
#endif
-#if defined(sun) || defined(__FreeBSD__) || defined(__OpenBSD__)
+#if defined(sun) || defined(__FreeBSD__) || defined(__OpenBSD__) || defined(__DragonFly__)
#include <sys/cdio.h>
#endif
@@ -45,7 +45,7 @@
* so that we don't have to repeat the code.
*/
-#ifdef __FreeBSD__
+#if defined __FreeBSD__ || defined __DragonFly__
#define CDDB_TOC_HEADER_STRUCT ioc_toc_header
#define CDDB_STARTING_TRACK_FIELD starting_track

View File

@ -1,7 +0,0 @@
This is actually a set of three modules to access the CDDB online
database of audio CD track titles and information. It includes a
C extension module to fetch track lengths under Linux, FreeBSD,
OpenBSD, Solaris, and Win32, which is easily ported to other
operating systems.
WWW: http://cddb-py.sourceforge.net/

View File

@ -809,7 +809,6 @@
SUBDIR += py-sqlparse020
SUBDIR += py-sqlrelay
SUBDIR += py-swift
SUBDIR += py-sybase
SUBDIR += py-tableschema
SUBDIR += py-tarantool
SUBDIR += py-tiledb

View File

@ -1,61 +0,0 @@
# Created by: Gregory Bond <gnb@itga.com.au>
# $FreeBSD$
PORTNAME= sybase
PORTVERSION= 0.37
PORTREVISION= 5
CATEGORIES= databases python
MASTER_SITES= http://object-craft.com.au/projects/sybase/download/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${PORTNAME}-html${EXTRACT_SUFX}
MAINTAINER= gnb@itga.com.au
COMMENT= Python Database API interface to the Sybase RDBMS
LICENSE= BSD3CLAUSE
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
LIB_DEPENDS= libct.so:databases/freetds
USES= python:2.7
USE_PYTHON= distutils
OPTIONS_DEFINE= DOCS THREADS EXAMPLES
OPTIONS_DEFAULT=THREADS
.if defined(TDS_VERSION)
TDS_SUF="=${TDS_VERSION}"
.else
.include <bsd.port.options.mk>
pre-build:
@V=`${PKG_INFO} | ${SED} -ne 's/^freetds-0.\(..\).*/\1/p'` ; \
if [ $$V -le 60 ]; then \
${ECHO_MSG} "Suggest you update your FreeTDS port to at least version 0.61" ; \
${ECHO_MSG} "Otherwise, you will need to add TDS_VERSION=$$V to the Make command" ; \
exit 1 ;\
fi
.endif # defined(TDS_VERSION)
MAKE_ENV+= SYBASE=${LOCALBASE}
.if ${PORT_OPTIONS:MTHREADS}
BUILDARGS= -D WANT_THREADS -U WANT_BULKCOPY -D HAVE_FREETDS${TDS_SUF}
.else
BUILDARGS= -U WANT_BULKCOPY -D HAVE_FREETDS${TDS_SUF}
.endif
# Need this because -D<> args needed for build_ext but illegal for build
do-build:
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} build_ext ${BUILDARGS} )
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${PYSETUP} build)
post-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR} ${STAGEDIR}${DOCSDIR}
@${TAR} -cf - -C ${WRKSRC}/examples . | ${TAR} -xf - -C ${STAGEDIR}${EXAMPLESDIR}
@${TAR} -cf - -C ${WRKDIR}/${PORTNAME} . | ${TAR} -xf - -C ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>

View File

@ -1,4 +0,0 @@
SHA256 (sybase-0.37.tar.gz) = 4bcf2658ea51a17f132a1d3d8c75a09d90377f9441c0813366b4fbb976300084
SIZE (sybase-0.37.tar.gz) = 95081
SHA256 (sybase-html.tar.gz) = 0cea62ba55c78f1d04283b072582b44217fe4e8866ba1e37477b50d9cf4b2325
SIZE (sybase-html.tar.gz) = 39956

View File

@ -1,5 +0,0 @@
A Python interface to the Sybase relational database system. The
Sybase package supports all of the Python Database API, version 2.0
with extensions.
WWW: http://object-craft.com.au/projects/sybase/

View File

@ -1,72 +0,0 @@
%%PYTHON_SITELIBDIR%%/Sybase.py
%%PYTHON_SITELIBDIR%%/Sybase.pyc
%%PYTHON_SITELIBDIR%%/Sybase.pyo
%%PYTHON_SITELIBDIR%%/sybasect.so
%%PORTDOCS%%%%DOCSDIR%%/about.html
%%PORTDOCS%%%%DOCSDIR%%/contents.html
%%PORTDOCS%%%%DOCSDIR%%/front.html
%%PORTDOCS%%%%DOCSDIR%%/genindex.html
%%PORTDOCS%%%%DOCSDIR%%/images.aux
%%PORTDOCS%%%%DOCSDIR%%/images.idx
%%PORTDOCS%%%%DOCSDIR%%/images.log
%%PORTDOCS%%%%DOCSDIR%%/images.tex
%%PORTDOCS%%%%DOCSDIR%%/img1.gif
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/modimages.idx
%%PORTDOCS%%%%DOCSDIR%%/module-Sybase.html
%%PORTDOCS%%%%DOCSDIR%%/module-sybasect.html
%%PORTDOCS%%%%DOCSDIR%%/node10.html
%%PORTDOCS%%%%DOCSDIR%%/node12.html
%%PORTDOCS%%%%DOCSDIR%%/node13.html
%%PORTDOCS%%%%DOCSDIR%%/node14.html
%%PORTDOCS%%%%DOCSDIR%%/node15.html
%%PORTDOCS%%%%DOCSDIR%%/node16.html
%%PORTDOCS%%%%DOCSDIR%%/node17.html
%%PORTDOCS%%%%DOCSDIR%%/node18.html
%%PORTDOCS%%%%DOCSDIR%%/node19.html
%%PORTDOCS%%%%DOCSDIR%%/node20.html
%%PORTDOCS%%%%DOCSDIR%%/node21.html
%%PORTDOCS%%%%DOCSDIR%%/node22.html
%%PORTDOCS%%%%DOCSDIR%%/node23.html
%%PORTDOCS%%%%DOCSDIR%%/node3.html
%%PORTDOCS%%%%DOCSDIR%%/node4.html
%%PORTDOCS%%%%DOCSDIR%%/node5.html
%%PORTDOCS%%%%DOCSDIR%%/node6.html
%%PORTDOCS%%%%DOCSDIR%%/node7.html
%%PORTDOCS%%%%DOCSDIR%%/node9.html
%%PORTDOCS%%%%DOCSDIR%%/sybase.css
%%PORTDOCS%%%%DOCSDIR%%/sybase.html
%%PORTDOCS%%%%DOCSDIR%%/icons/blank.gif
%%PORTDOCS%%%%DOCSDIR%%/icons/blank.png
%%PORTDOCS%%%%DOCSDIR%%/icons/contents.gif
%%PORTDOCS%%%%DOCSDIR%%/icons/contents.png
%%PORTDOCS%%%%DOCSDIR%%/icons/index.gif
%%PORTDOCS%%%%DOCSDIR%%/icons/index.png
%%PORTDOCS%%%%DOCSDIR%%/icons/modules.gif
%%PORTDOCS%%%%DOCSDIR%%/icons/modules.png
%%PORTDOCS%%%%DOCSDIR%%/icons/next.gif
%%PORTDOCS%%%%DOCSDIR%%/icons/next.png
%%PORTDOCS%%%%DOCSDIR%%/icons/previous.gif
%%PORTDOCS%%%%DOCSDIR%%/icons/previous.png
%%PORTDOCS%%%%DOCSDIR%%/icons/up.gif
%%PORTDOCS%%%%DOCSDIR%%/icons/up.png
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/array_bind.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/array_bind.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bulkcopy.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bulkcopy.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cursor_sel.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cursor_upd.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cursor_upd.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/diag_example.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dynamic_cur.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dynamic_ins.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dynamic_ins.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/example.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mult_text.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mult_text.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/params.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpc.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rpc.sql
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timeout.py
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/timeout.readme

View File

@ -4784,7 +4784,6 @@
SUBDIR += py-positional
SUBDIR += py-posix_ipc
SUBDIR += py-poyo
SUBDIR += py-pp
SUBDIR += py-prance
SUBDIR += py-pre-commit
SUBDIR += py-preshed

View File

@ -1,24 +0,0 @@
# Created by: Li-Wen Hsu <lwhsu@lwhsu.org>
# $FreeBSD$
PORTNAME= pp
PORTVERSION= 1.6.6
PORTREVISION= 1
CATEGORIES= devel python
MASTER_SITES= http://www.parallelpython.com/downloads/pp/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= lwhsu@FreeBSD.org
COMMENT= Parallel python execution server
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/COPYING
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
USES= python:2.7
USE_PYTHON= distutils autoplist
NO_ARCH= yes
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
TIMESTAMP = 1512021851
SHA256 (pp-1.6.6.tar.gz) = a224f4d43472ac8b7700a0a6a117885f798d2462b1f815d4525457f319dc23b7
SIZE (pp-1.6.6.tar.gz) = 30859

View File

@ -1,9 +0,0 @@
pp is a python module which provides mechanism for parallel execution of
python code on SMP (systems with multiple processors or cores) and clusters
(computers connected via network)
It is light, easy to install and integrate with other python software.
pp is an open source and cross-platform module written in pure python
WWW: https://www.parallelpython.com/

View File

@ -817,7 +817,6 @@
SUBDIR += py-pyodeint
SUBDIR += py-pyodesys
SUBDIR += py-pysmt
SUBDIR += py-pysparse
SUBDIR += py-pystan
SUBDIR += py-pysym
SUBDIR += py-python-fcl

View File

@ -1,32 +0,0 @@
# Created by: Yuri Victorovich <yuri@rawbw.com>
# $FreeBSD$
PORTNAME= pysparse
PORTVERSION= 1.3
PORTREVISION= 11
CATEGORIES= math python
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= yuri@FreeBSD.org
COMMENT= Fast sparse matrix library for Python
LICENSE= BSD3CLAUSE
LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2,1:math/py-numpy@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}numpy>=1.2,1:math/py-numpy@${PY_FLAVOR}
LIB_DEPENDS= libopenblas.so:math/openblas
USE_GITHUB= yes
GH_ACCOUNT= PythonOptimizers
GH_TAGNAME= f8430bd
LDFLAGS+= -shared # Workaround for an obscure bug in py-numpy, see https://github.com/numpy/numpy/issues/7779
USES= fortran python:2.7 # fortran is needed for the correct build flags passed to py-numpy extension build process
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
TIMESTAMP = 1480154575
SHA256 (PythonOptimizers-pysparse-1.3-f8430bd_GH0.tar.gz) = 4c4ad1e02a97ea257365331f677205c76e572d22eafbe818f39c4eb462987848
SIZE (PythonOptimizers-pysparse-1.3-f8430bd_GH0.tar.gz) = 1301990

View File

@ -1,19 +0,0 @@
--- setup.py.orig 2016-06-10 21:29:48 UTC
+++ setup.py
@@ -109,7 +109,7 @@ def get_version():
version = '1.3'
release = False
if not release:
- version += '-dev' + svn_version()
+ version += '-dev'
return version
def write_version_py(filename=os.path.join('pysparse', 'version.py')):
@@ -142,7 +142,6 @@ def setup_package():
author_email = "{hamsel,d-orban,wd15}@sf.net,",
maintainer = "PySparse Developers",
maintainer_email = "{hamsel,d-orban,wd15}@sf.net,",
- summary = "Fast sparse matrix library for Python",
description = "Fast sparse matrix library for Python",
long_description = "\n".join(DOCLINES[2:]),
url = "pysparse.sf.net",

View File

@ -1,12 +0,0 @@
PySparse extends the Python interpreter by a set of sparse matrix
types holding double precision values. PySparse also includes modules
that implement:
- iterative methods for solving linear systems of equations
- a set of standard preconditioners
- an interface to a direct solver for sparse linear systems of
equations (SuperLU)
- a Jacobi-Davidson eigenvalue solver for the symmetric, generalised
matrix eigenvalue problem (JDSYM)
WWW: https://github.com/PythonOptimizers/pysparse

View File

@ -126,7 +126,6 @@
SUBDIR += py-nbxmpp
SUBDIR += py-punjab
SUBDIR += py-python-telegram-bot
SUBDIR += py-skype4py
SUBDIR += py-slackclient
SUBDIR += py-sleekxmpp
SUBDIR += py-slixmpp
@ -162,7 +161,6 @@
SUBDIR += telepathy-farstream
SUBDIR += telepathy-gabble
SUBDIR += telepathy-glib
SUBDIR += telepathy-haze
SUBDIR += telepathy-idle
SUBDIR += telepathy-logger
SUBDIR += telepathy-logger-qt5

View File

@ -1,22 +0,0 @@
# Created by: Nicola Vitale <nivit@FreeBSD.org>
# $FreeBSD$
PORTNAME= Skype4Py
PORTVERSION= 1.0.35
PORTREVISION= 2
CATEGORIES= net-im devel
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Skype (TM) API wrapper for Python
LICENSE= BSD3CLAUSE
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
USES= python:2.7 zip
USE_PYTHON= distutils autoplist
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (Skype4Py-1.0.35.zip) = 79dbf9033a60b3d37ff1a8eb07fcc5f8dd1f5afb79cb83b216f721acca4d63c4
SIZE (Skype4Py-1.0.35.zip) = 173489

View File

@ -1,26 +0,0 @@
--- setup.py.orig 2013-05-25 11:00:56.000000000 +0200
+++ setup.py 2014-06-21 22:27:11.000000000 +0200
@@ -129,11 +129,21 @@
print >>sys.stderr, 'epydoc not installed, skipping build_doc.'
-commands = {'build_doc': build_doc,
- 'install_lib': install_lib}
+commands = {'build_doc': build_doc}
desc = open("README.rst").read() + "\n" + open("CHANGES.rst").read()
+if sys.platform[:3] == 'win':
+ platform = 'windows'
+elif sys.platform == 'darwin':
+ platform = 'darwin'
+else:
+ platform = 'posix'
+path = os.path.join('Skype4Py', 'api')
+for name in os.listdir(path):
+ if not (name.startswith('__') or name.startswith(platform)):
+ os.remove(os.path.join(path, name))
+
# start the distutils setup
setup(name='Skype4Py',
version=VERSION,

View File

@ -1,6 +0,0 @@
Skype4Py is a Python library which allows you to control Skype client
application.
Skype4Py Python project is not affiliate of Skype or Microsoft corporation.
WWW: https://github.com/awahlig/skype4py

View File

@ -1,26 +0,0 @@
# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
PORTNAME= telepathy-haze
PORTVERSION= 0.8.0
PORTREVISION= 3
CATEGORIES= net-im
MASTER_SITES= http://telepathy.freedesktop.org/releases/telepathy-haze/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Libpurple connection manager for telepathy
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
LIB_DEPENDS= libpurple.so:net-im/libpurple \
libidn.so:dns/libidn \
libtelepathy-glib.so:net-im/telepathy-glib
USES= gmake gnome pathfix pkgconfig python:2.7,build
USE_GNOME= libxslt:build
CPPFLAGS+= -I${LOCALBASE}/include
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (telepathy-haze-0.8.0.tar.gz) = 3e76049c05f2cd5900c5c0c1cfebdf7ae79eec987a599f1090946673c5b8f9c9
SIZE (telepathy-haze-0.8.0.tar.gz) = 580929

View File

@ -1,15 +0,0 @@
This patch fixes a build with libpurple 2.0.12.
http://pidgin.im/pipermail/devel/2015-March/023639.html
Replaces the old emu with the _PASSIVE.
--- src/media-stream.c.orig 2016-01-11 12:37:14.015586000 +0100
+++ src/media-stream.c 2016-01-11 12:39:24.449684000 +0100
@@ -1076,7 +1076,7 @@
if (proto == TP_MEDIA_STREAM_BASE_PROTO_UDP)
protocol = PURPLE_MEDIA_NETWORK_PROTOCOL_UDP;
else if (proto == TP_MEDIA_STREAM_BASE_PROTO_TCP)
- protocol = PURPLE_MEDIA_NETWORK_PROTOCOL_TCP;
+ protocol = PURPLE_MEDIA_NETWORK_PROTOCOL_TCP_PASSIVE;
else
DEBUG ("Unknown network protocol");

View File

@ -1,4 +0,0 @@
Libpurple-based Telepathy connection manager, to provide Telepathy clients
with access to the full range of protocols supported by libpurple.
WWW: http://developer.pidgin.im/wiki/Telepathy

View File

@ -1,3 +0,0 @@
libexec/telepathy-haze
man/man8/telepathy-haze.8.gz
share/dbus-1/services/org.freedesktop.Telepathy.ConnectionManager.haze.service

View File

@ -1003,7 +1003,6 @@
SUBDIR += py-amqp
SUBDIR += py-amqplib
SUBDIR += py-avahi
SUBDIR += py-beanstalkc
SUBDIR += py-cjdns
SUBDIR += py-cloudflare-scrape
SUBDIR += py-cloudflare-scrape-js2py

View File

@ -1,33 +0,0 @@
# Created by: Li-Wen Hsu <lwhsu@FreeBSD.org>
# $FreeBSD$
PORTNAME= beanstalkc
PORTVERSION= 0.4.0
CATEGORIES= net python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= koobs@FreeBSD.org
COMMENT= Simple beanstalkd client library for Python
LICENSE= APACHE20
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}nose>0:devel/py-nose@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
USES= python:2.7
USE_PYTHON= distutils autoplist
OPTIONS_DEFINE= YAML
OPTIONS_DEFAULT= YAML
YAML_DESC= YAML response parsing support
YAML_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (beanstalkc-0.4.0.tar.gz) = 98978e57797320146f4b233286d9a02f65d20bad0168424118839fc608085280
SIZE (beanstalkc-0.4.0.tar.gz) = 13921

View File

@ -1,8 +0,0 @@
--- ./setup.py.orig 2014-03-08 14:16:00.573786621 +1100
+++ ./setup.py 2014-03-08 14:16:32.606016182 +1100
@@ -29,4 +29,5 @@
'Operating System :: OS Independent',
'Topic :: Software Development :: Libraries :: Python Modules',
],
+ test_suite = 'nose.collector',
)

View File

@ -1,3 +0,0 @@
beanstalkc is a simple beanstalkd client library for Python.
WWW: https://github.com/earl/beanstalkc/

View File

@ -902,7 +902,6 @@
SUBDIR += py-josepy
SUBDIR += py-keepkey
SUBDIR += py-kerberos
SUBDIR += py-keyczar
SUBDIR += py-keyring
SUBDIR += py-keyrings.alt
SUBDIR += py-keystone

View File

@ -1,27 +0,0 @@
# Created by: Douglas Thrift <douglas@douglasthrift.net>
# $FreeBSD$
PORTNAME= keyczar
PORTVERSION= 0.716
PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
DISTNAME= python-${PORTNAME}-${PORTVERSION}
MAINTAINER= douglas@douglasthrift.net
COMMENT= Toolkit for safe and simple cryptography
LICENSE= APACHE20
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycrypto>=2.0:security/py-pycrypto@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pyasn1>0:devel/py-pyasn1@${PY_FLAVOR}
NO_ARCH= yes
USES= python:2.7
USE_PYTHON= autoplist distutils
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
TIMESTAMP = 1470607843
SHA256 (python-keyczar-0.716.tar.gz) = f9b614112dc8248af3d03b989da4aeca70e747d32fe7e6fce9512945365e3f83
SIZE (python-keyczar-0.716.tar.gz) = 242081

View File

@ -1,16 +0,0 @@
Keyczar is an open source cryptographic toolkit designed to make it easier and
safer for developers to use cryptography in their applications. Keyczar supports
authentication and encryption with both symmetric and asymmetric keys. Some
features of Keyczar include:
* A simple API
* Key rotation and versioning
* Safe default algorithms, modes, and key lengths
* Automated generation of initialization vectors and ciphertext signatures
* Java, Python, and C++ implementations
* International support in Java (Python coming soon)
Keyczar was originally developed by members of the Google Security Team and is
released under an Apache 2.0 license.
WWW: http://www.keyczar.org/

View File

@ -181,7 +181,6 @@
SUBDIR += py-tkinter
SUBDIR += py-tktreectrl
SUBDIR += py-wxPython28
SUBDIR += py-wxPython30
SUBDIR += py-wxPython40
SUBDIR += py-xlib
SUBDIR += pypy-tkinter

View File

@ -1,70 +0,0 @@
# $FreeBSD$
PORTNAME= wxPython
PORTVERSION= 3.0.2.0
PORTREVISION= 9
DISTVERSIONPREFIX= src-
CATEGORIES= x11-toolkits python
MASTER_SITES= SF/wxpython/wxPython/${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
PKGNAMESUFFIX= 30
MAINTAINER= python@FreeBSD.org
COMMENT= GUI toolkit for the Python programming language
DEPRECATED= Uses deprecated version of python
EXPIRATION_DATE= 2020-08-15
DIST_SUBDIR= python
WRKSRC_SUBDIR= wxPython
USES= compiler:c++11-lib python:2.7 shebangfix tar:bzip2
SHEBANG_FILES= wx/tools/Editra/Editra.pyw
.if defined(WITH_WXVERSION_ONLY)
PKGNAMESUFFIX= -common
USE_PYTHON= py3kplist flavors
do-build:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -d ${PYTHON_SITELIBDIR} -f ${WRKSRC}/wxversion
${PYTHON_CMD} -O ${PYTHON_LIBDIR}/compileall.py -d ${PYTHON_SITELIBDIR} -f ${WRKSRC}/wxversion
do-install:
@${MKDIR} ${STAGEDIR}${PYTHON_SITELIBDIR}
${INSTALL_DATA} ${WRKSRC}/wxversion/wxversion.py* ${STAGEDIR}${PYTHON_SITELIBDIR}/
${TOUCH} ${STAGEDIR}${PYTHON_SITELIBDIR}/wx.pth
.else
WXPORT= gtk3
WX_PYTHON_DIR= wx-${WX_VERSION}-${WXPORT}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}wxPython-common>0:x11-toolkits/py-wxPython-common@${PY_FLAVOR}
USES+= gettext pkgconfig
USE_WX= 3.0
USE_PYTHON= distutils autoplist
PYDISTUTILS_BUILDARGS= WX_CONFIG="${WX_CONFIG}" \
WXPORT="${WXPORT}" \
NO_SCRIPTS=1 \
INSTALL_MULTIVERSION=1
PYDISTUTILS_CONFIGUREARGS+= ${PYDISTUTILS_BUILDARGS}
PYDISTUTILS_INSTALLARGS+= ${PYDISTUTILS_BUILDARGS}
post-patch:
@${REINPLACE_CMD} -E \
-e 's,distutils\.command\.install\.install\),setuptools.command.install.install),g' \
-e 's,distutils\.command\.install$$,setuptools.command.install,g' \
-e 's,distutils\.command\.install\.install\.,setuptools.command.install.install.,g' \
${WRKSRC}/config.py
post-install:
@${ECHO_CMD} "@unexec ${REINPLACE_CMD} -i '' -e '\,${WX_PYTHON_DIR}$$,d' ${PYTHON_SITELIBDIR}/wx.pth 2>/dev/null || true" >> ${TMPPLIST}
@${ECHO_CMD} "@exec echo ${WX_PYTHON_DIR} >> ${PYTHON_SITELIBDIR}/wx.pth 2>/dev/null || true" >> ${TMPPLIST}
.endif
.include <bsd.port.mk>

View File

@ -1,2 +0,0 @@
SHA256 (python/wxPython-src-3.0.2.0.tar.bz2) = d54129e5fbea4fb8091c87b2980760b72c22a386cb3b9dd2eebc928ef5e8df61
SIZE (python/wxPython-src-3.0.2.0.tar.bz2) = 58304944

View File

@ -1,10 +0,0 @@
--- config.py.orig 2015-04-11 19:08:36 UTC
+++ config.py
@@ -1030,6 +1030,7 @@ elif os.name == 'posix' or COMPILER == '
cflags = getWxConfigValue('--cxxflags')
cflags = cflags.split()
+ cflags.append('-std=c++11')
if debug:
cflags.append('-ggdb')
cflags.append('-O0')

View File

@ -1,12 +0,0 @@
--- setup.py.orig 2014-06-23 12:08:27.268192923 -0300
+++ setup.py 2014-06-23 12:07:08.925198614 -0300
BUILD_OPTIONS = { 'build_base' : BUILD_BASE }
@@ -1011,7 +1006,7 @@
if not PREP_ONLY:
if not EGGing:
- if INSTALL_MULTIVERSION:
+ if False:
setup(name = 'wxPython-common',
version = VERSION,
description = DESCRIPTION,

View File

@ -1,20 +0,0 @@
--- src/gtk/_gdi_wrap.cpp.orig 2015-04-12 18:02:36 UTC
+++ src/gtk/_gdi_wrap.cpp
@@ -3856,7 +3856,7 @@ const wxString& wxPyLocale::GetSingularS
const wxString& domain) const
{
bool found;
- wxString str( _T("error in translation"));
+ static wxString str( _T("error in translation"));
wxPyBlock_t blocked = wxPyBeginBlockThreads();
if ((found=wxPyCBH_findCallback(m_myInst, "GetSingularString"))) {
PyObject* param1 = wx2PyString(origString);
@@ -3878,7 +3878,7 @@ const wxString& wxPyLocale::GetPluralStr
const wxString& domain) const
{
bool found;
- wxString str( _T("error in translation"));
+ static wxString str( _T("error in translation"));
wxPyBlock_t blocked = wxPyBeginBlockThreads();
if ((found=wxPyCBH_findCallback(m_myInst, "GetPluralString"))) {
PyObject* param1 = wx2PyString(origString);

View File

@ -1,11 +0,0 @@
--- src/gtk/propgrid_wrap.cpp.orig 2014-11-27 20:51:32 UTC
+++ src/gtk/propgrid_wrap.cpp
@@ -3639,7 +3639,7 @@ bool PyObject_to_wxPGPropArgCls( PyObjec
}
else if ( input == Py_None )
{
- *v = new wxPGPropArgCls(reinterpret_cast< wxPGProperty * >(NULL));
+ *v = new wxPGPropArgCls(static_cast<wxPGProperty*>(NULL));
}
else
{

View File

@ -1,7 +0,0 @@
wxPython is a GUI toolkit for the Python programming language. It allows Python
programmers to create programs with a robust, highly functional graphical user
interface, simply and easily. It is implemented as a Python extension module
(native code) that wraps the popular wxWidgets cross platform GUI library, which
is written in C++.
WWW: http://www.wxpython.org