ScudCloud is a non official open-source desktop client app for Slack.

ScudCloud improves the Slack integration with desktop featuring:

   * multiple teams support
   * native system notifications
   * count of unread direct mentions at launcher/sytray icon
   * alert/wobbling on new messages
   * optional tray notifications and "Close to Tray"
   * follow your desktop activity and will stay online while you're
     logged in (if correct packages are installed)

WWW: https://github.com/raelgc/scudcloud
This commit is contained in:
Nicola Vitale 2018-01-20 10:25:50 +00:00
parent ac107e3859
commit 4ec8013949
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=459509
7 changed files with 86 additions and 0 deletions

View File

@ -161,6 +161,7 @@
SUBDIR += rubygem-termtter
SUBDIR += rubygem-tinder
SUBDIR += sayaka
SUBDIR += scudcloud
SUBDIR += sendxmpp
SUBDIR += skype
SUBDIR += skype-devel

39
net-im/scudcloud/Makefile Normal file
View File

@ -0,0 +1,39 @@
# Created by: Nicola Stanislao Vitale <nivit@FreeBSD.org>
# $FreeBSD$
PORTNAME= scudcloud
PORTVERSION= 1.64
DISTVERSIONPREFIX= v
CATEGORIES= net-im
MAINTAINER= nivit@FreeBSD.org
COMMENT= Desktop client app for Slack
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}jsmin>0:devel/py-jsmin@${PY_FLAVOR}
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sip>0:devel/py-sip@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}qt5-webkit>0:www/py-qt5-webkit@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}qt5-webkitwidgets>0:www/py-qt5-webkitwidgets@${PY_FLAVOR}
GH_ACCOUNT= raelgc
HUNSPELL_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}hunspell>0:textproc/py-hunspell@${PY_FLAVOR} \
qupzilla:www/qupzilla-qt5
INSTALLS_ICONS= yes
OPTIONS_DEFINE= HUNSPELL
USES= python:3.4+
USE_GITHUB= yes
USE_PYTHON= autoplist distutils
post-patch:
@${REINPLACE_CMD} -i.bak -e 's,%%LOCALBASE%%,${LOCALBASE},1' \
${WRKSRC}/share/${PORTNAME}.desktop \
${WRKSRC}/${PORTNAME}/resources.py
.include <bsd.port.mk>

View File

@ -0,0 +1,3 @@
TIMESTAMP = 1516357189
SHA256 (raelgc-scudcloud-v1.64_GH0.tar.gz) = 669d51cb9ef619afccbf0f9cf2f1d065cc88139e2adbf9d5f355c976e2f44328
SIZE (raelgc-scudcloud-v1.64_GH0.tar.gz) = 185675

View File

@ -0,0 +1,11 @@
--- scudcloud/resources.py.orig 2018-01-19 13:48:09 UTC
+++ scudcloud/resources.py
@@ -13,7 +13,7 @@ class Resources:
GOOGLE_OAUTH2_URL_RE = re.compile(r'^https://accounts.google.com/o/oauth')
SPELL_LIMIT = 6
- SPELL_DICT_PATH = '/usr/share/hunspell'
+ SPELL_DICT_PATH = '%%LOCALBASE%%/share/hunspell'
DEFAULT_CONFDIR = '~/.config/scudcloud'
DEFAULT_CACHEDIR = '~/.cache/scudcloud'

View File

@ -0,0 +1,11 @@
--- setup.py.orig 2018-01-16 17:43:41 UTC
+++ setup.py
@@ -38,8 +38,6 @@ def _data_files():
files = glob.glob(os.path.join('share', 'icons', theme, '*.svg'))
yield directory, files
- yield os.path.join('share', 'doc', 'scudcloud'), \
- ['LICENSE', 'README']
yield os.path.join('share', 'applications'), \
glob.glob(os.path.join('share', '*.desktop'))
yield os.path.join('share', 'pixmaps'), \

View File

@ -0,0 +1,8 @@
--- share/scudcloud.desktop.orig 2018-01-19 13:45:06 UTC
+++ share/scudcloud.desktop
@@ -9,4 +9,4 @@ Comment=ScudCloud is an open-source clie
Keywords=slack;chat;instant-messaging;collaboration;
Exec=scudcloud
StartupWMClass=scudcloud
-Icon=/usr/share/pixmaps/scudcloud.png
+Icon=%%LOCALBASE%%/share/pixmaps/scudcloud.png

View File

@ -0,0 +1,13 @@
ScudCloud is a non official open-source desktop client app for Slack.
ScudCloud improves the Slack integration with desktop featuring:
* multiple teams support
* native system notifications
* count of unread direct mentions at launcher/sytray icon
* alert/wobbling on new messages
* optional tray notifications and "Close to Tray"
* follow your desktop activity and will stay online while you're
logged in (if correct packages are installed)
WWW: https://github.com/raelgc/scudcloud