- Add missing $CONFIGURE_ARGS. (Whoops again!)

- Actually install the images for Mailman's web front-end to
  ${PREFIX}/www/icons, instead of depending on the user to do this in a
  post-installation step.  Add a new build-time variable to control the
  location where these images are intstalled.
- Gratuitous change:  Change the GNU logo and link in the footer of most
  pages in Mailman's web front-end to a "Powered by FreeBSD" logo, and a link
  to the FreeBSD home page.  This was accomplished by:
  - Patching the source to allow for multiple footer bars based on a new
    configuration variable LOGO_OS.  If LOGO_OS is set to 'FreeBSD', the
    FreeBSD footer will be displayed; otherwise, it reverts to the default
    GNU footer.
  - Set LOGO_OS to 'FreeBSD' in the installed Defaults.py  (The user may
    override this in mm_cfg.py)
- Bump $PORTREVISION again.  (Sorry guys.)
This commit is contained in:
Johann Visagie 2002-02-20 09:09:44 +00:00
parent 96768ed912
commit 4eb62bb3af
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=54964
8 changed files with 246 additions and 13 deletions

View File

@ -7,7 +7,7 @@
PORTNAME= mailman
PORTVERSION= 2.0.8
PORTREVISION= 4
PORTREVISION= 5
CATEGORIES= mail
MASTER_SITES= http://www.list.org/ \
${MASTER_SITE_GNU} \
@ -20,10 +20,10 @@ MAINTAINER= wjv@FreeBSD.org
RUN_DEPENDS= ${LOCALBASE}/sbin/httpd:${PORTSDIR}/www/apache13
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${MAILMANDIR} \
--with-python=${PYTHON_CMD} \
--with-mail-gid=${MAIL_GID} --with-cgi-gid=${CGI_GID}
USE_PYTHON= yes
CONFIGURE_ARGS= --prefix=${MAILMANDIR} --with-python=${PYTHON_CMD} \
--with-username=${USERNAME} --with-groupname=${GROUPNAME} \
--with-mail-gid=${MAIL_GID} --with-cgi-gid=${CGI_GID}
PKGOPTS= ${FILESDIR}/pkg-opts
.include <bsd.port.pre.mk>
@ -43,6 +43,9 @@ MAIL_GID?= 26
MAIL_GID?= 1
.endif
CGI_GID?= 80
IMGDIR= ${PREFIX}/www/icons
#
# End of user-configurable variables.
MAILMANDIR= ${PREFIX}/${MMDIR}
PKGMESSAGE= ${WRKDIR}/pkg-message
@ -87,6 +90,11 @@ post-install:
@ ${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${MAILMANDIR}/${dir}
.endfor
@ ${CHGRP} -R ${GROUPNAME} ${MAILMANDIR}
@ ${MKDIR} ${IMGDIR}
.for imgfile in mailman.jpg PythonPowered.png gnu-head-tiny.jpg
@ ${CP} ${MAILMANDIR}/icons/${imgfile} ${IMGDIR}
.endfor
@ uudecode -p ${FILESDIR}/powerlogo.gif.uue > ${IMGDIR}/powerlogo.gif
.if !defined(NOPORTDOCS)
@ ${MKDIR} ${DOCSDIR}
.for docfile in BUGS FAQ INSTALL NEWS README* UPGRADING

View File

@ -0,0 +1,26 @@
--- Mailman/Defaults.py.in.orig Thu Nov 16 06:23:52 2000
+++ Mailman/Defaults.py.in Tue Feb 19 17:18:39 2002
@@ -47,8 +47,8 @@
# Don't change MAILMAN_URL, unless you want to point it at the list.org
# mirror.
-MAILMAN_URL = 'http://www.gnu.org/software/mailman/mailman.html'
-#MAILMAN_URL = 'http://www.list.org/'
+#MAILMAN_URL = 'http://www.gnu.org/software/mailman/mailman.html'
+MAILMAN_URL = 'http://www.list.org/'
# Site-specific settings
DEFAULT_HOST_NAME = '@FQDN@'
@@ -59,6 +59,12 @@
HOME_PAGE = 'index.html'
MAILMAN_OWNER = 'mailman-owner@%s' % DEFAULT_HOST_NAME
+
+# Should the operating system logo (and link) in the footer of Mailman's
+# web pages be for GNU or FreeBSD. Options are 'GNU' or 'FreeBSD', with
+# 'GNU' being the default. Note: This is not a standard Mailman
+# configuration option; it has been added by the FreeBSD port.
+LOGO_OS = 'FreeBSD'

View File

@ -0,0 +1,64 @@
--- Mailman/htmlformat.py.orig Tue Sep 12 06:02:36 2000
+++ Mailman/htmlformat.py Tue Feb 19 17:12:53 2002
@@ -503,15 +503,17 @@
# These are the URLs which the image logos link to. The Mailman home page now
# points at the gnu.org site instead of the www.list.org mirror.
#
-from mm_cfg import MAILMAN_URL
+from mm_cfg import MAILMAN_URL, LOGO_OS
PYTHON_URL = 'http://www.python.org/'
GNU_URL = 'http://www.gnu.org/'
+FREEBSD_URL = 'http://www.freebsd.org/'
# The names of the image logo files. These are concatentated onto
# mm_cfg.IMAGE_LOGOS (not urljoined).
DELIVERED_BY = 'mailman.jpg'
PYTHON_POWERED = 'PythonPowered.png'
GNU_HEAD = 'gnu-head-tiny.jpg'
+FREEBSD_POWERED = 'powerlogo.gif'
def MailmanLogo():
@@ -529,18 +531,34 @@
gnulink = Link(GNU_URL,
'<img src="%s" alt="GNU\'s Not Unix" border=0>' %
logo(GNU_HEAD))
- text = Container(Link(MAILMAN_URL, 'Mailman home page'),
- '<br>',
- Link(PYTHON_URL, 'Python home page'),
- '<br>',
- Link(GNU_URL, 'GNU home page'),
- )
- t.AddRow([mmlink, pylink, gnulink, text])
+ freebsdlink = Link(FREEBSD_URL,
+ '<img src="%s" alt="Powered by FreeBSD" border=0>' %
+ logo(FREEBSD_POWERED))
+ if LOGO_OS == 'FreeBSD':
+ text = Container(Link(MAILMAN_URL, 'Mailman home page'),
+ '<br>',
+ Link(PYTHON_URL, 'Python home page'),
+ '<br>',
+ Link(FREEBSD_URL, 'FreeBSD home page'),
+ )
+ t.AddRow([mmlink, pylink, freebsdlink, text])
+ else:
+ text = Container(Link(MAILMAN_URL, 'Mailman home page'),
+ '<br>',
+ Link(PYTHON_URL, 'Python home page'),
+ '<br>',
+ Link(GNU_URL, 'GNU home page'),
+ )
+ t.AddRow([mmlink, pylink, gnulink, text])
else:
# use only textual links
mmlink = Link(MAILMAN_URL,
'Delivered by Mailman<br>version %s' % mm_cfg.VERSION)
pylink = Link(PYTHON_URL, 'Python Powered')
gnulink = Link(GNU_URL, "Gnu's Not Unix")
- t.AddRow([mmlink, pylink, gnulink])
+ freebsdlink = Link(FREEBSD_URL, "Powered by FreeBSD")
+ if LOGO_OS == 'FreeBSD':
+ t.AddRow([mmlink, pylink, freebsdlink])
+ else:
+ t.AddRow([mmlink, pylink, gnulink])
return t

View File

@ -25,3 +25,4 @@ GGI_GID|80|The group id under which your web server executes CGI scripts
By default, this port works with the current port of Apache. If your
WWW server executes CGI scripts under a different GID, you'll have to
set this at build time.
IMGDIR|${PREFIX}/www/data/icons|The directory where icon images will be installed

View File

@ -0,0 +1,121 @@
begin 664 powerlogo.gif
M1TE&.#EAJP!``.<```````0#$@L`(0P,#Q,("!0:*A<0'ALE-!X:)2,`4"0D
M,"4`4B4@*28:*2<`52@P02H`62HB-"L#4RL&3BLG.2P`6RT`7C`P$S`P,#$I
M/3((5#(/0#(V13,O0#0>&C4D,S8I/S@H-SA&7#DP0#DP2#HS2CHV1#P22#PK
M"CP]3STP(SXU2#X^)C\X2D`624,V24,Y340]5D0^1$0^3D4<2$5%6D8S.D<0
M.D@714A(3TH_5TI(84ICA$LK.DPB/TPH/TU$74U-8DU38$]:;U`=0%$_35%)
M7%%ND%(W1U,C/54G0%<O1%<S,U=*5%=-8%=265A\H5HK/5I")5]?7V&'IV<Q
M/6A=3FAI9VLU06P]3'%%5'%.5G-R6G0H,G4:)G<Y17A(+7F<J7I6#GQ\77TP
M.X&!@H=&0(@[1HE=38F%>8I00HI@$(UG18Z.B)!M1)2)$Y<\1I=E"IA\"YE8
M,YF8C)IP`YM,`)M=`)N;`*!I'J.CHZ0B+:HP.*MC4JMV%*VLJZY_&*Z8,J]&
M3K")%;"C3["VN;(Z0K*QL;R\O+Z^OK^$`,"Z?L7#0,:%%LJ+%\O*MLPI,<P[
M0LR$&LUM2-`S.M"-#]"?$=9,3]=$1]>6#]GB=]NF"^+7(^;(%>JU">K)`.L]
M0>M%1.VF`O&F!?'I@/1-2_=$0_=44??Q#O?\ZOCE#_R_`/SX!OW[`_W]!O[^
M`_]:5_]K9?^P`/^Q`/^R`/^S`/^T`/^U`/^V`/^W`/^X`/^Y`/^Z`/^[`/^\
M`/^]`/^_`/_``/_!`/_"`/_#`/_$`/_%`/_&`/_(`/_)`/_*`/_+`/_,`/_-
M`/_.`/_/`/_0`/_1`/_2`/_3`/_4`/_5`/_6`/_7`/_8`/_9`/_:`/_;`/_<
M`/_=`/_>`/_?`/_@`/_A`/_B`/_C`/_D`/_E`/_F`/_G`/_H`/_I`/_J`/_K
M`/_L`/_M`/_N`/_O`/_P`/_Q`/_R`/_S`/_S(__U`/_V`/_Y`/_]`/_^\/__
M`/__9````````````````"'Y!`$``(D`+`````"K`$``0`C^`!,)'$BPH,&#
M"!,J7,BPH<.'$"-*G$BQHL6+"9]`@O/@@`P,'FY4P6(#00`"5PQ.,51$P"&,
M,&/*G-E03Y1%;5+=&),J%:E\8;Q0@L,D"9,0$2)T`,$`0!E$-`\"P%!0#P`&
MC-8`D")+#`$`BKR"K84"0!Q%*%"(`H!"EJQ*;!7%02$F#@`Q:._6<BL+@-DZ
M!`BLXB7&KZ)5=%>)07&L#HI-R90M:^8,&C1ITJA9NX8-F[9MW+I]`Q=.W#AR
MJGHP&K=N73LWETZ9R3*E2`Q!I4+I#@6*3X\/(YJTH-!$G_'CR),K7WX<#\5]
M?*.[G9/`1W1)2J1KW\YW%BU;MV[^Y=(E"4*"7[^$%3.3(($Q3PE.0&/&K%DS
M&I:D3:/^0ULVT*IT$T@%"?Q0#CGFJ$((&&!,L@4GJJB"QA9PP"*(`'B@@@<+
MEV#"&RBFF")($"44P=R)*"[GW$30<4>===L1&%T>YHTBW2P:.`#&+KSPX@MZ
MOSABWC#$%'/,,2Y`,(<G-$CS##319&;!`ME@XT:!WG@SFFGD+)'`(/&HLPX[
M[;SS3CSRS#.//?;<XR8^^M"3P0Q-3`$$B1F`T$$&&235Q"LI'N=*`QY$L046
M333QA`%6J/@<=Y!&VATMM8`W'H^]_/A+,,(,4TPQQAR#C&3U.?.D?M-48PTV
MV7P6VFC^I9U6SCGHI*,..^RX\PX\:,Y33YMNWH,/G*ZP`<LIAFPA0@D<'*"`
M#SK$(&T),:Q@;0<RP+"%*ZVP`FARKWP;J#XK1F7NN1%1P<,14*@+1`Q`[+##
M$#&T(=`A+#R2S[YM-*'%%DXX$8,.4$!1!+H()ZRP0G3\EL%+#"%`@!X+5VSQ
MN7_LT847/.GA11>/%,(''R%4\<476601"2B@4-)#`1QD,$+"4PE4!@!3))*#
M7P`,0,<3`-`QA5]T7.&4'@/PG#,`!@R``2([^S7`(4A+C3-!/?/\1"(#,)#(
M(0"8</$A9)BRQP$?=(%``07TE,@(D$#R114?-#"""0%`?''^0BU*ZO??DU:*
MRZ6*K*&(,,!PZJF1HBJC##/.5`;E--14PUFKH'7C#6GCG&8.)V"@@0<>:'!R
M9CQJHJ(``R.$\$$(/_2`Q`PK4("``8R,J[NC+$)*G00N!%_!`FZ-8D$"-$BB
M1A2RN"`!7VHL0,0LC20P1RVU&+\`(+T(F8`22]"@P?AS,+.,&>8EX$![)VQR
MC35S3/!#YEJ2)LX2#OQ`JYBYNL-KFJA8@H56D((21.``@CA%*5I&AA',(`A.
MJ($.BK.["I+K48`#W"@D(0GO",X6N<B$(S;Q(V!LBDA'0L:HS&>?9WC"$I;H
M1#.B00W/;"-+X%#%:,:!#M>HPU;^9-(5/.21IGK\ZDW#,HXK'A"*4YB"#TN8
MP0YT`(,'/.`,E)!!#"+@@3$$@A.H0$6X]/$*5'"""QXPPA!*P`5ZM")%Y=J;
M'!T"%:@0)!5_V%<JCO`"+&2A"5?H@R!>4((:U(`"B+!C09Z@!31H008"T\$.
M8E`"$A1"D7/,I"8/@DF!Z($*8:`"%:#``QZ(0`0[*$,A"K')5KJ2CFWHY"MG
M24N$_,$#A@A!!R!2!3A\@)6U#&;%]%`A,D1@#WLP!#(A@844C*`'(2B@4Q!!
M!P3L`0XIZ$`#9"G,;LH$$2'PPA]2\0@/+*(GJ2A#,LF0!!]$H0I12`("G)4!
M!1B`FS/^Z1D&,.`7BE6L#3A39,UHB0@F]$``!\C`!\H@@$?TY`A[@,0>D("%
M)9C@`0@8@`#\N3!]8L`$]AI:&_:Q#Q8`8!]WN8`4+B`&%K``I01PZ04`P`@`
MO'0?;@#`!5QJ4Y.2M*9N("E);4K2G#*"$``(A!1.*M2F.O6I4(WJ4S51!0N=
MP8EP>,$,%G$((?2`$I$0Q!>2$()L90`!FI"J6M<:1SH>@A&5X,MW;&&+N<Y"
M%K.812448:/MB$(1<2V>(C:QG;S^=1.ZT,4NUB*&5:PB&$0R1JB8\8QH-*,^
MSSA59JRQ*AN^RGZ>,X<XIH`&-[""'>]@A`Q&(`+<Y*84D3#^1!:0L`0DI$`'
M1C`!HRRXN[8^I&_7,0,.VN,"&@1/`PG(Q%TS*)VY;L(,2UA`?(J+W!-8`E3'
MB!\-EJ`!%VS/$EN@07LT8%SQ3<`%>?B$:,E!#DYP`AWMZ,038M$'*]`#'JK@
M@A4X<8]/B`$!'OC``U*PA"IDH08<(`1O+>A;AP!7.B_BRRC`X)9,Y`$'LJ#.
M!)8+!AJ<X`1YB(XCHN"""51A$[C8A?=^D;AAG&`!CEC&'!PP@4U@%DJ9H48>
M%M`?^HVF$^L#0SO.8:MUJ.,=\OC?/`@A"#-0(&9L&X$-EO"%,VC!"5JXLA-@
MP(D%ZZ[!#7EP="+LED9DQRTRXLO^'"1PWN"=P`'9F=()@N<""T#`$:OP7J>(
M00Q/Y.@'RU@&?9PAC4^H87V6P$8>\A>:^H7C-#D*!#SXUP[_]>I7]J"'"4H"
M@A2<P10*O$054A"$(00L8%9XHY?AB,'ML.<$?94.@0+KEB](%PR`P`X8:I&)
MXX'8$7EPP2B$T8CU`<(1C@"#!#3@B68,`@(G`$0GIO%L,)##/VJ(SR!@.`@W
M;``"@3B'.FY%IEVASE=L"E826<$$05#@`1)\@0DH4`5*D&'`(\B=[E[QA#Z<
MH@]9R``G7,$<,#-$S,R%E'>^(Q[%\B)3+`:&,/@<*E$E0]"4>5(T**>JRV7N
M&UL:1SG^S&&.6MVJ'64:8A'3C43CC`$,L*#$%P3A(3@X89(PV($,3`"#%\BL
M!3`H`0B,8`0=9(`$)1`X*A@!1G&AR.`+07C"M4,I2^4"4^A)7*>P:_''91S'
MJ5H5YCX;*P31*AUC*C>OYF%&0KB!$$TG%@9R$`(LU&`')4``*ESQK:4_`00Q
ML!T%C+`"=@6^4:LV#M2]*<<V.'244$#E#@(&A!H`H01'&,)3.HF((LB@"5+>
M0A""0,DA',$)C$\]3%9IRE+R@)1MH(,>>A(R4;8+"D-H%Q5$,`35^_[WP`^^
M\(>O>D3H(00"^`-#E$_\YD>$#EXX@P+HX)`_\,$#]G*^]FW^>0-*,$``6TL$
M'6Q@`!.406\%N0(?=""#[;M_((CP@BDX8H(,)*$+9%A"#U8P@A8(G0#,EPB(
M8``L$0%E\'[N]P>&X#)=H`9]$#=>L`>1\`)U5ULS$`*$(A208%$4T``(J'V)
MQ`15L`4]\05>X%#IM`=?@`558#)9``>0X`5)<``,T`$&D'T?V'SQAP;[@@9=
M0'NI$`9=``ED$`51\!L-@``4$`$*T`$!0'T)LT_[!%(70P<8<(`#@0'A-TO&
MYP4U4`!I@`1'8`/H1`5"L0=%85$*M3I3@4\T,5`WDS.)4`93<`5Z@`ATF`AZ
M,`4YLX?VH@=7,`74APA34`9T@(7^='A^GG0%5Q"'6(,!;5"(>C@%]H*'<F@Q
M0D`)57``(<`$!G``&X""&@$)9Y`%2V`#,+`"!4`5%^-1_40'82-^87,S99`#
M35&+`'`(&:4'A\!/8`,`5W"(`)`#<P@`3P`T*6$"5S,01',(!I"+.W,(M'@Q
M/6`*F'`&D8"&R#=[J<`#>T`)AG`&4=``(6`"(Y`W>S-0`V$T90`=*$``LG`!
M9;$8\]@7**`(^*@(:]$6N5`89X&/E5`6HC`+?G`7RV6/LZ`+A7$8!+!24C`8
MJ[!G7!<9@Z9Q.;89K/(9FO,-X?!HIZ$*1'8KYY`$L'`)9R`(EZ`%(I`%R"0(
M"Q@)9]#^!<`Q`S['`*@`)XFG'%"GC@*!ASRC%K)0!W[Q5P!``-\Q"F7A%W5@
MCVY!"X#A%VHA"DFY5&(0'6SQ%0!0!XDE!T7I6&QA#&71#%JA"(\#.1HW#92S
M&=G0*MS`#2`7*Z?A#8S0!VS`">P0#ZB`!G!0`W!P"I%P";F!":`0"IA@"&00
M`B/@!$9``@B@;SFIDZTV=9+9E+0@'H/C"X4!`)NP"BU6)*&"#!2)6<^`*ATW
M=AM9=N-P5*CP"9:@!IQ@:>]`"`'``2[)!V3P`P<@94L@;R.0`0U@!03WF+PC
M$5+7",9YG,@9:Y(Y"Y5R"YG0",CF")6`;)L@D<:`#)XP"'G^,`>-\`F5!4/@
M&9Z?(!H<^6CD4`[E$`Z,,`;T53IKAVZL\`$$T((]\`(=``,PD`+VI&#">2*+
MQS>0DFTGP!>98`8G<)!3QYQT=0NU4&SG(0R;,`<$X@/&D`S9E@>"Y@QNH`&#
M$`W/P`;(TPTBV@F6H`7F@02?\)%N$`AK@`=7$`N$P`B!H`8V8`.4``D#@`><
M\`D>$`)90"&&``FA@`9"0`%=UI_#&1%2EV$+`"/%DPF3Z4&U<`NXH`N\X`CK
MPV+!0`S400/'D`<%@G&F`@A1<@U7\@,VM`V@H0ULX``.,`BS4@[HH`KT`"%(
M-@_Q,`8RD`4R\``Y@`<<('^A8`K^H'`)-&<(32`$)D`/2`J9O>,B3<H7@/`\
MDH`##K``8)``TB4+FZ`!6"`)<S`E(38+9J`!>8`=$G`"/(*EUC,'RN8"EI`,
MS.`(!*(!8)`'EN`)F%$Y;I`__R&B6M*1+I``2'`.XB8FE69N]:`*6``+I?`"
M#Y"?!P`''4(&&2`",9`",W!S^=:HR?&?"+&D7<I!DO`%$\`7P]-7F9`)#D`$
M?"$)ERH+2I``C0`>N#"O<Q`DZ^-8PN`)MI8`@*`,SP`(:H`$=F8>+E`-W'"F
M'\<YYT`#F%HKK9$KNY(FOH(*2"`#16`$)7``!6`(UKA`9Q`$\K(#1O`$(1"<
MWGI!C[K^'60F"Z,`I6B6`'(UKN0*I;0P/'G@")*`;*/0"\"`I0NP=9(578!V
M8Y;Q">9A"=G@!CS6:)Q##D`V`>P`1)4&#T.D)IAV#ZW@"IR0`SF00)>`J,L2
M`T&0GT"0`H%00>$2+GSGMD[7')$)89$:(S1+H`0R!]%A(UFP`!HP"@['"YX0
M#*SJF<=@"1`P`<U@"2[@":>"#8Y@/=>@#6#Z`Z)A/^B0J6K0#D;F&F82#Y<&
M+&_R"JW0`AT!`C,P`S$``TOHL28P`S:`"KO#"$0P"9'`!U9&`6Z@LL@!K@>!
M<)(0!1I@`2>P!"'VKDI@`1J@!!16/&9@`<NF`6:`/;(@"4G^,CXTX`B^P"06
M8`'49;R7M0R60`/$ZV$T$`C=L):!(`'=2P,T4`(:\`-ND*+H0&E"=&Y'I&[&
M\0I5<`J@\`4/P`$CT`$FP`$]P`>@8`,S\`&$($8IX@J$``1;L`4_P`BNP+O?
M.K>365C80Z67T@N]@![!P"F&JT*D0AF6(0V683D9V99:PI&R8@YG=W*[DK7H
M)KHXJ0]C\`6F,*BPY01#0'JJ^P`9RP$EH`,K0`(QT`+U%P$?$`%\T@`F,`0D
MT&5QFZ00L:0;C%=5-SB*!<)9!UF&>PR1@7$6F9:7HY&.)@[G*<,F%T1GLG(L
M)RQDQ`E5939&(`)`4`1PH`5#\"[^2<=S,T`!-M`$15`&1Q4(8\`(C'S!KL`*
M&/QT&KS%E&FOE^(C(JPXV`6:9=D,F;5QU*`9G.$JW%`_7#)RZ%"_8^(.NA*Z
MZ88/=/P*.=`%I7`*6A`$'/``,P!&C*`#%$`!.4=Z"M``+1`#:Z0"G'#%O.6[
M!H$'=O#,T!S-TCS-U#S-=V`'UWP'VKS-W'P'<7`'=1`'X5P'Y%S.YEP'<H#.
M<K#.[-S.>"`'[QS/);`(^_((94``.1`(@?`&&=`'2%``?$(!!A`(HU/0HS,&
M#=`#L_4"V1K$04`!!&W0$CW1%,W,.1@1>I`/Z01*5.`$?3`)?1#263`#(D`%
M1Y`2""&-`UE6!$UP<S"@Q#M``NAWT;5T"*\72J3$`SL0+S<'!#I``@&8"'_`
M`$6``#TP956@!5<P24!P!!WMAC1-4(AP!*5T!%0]!#M@2B^1!HFP+QJ="&$0
M!J8F+SPP2C40U=I7"'J0>;U7"%33!D<@`JY7,`4S!$,`3&A]T6JM!V40!F6@
.!W^@!WB=UX2M20$!`#L`
`
end

View File

@ -41,7 +41,7 @@ POST-DEINSTALL)
if [ -d %%MAILMANDIR%% ]; then
echo '%%MAILMANDIR%% is not empty - this installation may have active lists!'
echo '- The "%%USER%%" user and "%%GROUP%%" group were therefore not deleted.'
echo '- You may delete them with "pw userdel %%USER%%".'
echo '- You may delete them with "pw groupdel %%GROUP%%; pw userdel %%USER%%".'
else
delete_account %%USER%% %%GROUP%%
fi

View File

@ -1,19 +1,26 @@
----------------------------------------------------------------------------
Mailman has been installed, but is not quite ready to be used yet!
You need to configure both Mailman and your MTA to integrate with each
other. At the very least, you'll have to create some aliases.
other. At the very least, you'll need to create these aliases:
See %%DOCSDIR%%/INSTALL for post-installation instructions,
with "prefix" being "%%MAILMANDIR%%". You may also find README
files with MTA-specific hints in %%DOCSDIR%%.
mailman: you@your.domain.com
mailman-owner: mailman
The entire Mailman installation resides under %%MAILMANDIR%%.
The command-line scripts necessary to administer Mailman have been
installed in %%MAILMANDIR%%/bin.
You will also find README files with MTA-specific hints in
%%DOCSDIR%%.
You'll need to add at least the following to Apache's httpd.conf to
activate Mailman's web interface. (Remember to restart your httpd!)
activate Mailman's web interface:
ScriptAlias /mailman/ "%%MAILMANDIR%%/cgi-bin/"
Alias /pipermail/ "%%MAILMANDIR%%/archives/public/"
Remember to reload your mail aliases if required, and to restart your httpd!
See %%DOCSDIR%%/INSTALL for further post-installation
instructions.
Note: The entire Mailman installation resides under %%MAILMANDIR%%.
The command-line scripts necessary to administer Mailman have been installed
in %%MAILMANDIR%%/bin.
----------------------------------------------------------------------------

View File

@ -298,6 +298,10 @@
%%PORTDOCS%%share/doc/mailman/README.QMAIL
%%PORTDOCS%%share/doc/mailman/README.SENDMAIL
%%PORTDOCS%%share/doc/mailman/UPGRADING
www/icons/PythonPowered.png
www/icons/gnu-head-tiny.jpg
www/icons/mailman.jpg
www/icons/powerlogo.gif
@dirrm %%MMDIR%%/templates
@dirrm %%MMDIR%%/scripts
@dirrm %%MMDIR%%/mail
@ -314,6 +318,8 @@
@dirrm %%MMDIR%%/Mailman/Bouncers
@dirrm %%MMDIR%%/Mailman/Archiver
%%PORTDOCS%%@dirrm share/doc/mailman
@unexec rmdir %D/www/icons 2>/dev/null || true
@unexec rmdir %D/www 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/spam 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/qfiles 2>/dev/null || true
@unexec rmdir %D/%%MMDIR%%/logs 2>/dev/null || true