Updated to version 1.91.4. Use the FTP URL for the master site instead
of the HTML one.
This commit is contained in:
parent
e907c2e2a0
commit
4e58b57407
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=3523
@ -3,13 +3,13 @@
|
||||
# Date created: 9 June 1996
|
||||
# Whom: jraynard
|
||||
#
|
||||
# $Id$
|
||||
# $Id: Makefile,v 1.1.1.1 1996/06/09 23:24:53 asami Exp $
|
||||
#
|
||||
|
||||
DISTNAME= analog.1.9.6
|
||||
PKGNAME= analog-1.9.6
|
||||
DISTNAME= analog.1.91.4
|
||||
PKGNAME= analog-1.91.4
|
||||
CATEGORIES+= www
|
||||
MASTER_SITES= http://www.statslab.cam.ac.uk/~sret1/analog/
|
||||
MASTER_SITES= ftp.statslab.cam.ac.uk/pub/users/sret1/analog/
|
||||
|
||||
MAINTAINER= jraynard@freebsd.org
|
||||
|
||||
@ -17,7 +17,7 @@ WRKSRC= ${WRKDIR}/analog
|
||||
|
||||
do-install:
|
||||
@mkdir -p ${PREFIX}/share/analog
|
||||
@(cd ${WRKSRC}; cp -r Readme.html domains.tab primes.tab analogo.gif images ${PREFIX}/share/analog; cp analog ${PREFIX}/bin)
|
||||
@(cd ${WRKSRC}; cp -r Readme.html domains.tab primes.tab images ${PREFIX}/share/analog; cp analog ${PREFIX}/bin)
|
||||
@(cd ${PREFIX}/share/analog; chmod +r *)
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -1,51 +1,31 @@
|
||||
*** Makefile.orig Wed Mar 6 15:12:05 1996
|
||||
--- Makefile Sun Jun 9 12:27:55 1996
|
||||
***************
|
||||
*** 2,8 ****
|
||||
--- Makefile.orig Sun Aug 4 09:19:11 1996
|
||||
+++ Makefile Sun Aug 4 09:20:41 1996
|
||||
@@ -2,7 +2,7 @@
|
||||
# Please read Readme.html, or http://www.statslab.cam.ac.uk/~sret1/analog/
|
||||
CC = gcc # which compiler to use. NB Different compilers need
|
||||
# different CFLAGS, e.g., -O instead of -O2.
|
||||
! CFLAGS = -O2 # options, e.g. for optimisation or ANSI compilation.
|
||||
LIBS = -lm # extra libraries needed
|
||||
PAGER = less # Your favourite pager program, e.g. more
|
||||
|
||||
--- 2,8 ----
|
||||
# Please read Readme.html, or http://www.statslab.cam.ac.uk/~sret1/analog/
|
||||
CC = gcc # which compiler to use. NB Different compilers need
|
||||
# different CFLAGS, e.g., -O instead of -O2.
|
||||
! #CFLAGS = -O2 # options, e.g. for optimisation or ANSI compilation.
|
||||
LIBS = -lm # extra libraries needed
|
||||
PAGER = less # Your favourite pager program, e.g. more
|
||||
|
||||
***************
|
||||
*** 16,21 ****
|
||||
--- 16,23 ----
|
||||
-CFLAGS = -O2 # options, e.g. for optimisation or ANSI compilation.
|
||||
+#CFLAGS = -O2 # options, e.g. for optimisation or ANSI compilation.
|
||||
DEFS = # any of -DNOPIPES -DNODNS -DNODIRENT
|
||||
OS = UNIX # Operating system: UNIX, DOS, MAC or VMS
|
||||
LIBS = -lm # extra libraries needed; Solaris 2 (SunOS 5) needs
|
||||
@@ -21,6 +21,8 @@
|
||||
FORMSRC = analform.c # The source code for that program
|
||||
FORMHTML = analogform.html # Where the form itself will go
|
||||
FORMOPTS = # Extra analog options when constructing the form
|
||||
+
|
||||
+ all: $(PROGRAM)
|
||||
+all: $(PROGRAM)
|
||||
|
||||
$(PROGRAM): $(OBJS) $(HEADERS) Makefile
|
||||
$(CC) $(CFLAGS) $(OBJS) -o $(PROGRAM) $(LIBS)
|
||||
|
||||
*** analform.c.orig Wed Apr 10 08:57:01 1996
|
||||
--- analform.c Sun Jun 9 12:45:57 1996
|
||||
***************
|
||||
*** 6,12 ****
|
||||
--- analform.c.orig Sat Jul 13 14:47:55 1996
|
||||
+++ analform.c Sun Aug 4 09:16:42 1996
|
||||
@@ -11,7 +11,7 @@
|
||||
|
||||
/* You must change the next line to indicate where the analog program lives */
|
||||
|
||||
! #define COMMAND "/usr/local/etc/httpd/analog/analog"
|
||||
-#define COMMAND "/usr/local/etc/httpd/analog/analog"
|
||||
+#define COMMAND "/usr/local/bin/analog"
|
||||
#define MAXARGLENGTH (2048) /* should be plenty */
|
||||
#define OK (0)
|
||||
#define ERR (-1)
|
||||
--- 6,12 ----
|
||||
|
||||
/* You must change the next line to indicate where the analog program lives */
|
||||
|
||||
! #define COMMAND "/usr/local/bin/analog"
|
||||
#define MAXARGLENGTH (2048) /* should be plenty */
|
||||
#define OK (0)
|
||||
#define ERR (-1)
|
||||
|
||||
|
@ -1,59 +1,50 @@
|
||||
*** analhead.h.orig Thu Apr 11 09:09:52 1996
|
||||
--- analhead.h Sun Jun 9 12:45:17 1996
|
||||
***************
|
||||
*** 17,27 ****
|
||||
--- analhead.h.orig Sat Jul 13 14:48:54 1996
|
||||
+++ analhead.h Sun Aug 4 09:31:54 1996
|
||||
@@ -17,11 +17,11 @@
|
||||
/* the URL of your host's home page, for linking to at the top of the
|
||||
output; use "-" for no linking. */
|
||||
|
||||
! #define DOMAINSFILE "/usr/local/etc/httpd/analog/domains.tab"
|
||||
-#define DOMAINSFILE "/usr/local/etc/httpd/analog/domains.tab"
|
||||
+#define DOMAINSFILE "/usr/local/share/analog/domains.tab"
|
||||
/* the name of the file where the domain definitions live; see README.html
|
||||
for the format of this file */
|
||||
|
||||
! #define LOGFILE "/usr/local/etc/httpd/logs/access_log"
|
||||
-#define LOGFILE "/usr/local/etc/httpd/logs/access_log"
|
||||
+#define LOGFILE "/usr/local/www/logs/access_log"
|
||||
/* The name of the default logfile; use "stdin" for stdin.
|
||||
Can be a list, separated by commas (but no spaces). */
|
||||
|
||||
--- 17,27 ----
|
||||
/* the URL of your host's home page, for linking to at the top of the
|
||||
output; use "-" for no linking. */
|
||||
@@ -30,7 +30,7 @@
|
||||
The URL can be absolute, or relative to the output page: e.g., just the
|
||||
empty string "" for the same directory as the output page. */
|
||||
|
||||
! #define DOMAINSFILE "/usr/local/share/analog/domains.tab"
|
||||
/* the name of the file where the domain definitions live; see README.html
|
||||
for the format of this file */
|
||||
-#define DEFAULTCONFIGFILE "/usr/local/etc/httpd/analog/analog.cfg"
|
||||
+#define DEFAULTCONFIGFILE "/usr/local/share/analog/analog.cfg"
|
||||
/* the name of the default configuration file; see README.html for a
|
||||
description of this file. Use "none" for no configuration file. */
|
||||
|
||||
! #define LOGFILE "/usr/local/www/logs/access_log"
|
||||
/* The name of the default logfile; use "stdin" for stdin.
|
||||
Can be a list, separated by commas (but no spaces). */
|
||||
|
||||
***************
|
||||
*** 113,126 ****
|
||||
@@ -80,20 +80,20 @@
|
||||
#define CACHEFILE "none"
|
||||
/* The default file of cached time info. Use "none" for none. */
|
||||
|
||||
! #define REFERER_LOG "/usr/local/etc/httpd/logs/referer_log"
|
||||
/* The name of the default referer_log. Use "none" for none.
|
||||
-#define REFERRER_LOG "/usr/local/etc/httpd/logs/referer_log"
|
||||
+#define REFERRER_LOG "/usr/local/www/logs/referer_log"
|
||||
/* The name of the default referrer_log (= referer_log). Use "none" for none.
|
||||
Can be a list, separated by commas. */
|
||||
|
||||
! #define BROWSER_LOG "/usr/local/etc/httpd/logs/agent_log"
|
||||
-#define BROWSER_LOG "/usr/local/etc/httpd/logs/agent_log"
|
||||
+#define BROWSER_LOG "/usr/local/www/logs/agent_log"
|
||||
/* The name of the default browser log (= agent_log) similarly. */
|
||||
|
||||
! #define ERROR_LOG "/usr/local/etc/httpd/logs/error_log"
|
||||
-#define ERROR_LOG "/usr/local/etc/httpd/logs/error_log"
|
||||
+#define ERROR_LOG "/usr/local/www/logs/error_log"
|
||||
/* The name of the default error_log similarly. */
|
||||
|
||||
#define REPORTORDER "mWdDhHoSirfbBce"
|
||||
--- 113,126 ----
|
||||
#define CACHEFILE "none"
|
||||
/* The default file of cached time info. Use "none" for none. */
|
||||
#define NUMLOOKUP (OFF)
|
||||
/* whether to try and resolve IP addresses. Can be slow. */
|
||||
|
||||
! #define REFERER_LOG "/usr/local/www/logs/referer_log"
|
||||
/* The name of the default referer_log. Use "none" for none.
|
||||
Can be a list, separated by commas. */
|
||||
|
||||
! #define BROWSER_LOG "/usr/local/www/logs/agent_log"
|
||||
/* The name of the default browser log (= agent_log) similarly. */
|
||||
|
||||
! #define ERROR_LOG "/usr/local/www/logs/error_log"
|
||||
/* The name of the default error_log similarly. */
|
||||
|
||||
#define REPORTORDER "mWdDhHoSirfbBce"
|
||||
-#define DNSFILE "/users4/sret1/misc/analog/dnscache"
|
||||
+#define DNSFILE "/usr/local/share/analog/dnscache"
|
||||
/* where to store resolved addresses so we don't have to look them up next
|
||||
time */
|
||||
|
||||
|
@ -2,7 +2,6 @@ bin/analog
|
||||
share/analog/Readme.html
|
||||
share/analog/domains.tab
|
||||
share/analog/primes.tab
|
||||
share/analog/analogo.gif
|
||||
share/analog/images/bar1.gif
|
||||
share/analog/images/bar16.gif
|
||||
share/analog/images/bar2.gif
|
||||
|
Loading…
Reference in New Issue
Block a user