- Update to 1.3 [1]

ChangeLog summary:
   * bugfixes

   * Add remote uid detection and translation ('idmap=user' option).
     Idea and implementation details worked out by Jean-Marc Valin

     (Since this is rather untested, it's not yet mentioned in pkg-message).

   * Add support for SSH protocol version 1.  Bug reported by Miklos Bagi Jr.

   * Add atomic create+open and ftruncate operation.  This should fix
     issues with 'cp' and other programs failing with "Permission
     denied".  To be effective, needs FUSE version 2.5 and kernel
     version 2.6.15 (just a guess, since neither of them is released yet).

     (Investigations are made whether this is possible/necessary for fuse4bsd)

- User lower case in first letter of IGNORE

Submitted by:	Anish Mistry (maintainer)
PR:		ports/88265
This commit is contained in:
Simon Barner 2005-10-31 12:49:43 +00:00
parent e86bfbbaee
commit 4e1f2cf3f4
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=146821
4 changed files with 26 additions and 15 deletions

View File

@ -5,7 +5,7 @@
#
PORTNAME= sshfs
PORTVERSION= 1.2
PORTVERSION= 1.3
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= fuse
@ -26,7 +26,7 @@ USE_REINPLACE= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 600000
IGNORE= Depends on kernel module that requires FreeBSD 6 or later
IGNORE= depends on kernel module that requires FreeBSD 6 or later
.endif
post-install:

View File

@ -1,2 +1,2 @@
MD5 (sshfs-fuse-1.2.tar.gz) = 685dc6611e20242602105fe4960a6ab9
SIZE (sshfs-fuse-1.2.tar.gz) = 86239
MD5 (sshfs-fuse-1.3.tar.gz) = 40fe4a353d03b80f8b37e4b0cc6159d3
SIZE (sshfs-fuse-1.3.tar.gz) = 88738

View File

@ -1,5 +1,5 @@
--- sshfs.c.orig Mon Aug 15 05:07:08 2005
+++ sshfs.c Sun Oct 9 13:12:45 2005
--- sshfs.c.orig Fri Oct 28 08:15:35 2005
+++ sshfs.c Mon Oct 31 02:59:33 2005
@@ -14,7 +14,11 @@
#include <unistd.h>
#include <fcntl.h>
@ -27,7 +27,7 @@
#include "cache.h"
#include "opts.h"
@@ -970,7 +981,11 @@
@@ -1070,7 +1081,11 @@
err = req->error;
goto out;
}
@ -39,7 +39,7 @@
if (req->reply_type != expect_type && req->reply_type != SSH_FXP_STATUS) {
fprintf(stderr, "protocol error\n");
goto out;
@@ -985,21 +1000,35 @@
@@ -1085,21 +1100,35 @@
if (expect_type == SSH_FXP_STATUS)
err = 0;
else
@ -76,19 +76,19 @@
}
} else {
buf_init(outbuf, req->reply.size - req->reply.len);
@@ -1039,7 +1068,11 @@
@@ -1142,7 +1171,11 @@
err = sftp_request(SSH_FXP_LSTAT, &buf, SSH_FXP_ATTRS, &outbuf);
if (!err) {
if (buf_get_attrs(&outbuf, stbuf) == -1)
if (buf_get_attrs(&outbuf, stbuf, NULL) == -1)
+#ifdef EPROTO
err = -EPROTO;
+#else
+ err = -EPROTONOSUPPORT;
+ err = -EPROTONOSUPPORT;
+#endif
buf_free(&outbuf);
}
buf_free(&buf);
@@ -1061,7 +1094,11 @@
@@ -1164,7 +1197,11 @@
if (!err) {
uint32_t count;
char *link;
@ -100,7 +100,7 @@
if(buf_get_uint32(&name, &count) != -1 && count == 1 &&
buf_get_string(&name, &link) != -1) {
strncpy(linkbuf, link, size-1);
@@ -1092,7 +1129,11 @@
@@ -1195,7 +1232,11 @@
err = sftp_request(SSH_FXP_READDIR, &handle, SSH_FXP_NAME, &name);
if (!err) {
if (buf_get_entries(&name, h, filler) == -1)
@ -112,7 +112,7 @@
buf_free(&name);
}
} while (!err);
@@ -1377,7 +1418,11 @@
@@ -1528,7 +1569,11 @@
err = sftp_request(SSH_FXP_READ, &buf, SSH_FXP_DATA, &data);
if (!err) {
uint32_t retsize;
@ -124,7 +124,7 @@
if (buf_get_uint32(&data, &retsize) != -1) {
if (retsize > size)
fprintf(stderr, "long read\n");
@@ -1399,7 +1444,11 @@
@@ -1550,7 +1595,11 @@
if (req->error)
chunk->res = req->error;
else if (req->replied) {
@ -136,3 +136,12 @@
if (req->reply_type == SSH_FXP_STATUS) {
uint32_t serr;
@@ -1771,7 +1820,7 @@
{
(void) path;
- buf->f_namelen = 255;
+ buf->f_namemax = 255;
buf->f_bsize = 512;
buf->f_blocks = 999999999 * 2;
buf->f_bfree = 999999999 * 2;

View File

@ -17,3 +17,5 @@ or
2)
% mount_fusefs auto /path/to/mount/point sshfs -o uid=<local uid> \
-o gid=<local gid> username@example.org:
For further options see ``sshfs -h''.