Fix the problem mpqc and mpqc-mpich port

produces two identical packages.
This commit is contained in:
Maho Nakata 2002-11-18 11:52:33 +00:00
parent 5a75100778
commit 4e1257f008
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=70399
6 changed files with 5233 additions and 78 deletions

View File

@ -6,30 +6,69 @@
#
PORTNAME= mpqc
PORTVERSION= 2.1.1
PORTVERSION= 2.1.2
CATEGORIES= science
MASTER_SITES= http://aros.ca.sandia.gov/~cljanss/mpqc/distrib/
DISTFILES= mpqc-${PORTVERSION}.tar.gz mpqc-val-2.1.0.tar.gz
.if !defined(NOPORTDOCS)
DISTFILES+= mpqc-man-${PORTVERSION}.tar.gz mpqc-html-${PORTVERSION}.tar.gz
.endif
MAINTAINER= chat95@mbox.kyoto-inet.or.jp
MAINTAINER= maho@FreeBSD.org
LIB_DEPENDS= lapack:${PORTSDIR}/math/lapack \
atlas:${PORTSDIR}/math/atlas
.include <bsd.port.pre.mk>
USE_BISON= yes
USE_AUTOCONF= yes
CONFIGURE_ARGS= --with-libdirs=-L${PREFIX}/lib \
CONFIGURE_ARGS= --with-cc=${CC} \
--with-cxx=${CXX} \
--with-f77=${F77} \
--with-libdirs=-L${LOCALBASE}/lib \
--with-blas="-lf77blas -latlas" \
--with-lapack="-lalapack -lcblas" \
--with-coptflags="${CFLAGS}" \
--with-cxxoptflags="${CFLAGS}" \
--with-cxxoptflags="${CXXFLAGS}" \
--with-f77optflags="${FFLAGS}"
USE_PERL5= yes
USE_GMAKE= yes
ALL_TARGET= # empty
MPQC_COMMAND= ${PREFIX}/bin/mpqc
.include "${.CURDIR}/files/manpages"
pre-configure:
@${ECHO} "You can override and CFLAGS on the command line."
@${ECHO} "Following is a recommended one."
@${ECHO} "make CFLAGS=\"-malign-double -fexpensive-optimizations -O4 -ffast-math -funroll-loops\""
.include <bsd.port.mk>
do-install:
@cd ${WRKSRC} ; ${GMAKE} install
@cd ${WRKSRC} ; ${GMAKE} install_devel
@cd ${WRKDIR}/${PORTNAME}-man-${PORTVERSION}/man3/ ; ${TAR} -chf - . | \
${TAR} -xf - -C ${PREFIX}/man/man3/
@${MKDIR} ${PREFIX}/share/mpqc/ref
@cd ${WRKDIR}/ref/ && ${TAR} -chf - . | \
${TAR} -xf - -C ${PREFIX}/share/mpqc/ref
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${PREFIX}/share/doc/mpqc
@cd ${WRKDIR}/${PORTNAME}-html-${PORTVERSION} && ${TAR} -chf - . | \
${TAR} -xf - -C ${PREFIX}/share/doc/mpqc/
.endif
validate: # it takes few days
@cd ${WRKSRC}/src/bin/mpqc/validate ; ${RM} -f ref ; ${LN} -s ${WRKSRC}/../ref .
@cd ${WRKSRC}/src/bin/mpqc/validate ; ${GMAKE} inputs
@cd ${WRKSRC}/src/bin/mpqc/validate ; \
for i in run/*.in ; \
do \
${ECHO} "Now calculating `basename $$i`"; \
${MPQC_COMMAND} $$i > $${i%.in}.out ; \
done
@cd ${WRKSRC}/src/bin/mpqc/validate ; ${GMAKE} check
.include <bsd.port.post.mk>

View File

@ -1 +1,4 @@
MD5 (mpqc-2.1.1.tar.gz) = 0294566b7c227a1c41990862e58e9e4d
MD5 (mpqc-2.1.2.tar.gz) = 37c9926b5e4bfadefa0ffb07033763f4
MD5 (mpqc-val-2.1.0.tar.gz) = 6bc61c91288d2e45c170542079b60405
MD5 (mpqc-man-2.1.2.tar.gz) = 856749d3f5b65041228b442441baefe9
MD5 (mpqc-html-2.1.2.tar.gz) = 5b474ba2f49d7a106fd6e0e98b47c373

232
science/mpqc/files/manpages Normal file
View File

@ -0,0 +1,232 @@
MAN3= \
sc__AccResult.3 \
sc__AccResultInfo.3 \
sc__ActiveMsgMemoryGrp.3 \
sc__AngularIntegrator.3 \
sc__AtomInfo.3 \
sc__BFGSUpdate.3 \
sc__BcastState.3 \
sc__BcastStateInBin.3 \
sc__BcastStateRecv.3 \
sc__BcastStateSend.3 \
sc__Becke88XFunctional.3 \
sc__BeckeIntegrationWeight.3 \
sc__BendSimpleCo.3 \
sc__CLHF.3 \
sc__CLSCF.3 \
sc__CartMolecularCoor.3 \
sc__CartesianIter.3 \
sc__CharacterTable.3 \
sc__ClassDesc.3 \
sc__ClassKey.3 \
sc__Compute.3 \
sc__ConnollyShape.3 \
sc__Convergence.3 \
sc__CorrelationTable.3 \
sc__DFPUpdate.3 \
sc__DIIS.3 \
sc__Debugger.3 \
sc__DenFunctional.3 \
sc__DenIntegrator.3 \
sc__DerivCenters.3 \
sc__DescribedClass.3 \
sc__DiagSCMatrix.3 \
sc__DiscreteConnollyShape.3 \
sc__DistSCMatrixKit.3 \
sc__DistShellPair.3 \
sc__EFCOpt.3 \
sc__EulerMaclaurinRadialIntegrator.3 \
sc__ExEnv.3 \
sc__FinDispMolecularHessian.3 \
sc__ForceLink.3 \
sc__ForceLinkBase.3 \
sc__Function.3 \
sc__G96XFunctional.3 \
sc__GaussLegendreAngularIntegrator.3 \
sc__GaussianBasisSet.3 \
sc__GaussianBasisSet__ValueData.3 \
sc__GaussianShell.3 \
sc__HSOSHF.3 \
sc__HSOSSCF.3 \
sc__HessianUpdate.3 \
sc__ISphericalTransform.3 \
sc__Identifier.3 \
sc__Identity.3 \
sc__IdentityTransform.3 \
sc__Int1eV3.3 \
sc__Int2eV3.3 \
sc__IntCoor.3 \
sc__IntCoorGen.3 \
sc__IntMolecularCoor.3 \
sc__Integral.3 \
sc__IntegralV3.3 \
sc__IntegrationWeight.3 \
sc__IrreducibleRepresentation.3 \
sc__KeyVal.3 \
sc__LSDACFunctional.3 \
sc__LYPCFunctional.3 \
sc__LebedevLaikovIntegrator.3 \
sc__LinIPSimpleCo.3 \
sc__LinOPSimpleCo.3 \
sc__LineOpt.3 \
sc__LocalSCMatrixKit.3 \
sc__MBPT2.3 \
sc__MPIMessageGrp.3 \
sc__MTMPIMemoryGrp.3 \
sc__MemoryGrp.3 \
sc__MemoryGrpBuf.3 \
sc__MessageGrp.3 \
sc__MolecularCoor.3 \
sc__MolecularEnergy.3 \
sc__MolecularFormula.3 \
sc__MolecularFrequencies.3 \
sc__Molecule.3 \
sc__MsgMemoryGrp.3 \
sc__MsgStateBufRecv.3 \
sc__MsgStateRecv.3 \
sc__MsgStateSend.3 \
sc__NCAccResult.3 \
sc__NCResult.3 \
sc__NElFunctional.3 \
sc__NonlinearTransform.3 \
sc__OneBodyDerivInt.3 \
sc__OneBodyDerivIntV3.3 \
sc__OneBodyInt.3 \
sc__OneBodyIntV3.3 \
sc__OneBodyWavefunction.3 \
sc__Optimize.3 \
sc__P86CFunctional.3 \
sc__PBECFunctional.3 \
sc__PBEXFunctional.3 \
sc__PW86XFunctional.3 \
sc__PW91CFunctional.3 \
sc__PW91XFunctional.3 \
sc__PW92LCFunctional.3 \
sc__PZ81LCFunctional.3 \
sc__ParentClass.3 \
sc__ParentClasses.3 \
sc__ParsedKeyVal.3 \
sc__PointGroup.3 \
sc__PointInputData.3 \
sc__PointOutputData.3 \
sc__PowellUpdate.3 \
sc__ProcMemoryGrp.3 \
sc__ProcMessageGrp.3 \
sc__ProcThreadGrp.3 \
sc__PsiCCSD.3 \
sc__PsiCCSD_T.3 \
sc__PsiCLHF.3 \
sc__PsiExEnv.3 \
sc__PsiFile11.3 \
sc__PsiHSOSHF.3 \
sc__PsiInput.3 \
sc__PsiSCF.3 \
sc__PsiUHF.3 \
sc__PsiWavefunction.3 \
sc__PthreadThreadGrp.3 \
sc__PumaThreadGrp.3 \
sc__QNewtonOpt.3 \
sc__RadialAngularIntegrator.3 \
sc__RadialIntegrator.3 \
sc__RedundMolecularCoor.3 \
sc__RedundantCartesianIter.3 \
sc__RedundantCartesianSubIter.3 \
sc__Ref.3 \
sc__RefBase.3 \
sc__RefCount.3 \
sc__RefDiagSCMatrix.3 \
sc__RefSCDimension.3 \
sc__RefSCMatrix.3 \
sc__RefSCVector.3 \
sc__RefSymmSCMatrix.3 \
sc__ReplSCMatrixKit.3 \
sc__Result.3 \
sc__ResultInfo.3 \
sc__SCBlockInfo.3 \
sc__SCDimension.3 \
sc__SCElementOp.3 \
sc__SCElementOp2.3 \
sc__SCElementOp3.3 \
sc__SCExtrapData.3 \
sc__SCExtrapError.3 \
sc__SCF.3 \
sc__SCFormIO.3 \
sc__SCMatrix.3 \
sc__SCMatrixBlock.3 \
sc__SCMatrixBlockIter.3 \
sc__SCMatrixDiagBlock.3 \
sc__SCMatrixDiagSubBlock.3 \
sc__SCMatrixKit.3 \
sc__SCMatrixLTriBlock.3 \
sc__SCMatrixLTriSubBlock.3 \
sc__SCMatrixRectBlock.3 \
sc__SCMatrixRectSubBlock.3 \
sc__SCMatrixSubblockIter.3 \
sc__SCVector.3 \
sc__SCVectorSimpleBlock.3 \
sc__SCVectorSimpleSubBlock.3 \
sc__SOBasis.3 \
sc__SOTransform.3 \
sc__SOTransformFunction.3 \
sc__SOTransformShell.3 \
sc__SSAccResult.3 \
sc__SavableState.3 \
sc__SavableStateProxy.3 \
sc__ScaledTorsSimpleCo.3 \
sc__SelfConsistentExtrapolation.3 \
sc__SetIntCoor.3 \
sc__Shape.3 \
sc__ShellRotation.3 \
sc__ShmMemoryGrp.3 \
sc__ShmMessageGrp.3 \
sc__SimpleCo.3 \
sc__SlaterXFunctional.3 \
sc__SphericalTransform.3 \
sc__SphericalTransformComponent.3 \
sc__SphericalTransformIter.3 \
sc__StateIn.3 \
sc__StateInBin.3 \
sc__StateInFile.3 \
sc__StateInText.3 \
sc__StateOut.3 \
sc__StateOutBin.3 \
sc__StateOutFile.3 \
sc__StateOutText.3 \
sc__StateRecv.3 \
sc__StateSend.3 \
sc__StdDenFunctional.3 \
sc__StreSimpleCo.3 \
sc__SumDenFunctional.3 \
sc__SumIntCoor.3 \
sc__SymRep.3 \
sc__SymmMolecularCoor.3 \
sc__SymmSCMatrix.3 \
sc__SymmetryOperation.3 \
sc__Thread.3 \
sc__ThreadGrp.3 \
sc__ThreadLock.3 \
sc__TorsSimpleCo.3 \
sc__TranslateData.3 \
sc__TranslateDataByteSwap.3 \
sc__TranslateDataIn.3 \
sc__TranslateDataOut.3 \
sc__TwoBodyDerivInt.3 \
sc__TwoBodyDerivIntV3.3 \
sc__TwoBodyInt.3 \
sc__TwoBodyIntV3.3 \
sc__UnionShape.3 \
sc__Units.3 \
sc__UnrestrictedSCF.3 \
sc__VDWShape.3 \
sc__VWN1LCFunctional.3 \
sc__VWN2LCFunctional.3 \
sc__VWN3LCFunctional.3 \
sc__VWN4LCFunctional.3 \
sc__VWN5LCFunctional.3 \
sc__VWNLCFunctional.3 \
sc__Volume.3 \
sc__Wavefunction.3 \
sc__XalphaFunctional.3 \
sc__intMessageGrp.3 \
sc__mPW91XFunctional.3 \
sc__scprintf.3

View File

@ -0,0 +1,18 @@
--- src/bin/mpqc/parse.yy.orig Mon Nov 18 17:18:27 2002
+++ src/bin/mpqc/parse.yy Mon Nov 18 17:18:43 2002
@@ -117,6 +117,7 @@
;
molecule: molecule_options_list atoms
+ ;
atoms: atoms atom
|
@@ -124,6 +125,7 @@
atom: string string string string atom_options_list
{ add_atom($1,$2,$3,$4); }
+ ;
atom_options_list:
T_BEG_OPT atom_options T_END_OPT

View File

@ -6,17 +6,19 @@ massively parallel computers. Its design is object oriented, using the C++
programming language.
Capabilities
Closed shell and general restricted open shell Hartree-Fock energies and
o Closed shell and general restricted open shell Hartree-Fock energies and
gradients
Second order open shell perturbation theory (OPT2[2]) and Z-averaged
o Second order open shell perturbation theory (OPT2[2]) and Z-averaged
perturbation theory (ZAPT2) energies.
Second order closed shell Moller-Plesset perturbation theory energies and
o Second order closed shell Moller-Plesset perturbation theory energies and
gradients.
Robust internal coordinate geometry optimizer that efficiently optimizes
o Robust internal coordinate geometry optimizer that efficiently optimizes
molecules with many degrees of freedom.
You can also validate your mpqc binaries when you employ other settings by:
% make validate >& validate.log &
(it may take few days, though)
For details, please see file:///usr/local/share/doc/mpqc/hierarchy.html
or http://aros.ca.sandia.gov/~cljanss/mpqc/html/ValidatingMPQC.html.
WWW: http://aros.ca.sandia.gov/~cljanss/mpqc/

File diff suppressed because it is too large Load Diff