- Move kpse* scripts from texlive-base to tex-kpathsea.
- Use install-strip target.
This commit is contained in:
parent
75efd3aad0
commit
4e0eed78e4
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=374714
17
UPDATING
17
UPDATING
@ -5,6 +5,23 @@ they are unavoidable.
|
||||
You should get into the habit of checking this file for changes each time
|
||||
you update your ports collection, before attempting any port upgrades.
|
||||
|
||||
20141214:
|
||||
AFFECTS: users of TeXLive
|
||||
AUTHOR: hrs@FreeBSD.org
|
||||
|
||||
Several scripts in print/texlive-base have been moved to
|
||||
devel/tex-kpathsea. Upgrading them can fail because texlive-base
|
||||
depends on tex-kpathsea, and the new tex-kpathsea tries to install
|
||||
files which were installed by the old texlive-base. The following
|
||||
error message indicates this situation:
|
||||
|
||||
pkg-static: tex-kpathsea-6.2.0_1 conflicts with texlive-base-20140525_3 (installs files into the same place). Problematic file: /usr/local/bin/kpsewhere
|
||||
|
||||
To solve this problem, remove both of tex-kpathsea and texlive-base first
|
||||
and install the new versions:
|
||||
|
||||
# pkg delete -f tex-kpathsea texlive-base
|
||||
|
||||
20141209:
|
||||
AFFECTS: users of emulators/linux_base-f10 and emulators/linux_base-c6
|
||||
AUTHOR: xmj@freebsd.org
|
||||
|
@ -2,6 +2,7 @@
|
||||
|
||||
PORTNAME= kpathsea
|
||||
PORTVERSION= 6.2.0
|
||||
PORTREVISION= 1
|
||||
CATEGORIES= devel
|
||||
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2014/
|
||||
PKGNAMEPREFIX= tex-
|
||||
@ -16,10 +17,24 @@ USE_LDCONFIG= yes
|
||||
USE_TEX= yes
|
||||
EXTRACT_AFTER_ARGS= ${EXTRACT_FILES}
|
||||
EXTRACT_FILES= ${DISTNAME}/build-aux \
|
||||
${DISTNAME}/texk/kpathsea
|
||||
${DISTNAME}/texk/kpathsea \
|
||||
${DISTNAME}/texk/texlive/tl_scripts
|
||||
WRKSRC= ${WRKDIR}/${DISTNAME}/texk/kpathsea
|
||||
GNU_CONFIGURE= yes
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
INFO= kpathsea
|
||||
|
||||
post-install:
|
||||
cd ${WRKDIR}/${DISTNAME}/texk/texlive/tl_scripts && \
|
||||
for f in kpsetool kpsewhere; do \
|
||||
${INSTALL_SCRIPT} $${f}.sh ${STAGEDIR}${PREFIX}/bin/$$f; \
|
||||
${INSTALL_MAN} $${f}.1 \
|
||||
${STAGEDIR}${MANPREFIX}/man/man1/$${f}.1; \
|
||||
done; \
|
||||
for l in kpsexpand kpsepath; do \
|
||||
${LN} -sf kpsetool ${STAGEDIR}${PREFIX}/bin/$$l; \
|
||||
${LN} -sf kpsetool.1 ${STAGEDIR}${MANPREFIX}/man/man1/$${l}.1; \
|
||||
done
|
||||
|
||||
.include <bsd.port.mk>
|
||||
|
@ -7,6 +7,10 @@ bin/mktexmf
|
||||
bin/mktexpk
|
||||
bin/mktextfm
|
||||
bin/texhash
|
||||
bin/kpsewhere
|
||||
bin/kpsetool
|
||||
bin/kpsexpand
|
||||
bin/kpsepath
|
||||
include/kpathsea/absolute.h
|
||||
include/kpathsea/c-auto.h
|
||||
include/kpathsea/c-ctype.h
|
||||
@ -57,6 +61,10 @@ man/man1/kpseaccess.1.gz
|
||||
man/man1/kpsereadlink.1.gz
|
||||
man/man1/kpsestat.1.gz
|
||||
man/man1/kpsewhich.1.gz
|
||||
man/man1/kpsepath.1.gz
|
||||
man/man1/kpsetool.1.gz
|
||||
man/man1/kpsewhere.1.gz
|
||||
man/man1/kpsexpand.1.gz
|
||||
man/man1/mktexlsr.1.gz
|
||||
man/man1/mktexmf.1.gz
|
||||
man/man1/mktexpk.1.gz
|
||||
|
@ -2,7 +2,7 @@
|
||||
|
||||
PORTNAME= texlive
|
||||
PORTVERSION= 20140525
|
||||
PORTREVISION= 3
|
||||
PORTREVISION= 4
|
||||
CATEGORIES= print
|
||||
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2014/
|
||||
PKGNAMESUFFIX= -base
|
||||
@ -114,6 +114,7 @@ CFLAGS+= -I${LOCALBASE}/include \
|
||||
-I${LOCALBASE}/include/kpathsea \
|
||||
-I${LOCALBASE}/include/ptexenc
|
||||
PLIST_SUB= INSTALL_DATA="${INSTALL_DATA}"
|
||||
INSTALL_TARGET= install-strip
|
||||
|
||||
SHEBANG_FILES= texk/texlive/linked_scripts/a2ping/a2ping.pl \
|
||||
texk/texlive/linked_scripts/accfonts/mkt1font \
|
||||
|
@ -1,5 +1,5 @@
|
||||
--- ./texk/texlive/tl_scripts/Makefile.in.orig 2013-12-26 00:37:50.000000000 +0900
|
||||
+++ ./texk/texlive/tl_scripts/Makefile.in 2014-08-20 23:57:06.000000000 +0900
|
||||
--- texk/texlive/tl_scripts/Makefile.in.orig 2013-12-26 00:37:50.000000000 +0900
|
||||
+++ texk/texlive/tl_scripts/Makefile.in 2014-12-15 00:41:48.000000000 +0900
|
||||
@@ -121,10 +121,9 @@
|
||||
|| { echo " ( cd '$$dir' && rm -f" $$files ")"; \
|
||||
$(am__cd) "$$dir" && rm -f $$files; }; \
|
||||
@ -13,7 +13,41 @@
|
||||
SCRIPTS = $(dist_texconfig_SCRIPTS) $(dist_texmf_SCRIPTS) \
|
||||
$(nodist_bin_SCRIPTS)
|
||||
AM_V_P = $(am__v_P_@AM_V@)
|
||||
@@ -627,7 +626,7 @@
|
||||
@@ -253,8 +252,6 @@
|
||||
dvired \
|
||||
fmtutil \
|
||||
fontinst \
|
||||
- kpsetool \
|
||||
- kpsewhere \
|
||||
ps2frag \
|
||||
pslatex \
|
||||
rubibtex \
|
||||
@@ -283,8 +280,6 @@
|
||||
fmtutil.1 \
|
||||
fmtutil.cnf.5 \
|
||||
fontinst.1 \
|
||||
- kpsetool.1 \
|
||||
- kpsewhere.1 \
|
||||
ps2frag.1 \
|
||||
pslatex.1 \
|
||||
rubibtex.1 \
|
||||
@@ -296,14 +291,10 @@
|
||||
|
||||
bin_links = \
|
||||
allcm:allec \
|
||||
- fmtutil:mktexfmt \
|
||||
- kpsetool:kpsexpand \
|
||||
- kpsetool:kpsepath
|
||||
+ fmtutil:mktexfmt
|
||||
|
||||
man1_links = \
|
||||
fmtutil:fmtutil-sys \
|
||||
- kpsetool:kpsexpand \
|
||||
- kpsetool:kpsepath \
|
||||
fmtutil:mktexfmt \
|
||||
texconfig:texconfig-sys \
|
||||
updmap:updmap-sys
|
||||
@@ -627,7 +618,7 @@
|
||||
check: check-am
|
||||
all-am: Makefile $(SCRIPTS) $(MANS) $(DATA) all-local
|
||||
installdirs:
|
||||
@ -22,7 +56,7 @@
|
||||
test -z "$$dir" || $(MKDIR_P) "$$dir"; \
|
||||
done
|
||||
install: install-am
|
||||
@@ -681,8 +680,8 @@
|
||||
@@ -681,8 +672,8 @@
|
||||
|
||||
info-am:
|
||||
|
||||
|
@ -99,10 +99,6 @@ bin/kanji-config-updmap
|
||||
bin/kanji-config-updmap-sys
|
||||
bin/kanji-fontmap-creator
|
||||
bin/komkindex
|
||||
bin/kpsepath
|
||||
bin/kpsetool
|
||||
bin/kpsewhere
|
||||
bin/kpsexpand
|
||||
bin/lacheck
|
||||
bin/latex-git-log
|
||||
bin/latex2man
|
||||
@ -283,10 +279,6 @@ man/man1/fmtutil.1.gz
|
||||
man/man1/fontinst.1.gz
|
||||
man/man1/gsftopk.1.gz
|
||||
man/man1/hbf2gf.1.gz
|
||||
man/man1/kpsepath.1.gz
|
||||
man/man1/kpsetool.1.gz
|
||||
man/man1/kpsewhere.1.gz
|
||||
man/man1/kpsexpand.1.gz
|
||||
man/man1/lacheck.1.gz
|
||||
man/man1/mag.1.gz
|
||||
man/man1/makeindex.1.gz
|
||||
@ -471,8 +463,6 @@ man/man5/updmap.cfg.5.gz
|
||||
%%TEXMFDISTDIR%%/scripts/texlive/fmtutil-sys.sh
|
||||
%%TEXMFDISTDIR%%/scripts/texlive/fmtutil.sh
|
||||
%%TEXMFDISTDIR%%/scripts/texlive/fontinst.sh
|
||||
%%TEXMFDISTDIR%%/scripts/texlive/kpsetool.sh
|
||||
%%TEXMFDISTDIR%%/scripts/texlive/kpsewhere.sh
|
||||
%%TEXMFDISTDIR%%/scripts/texlive/ps2frag.sh
|
||||
%%TEXMFDISTDIR%%/scripts/texlive/pslatex.sh
|
||||
%%TEXMFDISTDIR%%/scripts/texlive/rubibtex.sh
|
||||
|
Loading…
Reference in New Issue
Block a user