Respect CC and CFLAGS

This commit is contained in:
Kris Kennaway 2003-10-23 00:14:06 +00:00
parent d4788043a6
commit 4ddff8912d
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=91919
3 changed files with 37 additions and 0 deletions

View File

@ -0,0 +1,13 @@
--- biffer/Makefile.orig Wed Oct 22 17:11:30 2003
+++ biffer/Makefile Wed Oct 22 17:11:43 2003
@@ -7,7 +7,9 @@
INCLUDES = ../Include/biffer.h ../Include/biffoptions.h
-CFLAGS = -O -I../Include
+CC ?= cc
+CFLAGS ?= -O -pipe
+CFLAGS += -I../Include
LIBS = -lcompat

View File

@ -0,0 +1,11 @@
--- biffer_comsat/Makefile.orig Wed Oct 22 17:11:51 2003
+++ biffer_comsat/Makefile Wed Oct 22 17:12:01 2003
@@ -11,6 +11,8 @@
BINDIR= /usr/local/libexec
MANDIR= /usr/local/man/man
+CC?= cc
+CFLAGS?= -O -pipe
CFLAGS+= -I../Include
.include <bsd.prog.mk>

View File

@ -0,0 +1,13 @@
--- biffopt/Makefile.orig Wed Oct 22 17:12:06 2003
+++ biffopt/Makefile Wed Oct 22 17:12:25 2003
@@ -7,7 +7,9 @@
INCLUDES = ../Include/biffer.h ../Include/biffoptions.h
-CFLAGS = -O -I../Include
+CC ?= cc
+CFLAGS ?= -O -pipe
+CFLAGS += -I../Include
LIBS = -lcompat