upgrade to 3.2.1

This commit is contained in:
Ying-Chieh Liao 2002-06-18 09:37:58 +00:00
parent 3091de99ec
commit 4dd9a866cd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=61497
4 changed files with 13 additions and 52 deletions

View File

@ -7,7 +7,7 @@
#
PORTNAME= cgicc
PORTVERSION= 3.2
PORTVERSION= 3.2.1
CATEGORIES= www devel
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@ -20,7 +20,7 @@ CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
INSTALLS_SHLIB= yes
post-patch:
@${PERL} -pi -e 's| install-data-local||g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's| install-data-local||g' ${WRKSRC}/Makefile.in
post-install:
.if !defined(NOPORTDOCS)

View File

@ -1 +1 @@
MD5 (cgicc-3.2.tar.gz) = 9b94938475aebb335075ba3f12b5d721
MD5 (cgicc-3.2.1.tar.gz) = 2ddd359775976aa6ae4a65873e184df9

View File

@ -1,41 +0,0 @@
--- ltmain.sh.orig Mon Nov 5 08:29:48 2001
+++ ltmain.sh Sun Mar 10 03:05:06 2002
@@ -1043,14 +1043,14 @@
# These systems don't actually have a C library (as such)
test "X$arg" = "X-lc" && continue
;;
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc due to us having libc/libc_r.
test "X$arg" = "X-lc" && continue
;;
esac
elif test "X$arg" = "X-lc_r"; then
case $host in
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc_r directly, use -pthread flag.
continue
;;
@@ -2441,7 +2441,7 @@
*-*-netbsd*)
# Don't link with libc until the a.out ld.so is fixed.
;;
- *-*-openbsd*)
+ *-*-openbsd* | *-*-freebsd*)
# Do not include libc due to us having libc/libc_r.
;;
*)
@@ -4210,10 +4210,12 @@
fi
# Install the pseudo-library for information purposes.
+ if /usr/bin/false; then
name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
instname="$dir/$name"i
$show "$install_prog $instname $destdir/$name"
$run eval "$install_prog $instname $destdir/$name" || exit $?
+ fi
# Maybe install the static library, too.
test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"

View File

@ -1,6 +1,7 @@
bin/cgicc-config
include/cgicc/CgiDefs.h
include/cgicc/CgiEnvironment.h
include/cgicc/CgiInput.h
include/cgicc/CgiUtils.h
include/cgicc/Cgicc.h
include/cgicc/FormEntry.h
@ -16,16 +17,17 @@ include/cgicc/HTMLElementList.h
include/cgicc/HTTPContentHeader.h
include/cgicc/HTTPCookie.h
include/cgicc/HTTPHTMLHeader.h
include/cgicc/HTTPHeaders.h
include/cgicc/HTTPHeader.h
include/cgicc/HTTPPlainHeader.h
include/cgicc/HTTPRedirectHeader.h
include/cgicc/HTTPResponseHeader.h
include/cgicc/HTTPStatusHeader.h
include/cgicc/MStreamable.h
@dirrm include/cgicc
lib/libcgicc.a
lib/libcgicc.la
lib/libcgicc.so
lib/libcgicc.so.3
lib/libcgicc.so.4
%%PORTDOCS%%share/doc/cgicc/COPYING-source.html
%%PORTDOCS%%share/doc/cgicc/COPYING_8DOC-source.html
%%PORTDOCS%%share/doc/cgicc/COPYING_8LIB-source.html
@ -33,6 +35,8 @@ lib/libcgicc.so.3
%%PORTDOCS%%share/doc/cgicc/CgiDefs_8h.html
%%PORTDOCS%%share/doc/cgicc/CgiEnvironment_8h-source.html
%%PORTDOCS%%share/doc/cgicc/CgiEnvironment_8h.html
%%PORTDOCS%%share/doc/cgicc/CgiInput_8h-source.html
%%PORTDOCS%%share/doc/cgicc/CgiInput_8h.html
%%PORTDOCS%%share/doc/cgicc/CgiUtils_8h-source.html
%%PORTDOCS%%share/doc/cgicc/CgiUtils_8h.html
%%PORTDOCS%%share/doc/cgicc/Cgicc_8h-source.html
@ -65,7 +69,6 @@ lib/libcgicc.so.3
%%PORTDOCS%%share/doc/cgicc/HTTPHTMLHeader_8h.html
%%PORTDOCS%%share/doc/cgicc/HTTPHeader_8h-source.html
%%PORTDOCS%%share/doc/cgicc/HTTPHeader_8h.html
%%PORTDOCS%%share/doc/cgicc/HTTPHeaders_8h-source.html
%%PORTDOCS%%share/doc/cgicc/HTTPPlainHeader_8h-source.html
%%PORTDOCS%%share/doc/cgicc/HTTPPlainHeader_8h.html
%%PORTDOCS%%share/doc/cgicc/HTTPRedirectHeader_8h-source.html
@ -80,8 +83,8 @@ lib/libcgicc.so.3
%%PORTDOCS%%share/doc/cgicc/bugs_8tmpl-source.html
%%PORTDOCS%%share/doc/cgicc/cgi-overview_8tmpl-source.html
%%PORTDOCS%%share/doc/cgicc/cgi_overview.html
%%PORTDOCS%%share/doc/cgicc/cgicc-logo.jpg
%%PORTDOCS%%share/doc/cgicc/cgicc.css
%%PORTDOCS%%share/doc/cgicc/cgicc-doc.css
%%PORTDOCS%%share/doc/cgicc/cgicc.png
%%PORTDOCS%%share/doc/cgicc/cgicc_bugs.html
%%PORTDOCS%%share/doc/cgicc/cgicc_demos.html
%%PORTDOCS%%share/doc/cgicc/cgicc_license.html
@ -89,6 +92,8 @@ lib/libcgicc.so.3
%%PORTDOCS%%share/doc/cgicc/cgicc_tutorial.html
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1CgiEnvironment-members.html
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1CgiEnvironment.html
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1CgiInput-members.html
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1CgiInput.html
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1Cgicc-members.html
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1Cgicc.html
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1FormEntry-members.html
@ -144,14 +149,12 @@ lib/libcgicc.so.3
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1comment-members.html
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1comment.gif
%%PORTDOCS%%share/doc/cgicc/classcgicc_1_1comment.html
%%PORTDOCS%%share/doc/cgicc/classes.html
%%PORTDOCS%%share/doc/cgicc/config_8h-source.html
%%PORTDOCS%%share/doc/cgicc/cookie_8cpp-source.html
%%PORTDOCS%%share/doc/cgicc/cookie_8cpp.html
%%PORTDOCS%%share/doc/cgicc/demos_8tmpl-source.html
%%PORTDOCS%%share/doc/cgicc/dns_8cpp-source.html
%%PORTDOCS%%share/doc/cgicc/dns_8cpp.html
%%PORTDOCS%%share/doc/cgicc/doxygen.css
%%PORTDOCS%%share/doc/cgicc/doxygen.gif
%%PORTDOCS%%share/doc/cgicc/files.html
%%PORTDOCS%%share/doc/cgicc/functions.html
@ -176,4 +179,3 @@ lib/libcgicc.so.3
%%PORTDOCS%%share/doc/cgicc/upload_8cpp-source.html
%%PORTDOCS%%share/doc/cgicc/upload_8cpp.html
%%PORTDOCS%%@dirrm share/doc/cgicc
@dirrm include/cgicc