- Delete expired mediawiki ports

This commit is contained in:
Pav Lucistnik 2008-08-22 12:09:20 +00:00
parent 012210ac8c
commit 4dab0aeacc
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=218990
12 changed files with 2 additions and 180 deletions

2
MOVED
View File

@ -3569,3 +3569,5 @@ x11-themes/enlightenment-theme-BlueSteel||2008-08-20|Deprecated by x11-themes/e1
x11-themes/enlightenment-theme-BrushedMetal-Tigert||2008-08-20|Deprecated by x11-themes/e16-themes
x11-themes/enlightenment-theme-Ganymede|2008-08-20||Deprecated by x11-themes/e16-themes
x11-themes/enlightenment-theme-ShinyMetal||2008-08-20|Deprecated by x11-themes/e16-themes
www/mediawiki17||2008-08-22|Expired, use www/mediawiki instead
www/mediawiki18||2008-08-22|Expired, use www/mediawiki instead

View File

@ -348,8 +348,6 @@
SUBDIR += mediawiki110
SUBDIR += mediawiki111
SUBDIR += mediawiki16
SUBDIR += mediawiki17
SUBDIR += mediawiki18
SUBDIR += mediawiki19
SUBDIR += mergelog
SUBDIR += metacafe_dl

View File

@ -1,58 +0,0 @@
# New ports collection makefile for: www/mediawiki
# Date created: February 1st 2005
# Whom: Gerrit Beine <tux@pinguru.net>
#
# $FreeBSD$
#
PORTNAME= mediawiki
PORTVERSION= 1.7.3
CATEGORIES= www
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= wikipedia
MAINTAINER= gerrit.beine@gmx.de
COMMENT= The wiki engine used by Wikipedia
CONFLICTS= mediawiki-1.[0-68-9].*
DEPRECATED= No longer supported, please upgrade your wiki installation
EXPIRES= 2007-05-31
NO_LATEST_LINK= yes
NO_BUILD= yes
USE_MYSQL= yes
IGNORE_WITH_MYSQL= 323
USE_PHP= iconv mbstring pcre session xml zlib readline
IGNORE_WITH_PHP= 4
WANT_PHP_WEB= yes
MEDIAWIKIDIR?= www/mediawiki
OPTIONS= PGSQL "Use PostgreSQL instead of MySQL (not funtional)" off \
LDAP "Use LDAP authentication" off
.include <bsd.port.pre.mk>
.if defined(WITH_PGSQL)
USE_PHP+= pgsql
.else
USE_PHP+= mysql
.endif
.if defined(WITH_LDAP)
USE_PHP+= ldap
.endif
do-install:
@${MKDIR} ${PREFIX}/${MEDIAWIKIDIR}
${CP} -r ${WRKSRC}/ ${PREFIX}/${MEDIAWIKIDIR}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MEDIAWIKIDIR}
post-install:
@${FIND} ${WRKSRC}/${file} -not -type d \
| ${SED} -ne 's,^${WRKSRC},${MEDIAWIKIDIR},p' >> ${TMPPLIST}
@${FIND} -d ${WRKSRC}/${file} -type d \
| ${SED} -ne 's,^${WRKSRC},@dirrm ${MEDIAWIKIDIR},p' >> ${TMPPLIST}
@${SED} -e 's|%%MEDIAWIKIDIR%%|${PREFIX}/${MEDIAWIKIDIR}|' ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,3 +0,0 @@
MD5 (mediawiki-1.7.3.tar.gz) = 5c0e20609c2249d183b43e7fdf611b51
SHA256 (mediawiki-1.7.3.tar.gz) = 5429f202005aeeec25fe91f981513875b4762812d3cafae8aaf4cd259587625e
SIZE (mediawiki-1.7.3.tar.gz) = 3256345

View File

@ -1,11 +0,0 @@
--- config/index.php.orig Tue Jun 6 11:04:04 2006
+++ config/index.php Sat Jul 1 13:27:04 2006
@@ -340,7 +340,7 @@
$diff3locations = array("/usr/bin", "/opt/csw/bin", "/usr/gnu/bin", "/usr/sfw/bin") + explode($sep, getenv("PATH"));
$diff3names = array("gdiff3", "diff3", "diff3.exe");
-$diff3versioninfo = array('$1 --version 2>&1', 'diff3 (GNU diffutils)');
+$diff3versioninfo = array('$1 --version 2>&1', 'diff3 - GNU diffutils');
foreach ($diff3locations as $loc) {
$exe = locate_executable($loc, $diff3names, $diff3versioninfo);
if ($exe !== false) {

View File

@ -1,6 +0,0 @@
MediaWiki is the collaborative editing software that runs Wikipedia,
the free encyclopedia, and other projects.
It's designed to handle a large number of users and pages without imposing
too rigid a structure or workflow.
WWW: http://www.mediawiki.org/

View File

@ -1,11 +0,0 @@
**** NOTE ****
Remember to check
%%MEDIAWIKIDIR%%/INSTALL
and
%%MEDIAWIKIDIR%%/UPGRADE
for details

View File

@ -1,58 +0,0 @@
# New ports collection makefile for: www/mediawiki
# Date created: February 1st 2005
# Whom: Gerrit Beine <tux@pinguru.net>
#
# $FreeBSD$
#
PORTNAME= mediawiki
PORTVERSION= 1.8.5
CATEGORIES= www
MASTER_SITES= http://download.wikimedia.org/mediawiki/1.8/
MAINTAINER= gerrit.beine@gmx.de
COMMENT= The wiki engine used by Wikipedia
CONFLICTS= mediawiki-1.[0-79].*
DEPRECATED= No longer supported, please upgrade your wiki installation
EXPIRES= 2007-06-30
NO_BUILD= yes
USE_MYSQL= yes
IGNORE_WITH_MYSQL= 323
USE_PHP= iconv mbstring pcre session xml zlib readline
IGNORE_WITH_PHP= 4
WANT_PHP_WEB= yes
MEDIAWIKIDIR?= www/mediawiki
OPTIONS= PGSQL "Use PostgreSQL instead of MySQL (not funtional)" off \
LDAP "Use LDAP authentication" off
.include <bsd.port.pre.mk>
.if defined(WITH_PGSQL)
USE_PHP+= pgsql
.else
USE_PHP+= mysql
.endif
.if defined(WITH_LDAP)
USE_PHP+= ldap
.endif
# Fix USE_PHP after bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.php.mk"
do-install:
@${MKDIR} ${PREFIX}/${MEDIAWIKIDIR}
${CP} -r ${WRKSRC}/ ${PREFIX}/${MEDIAWIKIDIR}
${CHOWN} -R ${WWWOWN}:${WWWGRP} ${PREFIX}/${MEDIAWIKIDIR}
post-install:
@${FIND} ${WRKSRC}/${file} -not -type d \
| ${SED} -ne 's,^${WRKSRC},${MEDIAWIKIDIR},p' >> ${TMPPLIST}
@${FIND} -d ${WRKSRC}/${file} -type d \
| ${SED} -ne 's,^${WRKSRC},@dirrm ${MEDIAWIKIDIR},p' >> ${TMPPLIST}
@${SED} -e 's|%%MEDIAWIKIDIR%%|${PREFIX}/${MEDIAWIKIDIR}|' ${PKGMESSAGE}
.include <bsd.port.post.mk>

View File

@ -1,3 +0,0 @@
MD5 (mediawiki-1.8.5.tar.gz) = 8521cad53aa4dbda59bfd7ef1cba2553
SHA256 (mediawiki-1.8.5.tar.gz) = cb2e25d74fdb841a56d54ee6de33183fba14b0266c01948b76892c3b7b287580
SIZE (mediawiki-1.8.5.tar.gz) = 3497708

View File

@ -1,11 +0,0 @@
--- config/index.php.orig Sat Oct 14 02:06:36 2006
+++ config/index.php Sun Dec 3 16:18:18 2006
@@ -434,7 +434,7 @@
$diff3locations = array( "/usr/bin", "/usr/local/bin", "/opt/csw/bin", "/usr/gnu/bin", "/usr/sfw/bin" ) + explode( $sep, getenv( "PATH" ) );
$diff3names = array( "gdiff3", "diff3", "diff3.exe" );
-$diff3versioninfo = array( '$1 --version 2>&1', 'diff3 (GNU diffutils)' );
+$diff3versioninfo = array('$1 --version 2>&1', 'diff3 - GNU diffutils');
foreach ($diff3locations as $loc) {
$exe = locate_executable($loc, $diff3names, $diff3versioninfo);
if ($exe !== false) {

View File

@ -1,6 +0,0 @@
MediaWiki is the collaborative editing software that runs Wikipedia,
the free encyclopedia, and other projects.
It's designed to handle a large number of users and pages without imposing
too rigid a structure or workflow.
WWW: http://www.mediawiki.org/

View File

@ -1,11 +0,0 @@
**** NOTE ****
Remember to check
%%MEDIAWIKIDIR%%/INSTALL
and
%%MEDIAWIKIDIR%%/UPGRADE
for details