- Update to 1.4

This commit is contained in:
Dmitry Marakasov 2018-02-07 18:16:39 +00:00
parent 800a9293b0
commit 4d7bc0507a
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=461162
6 changed files with 29 additions and 23 deletions

View File

@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= geeqie
PORTVERSION= 1.3
PORTREVISION= 2
PORTVERSION= 1.4
CATEGORIES= graphics
MASTER_SITES= http://www.geeqie.org/

View File

@ -1,3 +1,3 @@
TIMESTAMP = 1464486383
SHA256 (geeqie-1.3.tar.xz) = 4b6f566dd1a8badac68c4353c7dd0f4de17f8627b85a7a70d5eb1ae3b540ec3f
SIZE (geeqie-1.3.tar.xz) = 1141820
TIMESTAMP = 1515356766
SHA256 (geeqie-1.4.tar.xz) = 5c583a165573ec37874c278f9dc57e73df356b30e09a9ccac3179dd5d97e3e32
SIZE (geeqie-1.4.tar.xz) = 35881152

View File

@ -0,0 +1,14 @@
--- Makefile.am.orig 2017-12-31 12:31:21 UTC
+++ Makefile.am
@@ -10,9 +10,9 @@ man_MANS = geeqie.1
readmedir = @readmedir@
if HAVE_MARKDOWN
-readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS README.html ChangeLog.html
+readme_DATA = README.md TODO README.lirc AUTHORS
else
-readme_DATA = README.md COPYING ChangeLog TODO README.lirc AUTHORS ChangeLog.html
+readme_DATA = README.md TODO README.lirc AUTHORS
endif
desktopdir = $(datadir)/applications

View File

@ -0,0 +1,10 @@
--- src/layout_util.c.orig 2017-12-31 12:31:21 UTC
+++ src/layout_util.c
@@ -59,6 +59,7 @@
#include "desktop_file.h"
#include <gdk/gdkkeysyms.h> /* for keyboard values */
+#include <sys/wait.h> /* for WEXITSTATUS */
#include "keymap_template.c"
#define MENU_EDIT_ACTION_OFFSET 16

View File

@ -1,18 +0,0 @@
--- ./src/view_file_icon.c.orig 2016-05-28 21:43:05 UTC
+++ ./src/view_file_icon.c
@@ -379,6 +379,7 @@ static void vficon_mark_toggled_cb(GtkCe
static void tip_show(ViewFile *vf)
{
+ return; // or crash
GtkWidget *label;
gint x, y;
@@ -460,6 +461,7 @@ static void tip_unschedule(ViewFile *vf)
static void tip_update(ViewFile *vf, IconData *id)
{
+ return; // or crash
if (VFICON(vf)->tip_window)
{
gint x, y;

View File

@ -3,6 +3,7 @@ lib/geeqie/geeqie-import
lib/geeqie/geeqie-rotate
lib/geeqie/geeqie-symlink
lib/geeqie/geeqie-ufraw
lib/geeqie/geocode-parameters.awk
man/man1/geeqie.1.gz
share/applications/geeqie.desktop
%%DATADIR%%/applications/geeqie-import-geeqie.desktop