- Update to 20061102
PR: ports/105086 Submitted by: Juergen Lock <nox@jelal.kn-bremen.de> (maintainer) Sponsored by: FreeBSD Bug-a-thon #2
This commit is contained in:
parent
5a29b7daa4
commit
4d356ed643
Notes:
svn2git
2021-03-31 03:12:20 +00:00
svn path=/head/; revision=176353
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= qemu
|
||||
PORTVERSION= 0.8.2s.20061031
|
||||
PORTVERSION= 0.8.2s.20061102
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://www.qemu.org/:release \
|
||||
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
|
||||
@ -14,7 +14,7 @@ MASTER_SITES= http://www.qemu.org/:release \
|
||||
http://www.volny.cz/xnavara/qemu/:snapshot \
|
||||
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
|
||||
http://people.freebsd.org/~maho/qemu/:misc
|
||||
DISTNAME= ${PORTNAME}-snapshot-2006-10-31_05
|
||||
DISTNAME= ${PORTNAME}-snapshot-2006-11-02_05
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
|
||||
DIST_SUBDIR= qemu
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
@ -1,6 +1,6 @@
|
||||
MD5 (qemu/qemu-snapshot-2006-10-31_05.tar.bz2) = ff3943d14548b6e1b99ad3a052af5df6
|
||||
SHA256 (qemu/qemu-snapshot-2006-10-31_05.tar.bz2) = af189f92043e7280589021e2ddabe3758f413ada6db674504b67358f153bf766
|
||||
SIZE (qemu/qemu-snapshot-2006-10-31_05.tar.bz2) = 1493895
|
||||
MD5 (qemu/qemu-snapshot-2006-11-02_05.tar.bz2) = 51fb1369ea3225f5d734c54f0112ffec
|
||||
SHA256 (qemu/qemu-snapshot-2006-11-02_05.tar.bz2) = cee2ba40b46beb72357042c608ee3be9f1d0ec726d78b4cb956cd39a5f160999
|
||||
SIZE (qemu/qemu-snapshot-2006-11-02_05.tar.bz2) = 1494519
|
||||
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
|
||||
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
|
||||
SIZE (qemu/patch3_cirrus) = 8817
|
||||
|
@ -1,4 +1,15 @@
|
||||
Index: qemu/Makefile
|
||||
@@ -20,6 +20,10 @@
|
||||
LDFLAGS+=-static
|
||||
endif
|
||||
ifdef BUILD_DOCS
|
||||
+ifdef NOPORTDOCS
|
||||
+DOCS=qemu.1 qemu-img.1
|
||||
+else
|
||||
DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1
|
||||
+endif
|
||||
else
|
||||
DOCS=
|
||||
@@ -28,7 +28,8 @@
|
||||
ifndef CONFIG_DARWIN
|
||||
ifndef CONFIG_WIN32
|
||||
@ -9,3 +20,14 @@ Index: qemu/Makefile
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
@@ -72,8 +75,10 @@
|
||||
common de-ch es fo fr-ca hu ja mk nl-be pt sl tr
|
||||
|
||||
install-doc: $(DOCS)
|
||||
+ifndef NOPORTDOCS
|
||||
mkdir -p "$(DESTDIR)$(docdir)"
|
||||
$(INSTALL) -m 644 qemu-doc.html qemu-tech.html "$(DESTDIR)$(docdir)"
|
||||
+endif
|
||||
ifndef CONFIG_WIN32
|
||||
mkdir -p "$(DESTDIR)$(mandir)/man1"
|
||||
$(INSTALL) qemu.1 qemu-img.1 "$(DESTDIR)$(mandir)/man1"
|
||||
|
40
emulators/qemu-devel/files/patch-block-raw.c
Normal file
40
emulators/qemu-devel/files/patch-block-raw.c
Normal file
@ -0,0 +1,40 @@
|
||||
Index: qemu/block-raw.c
|
||||
@@ -164,9 +164,20 @@
|
||||
static int aio_sig_num = SIGUSR2;
|
||||
static RawAIOCB *first_aio; /* AIO issued */
|
||||
static int aio_initialized = 0;
|
||||
+// FreeBSD 4.x doesn't have sigwait
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ <= 4
|
||||
+static int sigaio_dont = 0;
|
||||
+#endif
|
||||
|
||||
static void aio_signal_handler(int signum)
|
||||
{
|
||||
+// FreeBSD 4.x doesn't have sigwait
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ <= 4
|
||||
+ if (sigaio_dont) {
|
||||
+ --sigaio_dont;
|
||||
+ return;
|
||||
+ }
|
||||
+#endif
|
||||
#ifndef QEMU_TOOL
|
||||
CPUState *env = cpu_single_env;
|
||||
if (env) {
|
||||
@@ -281,9 +292,17 @@
|
||||
if (qemu_bh_poll())
|
||||
return;
|
||||
#endif
|
||||
+// FreeBSD 4.x doesn't have sigwait
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ <= 4
|
||||
+ ++sigaio_dont;
|
||||
+ do
|
||||
+ sigsuspend(&wait_oset);
|
||||
+ while (sigaio_dont);
|
||||
+#else
|
||||
sigemptyset(&set);
|
||||
sigaddset(&set, aio_sig_num);
|
||||
sigwait(&set, &nb_sigs);
|
||||
+#endif
|
||||
qemu_aio_poll();
|
||||
}
|
||||
|
17
emulators/qemu-devel/files/patch-fpu-softfloat-native.c
Normal file
17
emulators/qemu-devel/files/patch-fpu-softfloat-native.c
Normal file
@ -0,0 +1,17 @@
|
||||
Index: qemu/fpu/softfloat-native.c
|
||||
@@ -228,7 +228,15 @@
|
||||
*----------------------------------------------------------------------------*/
|
||||
float64 float64_trunc_to_int( float64 a STATUS_PARAM )
|
||||
{
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ <= 4
|
||||
+ float64 ret;
|
||||
+ fpsetround(FP_RZ);
|
||||
+ ret = rint(a);
|
||||
+ fpsetround(STATUS(float_rounding_mode));
|
||||
+ return ret;
|
||||
+#else
|
||||
return trunc(a);
|
||||
+#endif
|
||||
}
|
||||
|
||||
float64 float64_round_to_int( float64 a STATUS_PARAM )
|
@ -6,7 +6,7 @@
|
||||
#
|
||||
|
||||
PORTNAME= qemu
|
||||
PORTVERSION= 0.8.2s.20061031
|
||||
PORTVERSION= 0.8.2s.20061102
|
||||
CATEGORIES= emulators
|
||||
MASTER_SITES= http://www.qemu.org/:release \
|
||||
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
|
||||
@ -14,7 +14,7 @@ MASTER_SITES= http://www.qemu.org/:release \
|
||||
http://www.volny.cz/xnavara/qemu/:snapshot \
|
||||
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
|
||||
http://people.freebsd.org/~maho/qemu/:misc
|
||||
DISTNAME= ${PORTNAME}-snapshot-2006-10-31_05
|
||||
DISTNAME= ${PORTNAME}-snapshot-2006-11-02_05
|
||||
DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
|
||||
DIST_SUBDIR= qemu
|
||||
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
|
||||
|
@ -1,6 +1,6 @@
|
||||
MD5 (qemu/qemu-snapshot-2006-10-31_05.tar.bz2) = ff3943d14548b6e1b99ad3a052af5df6
|
||||
SHA256 (qemu/qemu-snapshot-2006-10-31_05.tar.bz2) = af189f92043e7280589021e2ddabe3758f413ada6db674504b67358f153bf766
|
||||
SIZE (qemu/qemu-snapshot-2006-10-31_05.tar.bz2) = 1493895
|
||||
MD5 (qemu/qemu-snapshot-2006-11-02_05.tar.bz2) = 51fb1369ea3225f5d734c54f0112ffec
|
||||
SHA256 (qemu/qemu-snapshot-2006-11-02_05.tar.bz2) = cee2ba40b46beb72357042c608ee3be9f1d0ec726d78b4cb956cd39a5f160999
|
||||
SIZE (qemu/qemu-snapshot-2006-11-02_05.tar.bz2) = 1494519
|
||||
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
|
||||
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
|
||||
SIZE (qemu/patch3_cirrus) = 8817
|
||||
|
@ -1,4 +1,15 @@
|
||||
Index: qemu/Makefile
|
||||
@@ -20,6 +20,10 @@
|
||||
LDFLAGS+=-static
|
||||
endif
|
||||
ifdef BUILD_DOCS
|
||||
+ifdef NOPORTDOCS
|
||||
+DOCS=qemu.1 qemu-img.1
|
||||
+else
|
||||
DOCS=qemu-doc.html qemu-tech.html qemu.1 qemu-img.1
|
||||
+endif
|
||||
else
|
||||
DOCS=
|
||||
@@ -28,7 +28,8 @@
|
||||
ifndef CONFIG_DARWIN
|
||||
ifndef CONFIG_WIN32
|
||||
@ -9,3 +20,14 @@ Index: qemu/Makefile
|
||||
endif
|
||||
endif
|
||||
endif
|
||||
@@ -72,8 +75,10 @@
|
||||
common de-ch es fo fr-ca hu ja mk nl-be pt sl tr
|
||||
|
||||
install-doc: $(DOCS)
|
||||
+ifndef NOPORTDOCS
|
||||
mkdir -p "$(DESTDIR)$(docdir)"
|
||||
$(INSTALL) -m 644 qemu-doc.html qemu-tech.html "$(DESTDIR)$(docdir)"
|
||||
+endif
|
||||
ifndef CONFIG_WIN32
|
||||
mkdir -p "$(DESTDIR)$(mandir)/man1"
|
||||
$(INSTALL) qemu.1 qemu-img.1 "$(DESTDIR)$(mandir)/man1"
|
||||
|
40
emulators/qemu/files/patch-block-raw.c
Normal file
40
emulators/qemu/files/patch-block-raw.c
Normal file
@ -0,0 +1,40 @@
|
||||
Index: qemu/block-raw.c
|
||||
@@ -164,9 +164,20 @@
|
||||
static int aio_sig_num = SIGUSR2;
|
||||
static RawAIOCB *first_aio; /* AIO issued */
|
||||
static int aio_initialized = 0;
|
||||
+// FreeBSD 4.x doesn't have sigwait
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ <= 4
|
||||
+static int sigaio_dont = 0;
|
||||
+#endif
|
||||
|
||||
static void aio_signal_handler(int signum)
|
||||
{
|
||||
+// FreeBSD 4.x doesn't have sigwait
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ <= 4
|
||||
+ if (sigaio_dont) {
|
||||
+ --sigaio_dont;
|
||||
+ return;
|
||||
+ }
|
||||
+#endif
|
||||
#ifndef QEMU_TOOL
|
||||
CPUState *env = cpu_single_env;
|
||||
if (env) {
|
||||
@@ -281,9 +292,17 @@
|
||||
if (qemu_bh_poll())
|
||||
return;
|
||||
#endif
|
||||
+// FreeBSD 4.x doesn't have sigwait
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ <= 4
|
||||
+ ++sigaio_dont;
|
||||
+ do
|
||||
+ sigsuspend(&wait_oset);
|
||||
+ while (sigaio_dont);
|
||||
+#else
|
||||
sigemptyset(&set);
|
||||
sigaddset(&set, aio_sig_num);
|
||||
sigwait(&set, &nb_sigs);
|
||||
+#endif
|
||||
qemu_aio_poll();
|
||||
}
|
||||
|
17
emulators/qemu/files/patch-fpu-softfloat-native.c
Normal file
17
emulators/qemu/files/patch-fpu-softfloat-native.c
Normal file
@ -0,0 +1,17 @@
|
||||
Index: qemu/fpu/softfloat-native.c
|
||||
@@ -228,7 +228,15 @@
|
||||
*----------------------------------------------------------------------------*/
|
||||
float64 float64_trunc_to_int( float64 a STATUS_PARAM )
|
||||
{
|
||||
+#if defined(__FreeBSD__) && __FreeBSD__ <= 4
|
||||
+ float64 ret;
|
||||
+ fpsetround(FP_RZ);
|
||||
+ ret = rint(a);
|
||||
+ fpsetround(STATUS(float_rounding_mode));
|
||||
+ return ret;
|
||||
+#else
|
||||
return trunc(a);
|
||||
+#endif
|
||||
}
|
||||
|
||||
float64 float64_round_to_int( float64 a STATUS_PARAM )
|
Loading…
Reference in New Issue
Block a user