Update to 2.35 Final.

PR:		ports/18487
Submitted by:	FUJISHIMA Satsuki <k5@cheerful.com>
This commit is contained in:
Yukihiro Nakai 2000-06-05 10:19:39 +00:00
parent 5504b50b48
commit 4ccf95842b
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=29213
6 changed files with 52 additions and 31 deletions

View File

@ -1,4 +1,4 @@
# New ports collection makefile for: gogo no coder
# New ports collection makefile for: GOGO-no-coda
# Date created: 01 July 1999
# Whom: Yukihiro Nakai <Nacai@iname.com>
#
@ -6,44 +6,50 @@
#
PORTNAME= gogo
PORTVERSION= 2.30f
PORTVERSION= 2.35
CATEGORIES= audio
MASTER_SITES= http://homepage1.nifty.com/herumi/soft/gogo2/src/
DISTNAME= gogo230f
DISTNAME= gogo235
EXTRACT_SUFX= .tgz
MAINTAINER= nakai@FreeBSD.org
# More than version 0.98
BUILD_DEPENDS= nasm-0.98:${PORTSDIR}/devel/nasm
.if !defined(MINIMAL)
RUN_DEPENDS= cdda2wav:${PORTSDIR}/sysutils/cdrecord \
list_audio_tracks:${PORTSDIR}/sysutils/cdrecord
.endif
USE_GMAKE= yes
ALL_TARGET= gogo
.if(!defined(KANJI))
MAKE_ARGS+= DONT_USE_KANJI=-DNO_KANJI
.else
MAKE_ARGS+= DONT_USE_KANJI=
.endif
RESTRICTED= Condition is not clear
ONLY_FOR_ARCHS= i386
WRKSRC= ${WRKDIR}/gogo231f
# A sample of heavily optimized CFLAGS(typically used with pgcc).
# Recommended ONLY for benchmarks.
# CFLAGS=-march=pentiumpro -O6 -finline-functions -fomit-frame-pointer -funrol
MAKE_ENV= "CC=$(CCMD)" "LD=$(CC)"
CCMD!= ${ECHO} "$(CC) -c $(CFLAGS)"
pre-fetch:
.if !defined(USE_MT)
@${ECHO_MSG} "set USE_MT to compile with linuxthreads."
@${ECHO_MSG} "It would increase performance in SMP environment."
.else
MAKE_ENV+= "USE_MT=yes"
LIB_DEPENDS= lthread.2:${PORTSDIR}/devel/linuxthreads
.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/gogo ${PREFIX}/bin
.if !defined(MINIMAL)
${INSTALL_SCRIPT} ${WRKSRC}/sakai/cdda2mp3.bsd \
${INSTALL_SCRIPT} ${WRKSRC}/contrib/cdda2mp3.bsd \
${PREFIX}/bin/cdda2mp3.gogo
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/gogo
${INSTALL_DATA} ${WRKSRC}/sakai/cdda2mp3.txt \
${PREFIX}/share/doc/gogo/cdda2mp3.gogo.jp
${INSTALL_DATA} ${WRKSRC}/sakai/readme_e.txt \
${INSTALL_DATA} ${WRKSRC}/contrib/cdda2mp3.txt \
${PREFIX}/share/doc/gogo/cdda2mp3.gogo.en
.endif
${INSTALL_DATA} ${WRKSRC}/contrib/cdda2mp3.euc \
${PREFIX}/share/doc/gogo/cdda2mp3.gogo.ja
.endif
.include <bsd.port.mk>

View File

@ -1 +1 @@
MD5 (gogo230f.tgz) = 9e243764fcc5777ff7936a3c34773893
MD5 (gogo235.tgz) = caaab77a8711e7cfc375bef1339beb5b

15
audio/gogo/files/patch-ac Normal file
View File

@ -0,0 +1,15 @@
--- Makefile.orig Fri Apr 28 13:11:32 2000
+++ Makefile Thu May 11 01:52:23 2000
@@ -30,10 +30,10 @@
endif
# common definition
-LD=gcc
+#LD=gcc
#LD=gcc -Wl,-Map,gogo.map
LIBS=-lm
-CC=gcc -c -m486 -O3 -finline-functions -fomit-frame-pointer -funroll-loops
+#CC=gcc -c -m486 -O3 -finline-functions -fomit-frame-pointer -funroll-loops
# This option is available for gcc-2.8.x
#CC=gcc -c -mcpu=pentiumpro -malign-double -O6 -fstrength-reduce -fexpensive-optimizations -finline-functions -fomit-frame-pointer -funroll-loops
# This option is available for gcc-2.95.1, gcc-2.95.2, gcc-2.95.3,...

View File

@ -1 +1 @@
Very fast MP3 encoder with MMX, 3D Now! and PentiumIII SSE support
Very fast MP3 encoder using recent x86 processors' features

View File

@ -1,12 +1,12 @@
gogo, 'Gogo no coder' (which means 'afternoon coder'), is very fast
MP3 encoder based on lame-3.23 which is optimized for MMX, K6-2 3DNow!
and Intel PentiumIII SSE. The latter is available when FreeBSD
supports SSE. (Linux supports it.)
GOGO-no-coda is very fast MP3 encoder based on lame-3.29beta,
optimized with MMX, 3DNow!, Enhanced 3DNow! and SSE (patched nasm required
to compile with E3DNow! and kernel support needed to enable SSE but FreeBSD
does not have it yet).
*** DON'T OVERCLOCK YOUR K6-2 ***
Gogo heavily uses the 3DNow! unit that almost sleeps in usual,
and the encoding CPU becomes very hot even with its normal clock.
So overclock may cause serious internal errors or crazy results.
Also, this may be same on PentiumIII or others.
*** DO NOT OVERCLOCK YOUR CPUs ***
GOGO heavily uses the part of processors that almost sleeps in usual,
so makes them very hot even it runs standard clock.
Overclocking may cause serious internal errors and crazy results.
Or you need gigantic heatsink and extra-noisy fans. :-)
WWW: http://homepage1.nifty.com/herumi/gogo_e.html

View File

@ -1,5 +1,5 @@
bin/cdda2mp3.gogo
bin/gogo
share/doc/gogo/cdda2mp3.gogo.en
share/doc/gogo/cdda2mp3.gogo.jp
share/doc/gogo/cdda2mp3.gogo.ja
@dirrm share/doc/gogo