- Update to 3.0.0.

PR:		ports/133631
Submitted by:	Dan Langille <dan@langille.org> (maintainer)
This commit is contained in:
Wesley Shields 2009-04-13 02:38:39 +00:00
parent b5a2d6b67c
commit 4cb9ddcc36
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=232263
11 changed files with 71 additions and 90 deletions

View File

@ -6,8 +6,7 @@
#
PORTNAME= bacula
DISTVERSION= 2.4.4
PORTREVISION= 1
DISTVERSION= 3.0.0
CATEGORIES?= sysutils
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= bacula
@ -23,6 +22,14 @@ UNIQUENAME?=${PORTNAME}${PKGNAMESUFFIX}
DISTFILES= ${PORTNAME}-${PORTVERSION}.tar.gz
PORTDOCS= VERIFYING \
technotes \
ChangeLog \
README \
ReleaseNotes \
LICENSE \
INSTALL
.if !defined(WITH_BAT)
.if !defined(WITH_CLIENT_ONLY)
USE_RC_SUBR?= bacula-dir bacula-sd
@ -46,9 +53,18 @@ CONFIGURE_ARGS+= --with-tcp-wrappers=/usr/lib \
--enable-smartalloc \
--with-working-dir=${BACULA_DIR} \
--with-scriptdir=${PREFIX}/share/${PORTNAME} \
--docdir=${DOCSDIR} \
--htmldir=${DOCSDIR} \
--with-readline=yes \
--disable-conio \
--enable-batch-insert
--enable-batch-insert \
--with-plugindir=${LOCALBASE}/lib \
--with-libdir=${PREFIX}lib/bacula \
--with-dump-email=root@localhost \
--with-job-email=root@localhost \
--with-db-name=bacula \
--with-db-user=bacula \
--with-baseport=9101
.if defined(WITH_CLIENT_ONLY)
CONFIGURE_ARGS+= --with-fd-user=root \
@ -152,7 +168,7 @@ USE_MYSQL= yes
DBTYPE= mysql
SUB_LIST+= REQ_MYSQL=mysql REQ_PGSQL=""
.elif defined(WITH_POSTGRESQL)
DEFAULT_PGSQL_VER?= 82
DEFAULT_PGSQL_VER?= 83
USE_PGSQL= yes
CONFIGURE_ARGS+= --with-postgresql=yes
DBTYPE= postgresql
@ -214,6 +230,10 @@ pre-everything::
.endif
post-patch:
# Respect NOPORTDOCS
.if defined(NOPORTDOCS)
${REINPLACE_CMD} -e '/docdir/d' ${WRKSRC}/Makefile.in
.endif
# Default bconsole.conf is ${PREFIX}/etc
@${REINPLACE_CMD} -e 's|./bconsole.conf|${PREFIX}/etc/bconsole.conf|g' ${WRKSRC}/src/console/console.c
.if defined(WITH_CLIENT_ONLY)

View File

@ -1,3 +1,3 @@
MD5 (bacula-2.4.4.tar.gz) = 4eb6155b45611018af03002d37a2ffde
SHA256 (bacula-2.4.4.tar.gz) = 3a698bdf0fd3f55733a6a4aabe8c3dc2b1ed1ad5ca7fab000f6e0f804a9d3d38
SIZE (bacula-2.4.4.tar.gz) = 3145564
MD5 (bacula-3.0.0.tar.gz) = 5ea5294c4f66f0d8ba1414f1ca9dc79b
SHA256 (bacula-3.0.0.tar.gz) = cafcf9e9682662d2efcef84a6d90ee09230c60c7ed15a7051b70a30f2966d45c
SIZE (bacula-3.0.0.tar.gz) = 3834280

View File

@ -1,6 +1,6 @@
--- scripts/Makefile.in.orig Tue Sep 12 12:03:08 2006
+++ scripts/Makefile.in Tue Sep 12 12:03:08 2006
@@ -33,8 +33,6 @@
@@ -139,8 +139,6 @@
$(MKDIR) $(DESTDIR)$(mandir)
install: installdirs

View File

@ -1,19 +0,0 @@
*** src/console/Makefile.in.org Sat Apr 3 20:40:26 2004
--- src/console/Makefile.in Sat May 8 14:01:49 2004
***************
*** 89,95 ****
destconf=$$srcconf; \
if test -f ${DESTDIR}${sysconfdir}/console.conf; then \
echo "Existing console.conf moved to bconsole.conf"; \
! @$(MV) ${DESTDIR}${sysconfdir}/console.conf ${DESTDIR}${sysconfdir}/bconsole.conf; \
destconf=$$srcconf.new; \
fi; \
fi; \
--- 89,95 ----
destconf=$$srcconf; \
if test -f ${DESTDIR}${sysconfdir}/console.conf; then \
echo "Existing console.conf moved to bconsole.conf"; \
! $(MV) ${DESTDIR}${sysconfdir}/console.conf ${DESTDIR}${sysconfdir}/bconsole.conf; \
destconf=$$srcconf.new; \
fi; \
fi; \

View File

@ -1,11 +0,0 @@
--- src/qt-console/build-depkgs-qt-console.orig Sat Sep 15 12:11:32 2007
+++ src/qt-console/build-depkgs-qt-console Sat Sep 15 12:11:32 2007
@@ -147,7 +147,7 @@
echo " INSTALLBASE = ${TOP_DIR}/qwt" >>${TOP_DIR}/depkgs/qwt-5.0.2/qwtconfig.pri
echo "}" >>${TOP_DIR}/depkgs/qwt-5.0.2/qwtconfig.pri
cat ${TOP_DIR}/qwtconfig.pri >>${TOP_DIR}/depkgs/qwt-5.0.2/qwtconfig.pri
- qmake >make.log
+ ${QMAKE} >make.log
do_make Makefile >>make.log
do_make Makefile install >>make.log
echo "In case of problems see: `pwd`/make.log"

View File

@ -1,23 +0,0 @@
Index: src/stored/acquire.c
===================================================================
--- src/stored/acquire.c (revision 8426)
+++ src/stored/acquire.c (working copy)
@@ -1,7 +1,7 @@
/*
Bacula® - The Network Backup Solution
- Copyright (C) 2002-2008 Free Software Foundation Europe e.V.
+ Copyright (C) 2002-2009 Free Software Foundation Europe e.V.
The main author of Bacula is Kern Sibbald, with contributions from
many others, a complete list can be found in the file AUTHORS.
@@ -647,8 +647,8 @@
/* Detach this dcr only if attached */
if (dcr->attached_to_dev && dev) {
+ dev->dlock();
dcr->unreserve_device();
- dev->dlock();
dcr->dev->attached_dcrs->remove(dcr); /* detach dcr from device */
dcr->attached_to_dev = false;
// remove_dcr_from_dcrs(dcr); /* remove dcr from jcr list */

View File

@ -1,28 +0,0 @@
Index: src/stored/reserve.c
===================================================================
--- src/stored/reserve.c (revision 8426)
+++ src/stored/reserve.c (working copy)
@@ -1,7 +1,7 @@
/*
Bacula® - The Network Backup Solution
- Copyright (C) 2000-2008 Free Software Foundation Europe e.V.
+ Copyright (C) 2000-2009 Free Software Foundation Europe e.V.
The main author of Bacula is Kern Sibbald, with contributions from
many others, a complete list can be found in the file AUTHORS.
@@ -498,7 +498,6 @@
void DCR::unreserve_device()
{
lock_volumes();
- dev->dlock();
if (is_reserved()) {
clear_reserved();
reserved_volume = false;
@@ -514,7 +513,6 @@
volume_unused(this);
}
}
- dev->dunlock();
unlock_volumes();
}

View File

@ -0,0 +1,11 @@
--- src/cats/sql.c.orig 2009-04-12 11:07:46.218959381 -0400
+++ src/cats/sql.c 2009-04-12 11:08:15.509974021 -0400
@@ -759,7 +759,7 @@
if (mdb->lock.valid == RWLOCK_VALID) {
fprintf(fp, "\tRWLOCK=%p w_active=%i w_wait=%i\n", &mdb->lock, mdb->lock.w_active, mdb->lock.w_wait);
#ifndef HAVE_WIN32
- fprintf(fp, "\t\tthreadid=0x%x mutex=%p\n", (int)mdb->lock.writer_id, &mdb->lock.mutex);
+ fprintf(fp, "\t\tthreadid=0x%lx mutex=%p\n", (long)mdb->lock.writer_id, &mdb->lock.mutex);
#endif
}
}

View File

@ -0,0 +1,13 @@
--- src/lib/jcr.c.orig 2009-04-12 11:07:07.079940037 -0400
+++ src/lib/jcr.c 2009-04-12 11:07:20.116947254 -0400
@@ -1063,8 +1063,8 @@
fprintf(fp, "\tuse_count=%i\n",
jcr->use_count());
#else
- fprintf(fp, "\tuse_count=%i threadid=0x%x\n",
- jcr->use_count(), (int)jcr->my_thread_id);
+ fprintf(fp, "\tuse_count=%i threadid=0x%lx\n",
+ jcr->use_count(), (long)jcr->my_thread_id);
#endif
fprintf(fp, "\tJobType=%c JobLevel=%c\n",
jcr->get_JobType(), jcr->get_JobLevel());

View File

@ -1,3 +1,20 @@
lib/bpipe-fd.so
lib/libbac.la
lib/libbac.so
lib/libbac.so.1
lib/libbaccfg.la
lib/libbaccfg.so
lib/libbaccfg.so.1
lib/libbacfind.la
lib/libbacfind.so
lib/libbacfind.so.1
lib/libbacpy.la
lib/libbacpy.so
lib/libbacpy.so.1
lib/libbacsql.la
lib/libbacsql.so
lib/libbacsql.so.1
sbin/bacula
sbin/bacula-dir
sbin/bacula-sd
sbin/bcopy
@ -34,6 +51,7 @@ sbin/dbcheck
%%DATADIR%%/make_catalog_backup
%%DATADIR%%/make_%%DBTYPE%%_tables
%%DATADIR%%/mtx-changer
%%DATADIR%%/mtx-changer.conf
%%DATADIR%%/query.sql
%%DATADIR%%/update_bacula_tables
%%DATADIR%%/update_%%DBTYPE%%_tables

View File

@ -1,7 +1,7 @@
sbin/bacula-fd
sbin/bconsole
%%GNOMECONS%%sbin/gnome-console
%%WXCONS%%sbin/wx-console
%%WXCONS%%sbin/bwx-console
@unexec /usr/bin/killall badula-fd > /dev/null 2>&1 || true
@exec mkdir -p %%BACULA_DIR%%
@dirrmtry %%BACULA_DIR%%