Remove an old deprecated port.

This commit is contained in:
Thierry Thomas 2006-04-08 07:58:20 +00:00
parent 22b94015bc
commit 4c6dbff1bd
Notes: svn2git 2021-03-31 03:12:20 +00:00
svn path=/head/; revision=159105
10 changed files with 1 additions and 248 deletions

1
MOVED
View File

@ -2245,3 +2245,4 @@ textproc/p5-JSON-Syck|textproc/p5-YAML-Syck|2006-04-07|The textproc/p5-YAML-Syck
www/linux-flashplugin||2006-04-08|Removed due to license problem
www/linux-flashplugin6||2006-04-08|Removed due to license problem
www/linux-flashplugin7||2006-04-08|Removed due to license problem
net/nic||2006-04-08|Deprecated for a long time

View File

@ -330,7 +330,6 @@
SUBDIR += ng_netflow
SUBDIR += ngrep
SUBDIR += ngrep-lib
SUBDIR += nic
SUBDIR += nicmond
SUBDIR += nifmon
SUBDIR += nload

View File

@ -1,76 +0,0 @@
# Ports collection makefile for: Nic
# Date created: Sun Dec 30, 2001
# Whom: Thierry Thomas (<thierry@pompo.net>)
#
# $FreeBSD$
#
PORTNAME= nic
PORTVERSION= 0.0.2.011230
PORTREVISION= 1
CATEGORIES= net www
MASTER_SITES= http://pompo.net/horde/nic/
MAINTAINER= thierry@FreeBSD.org
COMMENT= Nic is a set of small web-based network applications
RUN_DEPENDS= ${LOCALBASE}/www/horde/index.php:${PORTSDIR}/www/horde
IGNORE= is not compatible with Horde 3 - to be refreshed
NO_BUILD= yes
USE_REINPLACE= yes
REINPLACE_ARGS= -i.beforeNic
DOCS= LICENSE README docs/CHANGES docs/CREDITS docs/INSTALL
CONFFILE= conf.php html.php menu.php
SUB_DIRS= config graphics lib templates
LHORDEDIR?= www/horde
LNICDIR?= ${LHORDEDIR}/nic
PLIST_SUB= HORDEDIR=${LHORDEDIR} NICDIR=${LNICDIR}
HORDEDIR= ${PREFIX}/${LHORDEDIR}
NICDIR= ${PREFIX}/${LNICDIR}
CONFDIR= ${NICDIR}/config
HORDE_INC= ${LOCALBASE}/etc/horde
do-install:
@${MKDIR} ${NICDIR}
.for REP in ${SUB_DIRS}
@${CP} -Rp ${WRKSRC}/${REP} ${NICDIR}
.endfor
@${CP} -p ${WRKSRC}/*.php ${NICDIR}
.for FILE in ${CONFFILE}
@if [ ! -f ${CONFDIR}/${FILE} ]; then \
${CP} ${CONFDIR}/${FILE}.dist ${CONFDIR}/${FILE} ; \
fi
.endfor
@${CHOWN} -R www:www ${NICDIR}
@${CHMOD} -R o-rwx ${CONFDIR}
@${CP} -p ${FILESDIR}/httpd.conf.nic ${HORDE_INC}
@${REINPLACE_CMD} -e "s:/home/httpd/html/horde/nic:${NICDIR}:g" \
${HORDE_INC}/httpd.conf.nic
@${RM} ${HORDE_INC}/httpd.conf.nic.beforeNic
@${REINPLACE_CMD} -e "s://UNCOMMENTWHENINSTNIC::" \
${HORDEDIR}/config/registry.php
@${CP} -p ${HORDEDIR}/config/registry.php \
${HORDEDIR}/config/registry.php.afterNic
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
.for FILE in ${DOCS}
@${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
@${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
.endif
post-install:
@${ECHO_MSG}
@${CAT} ${PKGMESSAGE} | \
${SED} -e "s:%%NICDIR%%:${NICDIR}:g;s:%%CONFDIR%%:${CONFDIR}:g"
@${ECHO_MSG}
.include <bsd.port.mk>

View File

@ -1,3 +0,0 @@
MD5 (nic-0.0.2.011230.tar.gz) = ce4fa57fedf482dc020308d0730952f6
SHA256 (nic-0.0.2.011230.tar.gz) = 74147f5020ba2a117f0fce0cca711d71f2a5dd567bee7d583954addad4ace974
SIZE (nic-0.0.2.011230.tar.gz) = 17417

View File

@ -1,19 +0,0 @@
# This is included in Apache's httpd.conf for Nic
#
# For security, don't serve pages from the Nic configuration and
# library directories.
#
<Directory "/home/httpd/html/horde/nic/config">
order deny,allow
deny from all
</Directory>
<Directory "/home/httpd/html/horde/nic/lib">
order deny,allow
deny from all
</Directory>
<Directory "/home/httpd/html/horde/nic/templates">
order deny,allow
deny from all
</Directory>
# End of Nic configuration ================

View File

@ -1,36 +0,0 @@
--- icq.php.orig Mon Oct 15 23:12:21 2001
+++ icq.php Mon Dec 31 00:37:35 2001
@@ -17,10 +17,10 @@
$uin = Horde::getFormData('uin');
$results="";
+$email_next=false;
if (!empty($uin)) {
- $fd = fopen("http://wwp.icq.com/$uin", 'r');
+ $fd = fopen("http://web.icq.com/wwp?Uin=" . $uin, 'r');
while ($buffer = fgetss($fd, 4096)) {
-
if (ereg('Handle/Nickname:', $buffer)) {
// echo ereg_replace('Handle/Nickname:', 'NickName: ', $buffer);
// echo "<br>";
@@ -34,6 +34,20 @@
$results .= ereg_replace('E-Mail', 'Email: ', $buffer);
$results .="<br>";
}
+
+ if (ereg('Hello my name is', $buffer)) {
+ $results .= ereg_replace('Hello my name is', 'Name:', $buffer);
+ $results .="<br>";
+ }
+
+ if ($email_next) {
+ $results .= 'Email: ' . $buffer;
+ $email_next = false;
+ }
+ if (ereg('Send me an Email message', $buffer)) {
+ $email_next = true;
+ }
+
}
fclose($fd);

View File

@ -1,11 +0,0 @@
--- ping.php.orig Wed Nov 21 23:17:27 2001
+++ ping.php Sun Dec 30 22:05:49 2001
@@ -26,7 +26,7 @@
$results .= "<br />$ping[$i]\n";
}
} else {
- exec("/bin/ping -c 5 \"$addr\"", $ping);
+ exec("/sbin/ping -c 5 \"$addr\"", $ping);
for ($i = 0; $i < count($ping); $i++) {
$results .= "<br />$ping[$i]\n";

View File

@ -1,14 +0,0 @@
NIC is the Horde's suite of simple network utilities.
The list of tools includes:
. Finger
. ICQ lookup
. DNS lookup
. Email address verification
. Ping
. SMTP open relay checking
. Service status
. Traceroute
. Whois
WWW: http://horde.org/nic/

View File

@ -1,14 +0,0 @@
************************************************************************
Nic has been installed in %%NICDIR%% with your blank
configuration files. It should be available from
<URL:http://localhost/horde/>.
You may tune the configuration files located in
%%CONFDIR%%/, specially the files conf.php.
To protect your configuration files, you have to restart Apache.
N.B.: if you don't have a file /usr/local/lib/php/Net/Socket.php, you
===== have to install it from
<URL:http://pear.php.net/get/Net_Socket-1.0.1.tgz>.
************************************************************************

View File

@ -1,74 +0,0 @@
%%PORTDOCS%%share/doc/nic/CHANGES
%%PORTDOCS%%share/doc/nic/CREDITS
%%PORTDOCS%%share/doc/nic/INSTALL
%%PORTDOCS%%share/doc/nic/LICENSE
%%PORTDOCS%%share/doc/nic/README
%%NICDIR%%/config/conf.php
%%NICDIR%%/config/conf.php.dist
%%NICDIR%%/config/html.php
%%NICDIR%%/config/html.php.dist
%%NICDIR%%/config/menu.php
%%NICDIR%%/config/menu.php.dist
%%NICDIR%%/finger.php
%%NICDIR%%/graphics/finger.gif
%%NICDIR%%/graphics/icq_disabled.gif
%%NICDIR%%/graphics/icq_offline.gif
%%NICDIR%%/graphics/icq_online.gif
%%NICDIR%%/graphics/mailaddrcheck.gif
%%NICDIR%%/graphics/nic.gif
%%NICDIR%%/graphics/ping.gif
%%NICDIR%%/graphics/relay.gif
%%NICDIR%%/graphics/services.gif
%%NICDIR%%/graphics/whois.gif
%%NICDIR%%/icq.php
%%NICDIR%%/index.php
%%NICDIR%%/lib/Finger.php
%%NICDIR%%/lib/NIC.php
%%NICDIR%%/lib/base.php
%%NICDIR%%/lib/version.php
%%NICDIR%%/lookup.php
%%NICDIR%%/mailaddrcheck.php
%%NICDIR%%/menu.php
%%NICDIR%%/nic.php
%%NICDIR%%/ping.php
%%NICDIR%%/relay.php
%%NICDIR%%/services.php
%%NICDIR%%/status.php
%%NICDIR%%/templates/common-footer.inc
%%NICDIR%%/templates/common-header.inc
%%NICDIR%%/templates/finger/finger.inc
%%NICDIR%%/templates/footer.inc
%%NICDIR%%/templates/icq/icq.inc
%%NICDIR%%/templates/index/css.inc
%%NICDIR%%/templates/index/notconfigured.inc
%%NICDIR%%/templates/lookup/lookup.inc
%%NICDIR%%/templates/mailaddrcheck/mailaddrcheck.inc
%%NICDIR%%/templates/menu/menu.inc
%%NICDIR%%/templates/nic_footer.html
%%NICDIR%%/templates/nic_frame.html
%%NICDIR%%/templates/ping/ping.inc
%%NICDIR%%/templates/relay/relay.inc
%%NICDIR%%/templates/services/services.inc
%%NICDIR%%/templates/traceroute/traceroute.inc
%%NICDIR%%/templates/whois/whois.inc
%%NICDIR%%/traceroute.php
%%NICDIR%%/whois.php
etc/horde/httpd.conf.nic
@dirrm %%NICDIR%%/config
@dirrm %%NICDIR%%/graphics
@dirrm %%NICDIR%%/lib
@dirrm %%NICDIR%%/templates/finger
@dirrm %%NICDIR%%/templates/icq
@dirrm %%NICDIR%%/templates/index
@dirrm %%NICDIR%%/templates/lookup
@dirrm %%NICDIR%%/templates/mailaddrcheck
@dirrm %%NICDIR%%/templates/menu
@dirrm %%NICDIR%%/templates/ping
@dirrm %%NICDIR%%/templates/relay
@dirrm %%NICDIR%%/templates/services
@dirrm %%NICDIR%%/templates/traceroute
@dirrm %%NICDIR%%/templates/whois
@dirrm %%NICDIR%%/templates
@dirrm %%NICDIR%%
%%PORTDOCS%%@dirrm share/doc/nic
@unexec if cmp -s %D/www/horde/config/registry.php %D/www/horde/config/registry.php.afterNic; then rm -f %D/www/horde/config/registry.php.afterNic; mv %D/www/horde/config/registry.php.beforeNic %D/www/horde/config/registry.php; fi